]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- rel 0.3
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.6
8 Release:        0.3
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-%{version}-src.tgz
13 # Source0-md5:  fcb4ea295b1ecbf7890d48bf721896a8
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 Patch0:         %{name}-twisted.patch
17 Patch1:         %{name}-scripts.patch
18 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
19 Requires:       losetup
20 Requires:       python-TwistedWeb
21 Requires:       ZopeInterface
22 BuildRequires:  curl-devel
23 BuildRequires:  python-devel
24 BuildRequires:  python-Twisted
25 BuildRequires:  bridge-utils
26 BuildRequires:  transfig
27 BuildRequires:  libidn-devel
28 BuildRequires:  zlib-devel
29 BuildRequires:  X11-devel
30 BuildRequires:  ncurses-devel
31 BuildRequires:  tetex-format-latex
32 BuildRequires:  tetex-latex-psnfss
33 BuildRequires:  tetex-dvips
34 ExclusiveArch:  %{ix86}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 This package contains the Xen hypervisor and Xen tools, needed to run
39 virtual machines on x86 systems, together with the kernel-xen*
40 packages. Information on how to use Xen can be found at the Xen
41 project pages.
42
43 Virtualisation can be used to run multiple versions or multiple Linux
44 distributions on one system, or to test untrusted applications in a
45 sandboxed environment. Note that the Xen technology is still in
46 development, and this RPM has received extremely little testing. Don't
47 be surprised if this RPM eats your data, drinks your coffee or makes
48 fun of you in front of your friends.
49
50 %description -l pl
51 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
52 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
53 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
54 projektu.
55
56 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
57 dystrybucji Linuksa na jednym systemie lub do testowania nie
58 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
59 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
60 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
61 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
62
63 %package devel
64 Summary:        Header files for xen
65 Summary(pl):    Pliki nag³ówkowe xena
66 Group:          Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68
69 %description devel
70 Header files for xen.
71
72 %description devel -l pl
73 Pliki nag³ówkowe xena.
74
75 %package static
76 Summary:        Static xen libraries
77 Summary(pl):    Statyczne biblioteki xena
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
80
81 %description static
82 Static xen libraries.
83
84 %description static -l pl
85 Statyczne biblioteki xena.
86
87 %package doc
88 Summary:        Xen documentation
89 Summary(pl):    Dokumentacja xena
90 Group:          Applications/System
91 Requires:       %{name} = %{epoch}:%{version}-%{release}
92
93 %description doc
94 Xen documentation.
95
96 %description doc -l pl
97 Dokumentacja xena.
98
99 %prep
100 %setup -q -n xen-2.0
101 %patch0 -p1 
102 %patch1 -p1
103 chmod -R u+w .
104 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
105
106 %build
107 CFLAGS="%{rpmcflags}" \
108 CXXFLAGS="%{rpmcflags}" \
109 %{__make} xen tools docs \
110         CC="%{__cc}" \
111         CXX="%{__cxx}"
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install-xen install-tools install-docs \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
120 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
121 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
122
123 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
124
125 #install -d $RPM_BUILD_ROOT%{_mandir}
126 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
127
128 #install -d doc-html-install/{interface,user}
129 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
130 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
131
132 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
133
134 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
135 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
136 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
137
138 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
139 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
140
141 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen
142 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/{sv,xend-db}
143 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/xend-db/{domain,vnet,migrate}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 /sbin/chkconfig --add xend
151 /sbin/chkconfig --add xendomains
152
153 %postun -p /sbin/ldconfig
154
155 %preun
156 if [ "$1" = "0" ]; then
157 #       if [ -f /var/lock/subsys/xend ]; then
158 #               /etc/rc.d/init.d/xend stop 1>&2
159 #       fi
160         /sbin/chkconfig --del xend
161 #       if [ -f /var/lock/subsys/xendomains ]; then
162 #               /etc/rc.d/init.d/xendomains stop 1>&2
163 #       fi
164         /sbin/chkconfig --del xendomains
165 fi
166
167 %files
168 %defattr(644,root,root,755)
169 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
170 %doc COPYING ChangeLog README docs/misc/*
171 /boot/%{name}-%{version}-syms
172 /boot/%{name}-%{version}.gz
173 /boot/%{name}.gz
174 %attr(754,root,root) /etc/rc.d/init.d/*
175 %dir %{_sysconfdir}/xen
176 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
177 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
178 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
179 %dir %{_sysconfdir}/xen/auto
180 %dir %{_sysconfdir}/xen/scripts
181 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
182 %attr(755,root,root) %{_bindir}/*
183 %attr(755,root,root) %{_sbindir}/*
184 %attr(755,root,root) %{_libdir}/lib*.so.*
185 %{_libdir}/python/%{name}
186 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
187 %{_mandir}/man?/*
188 %dir %{_sharedstatedir}/xen
189 %dir %{_sharedstatedir}/xen/sv
190 %dir %{_sharedstatedir}/xen/xend-db
191 %dir %{_sharedstatedir}/xen/xend-db/domain
192 %dir %{_sharedstatedir}/xen/xend-db/vnet
193 %dir %{_sharedstatedir}/xen/xend-db/migrate
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/lib*.so
198 %{_includedir}/*
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/lib*.a
203
204 %files doc
205 %defattr(644,root,root,755)
206 %dir %{_datadir}/xen
207 %{_datadir}/xen/*.pdf
This page took 0.049134 seconds and 4 git commands to generate.