]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
Version: 4.2.2
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.2
33 Release:        1
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  f7362b19401a47826f2d8fd603a1782a
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Source57:       xen.cfg
77 Source58:       xen.efi-boot-update
78 Source59:       vif-openvswitch
79 Patch0:         %{name}-python_scripts.patch
80 Patch1:         %{name}-symbols.patch
81 Patch2:         %{name}-curses.patch
82 Patch3:         pygrubfix.patch
83 Patch4:         xend.catchbt.patch
84 Patch5:         xend-pci-loop.patch
85 Patch6:         %{name}-dumpdir.patch
86 # Warning: this disables ingress filtering implemented in xen scripts!
87 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
88 Patch8:         %{name}-configure-xend.patch
89 Patch9:         %{name}-initscript.patch
90 Patch10:        %{name}-quemu-softloat-c99.patch
91 Patch11:        %{name}-qemu.patch
92 Patch12:        %{name}-scripts-locking.patch
93 Patch13:        %{name}-close_lockfd_after_lock_attempt.patch
94 Patch14:        %{name}-librt.patch
95 Patch15:        %{name}-ulong.patch
96 URL:            http://www.xen.org/products/xenhyp.html
97 %{?with_opengl:BuildRequires:   OpenGL-devel}
98 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
99 %ifarch %{ix86} %{x8664}
100 BuildRequires:  acpica
101 BuildRequires:  bcc
102 %endif
103 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
104 %{?with_brlapi:BuildRequires:   brlapi-devel}
105 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
106 BuildRequires:  bzip2-devel
107 BuildRequires:  ceph-devel
108 BuildRequires:  curl-devel
109 BuildRequires:  cyrus-sasl-devel >= 2
110 BuildRequires:  e2fsprogs-devel
111 BuildRequires:  gcc >= 5:3.4
112 BuildRequires:  gettext-devel
113 BuildRequires:  glib2-devel >= 1:2.12
114 BuildRequires:  gnutls-devel
115 BuildRequires:  latex2html >= 2008
116 BuildRequires:  libaio-devel
117 BuildRequires:  libiscsi-devel
118 BuildRequires:  libjpeg-devel
119 BuildRequires:  libpng-devel
120 BuildRequires:  libuuid-devel
121 BuildRequires:  lzo-devel >= 2
122 BuildRequires:  ncurses-devel
123 %if %{with ocaml}
124 BuildRequires:  ocaml >= 3.04-7
125 BuildRequires:  ocaml-findlib
126 %endif
127 BuildRequires:  nss-devel >= 3.12.8
128 BuildRequires:  openssl-devel
129 BuildRequires:  pciutils-devel
130 BuildRequires:  perl-base
131 BuildRequires:  pkgconfig
132 BuildRequires:  python-devel
133 BuildRequires:  rpm-pythonprov
134 BuildRequires:  rpmbuild(macros) >= 1.647
135 BuildRequires:  spice-protocol >= 0.6.0
136 BuildRequires:  spice-server-devel >= 0.6.0
137 BuildRequires:  texi2html
138 BuildRequires:  texlive-dvips
139 BuildRequires:  texlive-latex-psnfss
140 BuildRequires:  texlive-xetex
141 BuildRequires:  usbredir-devel
142 BuildRequires:  vde2-devel
143 BuildRequires:  which
144 # for xfsctl (<xfs/xfs.h>)
145 BuildRequires:  xfsprogs-devel
146 BuildRequires:  xorg-lib-libX11-devel
147 BuildRequires:  xorg-lib-libXext-devel
148 BuildRequires:  xz-devel
149 BuildRequires:  yajl-devel
150 BuildRequires:  zlib-devel
151 # FIXME: see qemu configure comments on top of spec
152 %{!?with_opengl:BuildConflicts: OpenGL-devel}
153 %{!?with_sdl:BuildConflicts:    SDL-devel}
154 %{!?with_sdl:BuildConflicts:    SDL-devel}
155 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
156 %{!?with_brlapi:BuildConflicts: brlapi-devel}
157 Requires(post,preun):   /sbin/chkconfig
158 Requires(post,preun,postun):    systemd-units >= 38
159 Requires:       %{name}-libs = %{version}-%{release}
160 Requires:       ZopeInterface
161 Requires:       bridge-utils
162 Requires:       coreutils
163 Requires:       diffutils
164 Requires:       gawk
165 Requires:       iptables
166 Requires:       losetup
167 Requires:       net-tools
168 Requires:       python-%{name} = %{version}-%{release}
169 Requires:       rc-scripts
170 Requires:       sed
171 Requires:       systemd-units >= 38
172 Requires:       util-linux
173 Requires:       which
174 Requires:       %{name}-guest = %{version}-%{release}
175 Obsoletes:      xen-doc
176 Obsoletes:      xen-udev
177 ExclusiveArch:  %{ix86} %{x8664}
178 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
179
180 # some PPC/SPARC boot images in ELF format
181 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
182
183 %description
184 This package contains the Xen hypervisor and Xen tools, needed to run
185 virtual machines on x86 systems, together with the kernel-xen*
186 packages. Information on how to use Xen can be found at the Xen
187 project pages.
188
189 Virtualisation can be used to run multiple versions or multiple Linux
190 distributions on one system, or to test untrusted applications in a
191 sandboxed environment. Note that the Xen technology is still in
192 development, and this RPM has received extremely little testing. Don't
193 be surprised if this RPM eats your data, drinks your coffee or makes
194 fun of you in front of your friends.
195
196 %description -l pl.UTF-8
197 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
198 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
199 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
200 projektu.
201
202 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
203 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
204 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
205 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
206 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
207 się wyśmiewał w obecności przyjaciół.
208
209 %package guest
210 Summary:        Xen tools for virtual machines
211 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
212 Group:          Applications/System
213 Requires:       %{name}-libs-guest = %{version}-%{release}
214
215 %description guest
216 Xen utilities for both dom0 and domU virtual domains.
217
218 %description guest -l pl.UTF-8
219 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
220
221 %package libs
222 Summary:        Xen libraries
223 Summary(pl.UTF-8):      Biblioteki Xena
224 Group:          Libraries
225 Requires:       %{name}-libs-guest = %{version}-%{release}
226
227 %description libs
228 Xen libraries.
229
230 %description libs -l pl.UTF-8
231 Biblioteki Xena.
232
233 %package libs-guest
234 Summary:        Xen libraries for virtual machines
235 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
236 Group:          Libraries
237
238 %description libs-guest
239 Xen libraries for both dom0 and domU virtual machines.
240
241 %description libs-guest -l pl.UTF-8
242 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
243
244 %package devel
245 Summary:        Header files for Xen
246 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
247 Group:          Development/Libraries
248 Requires:       %{name}-libs = %{version}-%{release}
249
250 %description devel
251 Header files for Xen.
252
253 %description devel -l pl.UTF-8
254 Pliki nagłówkowe Xena.
255
256 %package static
257 Summary:        Static Xen libraries
258 Summary(pl.UTF-8):      Statyczne biblioteki Xena
259 Group:          Development/Libraries
260 Requires:       %{name}-devel = %{version}-%{release}
261
262 %description static
263 Static Xen libraries.
264
265 %description static -l pl.UTF-8
266 Statyczne biblioteki Xena.
267
268 %package xend
269 Summary:        xend daemon
270 Summary(pl.UTF-8):      Demon xend
271 Group:          Daemons
272 Requires(post,preun,postun):    systemd-units >= 38
273 Requires:       systemd-units >= 38
274
275 %description xend
276 xend daemon.
277
278 %description xend -l pl.UTF-8
279 Demon xend.
280
281 %package -n ocaml-xen
282 Summary:        OCaml bindings for Xen
283 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
284 License:        LGPL v2.1 with linking exception
285 Group:          Libraries
286 Requires:       %{name}-libs = %{version}-%{release}
287 %if %{with ocaml}
288 %requires_eq    ocaml-runtime
289 %endif
290
291 %description -n ocaml-xen
292 OCaml bindings for Xen.
293
294 %description -n ocaml-xen -l pl.UTF-8
295 Wiązania OCamla dla Xena.
296
297 %package -n ocaml-xen-devel
298 Summary:        OCaml bindings for Xen - development files
299 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
300 License:        LGPL v2.1 with linking exception
301 Group:          Development/Libraries
302 Requires:       ocaml-xen = %{version}-%{release}
303 %if %{with ocaml}
304 %requires_eq    ocaml
305 %endif
306
307 %description -n ocaml-xen-devel
308 OCaml bindings for Xen - development files.
309
310 %description -n ocaml-xen-devel -l pl.UTF-8
311 Wiązania OCamla dla Xena - pliki programistyczne.
312
313 %package -n python-xen
314 Summary:        Xen Python modules
315 Summary(pl.UTF-8):      Moduły Pythona dla Xena
316 Group:          Libraries
317 Requires:       %{name}-libs = %{version}-%{release}
318 Conflicts:      xen < 3.2.1-0.3
319
320 %description -n python-xen
321 Xen Python modules.
322
323 %description -n python-xen -l pl.UTF-8
324 Moduły Pythona dla Xena.
325
326 %package -n python-xen-guest
327 Summary:        Xen Python modules for virtual machines
328 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
329 Group:          Libraries
330 Requires:       %{name}-libs-guest = %{version}-%{release}
331 Conflicts:      xen < 3.2.1-0.3
332
333 %description -n python-xen-guest
334 Xen Python modules for both dom0 and domU virtual machines.
335
336 %description -n python-xen-guest -l pl.UTF-8
337 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
338
339 %package -n bash-completion-%{name}
340 Summary:    bash-completion for Xen (xl)
341 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
342 Group:      Applications/Shells
343 Requires:   %{name} = %{version}-%{release}
344 Requires:   bash-completion
345
346 %description -n bash-completion-%{name}
347 This package provides bash-completion for Xen (xl).
348
349 %description -n bash-completion-%{name} -l pl.UTF-8
350 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
351
352 %package efi
353 Summary:        Xen hypervisor binary for EFI
354 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
355 Group:          Applications/System
356 Requires:       %{name}-libs-guest = %{version}-%{release}
357
358 %description efi
359 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
360 firmware without help from any additional bootloader.
361
362 %description efi -l pl.UTF-8
363 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
364 (U)EFI, bez potrzeby oddzielnego bootloadera.
365
366 %prep
367 %setup -q -a 16
368 %patch0 -p1
369 %patch1 -p1
370 %patch2 -p1
371 %patch3 -p1
372 %patch4 -p1
373 %patch5 -p1
374 %patch6 -p1
375 %patch7 -p1
376 %patch8 -p1
377 %patch9 -p1
378 %patch10 -p1
379 %patch11 -p1
380 %patch12 -p1
381 %patch13 -p1
382 %patch14 -p1
383 %patch15 -p1
384
385 # stubdom sources
386 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
387 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
388
389 # do not allow fetching anything via git
390 echo GIT=/bin/false >> Config.mk
391
392 %build
393 # if gold is used then bioses and grub doesn't build
394 install -d our-ld
395 ln -s /usr/bin/ld.bfd our-ld/ld
396 export PATH=$(pwd)/our-ld:$PATH
397
398 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
399 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
400
401 # NOTE:
402 # - there is a quoting bug (in tools/driver/Makefile) that causes
403 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
404 #   anyway (see configure), gcrypt is optional
405 # - prevent libiconv from being detected (not needed with glibc)
406 cd tools
407 %configure \
408         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
409         ac_cv_lib_iconv_libiconv_open=no \
410         --disable-debug
411 cd ..
412
413 %{__make} dist-xen dist-tools dist-docs \
414         %{!?with_ocaml:OCAML_TOOLS=n} \
415         prefix=%{_prefix} \
416         CC="%{__cc}" \
417         CXX="%{__cxx}" \
418         V=1
419
420 unset CFLAGS
421 unset CXXFLAGS
422
423 %{__make} -j1 dist-stubdom \
424         %{!?with_ocaml:OCAML_TOOLS=n} \
425         CC="%{__cc}" \
426         CXX="%{__cxx}" \
427         V=1
428
429 %install
430 rm -rf $RPM_BUILD_ROOT
431 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
432         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
433         $RPM_BUILD_ROOT/etc/efi-boot/update.d
434
435 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
436         %{!?with_ocaml:OCAML_TOOLS=n} \
437         prefix=%{_prefix} \
438         DESTDIR=$RPM_BUILD_ROOT \
439         HOTPLUGS=install-udev
440
441 %if "%{_lib}" == "lib64"
442 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
443 %endif
444
445 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
446 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
447 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
448 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
449 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
450 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
451 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
452 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
453 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
454 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
455 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
456 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
457 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
458 # sysvinit scripts
459 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
460 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
461 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
462 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
463 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
464 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
465 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
466 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
467
468 %if %{with efi}
469 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
470 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
471                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
472 %endif
473
474 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
475
476 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
477
478 # for %%doc
479 install -d _doc
480 for tool in blktap blktap2 pygrub xenmon ; do
481         cp -p tools/$tool/README _doc/README.$tool
482 done
483 cp -al tools/qemu-xen/docs _doc/qemu-xen
484
485 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
486 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
487
488 %py_postclean
489
490 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
491 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
492 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
493 # seems not needed, the path is wrong anyway
494 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
495
496 # remove unneeded files
497 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
498 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
499 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
500 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
501 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %post
507 /sbin/chkconfig --add xen-watchdog
508 /sbin/chkconfig --add xenconsoled
509 /sbin/chkconfig --add xenstored
510 /sbin/chkconfig --add xendomains
511 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
512
513 %preun
514 if [ "$1" = "0" ]; then
515         %service xendomains stop
516         /sbin/chkconfig --del xendomains
517
518         %service xenconsoled stop
519         /sbin/chkconfig --del xenconsoled
520
521         %service xenstored stop
522         /sbin/chkconfig --del xenstored
523
524         %service xen-watchdog stop
525         /sbin/chkconfig --del xen-watchdog
526 fi
527 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
528
529 %postun
530 %systemd_reload
531
532 %post xend
533 /sbin/chkconfig --add xend
534 %systemd_post xend.service
535
536 %preun xend
537 if [ "$1" = "0" ]; then
538         %service xend stop
539         /sbin/chkconfig --del xend
540 fi
541 %systemd_preun xend.service
542
543 %postun xend
544 %systemd_reload
545
546 %post   libs -p /sbin/ldconfig
547 %postun libs -p /sbin/ldconfig
548
549 %post   libs-guest -p /sbin/ldconfig
550 %postun libs-guest -p /sbin/ldconfig
551
552 %post efi
553 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
554
555 %files
556 %defattr(644,root,root,755)
557 %doc COPYING README* docs/misc/* 
558 %doc docs/html/*
559 %doc tools/qemu-xen-dir/*.html
560 %doc _doc/*
561 /boot/%{name}-syms-%{version}
562 /boot/%{name}-%{version}.gz
563 /boot/%{name}.gz
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
565 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
566 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
567 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
568 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
569 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
570 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
571 %attr(754,root,root) /etc/rc.d/init.d/xenstored
572 %attr(754,root,root) /etc/rc.d/init.d/xendomains
573 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
574 %{systemdunitdir}/proc-xen.mount
575 %{systemdunitdir}/var-lib-xenstored.mount
576 %{systemdunitdir}/xen-watchdog.service
577 %{systemdunitdir}/xenconsoled.service
578 %{systemdunitdir}/xenstored.service
579 %dir %{_sysconfdir}/xen
580 %dir %{_sysconfdir}/xen/auto
581 %dir %{_sysconfdir}/xen/examples
582 %dir %{_sysconfdir}/xen/scripts
583 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
585 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
586 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
588 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
589 %attr(755,root,root) %{_bindir}/pygrub
590 %attr(755,root,root) %{_bindir}/qemu-img-xen
591 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
592 %attr(755,root,root) %{_bindir}/remus
593 %attr(755,root,root) %{_bindir}/xencons
594 %attr(755,root,root) %{_bindir}/xentrace*
595 %attr(755,root,root) %{_sbindir}/blktapctrl
596 %attr(755,root,root) %{_sbindir}/flask-*
597 %attr(755,root,root) %{_sbindir}/gdbsx
598 %attr(755,root,root) %{_sbindir}/gtrace*
599 %attr(755,root,root) %{_sbindir}/img2qcow
600 %attr(755,root,root) %{_sbindir}/kdd
601 %attr(755,root,root) %{_sbindir}/lock-util
602 %attr(755,root,root) %{_sbindir}/qcow-create
603 %attr(755,root,root) %{_sbindir}/qcow2raw
604 %attr(755,root,root) %{_sbindir}/tap-ctl
605 %attr(755,root,root) %{_sbindir}/tapdisk*
606 %attr(755,root,root) %{_sbindir}/td-util
607 %attr(755,root,root) %{_sbindir}/vhd-*
608 %attr(755,root,root) %{_sbindir}/xen-*
609 %attr(755,root,root) %{_sbindir}/xenbaked
610 %attr(755,root,root) %{_sbindir}/xenconsoled
611 %attr(755,root,root) %{_sbindir}/xenlockprof
612 %attr(755,root,root) %{_sbindir}/xenmon.py
613 %attr(755,root,root) %{_sbindir}/xenperf
614 %attr(755,root,root) %{_sbindir}/xenpm
615 %attr(755,root,root) %{_sbindir}/xenpmd
616 %attr(755,root,root) %{_sbindir}/xenstored
617 %attr(755,root,root) %{_sbindir}/xentop
618 %attr(755,root,root) %{_sbindir}/xentrace_setmask
619 %attr(755,root,root) %{_sbindir}/xenwatchdogd
620 %attr(755,root,root) %{_sbindir}/xl
621 %attr(755,root,root) %{_sbindir}/xsview
622 %dir %{_libdir}/%{name}
623 %dir %{_libdir}/%{name}/bin
624 %attr(744,root,root) %{_libdir}/%{name}/bin/*
625 %if "%{_lib}" != "lib"
626 %dir %{_prefix}/lib/%{name}
627 %dir %{_prefix}/lib/%{name}/bin
628 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
629 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
630 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
631 %endif
632 %dir %{_prefix}/lib/%{name}/boot
633 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
634 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
635 %ifarch %{x8664}
636 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
637 %endif
638 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
639 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
640 %{_datadir}/xen
641 %{_mandir}/man1/qemu-img-xen.1*
642 %{_mandir}/man1/xentop.1*
643 %{_mandir}/man1/xentrace_format.1*
644 %{_mandir}/man1/xl.1*
645 %{_mandir}/man1/xm.1*
646 %{_mandir}/man5/xend-config.sxp.5*
647 %{_mandir}/man5/xl.cfg.5*
648 %{_mandir}/man5/xl.conf.5*
649 %{_mandir}/man5/xlcpupool.cfg.5*
650 %{_mandir}/man5/xmdomain.cfg.5*
651 %{_mandir}/man8/qemu-nbd-xen.8*
652 %{_mandir}/man8/xentrace.8*
653 %{_sharedstatedir}/xen
654 %{_sharedstatedir}/xenstored
655 %dir /var/run/xenstored
656 %{systemdtmpfilesdir}/xenstored.conf
657 %{systemdtmpfilesdir}/xen.conf
658 %dir %attr(0700,root,root) /var/log/xen
659 %dir %attr(0700,root,root) /var/log/xen/console
660 %{_datadir}/qemu-xen
661
662 %files guest
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_bindir}/xen-detect
665 %attr(755,root,root) %{_bindir}/xenstore*
666
667 %files libs
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
671 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
672 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
673 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
675 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
677 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
678 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
679 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
680 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
681 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
682 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
683 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
684 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
685 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
686 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
687 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
688 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
689 %dir %{_libdir}/fs
690 %dir %{_libdir}/fs/ext2fs-lib
691 %dir %{_libdir}/fs/fat
692 %dir %{_libdir}/fs/iso9660
693 %dir %{_libdir}/fs/reiserfs
694 %dir %{_libdir}/fs/ufs
695 %dir %{_libdir}/fs/xfs
696 %dir %{_libdir}/fs/zfs
697 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
698
699 %files libs-guest
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
702 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
703
704 %files devel
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/libblktap.so
707 %attr(755,root,root) %{_libdir}/libblktapctl.so
708 %attr(755,root,root) %{_libdir}/libfsimage.so
709 %attr(755,root,root) %{_libdir}/libvhd.so
710 %attr(755,root,root) %{_libdir}/libxenctrl.so
711 %attr(755,root,root) %{_libdir}/libxenguest.so
712 %attr(755,root,root) %{_libdir}/libxenlight.so
713 %attr(755,root,root) %{_libdir}/libxenstat.so
714 %attr(755,root,root) %{_libdir}/libxenstore.so
715 %attr(755,root,root) %{_libdir}/libxenvchan.so
716 %attr(755,root,root) %{_libdir}/libxlutil.so
717 %{_includedir}/_libxl_list.h
718 %{_includedir}/_libxl_types.h
719 %{_includedir}/_libxl_types_json.h
720 %{_includedir}/blktaplib.h
721 %{_includedir}/fsimage*.h
722 %{_includedir}/libxenvchan.h
723 %{_includedir}/libxl*.h
724 %{_includedir}/xen*.h
725 %{_includedir}/xs*.h
726 %{_includedir}/xen
727 %{_includedir}/xenstore-compat
728
729 %files static
730 %defattr(644,root,root,755)
731 %{_libdir}/libblktap.a
732 %{_libdir}/libblktapctl.a
733 %{_libdir}/libvhd.a
734 %{_libdir}/libxenctrl.a
735 %{_libdir}/libxenguest.a
736 %{_libdir}/libxenlight.a
737 %{_libdir}/libxenvchan.a
738 %{_libdir}/libxenstat.a
739 %{_libdir}/libxenstore.a
740 %{_libdir}/libxlutil.a
741
742 %files xend
743 %defattr(644,root,root,755)
744 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
745 %{systemdunitdir}/blktapctrl.service
746 %{systemdunitdir}/xend.service
747 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
748 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
749 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
750 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
751 %attr(755,root,root) %{_sbindir}/xend
752 %attr(755,root,root) %{_sbindir}/xm
753 %dir %attr(700,root,root) /var/run/xend
754 %{systemdtmpfilesdir}/xend.conf
755
756 %if %{with ocaml}
757 %files -n ocaml-xen
758 %defattr(644,root,root,755)
759 %doc tools/ocaml/LICENSE
760 %attr(755,root,root) %{_sbindir}/oxenstored
761 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
762 %dir %{_libdir}/ocaml/site-lib/xenbus
763 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
764 %dir %{_libdir}/ocaml/site-lib/xenctrl
765 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
766 %dir %{_libdir}/ocaml/site-lib/xeneventchn
767 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
768 %dir %{_libdir}/ocaml/site-lib/xenlight
769 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
770 %dir %{_libdir}/ocaml/site-lib/xenmmap
771 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
772
773 %files -n ocaml-xen-devel
774 %defattr(644,root,root,755)
775 %{_libdir}/ocaml/site-lib/xenbus/META
776 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
777 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
778 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
779 %{_libdir}/ocaml/site-lib/xenctrl/META
780 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
781 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
782 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
783 %{_libdir}/ocaml/site-lib/xeneventchn/META
784 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
785 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
786 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
787 %{_libdir}/ocaml/site-lib/xenmmap/META
788 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
789 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
790 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
791 %{_libdir}/ocaml/site-lib/xenlight/META
792 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
793 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
794 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
795 %dir %{_libdir}/ocaml/site-lib/xenstore
796 %{_libdir}/ocaml/site-lib/xenstore/META
797 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
798 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
799 %endif
800
801 %files -n python-xen
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{py_sitedir}/fsimage.so
804 %{py_sitedir}/grub
805 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
806 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
807 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
808 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
809 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
810 %{py_sitedir}/xen/remus
811 %{py_sitedir}/xen/sv
812 %{py_sitedir}/xen/util
813 %{py_sitedir}/xen/web
814 %{py_sitedir}/xen/xend
815 %{py_sitedir}/xen/xm
816 %{py_sitedir}/xen/xsview
817 %if "%{py_ver}" > "2.4"
818 %{py_sitedir}/pygrub-0.3-py*.egg-info
819 %{py_sitedir}/xen-3.0-py*.egg-info
820 %endif
821
822 %files -n python-xen-guest
823 %defattr(644,root,root,755)
824 %dir %{py_sitedir}/xen
825 %{py_sitedir}/xen/__init__.py*
826 %dir %{py_sitedir}/xen/lowlevel
827 %{py_sitedir}/xen/lowlevel/__init__.py*
828 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
829
830 %files -n bash-completion-%{name}
831 %defattr(644,root,root,755)
832 /etc/bash_completion.d/xl.sh
833
834 %if %{with efi}
835 %files efi
836 %defattr(644,root,root,755)
837 %dir %{_libdir}/efi
838 %{_libdir}/efi/*.efi
839 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
840 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
841 %endif
This page took 0.264363 seconds and 4 git commands to generate.