]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
TODO updates
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.0
33 Release:        1
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  f4f217969afc38f09251039966d91a87
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Patch0:         %{name}-python_scripts.patch
76 Patch1:         %{name}-symbols.patch
77 Patch2:         %{name}-curses.patch
78 Patch3:         pygrubfix.patch
79 Patch4:         xend.catchbt.patch
80 Patch5:         xend-pci-loop.patch
81 Patch6:         xen-dumpdir.patch
82 # Warning: this disables ingress filtering implemented in xen scripts!
83 Patch7:         xen-net-disable-iptables-on-bridge.patch
84 Patch8:         xen-configure-xend.patch
85 Patch9:         xen-initscript.patch
86 Patch10:        xen-quemu-softloat-c99.patch
87 Patch11:        xen-qemu.patch
88 URL:            http://www.xen.org/products/xenhyp.html
89 %{?with_opengl:BuildRequires:   OpenGL-devel}
90 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
91 %ifarch %{ix86} %{x8664}
92 BuildRequires:  acpica
93 BuildRequires:  bcc
94 %endif
95 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
96 %{?with_brlapi:BuildRequires:   brlapi-devel}
97 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
98 BuildRequires:  bzip2-devel
99 BuildRequires:  ceph-devel
100 BuildRequires:  curl-devel
101 BuildRequires:  cyrus-sasl-devel >= 2
102 BuildRequires:  e2fsprogs-devel
103 BuildRequires:  gcc >= 5:3.4
104 BuildRequires:  gettext-devel
105 BuildRequires:  glib2-devel >= 1:2.12
106 BuildRequires:  gnutls-devel
107 BuildRequires:  latex2html >= 2008
108 BuildRequires:  libaio-devel
109 BuildRequires:  libiscsi-devel
110 BuildRequires:  libjpeg-devel
111 BuildRequires:  libpng-devel
112 BuildRequires:  libuuid-devel
113 BuildRequires:  lzo-devel >= 2
114 BuildRequires:  ncurses-devel
115 %if %{with ocaml}
116 BuildRequires:  ocaml >= 3.04-7
117 BuildRequires:  ocaml-findlib
118 %endif
119 BuildRequires:  nss-devel >= 3.12.8
120 BuildRequires:  openssl-devel
121 BuildRequires:  pciutils-devel
122 BuildRequires:  perl-base
123 BuildRequires:  pkgconfig
124 BuildRequires:  python-devel
125 BuildRequires:  rpm-pythonprov
126 BuildRequires:  rpmbuild(macros) >= 1.647
127 BuildRequires:  spice-protocol >= 0.6.0
128 BuildRequires:  spice-server-devel >= 0.6.0
129 BuildRequires:  texi2html
130 BuildRequires:  texlive-dvips
131 BuildRequires:  texlive-latex-psnfss
132 BuildRequires:  texlive-xetex
133 BuildRequires:  usbredir-devel
134 BuildRequires:  vde2-devel
135 BuildRequires:  which
136 # for xfsctl (<xfs/xfs.h>)
137 BuildRequires:  xfsprogs-devel
138 BuildRequires:  xorg-lib-libX11-devel
139 BuildRequires:  xorg-lib-libXext-devel
140 BuildRequires:  xz-devel
141 BuildRequires:  yajl-devel
142 BuildRequires:  zlib-devel
143 # FIXME: see qemu configure comments on top of spec
144 %{!?with_opengl:BuildConflicts: OpenGL-devel}
145 %{!?with_sdl:BuildConflicts:    SDL-devel}
146 %{!?with_sdl:BuildConflicts:    SDL-devel}
147 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
148 %{!?with_brlapi:BuildConflicts: brlapi-devel}
149 Requires(post,preun):   /sbin/chkconfig
150 Requires(post,preun,postun):    systemd-units >= 38
151 Requires:       %{name}-libs = %{version}-%{release}
152 Requires:       ZopeInterface
153 Requires:       bridge-utils
154 Requires:       coreutils
155 Requires:       diffutils
156 Requires:       gawk
157 Requires:       iptables
158 Requires:       losetup
159 Requires:       net-tools
160 Requires:       python-%{name} = %{version}-%{release}
161 Requires:       rc-scripts
162 Requires:       sed
163 Requires:       systemd-units >= 38
164 Requires:       util-linux
165 Requires:       which
166 Requires:       %{name}-guest = %{version}-%{release}
167 Obsoletes:      xen-doc
168 Obsoletes:      xen-udev
169 ExclusiveArch:  %{ix86} %{x8664}
170 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
171
172 # some PPC/SPARC boot images in ELF format
173 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
174
175 %description
176 This package contains the Xen hypervisor and Xen tools, needed to run
177 virtual machines on x86 systems, together with the kernel-xen*
178 packages. Information on how to use Xen can be found at the Xen
179 project pages.
180
181 Virtualisation can be used to run multiple versions or multiple Linux
182 distributions on one system, or to test untrusted applications in a
183 sandboxed environment. Note that the Xen technology is still in
184 development, and this RPM has received extremely little testing. Don't
185 be surprised if this RPM eats your data, drinks your coffee or makes
186 fun of you in front of your friends.
187
188 %description -l pl.UTF-8
189 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
190 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
191 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
192 projektu.
193
194 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
195 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
196 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
197 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
198 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
199 się wyśmiewał w obecności przyjaciół.
200
201 %package guest
202 Summary:        Xen tools for virtual machines
203 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
204 Group:          Applications/System
205 Requires:       %{name}-libs-guest = %{version}-%{release}
206
207 %description guest
208 Xen utilities for both dom0 and domU virtual domains.
209
210 %description guest -l pl.UTF-8
211 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
212
213 %package libs
214 Summary:        Xen libraries
215 Summary(pl.UTF-8):      Biblioteki Xena
216 Group:          Libraries
217 Requires:       %{name}-libs-guest = %{version}-%{release}
218
219 %description libs
220 Xen libraries.
221
222 %description libs -l pl.UTF-8
223 Biblioteki Xena.
224
225 %package libs-guest
226 Summary:        Xen libraries for virtual machines
227 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
228 Group:          Libraries
229
230 %description libs-guest
231 Xen libraries for both dom0 and domU virtual machines.
232
233 %description libs-guest -l pl.UTF-8
234 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
235
236 %package devel
237 Summary:        Header files for Xen
238 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
239 Group:          Development/Libraries
240 Requires:       %{name}-libs = %{version}-%{release}
241
242 %description devel
243 Header files for Xen.
244
245 %description devel -l pl.UTF-8
246 Pliki nagłówkowe Xena.
247
248 %package static
249 Summary:        Static Xen libraries
250 Summary(pl.UTF-8):      Statyczne biblioteki Xena
251 Group:          Development/Libraries
252 Requires:       %{name}-devel = %{version}-%{release}
253
254 %description static
255 Static Xen libraries.
256
257 %description static -l pl.UTF-8
258 Statyczne biblioteki Xena.
259
260 %package xend
261 Summary:        xend daemon
262 Summary(pl.UTF-8):      Demon xend
263 Group:          Daemons
264 Requires(post,preun,postun):    systemd-units >= 38
265 Requires:       systemd-units >= 38
266
267 %description xend
268 xend daemon.
269
270 %description xend -l pl.UTF-8
271 Demon xend.
272
273 %package -n ocaml-xen
274 Summary:        OCaml bindings for Xen
275 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
276 License:        LGPL v2.1 with linking exception
277 Group:          Libraries
278 Requires:       %{name}-libs = %{version}-%{release}
279 %if %{with ocaml}
280 %requires_eq    ocaml-runtime
281 %endif
282
283 %description -n ocaml-xen
284 OCaml bindings for Xen.
285
286 %description -n ocaml-xen -l pl.UTF-8
287 Wiązania OCamla dla Xena.
288
289 %package -n ocaml-xen-devel
290 Summary:        OCaml bindings for Xen - development files
291 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
292 License:        LGPL v2.1 with linking exception
293 Group:          Development/Libraries
294 Requires:       ocaml-xen = %{version}-%{release}
295 %if %{with ocaml}
296 %requires_eq    ocaml
297 %endif
298
299 %description -n ocaml-xen-devel
300 OCaml bindings for Xen - development files.
301
302 %description -n ocaml-xen-devel -l pl.UTF-8
303 Wiązania OCamla dla Xena - pliki programistyczne.
304
305 %package -n python-xen
306 Summary:        Xen Python modules
307 Summary(pl.UTF-8):      Moduły Pythona dla Xena
308 Group:          Libraries
309 Requires:       %{name}-libs = %{version}-%{release}
310 Conflicts:      xen < 3.2.1-0.3
311
312 %description -n python-xen
313 Xen Python modules.
314
315 %description -n python-xen -l pl.UTF-8
316 Moduły Pythona dla Xena.
317
318 %package -n python-xen-guest
319 Summary:        Xen Python modules for virtual machines
320 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
321 Group:          Libraries
322 Requires:       %{name}-libs-guest = %{version}-%{release}
323 Conflicts:      xen < 3.2.1-0.3
324
325 %description -n python-xen-guest
326 Xen Python modules for both dom0 and domU virtual machines.
327
328 %description -n python-xen-guest -l pl.UTF-8
329 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
330
331 %package -n bash-completion-%{name}
332 Summary:    bash-completion for Xen (xl)
333 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
334 Group:      Applications/Shells
335 Requires:   %{name} = %{version}-%{release}
336 Requires:   bash-completion
337
338 %description -n bash-completion-%{name}
339 This package provides bash-completion for Xen (xl).
340
341 %description -n bash-completion-%{name} -l pl.UTF-8
342 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
343
344 %package efi
345 Summary:        Xen hypervisor binary for EFI
346 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
347 Group:          Applications/System
348 Requires:       %{name}-libs-guest = %{version}-%{release}
349
350 %description efi
351 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
352 firmware without help from any additional bootloader.
353
354 %description efi -l pl.UTF-8
355 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
356 (U)EFI, bez potrzeby oddzielnego bootloadera.
357
358 %prep
359 %setup -q -a 16
360 %patch0 -p1
361 %patch1 -p1
362 %patch2 -p1
363 %patch3 -p1
364 %patch4 -p1
365 %patch5 -p1
366 %patch6 -p1
367 %patch7 -p1
368 %patch8 -p1
369 %patch9 -p1
370 %patch10 -p1
371 %patch11 -p1
372
373 # stubdom sources
374 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
375 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
376
377 # do not allow fetching anything via git
378 echo GIT=/bin/false >> Config.mk
379
380 %build
381 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
382 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
383
384 # NOTE:
385 # - there is a quoting bug (in tools/driver/Makefile) that causes
386 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
387 #   anyway (see configure), gcrypt is optional
388 # - prevent libiconv from being detected (not needed with glibc)
389 cd tools
390 %configure \
391         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
392         ac_cv_lib_iconv_libiconv_open=no \
393         --disable-debug
394 cd ..
395
396 %{__make} dist-xen dist-tools dist-docs \
397         %{!?with_ocaml:OCAML_TOOLS=n} \
398         prefix=%{_prefix} \
399         CC="%{__cc}" \
400         CXX="%{__cxx}" \
401         V=1
402
403 unset CFLAGS
404 unset CXXFLAGS
405
406 %{__make} -j1 dist-stubdom \
407         %{!?with_ocaml:OCAML_TOOLS=n} \
408         CC="%{__cc}" \
409         CXX="%{__cxx}" \
410         V=1
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
415         $RPM_BUILD_ROOT{/usr/lib/tmpfiles.d,%{systemdunitdir},/var/log/xen/console}
416
417 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
418         %{!?with_ocaml:OCAML_TOOLS=n} \
419         prefix=%{_prefix} \
420         DESTDIR=$RPM_BUILD_ROOT \
421         HOTPLUGS=install-udev
422
423 %if "%{_lib}" == "lib64"
424 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
425 %endif
426
427 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
428 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
429 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
430 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
431 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
432 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
433 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
434 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
435 install %{SOURCE38} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/xenstored.conf
436 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
437 install %{SOURCE40} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/xend.conf
438 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
439 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
440 # sysvinit scripts
441 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
442 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
443 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
444 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
445 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
446 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
447 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
448
449 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
450
451 # for %%doc
452 install -d _doc
453 for tool in blktap blktap2 pygrub xenmon ; do
454         cp -p tools/$tool/README _doc/README.$tool
455 done
456 cp -al tools/qemu-xen/docs _doc/qemu-xen
457
458 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
459 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
460
461 %py_postclean
462
463 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
464 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
465 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
466 # seems not needed, the path is wrong anyway
467 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
468
469 # remove unneeded files
470 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
471 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
472 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
473 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
474 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
475
476 %clean
477 rm -rf $RPM_BUILD_ROOT
478
479 %post
480 /sbin/chkconfig --add xen-watchdog
481 /sbin/chkconfig --add xenconsoled
482 /sbin/chkconfig --add xenstored
483 /sbin/chkconfig --add xendomains
484 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
485
486 %preun
487 if [ "$1" = "0" ]; then
488         %service xendomains stop
489         /sbin/chkconfig --del xendomains
490
491         %service xenconsoled stop
492         /sbin/chkconfig --del xenconsoled
493
494         %service xenstored stop
495         /sbin/chkconfig --del xenstored
496
497         %service xen-watchdog stop
498         /sbin/chkconfig --del xen-watchdog
499 fi
500 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
501
502 %postun
503 %systemd_reload
504
505 %post xend
506 /sbin/chkconfig --add xend
507 %systemd_post xend.service
508
509 %preun xend
510 if [ "$1" = "0" ]; then
511         %service xend stop
512         /sbin/chkconfig --del xend
513 fi
514 %systemd_preun xend.service
515
516 %postun xend
517 %systemd_reload
518
519 %post   libs -p /sbin/ldconfig
520 %postun libs -p /sbin/ldconfig
521
522 %post   libs-guest -p /sbin/ldconfig
523 %postun libs-guest -p /sbin/ldconfig
524
525 %files
526 %defattr(644,root,root,755)
527 %doc COPYING README* docs/misc/* 
528 %doc docs/html/*
529 %doc tools/qemu-xen-dir/*.html
530 %doc _doc/*
531 /boot/%{name}-syms-%{version}
532 /boot/%{name}-%{version}.gz
533 /boot/%{name}.gz
534 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
535 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
536 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
537 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
539 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
540 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
541 %attr(754,root,root) /etc/rc.d/init.d/xenstored
542 %attr(754,root,root) /etc/rc.d/init.d/xendomains
543 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
544 %{systemdunitdir}/proc-xen.mount
545 %{systemdunitdir}/var-lib-xenstored.mount
546 %{systemdunitdir}/xen-watchdog.service
547 %{systemdunitdir}/xenconsoled.service
548 %{systemdunitdir}/xenstored.service
549 %dir %{_sysconfdir}/xen
550 %dir %{_sysconfdir}/xen/auto
551 %dir %{_sysconfdir}/xen/examples
552 %dir %{_sysconfdir}/xen/scripts
553 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
557 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
558 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
559 %attr(755,root,root) %{_bindir}/pygrub
560 %attr(755,root,root) %{_bindir}/qemu-img-xen
561 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
562 %attr(755,root,root) %{_bindir}/remus
563 %attr(755,root,root) %{_bindir}/xencons
564 %attr(755,root,root) %{_bindir}/xentrace*
565 %attr(755,root,root) %{_sbindir}/blktapctrl
566 %attr(755,root,root) %{_sbindir}/flask-*
567 %attr(755,root,root) %{_sbindir}/gdbsx
568 %attr(755,root,root) %{_sbindir}/gtrace*
569 %attr(755,root,root) %{_sbindir}/img2qcow
570 %attr(755,root,root) %{_sbindir}/kdd
571 %attr(755,root,root) %{_sbindir}/lock-util
572 %attr(755,root,root) %{_sbindir}/qcow-create
573 %attr(755,root,root) %{_sbindir}/qcow2raw
574 %attr(755,root,root) %{_sbindir}/tap-ctl
575 %attr(755,root,root) %{_sbindir}/tapdisk*
576 %attr(755,root,root) %{_sbindir}/td-util
577 %attr(755,root,root) %{_sbindir}/vhd-*
578 %attr(755,root,root) %{_sbindir}/xen-*
579 %attr(755,root,root) %{_sbindir}/xenbaked
580 %attr(755,root,root) %{_sbindir}/xenconsoled
581 %attr(755,root,root) %{_sbindir}/xenlockprof
582 %attr(755,root,root) %{_sbindir}/xenmon.py
583 %attr(755,root,root) %{_sbindir}/xenperf
584 %attr(755,root,root) %{_sbindir}/xenpm
585 %attr(755,root,root) %{_sbindir}/xenpmd
586 %attr(755,root,root) %{_sbindir}/xenstored
587 %attr(755,root,root) %{_sbindir}/xentop
588 %attr(755,root,root) %{_sbindir}/xentrace_setmask
589 %attr(755,root,root) %{_sbindir}/xenwatchdogd
590 %attr(755,root,root) %{_sbindir}/xl
591 %attr(755,root,root) %{_sbindir}/xsview
592 %dir %{_libdir}/%{name}
593 %dir %{_libdir}/%{name}/bin
594 %attr(744,root,root) %{_libdir}/%{name}/bin/*
595 %if "%{_lib}" != "lib"
596 %dir %{_prefix}/lib/%{name}
597 %dir %{_prefix}/lib/%{name}/bin
598 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
599 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
600 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
601 %endif
602 %dir %{_prefix}/lib/%{name}/boot
603 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
604 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
605 %ifarch %{x8664}
606 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
607 %endif
608 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
609 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
610 %{_datadir}/xen
611 %{_mandir}/man1/qemu-img-xen.1*
612 %{_mandir}/man1/xentop.1*
613 %{_mandir}/man1/xentrace_format.1*
614 %{_mandir}/man1/xl.1*
615 %{_mandir}/man1/xm.1*
616 %{_mandir}/man5/xend-config.sxp.5*
617 %{_mandir}/man5/xl.cfg.5*
618 %{_mandir}/man5/xl.conf.5*
619 %{_mandir}/man5/xlcpupool.cfg.5*
620 %{_mandir}/man5/xmdomain.cfg.5*
621 %{_mandir}/man8/qemu-nbd-xen.8*
622 %{_mandir}/man8/xentrace.8*
623 %{_sharedstatedir}/xen
624 %{_sharedstatedir}/xenstored
625 %dir /var/run/xenstored
626 %{systemdtmpfilesdir}/xenstored.conf
627 %dir %attr(0700,root,root) /var/log/xen
628 %dir %attr(0700,root,root) /var/log/xen/console
629 %{_datadir}/qemu-xen
630
631 %files guest
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_bindir}/xen-detect
634 %attr(755,root,root) %{_bindir}/xenstore*
635
636 %files libs
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
640 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
642 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
644 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
646 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
648 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
650 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
652 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
654 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
656 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
657 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
658 %dir %{_libdir}/fs
659 %dir %{_libdir}/fs/ext2fs-lib
660 %dir %{_libdir}/fs/fat
661 %dir %{_libdir}/fs/iso9660
662 %dir %{_libdir}/fs/reiserfs
663 %dir %{_libdir}/fs/ufs
664 %dir %{_libdir}/fs/xfs
665 %dir %{_libdir}/fs/zfs
666 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
667
668 %files libs-guest
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
671 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
672
673 %files devel
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/libblktap.so
676 %attr(755,root,root) %{_libdir}/libblktapctl.so
677 %attr(755,root,root) %{_libdir}/libfsimage.so
678 %attr(755,root,root) %{_libdir}/libvhd.so
679 %attr(755,root,root) %{_libdir}/libxenctrl.so
680 %attr(755,root,root) %{_libdir}/libxenguest.so
681 %attr(755,root,root) %{_libdir}/libxenlight.so
682 %attr(755,root,root) %{_libdir}/libxenstat.so
683 %attr(755,root,root) %{_libdir}/libxenstore.so
684 %attr(755,root,root) %{_libdir}/libxenvchan.so
685 %attr(755,root,root) %{_libdir}/libxlutil.so
686 %{_includedir}/_libxl_list.h
687 %{_includedir}/_libxl_types.h
688 %{_includedir}/_libxl_types_json.h
689 %{_includedir}/blktaplib.h
690 %{_includedir}/fsimage*.h
691 %{_includedir}/libxenvchan.h
692 %{_includedir}/libxl*.h
693 %{_includedir}/xen*.h
694 %{_includedir}/xs*.h
695 %{_includedir}/xen
696 %{_includedir}/xenstore-compat
697
698 %files static
699 %defattr(644,root,root,755)
700 %{_libdir}/libblktap.a
701 %{_libdir}/libblktapctl.a
702 %{_libdir}/libvhd.a
703 %{_libdir}/libxenctrl.a
704 %{_libdir}/libxenguest.a
705 %{_libdir}/libxenlight.a
706 %{_libdir}/libxenvchan.a
707 %{_libdir}/libxenstat.a
708 %{_libdir}/libxenstore.a
709 %{_libdir}/libxlutil.a
710
711 %files xend
712 %defattr(644,root,root,755)
713 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
714 %{systemdunitdir}/blktapctrl.service
715 %{systemdunitdir}/xend.service
716 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
717 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
718 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
719 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
720 %attr(755,root,root) %{_sbindir}/xend
721 %attr(755,root,root) %{_sbindir}/xm
722 %dir %attr(700,root,root) /var/run/xend
723 %{systemdtmpfilesdir}/xend.conf
724
725 %if %{with ocaml}
726 %files -n ocaml-xen
727 %defattr(644,root,root,755)
728 %doc tools/ocaml/LICENSE
729 %attr(755,root,root) %{_sbindir}/oxenstored
730 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
731 %dir %{_libdir}/ocaml/site-lib/xenbus
732 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
733 %dir %{_libdir}/ocaml/site-lib/xenctrl
734 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
735 %dir %{_libdir}/ocaml/site-lib/xeneventchn
736 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
737 %dir %{_libdir}/ocaml/site-lib/xenlight
738 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
739 %dir %{_libdir}/ocaml/site-lib/xenmmap
740 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
741
742 %files -n ocaml-xen-devel
743 %defattr(644,root,root,755)
744 %{_libdir}/ocaml/site-lib/xenbus/META
745 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
746 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
747 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
748 %{_libdir}/ocaml/site-lib/xenctrl/META
749 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
750 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
751 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
752 %{_libdir}/ocaml/site-lib/xeneventchn/META
753 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
754 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
755 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
756 %{_libdir}/ocaml/site-lib/xenmmap/META
757 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
758 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
759 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
760 %{_libdir}/ocaml/site-lib/xenlight/META
761 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
762 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
763 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
764 %dir %{_libdir}/ocaml/site-lib/xenstore
765 %{_libdir}/ocaml/site-lib/xenstore/META
766 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
767 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
768 %endif
769
770 %files -n python-xen
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{py_sitedir}/fsimage.so
773 %{py_sitedir}/grub
774 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
775 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
776 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
777 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
778 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
779 %{py_sitedir}/xen/remus
780 %{py_sitedir}/xen/sv
781 %{py_sitedir}/xen/util
782 %{py_sitedir}/xen/web
783 %{py_sitedir}/xen/xend
784 %{py_sitedir}/xen/xm
785 %{py_sitedir}/xen/xsview
786 %if "%{py_ver}" > "2.4"
787 %{py_sitedir}/pygrub-0.3-py*.egg-info
788 %{py_sitedir}/xen-3.0-py*.egg-info
789 %endif
790
791 %files -n python-xen-guest
792 %defattr(644,root,root,755)
793 %dir %{py_sitedir}/xen
794 %{py_sitedir}/xen/__init__.py*
795 %dir %{py_sitedir}/xen/lowlevel
796 %{py_sitedir}/xen/lowlevel/__init__.py*
797 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
798
799 %files -n bash-completion-%{name}
800 %defattr(644,root,root,755)
801 /etc/bash_completion.d/xl.sh
802
803 %if %{with efi}
804 %files efi
805 %defattr(644,root,root,755)
806 %dir %{_libdir}/efi
807 %{_libdir}/efi/*.efi
808 %endif
This page took 0.145764 seconds and 4 git commands to generate.