]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
Use the %%{systemdtmpfilesdir} macro
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.0
33 Release:        2
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  f4f217969afc38f09251039966d91a87
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Patch0:         %{name}-python_scripts.patch
77 Patch1:         %{name}-symbols.patch
78 Patch2:         %{name}-curses.patch
79 Patch3:         pygrubfix.patch
80 Patch4:         xend.catchbt.patch
81 Patch5:         xend-pci-loop.patch
82 Patch6:         xen-dumpdir.patch
83 # Warning: this disables ingress filtering implemented in xen scripts!
84 Patch7:         xen-net-disable-iptables-on-bridge.patch
85 Patch8:         xen-configure-xend.patch
86 Patch9:         xen-initscript.patch
87 Patch10:        xen-quemu-softloat-c99.patch
88 Patch11:        xen-qemu.patch
89 Patch12:        xen-scripts-locking.patch
90 URL:            http://www.xen.org/products/xenhyp.html
91 %{?with_opengl:BuildRequires:   OpenGL-devel}
92 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
93 %ifarch %{ix86} %{x8664}
94 BuildRequires:  acpica
95 BuildRequires:  bcc
96 %endif
97 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
98 %{?with_brlapi:BuildRequires:   brlapi-devel}
99 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
100 BuildRequires:  bzip2-devel
101 BuildRequires:  ceph-devel
102 BuildRequires:  curl-devel
103 BuildRequires:  cyrus-sasl-devel >= 2
104 BuildRequires:  e2fsprogs-devel
105 BuildRequires:  gcc >= 5:3.4
106 BuildRequires:  gettext-devel
107 BuildRequires:  glib2-devel >= 1:2.12
108 BuildRequires:  gnutls-devel
109 BuildRequires:  latex2html >= 2008
110 BuildRequires:  libaio-devel
111 BuildRequires:  libiscsi-devel
112 BuildRequires:  libjpeg-devel
113 BuildRequires:  libpng-devel
114 BuildRequires:  libuuid-devel
115 BuildRequires:  lzo-devel >= 2
116 BuildRequires:  ncurses-devel
117 %if %{with ocaml}
118 BuildRequires:  ocaml >= 3.04-7
119 BuildRequires:  ocaml-findlib
120 %endif
121 BuildRequires:  nss-devel >= 3.12.8
122 BuildRequires:  openssl-devel
123 BuildRequires:  pciutils-devel
124 BuildRequires:  perl-base
125 BuildRequires:  pkgconfig
126 BuildRequires:  python-devel
127 BuildRequires:  rpm-pythonprov
128 BuildRequires:  rpmbuild(macros) >= 1.647
129 BuildRequires:  spice-protocol >= 0.6.0
130 BuildRequires:  spice-server-devel >= 0.6.0
131 BuildRequires:  texi2html
132 BuildRequires:  texlive-dvips
133 BuildRequires:  texlive-latex-psnfss
134 BuildRequires:  texlive-xetex
135 BuildRequires:  usbredir-devel
136 BuildRequires:  vde2-devel
137 BuildRequires:  which
138 # for xfsctl (<xfs/xfs.h>)
139 BuildRequires:  xfsprogs-devel
140 BuildRequires:  xorg-lib-libX11-devel
141 BuildRequires:  xorg-lib-libXext-devel
142 BuildRequires:  xz-devel
143 BuildRequires:  yajl-devel
144 BuildRequires:  zlib-devel
145 # FIXME: see qemu configure comments on top of spec
146 %{!?with_opengl:BuildConflicts: OpenGL-devel}
147 %{!?with_sdl:BuildConflicts:    SDL-devel}
148 %{!?with_sdl:BuildConflicts:    SDL-devel}
149 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
150 %{!?with_brlapi:BuildConflicts: brlapi-devel}
151 Requires(post,preun):   /sbin/chkconfig
152 Requires(post,preun,postun):    systemd-units >= 38
153 Requires:       %{name}-libs = %{version}-%{release}
154 Requires:       ZopeInterface
155 Requires:       bridge-utils
156 Requires:       coreutils
157 Requires:       diffutils
158 Requires:       gawk
159 Requires:       iptables
160 Requires:       losetup
161 Requires:       net-tools
162 Requires:       python-%{name} = %{version}-%{release}
163 Requires:       rc-scripts
164 Requires:       sed
165 Requires:       systemd-units >= 38
166 Requires:       util-linux
167 Requires:       which
168 Requires:       %{name}-guest = %{version}-%{release}
169 Obsoletes:      xen-doc
170 Obsoletes:      xen-udev
171 ExclusiveArch:  %{ix86} %{x8664}
172 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
173
174 # some PPC/SPARC boot images in ELF format
175 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
176
177 %description
178 This package contains the Xen hypervisor and Xen tools, needed to run
179 virtual machines on x86 systems, together with the kernel-xen*
180 packages. Information on how to use Xen can be found at the Xen
181 project pages.
182
183 Virtualisation can be used to run multiple versions or multiple Linux
184 distributions on one system, or to test untrusted applications in a
185 sandboxed environment. Note that the Xen technology is still in
186 development, and this RPM has received extremely little testing. Don't
187 be surprised if this RPM eats your data, drinks your coffee or makes
188 fun of you in front of your friends.
189
190 %description -l pl.UTF-8
191 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
192 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
193 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
194 projektu.
195
196 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
197 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
198 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
199 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
200 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
201 się wyśmiewał w obecności przyjaciół.
202
203 %package guest
204 Summary:        Xen tools for virtual machines
205 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
206 Group:          Applications/System
207 Requires:       %{name}-libs-guest = %{version}-%{release}
208
209 %description guest
210 Xen utilities for both dom0 and domU virtual domains.
211
212 %description guest -l pl.UTF-8
213 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
214
215 %package libs
216 Summary:        Xen libraries
217 Summary(pl.UTF-8):      Biblioteki Xena
218 Group:          Libraries
219 Requires:       %{name}-libs-guest = %{version}-%{release}
220
221 %description libs
222 Xen libraries.
223
224 %description libs -l pl.UTF-8
225 Biblioteki Xena.
226
227 %package libs-guest
228 Summary:        Xen libraries for virtual machines
229 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
230 Group:          Libraries
231
232 %description libs-guest
233 Xen libraries for both dom0 and domU virtual machines.
234
235 %description libs-guest -l pl.UTF-8
236 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
237
238 %package devel
239 Summary:        Header files for Xen
240 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
241 Group:          Development/Libraries
242 Requires:       %{name}-libs = %{version}-%{release}
243
244 %description devel
245 Header files for Xen.
246
247 %description devel -l pl.UTF-8
248 Pliki nagłówkowe Xena.
249
250 %package static
251 Summary:        Static Xen libraries
252 Summary(pl.UTF-8):      Statyczne biblioteki Xena
253 Group:          Development/Libraries
254 Requires:       %{name}-devel = %{version}-%{release}
255
256 %description static
257 Static Xen libraries.
258
259 %description static -l pl.UTF-8
260 Statyczne biblioteki Xena.
261
262 %package xend
263 Summary:        xend daemon
264 Summary(pl.UTF-8):      Demon xend
265 Group:          Daemons
266 Requires(post,preun,postun):    systemd-units >= 38
267 Requires:       systemd-units >= 38
268
269 %description xend
270 xend daemon.
271
272 %description xend -l pl.UTF-8
273 Demon xend.
274
275 %package -n ocaml-xen
276 Summary:        OCaml bindings for Xen
277 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
278 License:        LGPL v2.1 with linking exception
279 Group:          Libraries
280 Requires:       %{name}-libs = %{version}-%{release}
281 %if %{with ocaml}
282 %requires_eq    ocaml-runtime
283 %endif
284
285 %description -n ocaml-xen
286 OCaml bindings for Xen.
287
288 %description -n ocaml-xen -l pl.UTF-8
289 Wiązania OCamla dla Xena.
290
291 %package -n ocaml-xen-devel
292 Summary:        OCaml bindings for Xen - development files
293 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
294 License:        LGPL v2.1 with linking exception
295 Group:          Development/Libraries
296 Requires:       ocaml-xen = %{version}-%{release}
297 %if %{with ocaml}
298 %requires_eq    ocaml
299 %endif
300
301 %description -n ocaml-xen-devel
302 OCaml bindings for Xen - development files.
303
304 %description -n ocaml-xen-devel -l pl.UTF-8
305 Wiązania OCamla dla Xena - pliki programistyczne.
306
307 %package -n python-xen
308 Summary:        Xen Python modules
309 Summary(pl.UTF-8):      Moduły Pythona dla Xena
310 Group:          Libraries
311 Requires:       %{name}-libs = %{version}-%{release}
312 Conflicts:      xen < 3.2.1-0.3
313
314 %description -n python-xen
315 Xen Python modules.
316
317 %description -n python-xen -l pl.UTF-8
318 Moduły Pythona dla Xena.
319
320 %package -n python-xen-guest
321 Summary:        Xen Python modules for virtual machines
322 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
323 Group:          Libraries
324 Requires:       %{name}-libs-guest = %{version}-%{release}
325 Conflicts:      xen < 3.2.1-0.3
326
327 %description -n python-xen-guest
328 Xen Python modules for both dom0 and domU virtual machines.
329
330 %description -n python-xen-guest -l pl.UTF-8
331 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
332
333 %package -n bash-completion-%{name}
334 Summary:    bash-completion for Xen (xl)
335 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
336 Group:      Applications/Shells
337 Requires:   %{name} = %{version}-%{release}
338 Requires:   bash-completion
339
340 %description -n bash-completion-%{name}
341 This package provides bash-completion for Xen (xl).
342
343 %description -n bash-completion-%{name} -l pl.UTF-8
344 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
345
346 %package efi
347 Summary:        Xen hypervisor binary for EFI
348 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
349 Group:          Applications/System
350 Requires:       %{name}-libs-guest = %{version}-%{release}
351
352 %description efi
353 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
354 firmware without help from any additional bootloader.
355
356 %description efi -l pl.UTF-8
357 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
358 (U)EFI, bez potrzeby oddzielnego bootloadera.
359
360 %prep
361 %setup -q -a 16
362 %patch0 -p1
363 %patch1 -p1
364 %patch2 -p1
365 %patch3 -p1
366 %patch4 -p1
367 %patch5 -p1
368 %patch6 -p1
369 %patch7 -p1
370 %patch8 -p1
371 %patch9 -p1
372 %patch10 -p1
373 %patch11 -p1
374 %patch12 -p1
375
376 # stubdom sources
377 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
378 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
379
380 # do not allow fetching anything via git
381 echo GIT=/bin/false >> Config.mk
382
383 %build
384 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
385 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
386
387 # NOTE:
388 # - there is a quoting bug (in tools/driver/Makefile) that causes
389 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
390 #   anyway (see configure), gcrypt is optional
391 # - prevent libiconv from being detected (not needed with glibc)
392 cd tools
393 %configure \
394         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
395         ac_cv_lib_iconv_libiconv_open=no \
396         --disable-debug
397 cd ..
398
399 %{__make} dist-xen dist-tools dist-docs \
400         %{!?with_ocaml:OCAML_TOOLS=n} \
401         prefix=%{_prefix} \
402         CC="%{__cc}" \
403         CXX="%{__cxx}" \
404         V=1
405
406 unset CFLAGS
407 unset CXXFLAGS
408
409 %{__make} -j1 dist-stubdom \
410         %{!?with_ocaml:OCAML_TOOLS=n} \
411         CC="%{__cc}" \
412         CXX="%{__cxx}" \
413         V=1
414
415 %install
416 rm -rf $RPM_BUILD_ROOT
417 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
418         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
419
420 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
421         %{!?with_ocaml:OCAML_TOOLS=n} \
422         prefix=%{_prefix} \
423         DESTDIR=$RPM_BUILD_ROOT \
424         HOTPLUGS=install-udev
425
426 %if "%{_lib}" == "lib64"
427 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
428 %endif
429
430 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
431 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
432 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
433 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
434 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
435 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
436 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
437 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
438 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
439 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
440 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
441 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
442 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
443 # sysvinit scripts
444 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
445 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
446 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
447 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
448 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
449 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
450 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
451 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
452
453 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
454
455 # for %%doc
456 install -d _doc
457 for tool in blktap blktap2 pygrub xenmon ; do
458         cp -p tools/$tool/README _doc/README.$tool
459 done
460 cp -al tools/qemu-xen/docs _doc/qemu-xen
461
462 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
463 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
464
465 %py_postclean
466
467 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
468 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
469 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
470 # seems not needed, the path is wrong anyway
471 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
472
473 # remove unneeded files
474 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
475 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
476 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
477 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
478 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
479
480 %clean
481 rm -rf $RPM_BUILD_ROOT
482
483 %post
484 /sbin/chkconfig --add xen-watchdog
485 /sbin/chkconfig --add xenconsoled
486 /sbin/chkconfig --add xenstored
487 /sbin/chkconfig --add xendomains
488 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
489
490 %preun
491 if [ "$1" = "0" ]; then
492         %service xendomains stop
493         /sbin/chkconfig --del xendomains
494
495         %service xenconsoled stop
496         /sbin/chkconfig --del xenconsoled
497
498         %service xenstored stop
499         /sbin/chkconfig --del xenstored
500
501         %service xen-watchdog stop
502         /sbin/chkconfig --del xen-watchdog
503 fi
504 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
505
506 %postun
507 %systemd_reload
508
509 %post xend
510 /sbin/chkconfig --add xend
511 %systemd_post xend.service
512
513 %preun xend
514 if [ "$1" = "0" ]; then
515         %service xend stop
516         /sbin/chkconfig --del xend
517 fi
518 %systemd_preun xend.service
519
520 %postun xend
521 %systemd_reload
522
523 %post   libs -p /sbin/ldconfig
524 %postun libs -p /sbin/ldconfig
525
526 %post   libs-guest -p /sbin/ldconfig
527 %postun libs-guest -p /sbin/ldconfig
528
529 %files
530 %defattr(644,root,root,755)
531 %doc COPYING README* docs/misc/* 
532 %doc docs/html/*
533 %doc tools/qemu-xen-dir/*.html
534 %doc _doc/*
535 /boot/%{name}-syms-%{version}
536 /boot/%{name}-%{version}.gz
537 /boot/%{name}.gz
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
542 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
543 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
544 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
545 %attr(754,root,root) /etc/rc.d/init.d/xenstored
546 %attr(754,root,root) /etc/rc.d/init.d/xendomains
547 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
548 %{systemdunitdir}/proc-xen.mount
549 %{systemdunitdir}/var-lib-xenstored.mount
550 %{systemdunitdir}/xen-watchdog.service
551 %{systemdunitdir}/xenconsoled.service
552 %{systemdunitdir}/xenstored.service
553 %dir %{_sysconfdir}/xen
554 %dir %{_sysconfdir}/xen/auto
555 %dir %{_sysconfdir}/xen/examples
556 %dir %{_sysconfdir}/xen/scripts
557 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
562 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
563 %attr(755,root,root) %{_bindir}/pygrub
564 %attr(755,root,root) %{_bindir}/qemu-img-xen
565 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
566 %attr(755,root,root) %{_bindir}/remus
567 %attr(755,root,root) %{_bindir}/xencons
568 %attr(755,root,root) %{_bindir}/xentrace*
569 %attr(755,root,root) %{_sbindir}/blktapctrl
570 %attr(755,root,root) %{_sbindir}/flask-*
571 %attr(755,root,root) %{_sbindir}/gdbsx
572 %attr(755,root,root) %{_sbindir}/gtrace*
573 %attr(755,root,root) %{_sbindir}/img2qcow
574 %attr(755,root,root) %{_sbindir}/kdd
575 %attr(755,root,root) %{_sbindir}/lock-util
576 %attr(755,root,root) %{_sbindir}/qcow-create
577 %attr(755,root,root) %{_sbindir}/qcow2raw
578 %attr(755,root,root) %{_sbindir}/tap-ctl
579 %attr(755,root,root) %{_sbindir}/tapdisk*
580 %attr(755,root,root) %{_sbindir}/td-util
581 %attr(755,root,root) %{_sbindir}/vhd-*
582 %attr(755,root,root) %{_sbindir}/xen-*
583 %attr(755,root,root) %{_sbindir}/xenbaked
584 %attr(755,root,root) %{_sbindir}/xenconsoled
585 %attr(755,root,root) %{_sbindir}/xenlockprof
586 %attr(755,root,root) %{_sbindir}/xenmon.py
587 %attr(755,root,root) %{_sbindir}/xenperf
588 %attr(755,root,root) %{_sbindir}/xenpm
589 %attr(755,root,root) %{_sbindir}/xenpmd
590 %attr(755,root,root) %{_sbindir}/xenstored
591 %attr(755,root,root) %{_sbindir}/xentop
592 %attr(755,root,root) %{_sbindir}/xentrace_setmask
593 %attr(755,root,root) %{_sbindir}/xenwatchdogd
594 %attr(755,root,root) %{_sbindir}/xl
595 %attr(755,root,root) %{_sbindir}/xsview
596 %dir %{_libdir}/%{name}
597 %dir %{_libdir}/%{name}/bin
598 %attr(744,root,root) %{_libdir}/%{name}/bin/*
599 %if "%{_lib}" != "lib"
600 %dir %{_prefix}/lib/%{name}
601 %dir %{_prefix}/lib/%{name}/bin
602 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
603 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
604 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
605 %endif
606 %dir %{_prefix}/lib/%{name}/boot
607 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
608 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
609 %ifarch %{x8664}
610 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
611 %endif
612 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
613 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
614 %{_datadir}/xen
615 %{_mandir}/man1/qemu-img-xen.1*
616 %{_mandir}/man1/xentop.1*
617 %{_mandir}/man1/xentrace_format.1*
618 %{_mandir}/man1/xl.1*
619 %{_mandir}/man1/xm.1*
620 %{_mandir}/man5/xend-config.sxp.5*
621 %{_mandir}/man5/xl.cfg.5*
622 %{_mandir}/man5/xl.conf.5*
623 %{_mandir}/man5/xlcpupool.cfg.5*
624 %{_mandir}/man5/xmdomain.cfg.5*
625 %{_mandir}/man8/qemu-nbd-xen.8*
626 %{_mandir}/man8/xentrace.8*
627 %{_sharedstatedir}/xen
628 %{_sharedstatedir}/xenstored
629 %dir /var/run/xenstored
630 %{systemdtmpfilesdir}/xenstored.conf
631 %{systemdtmpfilesdir}/xen.conf
632 %dir %attr(0700,root,root) /var/log/xen
633 %dir %attr(0700,root,root) /var/log/xen/console
634 %{_datadir}/qemu-xen
635
636 %files guest
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/xen-detect
639 %attr(755,root,root) %{_bindir}/xenstore*
640
641 %files libs
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
645 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
647 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
649 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
651 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
653 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
655 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
657 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
659 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
661 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
663 %dir %{_libdir}/fs
664 %dir %{_libdir}/fs/ext2fs-lib
665 %dir %{_libdir}/fs/fat
666 %dir %{_libdir}/fs/iso9660
667 %dir %{_libdir}/fs/reiserfs
668 %dir %{_libdir}/fs/ufs
669 %dir %{_libdir}/fs/xfs
670 %dir %{_libdir}/fs/zfs
671 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
672
673 %files libs-guest
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
677
678 %files devel
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libblktap.so
681 %attr(755,root,root) %{_libdir}/libblktapctl.so
682 %attr(755,root,root) %{_libdir}/libfsimage.so
683 %attr(755,root,root) %{_libdir}/libvhd.so
684 %attr(755,root,root) %{_libdir}/libxenctrl.so
685 %attr(755,root,root) %{_libdir}/libxenguest.so
686 %attr(755,root,root) %{_libdir}/libxenlight.so
687 %attr(755,root,root) %{_libdir}/libxenstat.so
688 %attr(755,root,root) %{_libdir}/libxenstore.so
689 %attr(755,root,root) %{_libdir}/libxenvchan.so
690 %attr(755,root,root) %{_libdir}/libxlutil.so
691 %{_includedir}/_libxl_list.h
692 %{_includedir}/_libxl_types.h
693 %{_includedir}/_libxl_types_json.h
694 %{_includedir}/blktaplib.h
695 %{_includedir}/fsimage*.h
696 %{_includedir}/libxenvchan.h
697 %{_includedir}/libxl*.h
698 %{_includedir}/xen*.h
699 %{_includedir}/xs*.h
700 %{_includedir}/xen
701 %{_includedir}/xenstore-compat
702
703 %files static
704 %defattr(644,root,root,755)
705 %{_libdir}/libblktap.a
706 %{_libdir}/libblktapctl.a
707 %{_libdir}/libvhd.a
708 %{_libdir}/libxenctrl.a
709 %{_libdir}/libxenguest.a
710 %{_libdir}/libxenlight.a
711 %{_libdir}/libxenvchan.a
712 %{_libdir}/libxenstat.a
713 %{_libdir}/libxenstore.a
714 %{_libdir}/libxlutil.a
715
716 %files xend
717 %defattr(644,root,root,755)
718 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
719 %{systemdunitdir}/blktapctrl.service
720 %{systemdunitdir}/xend.service
721 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
722 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
723 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
724 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
725 %attr(755,root,root) %{_sbindir}/xend
726 %attr(755,root,root) %{_sbindir}/xm
727 %dir %attr(700,root,root) /var/run/xend
728 %{systemdtmpfilesdir}/xend.conf
729
730 %if %{with ocaml}
731 %files -n ocaml-xen
732 %defattr(644,root,root,755)
733 %doc tools/ocaml/LICENSE
734 %attr(755,root,root) %{_sbindir}/oxenstored
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
736 %dir %{_libdir}/ocaml/site-lib/xenbus
737 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
738 %dir %{_libdir}/ocaml/site-lib/xenctrl
739 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
740 %dir %{_libdir}/ocaml/site-lib/xeneventchn
741 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
742 %dir %{_libdir}/ocaml/site-lib/xenlight
743 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
744 %dir %{_libdir}/ocaml/site-lib/xenmmap
745 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
746
747 %files -n ocaml-xen-devel
748 %defattr(644,root,root,755)
749 %{_libdir}/ocaml/site-lib/xenbus/META
750 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
751 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
752 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
753 %{_libdir}/ocaml/site-lib/xenctrl/META
754 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
755 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
756 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
757 %{_libdir}/ocaml/site-lib/xeneventchn/META
758 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
759 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
760 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
761 %{_libdir}/ocaml/site-lib/xenmmap/META
762 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
763 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
764 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
765 %{_libdir}/ocaml/site-lib/xenlight/META
766 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
767 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
768 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
769 %dir %{_libdir}/ocaml/site-lib/xenstore
770 %{_libdir}/ocaml/site-lib/xenstore/META
771 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
772 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
773 %endif
774
775 %files -n python-xen
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{py_sitedir}/fsimage.so
778 %{py_sitedir}/grub
779 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
780 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
781 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
782 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
783 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
784 %{py_sitedir}/xen/remus
785 %{py_sitedir}/xen/sv
786 %{py_sitedir}/xen/util
787 %{py_sitedir}/xen/web
788 %{py_sitedir}/xen/xend
789 %{py_sitedir}/xen/xm
790 %{py_sitedir}/xen/xsview
791 %if "%{py_ver}" > "2.4"
792 %{py_sitedir}/pygrub-0.3-py*.egg-info
793 %{py_sitedir}/xen-3.0-py*.egg-info
794 %endif
795
796 %files -n python-xen-guest
797 %defattr(644,root,root,755)
798 %dir %{py_sitedir}/xen
799 %{py_sitedir}/xen/__init__.py*
800 %dir %{py_sitedir}/xen/lowlevel
801 %{py_sitedir}/xen/lowlevel/__init__.py*
802 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
803
804 %files -n bash-completion-%{name}
805 %defattr(644,root,root,755)
806 /etc/bash_completion.d/xl.sh
807
808 %if %{with efi}
809 %files efi
810 %defattr(644,root,root,755)
811 %dir %{_libdir}/efi
812 %{_libdir}/efi/*.efi
813 %endif
This page took 0.146017 seconds and 4 git commands to generate.