]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- patch upstream systemd services to match PLD ones
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
10 #
11 # Conditional build:
12 %bcond_without  qemu_traditional        # without qemu-xen-traditional
13 %bcond_without  opengl                  # OpenGL support in Xen qemu
14 %bcond_without  sdl                     # SDL support in Xen qemu
15 %bcond_without  bluetooth               # bluetooth support in Xen qemu
16 %bcond_without  brlapi                  # brlapi support in Xen qemu
17 %bcond_without  ocaml                   # Ocaml libraries for Xen tools
18 %bcond_without  efi                     # EFI hypervisor
19 %bcond_without  hypervisor              # Xen hypervisor build
20 %bcond_without  stubdom                 # stubdom build
21 %bcond_without  xsm                     # XSM security module (by default, Flask)
22
23 %ifnarch %{x8664} arm
24 %undefine       with_hypervisor
25 %endif
26 %ifnarch %{x8664}
27 %undefine       with_efi
28 %endif
29 %ifnarch %{ix86} %{x8664}
30 %undefine       with_stubdom
31 %endif
32
33 # from ./stubdom/configure.ac
34 %define polarssl_version        1.1.4
35 %define tpm_emulator_version    0.7.4
36 %define gmp_version             4.3.2
37
38 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
39 Summary:        Xen - a virtual machine monitor
40 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
41 Name:           xen
42 Version:        4.6.1
43 Release:        0.1
44 License:        GPL v2, interface parts on BSD-like
45 Group:          Applications/System
46 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
47 # Source0-md5:  df2d854c3c90ffeefaf71e7f868fb326
48 # used by stubdoms
49 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
50 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
51 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
52 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
53 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
54 # Source12-md5: debc62758716a169df9f62e6ab2bc634
55 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
56 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
57 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
58 # Source14-md5: cd3f3eb54446be6003156158d51f4884
59 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
60 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
61 Source17:       %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
62 # Source17-md5: 7b72caf22b01464ee7d6165f2fd85f44
63 Source18:       http://xenbits.xen.org/xen-extfiles/tpm_emulator-%{tpm_emulator_version}.tar.gz
64 # Source18-md5: e26becb8a6a2b6695f6b3e8097593db8
65 Source19:       ftp://ftp.gmplib.org/pub/gmp-%{gmp_version}/gmp-%{gmp_version}.tar.bz2
66 # Source19-md5: dd60683d7057917e34630b4a787932e8
67 Source35:       xenconsoled.sysconfig
68 Source37:       xenstored.sysconfig
69 Source38:       xenstored.tmpfiles
70 Source43:       xendomains.sh
71 # sysvinit scripts
72 Source46:       xen-qemu-dom0-disk-backend.init
73 Source51:       xenconsoled.init
74 Source52:       xenstored.init
75 Source53:       xen-watchdog.init
76 Source54:       xendomains.init
77 Source55:       xen.logrotate
78 Source56:       xen.tmpfiles
79 Source57:       xen.cfg
80 Source58:       xen.efi-boot-update
81 Source59:       vif-openvswitch
82 Source60:       xen-init-list
83 Source61:       xen-toolstack
84 Patch0:         %{name}-python_scripts.patch
85 Patch1:         %{name}-symbols.patch
86 Patch2:         %{name}-curses.patch
87 Patch3:         pygrubfix.patch
88 # Warning: this disables ingress filtering implemented in xen scripts!
89 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
90 Patch9:         %{name}-gawk.patch
91 Patch10:        %{name}-qemu.patch
92 Patch12:        %{name}-doc.patch
93 Patch13:        %{name}-paths.patch
94 Patch14:        %{name}-no_fetcher.patch
95 Patch15:        odd-glib2-fix.patch
96 Patch16:        %{name}-gmp-abi.patch
97 Patch18:        %{name}-make.patch
98 Patch19:        %{name}-no_Werror.patch
99 # http://git.alpinelinux.org/cgit/aports/plain/main/xen/gnutls-3.4.0.patch
100 Patch20:        %{name}-gnutls-3.4.patch
101 Patch21:        %{name}-grep-typo.patch
102 Patch22:        %{name}-stubdom-build.patch
103 Patch23:        link.patch
104 Patch24:        %{name}-systemd.patch
105 URL:            http://www.xen.org/products/xenhyp.html
106 BuildRequires:  autoconf >= 2.67
107 %ifarch %{ix86} %{x8664}
108 BuildRequires:  acpica
109 BuildRequires:  bcc
110 BuildRequires:  bin86
111 %endif
112 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
113 BuildRequires:  bzip2-devel
114 %if %{with xsm}
115 BuildRequires:  checkpolicy
116 %endif
117 BuildRequires:  curl-devel
118 BuildRequires:  cyrus-sasl-devel >= 2
119 BuildRequires:  e2fsprogs-devel
120 BuildRequires:  gcc >= 6:4.1
121 %ifarch %{x8664}
122 BuildRequires:  gcc-multilib-32 >= 6:4.1
123 %endif
124 BuildRequires:  gettext-tools
125 BuildRequires:  glib2-devel >= 1:2.12
126 BuildRequires:  gnutls-devel
127 BuildRequires:  keyutils-devel
128 BuildRequires:  latex2html >= 2008
129 BuildRequires:  libaio-devel
130 BuildRequires:  libcap-devel
131 %ifarch arm aarch64
132 BuildRequires:  libfdt-devel
133 %endif
134 BuildRequires:  libjpeg-devel
135 BuildRequires:  libnl-devel >= 3.2.8
136 BuildRequires:  libpng-devel
137 BuildRequires:  libuuid-devel
138 BuildRequires:  lzo-devel >= 2
139 BuildRequires:  ncurses-devel
140 %if %{with ocaml}
141 BuildRequires:  ocaml >= 3.11.0
142 BuildRequires:  ocaml-findlib
143 %endif
144 BuildRequires:  nss-devel >= 3.12.8
145 BuildRequires:  openssl-devel
146 BuildRequires:  pciutils-devel
147 BuildRequires:  perl-base
148 BuildRequires:  perl-tools-pod
149 BuildRequires:  pkgconfig
150 BuildRequires:  python-devel
151 BuildRequires:  rpm-pythonprov
152 BuildRequires:  rpmbuild(macros) >= 1.647
153 BuildRequires:  seabios
154 BuildRequires:  texi2html
155 BuildRequires:  texlive-dvips
156 BuildRequires:  texlive-latex-psnfss
157 BuildRequires:  texlive-xetex
158 BuildRequires:  transfig
159 BuildRequires:  which
160 # for xfsctl (<xfs/xfs.h>)
161 BuildRequires:  xfsprogs-devel
162 BuildRequires:  xz-devel
163 BuildRequires:  yajl-devel
164 BuildRequires:  zlib-devel
165 %if %{with qemu_traditional}
166 %{?with_opengl:BuildRequires:   OpenGL-devel}
167 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
168 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
169 %{?with_brlapi:BuildRequires:   brlapi-devel}
170 BuildRequires:  vde2-devel
171 BuildRequires:  xorg-lib-libX11-devel
172 BuildRequires:  xorg-lib-libXext-devel
173 %endif
174 %if %{with qemu_traditional}
175 # FIXME: see qemu configure comments on top of spec
176 %{!?with_opengl:BuildConflicts: OpenGL-devel}
177 %{!?with_sdl:BuildConflicts:    SDL-devel}
178 %{!?with_sdl:BuildConflicts:    SDL-devel}
179 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
180 %{!?with_brlapi:BuildConflicts: brlapi-devel}
181 %endif
182 Requires(post,preun):   /sbin/chkconfig
183 Requires(post,preun,postun):    systemd-units >= 38
184 Requires:       %{name}-libs = %{version}-%{release}
185 Requires:       ZopeInterface
186 Requires:       bridge-utils
187 Requires:       coreutils
188 Requires:       diffutils
189 Requires:       gawk
190 Requires:       iptables
191 Requires:       losetup
192 Requires:       net-tools
193 Requires:       python-%{name} = %{version}-%{release}
194 Requires:       rc-scripts
195 Requires:       sed
196 Requires:       systemd-units >= 38
197 Requires:       util-linux
198 Requires:       which
199 Requires:       %{name}-guest = %{version}-%{release}
200 Obsoletes:      xen-doc
201 Obsoletes:      xen-udev
202 Obsoletes:      xen-xend
203 ExclusiveArch:  %{ix86} %{x8664} arm
204 %ifarch %{ix86} %{x8664}
205 # for HVM
206 Suggests:       qemu-system-x86
207 %endif
208 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
209
210 # some PPC/SPARC boot images in ELF format
211 %define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\|s390-ccw.img\\)
212
213 %description
214 This package contains the Xen hypervisor and Xen tools, needed to run
215 virtual machines on x86 systems, together with the kernel-xen*
216 packages. Information on how to use Xen can be found at the Xen
217 project pages.
218
219 Virtualisation can be used to run multiple versions or multiple Linux
220 distributions on one system, or to test untrusted applications in a
221 sandboxed environment. Note that the Xen technology is still in
222 development, and this RPM has received extremely little testing. Don't
223 be surprised if this RPM eats your data, drinks your coffee or makes
224 fun of you in front of your friends.
225
226 %description -l pl.UTF-8
227 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
228 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
229 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
230 projektu.
231
232 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
233 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
234 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
235 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
236 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
237 się wyśmiewał w obecności przyjaciół.
238
239 %package guest
240 Summary:        Xen tools for virtual machines
241 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
242 Group:          Applications/System
243 Requires:       %{name}-libs-guest = %{version}-%{release}
244
245 %description guest
246 Xen utilities for both dom0 and domU virtual domains.
247
248 %description guest -l pl.UTF-8
249 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
250
251 %package libs
252 Summary:        Xen libraries
253 Summary(pl.UTF-8):      Biblioteki Xena
254 Group:          Libraries
255 Requires:       %{name}-libs-guest = %{version}-%{release}
256
257 %description libs
258 Xen libraries.
259
260 %description libs -l pl.UTF-8
261 Biblioteki Xena.
262
263 %package libs-guest
264 Summary:        Xen libraries for virtual machines
265 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
266 Group:          Libraries
267
268 %description libs-guest
269 Xen libraries for both dom0 and domU virtual machines.
270
271 %description libs-guest -l pl.UTF-8
272 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
273
274 %package devel
275 Summary:        Header files for Xen
276 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
277 Group:          Development/Libraries
278 Requires:       %{name}-libs = %{version}-%{release}
279
280 %description devel
281 Header files for Xen.
282
283 %description devel -l pl.UTF-8
284 Pliki nagłówkowe Xena.
285
286 %package static
287 Summary:        Static Xen libraries
288 Summary(pl.UTF-8):      Statyczne biblioteki Xena
289 Group:          Development/Libraries
290 Requires:       %{name}-devel = %{version}-%{release}
291
292 %description static
293 Static Xen libraries.
294
295 %description static -l pl.UTF-8
296 Statyczne biblioteki Xena.
297
298 %package -n ocaml-xen
299 Summary:        OCaml bindings for Xen
300 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
301 License:        LGPL v2.1 with linking exception
302 Group:          Libraries
303 Requires:       %{name}-libs = %{version}-%{release}
304 %if %{with ocaml}
305 %requires_eq    ocaml-runtime
306 %endif
307
308 %description -n ocaml-xen
309 OCaml bindings for Xen.
310
311 %description -n ocaml-xen -l pl.UTF-8
312 Wiązania OCamla dla Xena.
313
314 %package -n ocaml-xen-devel
315 Summary:        OCaml bindings for Xen - development files
316 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
317 License:        LGPL v2.1 with linking exception
318 Group:          Development/Libraries
319 Requires:       ocaml-xen = %{version}-%{release}
320 %if %{with ocaml}
321 %requires_eq    ocaml
322 %endif
323
324 %description -n ocaml-xen-devel
325 OCaml bindings for Xen - development files.
326
327 %description -n ocaml-xen-devel -l pl.UTF-8
328 Wiązania OCamla dla Xena - pliki programistyczne.
329
330 %package -n python-xen
331 Summary:        Xen Python modules
332 Summary(pl.UTF-8):      Moduły Pythona dla Xena
333 Group:          Libraries
334 Requires:       %{name}-libs = %{version}-%{release}
335 Conflicts:      xen < 3.2.1-0.3
336
337 %description -n python-xen
338 Xen Python modules.
339
340 %description -n python-xen -l pl.UTF-8
341 Moduły Pythona dla Xena.
342
343 %package -n python-xen-guest
344 Summary:        Xen Python modules for virtual machines
345 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
346 Group:          Libraries
347 Requires:       %{name}-libs-guest = %{version}-%{release}
348 Conflicts:      xen < 3.2.1-0.3
349
350 %description -n python-xen-guest
351 Xen Python modules for both dom0 and domU virtual machines.
352
353 %description -n python-xen-guest -l pl.UTF-8
354 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
355
356 %package -n bash-completion-%{name}
357 Summary:        bash-completion for Xen (xl)
358 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
359 Group:          Applications/Shells
360 Requires:       %{name} = %{version}-%{release}
361 Requires:       bash-completion
362
363 %description -n bash-completion-%{name}
364 This package provides bash-completion for Xen (xl).
365
366 %description -n bash-completion-%{name} -l pl.UTF-8
367 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
368
369 %package efi
370 Summary:        Xen hypervisor binary for EFI
371 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
372 Group:          Applications/System
373 Requires:       %{name}-libs-guest = %{version}-%{release}
374
375 %description efi
376 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
377 firmware without help from any additional bootloader.
378
379 %description efi -l pl.UTF-8
380 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
381 (U)EFI, bez potrzeby oddzielnego bootloadera.
382
383 %prep
384 %setup -q
385 %patch0 -p1
386 %patch1 -p1
387 %patch2 -p1
388 %patch3 -p1
389 %patch7 -p1
390 %patch9 -p1
391 %patch10 -p1
392 %patch12 -p1
393 %patch13 -p1
394 %patch14 -p1
395 %patch15 -p1
396 %patch16 -p1
397 %patch18 -p1
398 %patch19 -p1
399 %patch20 -p1
400 %patch21 -p1
401 %patch22 -p1
402 %patch23 -p1
403 %patch24 -p1
404
405 # stubdom sources
406 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
407 ln -s %{SOURCE17} %{SOURCE18} %{SOURCE19} stubdom
408 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
409
410 # do not allow fetching anything via git
411 echo GIT=/bin/false >> Config.mk
412
413 %build
414 # based on the 'autoconf.sh' from the sources
415 %{__autoconf}
416 cd tools
417 %{__autoconf}
418 %{__autoheader}
419 cd ../stubdom
420 %{__autoconf}
421 cd ../docs
422 %{__autoconf}
423 cd ..
424
425 # if gold is used then bioses and grub doesn't build
426 install -d our-ld
427 ln -f -s /usr/bin/ld.bfd our-ld/ld
428 export PATH=$(pwd)/our-ld:$PATH
429
430 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
431 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
432
433 # NOTE on ac_cv_*:
434 # - use openssl (libcrypto) instead of libgcrypt as openssl is obligatory anyway
435 # - prevent libiconv from being detected (not needed with glibc)
436 %configure \
437         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
438         ac_cv_lib_gcrypt_gcry_md_hash_buffer=no \
439         ac_cv_lib_iconv_libiconv_open=no \
440         --disable-debug \
441         %{__enable_disable qemu_traditional qemu-traditional} \
442         --with-system-seabios=/usr/share/seabios/bios.bin \
443 %ifarch %{x8664}
444         --with-system-qemu=/usr/bin/qemu-system-x86_64 \
445 %else
446         --with-system-qemu=/usr/bin/qemu-system-i386 \
447 %endif
448         --with-systemd=%{systemdunitdir}
449
450 %{__make} -j1 dist-xen dist-tools dist-docs \
451         %{!?with_ocaml:OCAML_TOOLS=n} \
452         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
453         CC="%{__cc}" \
454         CXX="%{__cxx}" \
455         V=1
456
457 unset CFLAGS
458 unset CXXFLAGS
459
460 %if %{with stubdom}
461 %{__make} -j1 dist-stubdom \
462         %{!?with_ocaml:OCAML_TOOLS=n} \
463         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
464         CC="%{__cc}" \
465         CXX="%{__cxx}" \
466         V=1
467 %endif
468
469 %install
470 rm -rf $RPM_BUILD_ROOT
471 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
472         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
473
474 %if %{with efi}
475 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
476 %endif
477
478 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
479         %{!?with_ocaml:OCAML_TOOLS=n} \
480         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
481         DESTDIR=$RPM_BUILD_ROOT \
482         HOTPLUGS=install-udev
483
484 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
485 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
486 install %{SOURCE43} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xendomains.sh
487 # sysvinit scripts
488 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
489 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
490 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
491 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
492 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
493 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
494 install %{SOURCE46} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-qemu-dom0-disk-backend
495 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
496 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
497 install -d $RPM_BUILD_ROOT/var/run/xenstored
498 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
499
500 install %{SOURCE60} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-init-list
501 install %{SOURCE61} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-toolstack
502
503 %if %{with efi}
504 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
505 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
506                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
507 %endif
508
509 mv $RPM_BUILD_ROOT/etc/xen/{xlexample*,examples}
510
511 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
512
513 # for %%doc
514 install -d _doc
515 for tool in blktap2 pygrub ; do
516         cp -p tools/$tool/README _doc/README.$tool
517 done
518
519 cp -p xen/xen-syms $RPM_BUILD_ROOT/boot/%{name}-syms-%{version}
520
521 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
522 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
523
524 %py_postclean
525
526 # remove unneeded files
527 %if %{with hypervisor}
528 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.6.gz
529 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
530 %endif
531 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
532 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
533
534 %clean
535 rm -rf $RPM_BUILD_ROOT
536
537 %post
538 /sbin/chkconfig --add xen-watchdog
539 /sbin/chkconfig --add xenconsoled
540 /sbin/chkconfig --add xenstored
541 /sbin/chkconfig --add xendomains
542 /sbin/chkconfig --add xen-qemu-dom0-disk-backend
543 NORESTART=1
544 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
545
546 %preun
547 if [ "$1" = "0" ]; then
548         %service xendomains stop
549         /sbin/chkconfig --del xendomains
550
551         %service xenconsoled stop
552         /sbin/chkconfig --del xenconsoled
553
554         %service xenstored stop
555         /sbin/chkconfig --del xenstored
556
557         %service xen-watchdog stop
558         /sbin/chkconfig --del xen-watchdog
559
560         %service xen-qemu-dom0-disk-backend stop
561         /sbin/chkconfig --del xen-qemu-dom0-disk-backend
562 fi
563 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
564
565 %postun
566 %systemd_reload
567
568 %post   libs -p /sbin/ldconfig
569 %postun libs -p /sbin/ldconfig
570
571 %post   libs-guest -p /sbin/ldconfig
572 %postun libs-guest -p /sbin/ldconfig
573
574 %post efi
575 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
576
577 %files
578 %defattr(644,root,root,755)
579 %doc COPYING README* docs/misc/* docs/html/* _doc/*
580 %if %{with hypervisor}
581 /boot/%{name}-syms-%{version}
582 /boot/%{name}-%{version}.gz
583 /boot/%{name}.gz
584 %endif
585 %if %{with xsm}
586 /boot/xenpolicy-%{version}
587 %endif
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
589 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
590 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
591 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
592 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
593 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
594 %attr(754,root,root) /etc/rc.d/init.d/xenstored
595 %attr(754,root,root) /etc/rc.d/init.d/xendomains
596 %attr(754,root,root) /etc/rc.d/init.d/xen-qemu-dom0-disk-backend
597 %{_prefix}/lib/modules-load.d/xen.conf
598 %{systemdunitdir}/proc-xen.mount
599 %{systemdunitdir}/var-lib-xenstored.mount
600 %{systemdunitdir}/xen-init-dom0.service
601 %{systemdunitdir}/xen-watchdog.service
602 %{systemdunitdir}/xenconsoled.service
603 %{systemdunitdir}/xenstored.service
604 %{systemdunitdir}/xenstored.socket
605 %{systemdunitdir}/xenstored_ro.socket
606 %{systemdunitdir}/xendomains.service
607 %{systemdunitdir}/xen-qemu-dom0-disk-backend.service
608 %dir %{_sysconfdir}/xen
609 %dir %{_sysconfdir}/xen/auto
610 %dir %{_sysconfdir}/xen/examples
611 %dir %{_sysconfdir}/xen/scripts
612 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
617 %attr(755,root,root) %{_bindir}/pygrub
618 %if %{with qemu_traditional}
619 %attr(755,root,root) %{_bindir}/qemu-img-xen
620 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
621 %endif
622 %attr(755,root,root) %{_bindir}/xenalyze
623 %attr(755,root,root) %{_bindir}/xencons
624 %attr(755,root,root) %{_bindir}/xencov_split
625 %attr(755,root,root) %{_bindir}/xentrace_format
626 %if %{with xsm}
627 %attr(755,root,root) %{_sbindir}/flask-*
628 %endif
629 %attr(755,root,root) %{_sbindir}/gdbsx
630 %attr(755,root,root) %{_sbindir}/gtrace*
631 %attr(755,root,root) %{_sbindir}/img2qcow
632 %attr(755,root,root) %{_sbindir}/kdd
633 %attr(755,root,root) %{_sbindir}/lock-util
634 %attr(755,root,root) %{_sbindir}/qcow-create
635 %attr(755,root,root) %{_sbindir}/qcow2raw
636 %attr(755,root,root) %{_sbindir}/tap-ctl
637 %attr(755,root,root) %{_sbindir}/tapdisk*
638 %attr(755,root,root) %{_sbindir}/td-util
639 %attr(755,root,root) %{_sbindir}/vhd-*
640 %attr(755,root,root) %{_sbindir}/xen-*
641 %attr(755,root,root) %{_sbindir}/xenbaked
642 %attr(755,root,root) %{_sbindir}/xenconsoled
643 %attr(755,root,root) %{_sbindir}/xencov
644 %attr(755,root,root) %{_sbindir}/xenlockprof
645 %attr(755,root,root) %{_sbindir}/xenmon.py
646 %attr(755,root,root) %{_sbindir}/xenperf
647 %attr(755,root,root) %{_sbindir}/xenpm
648 %attr(755,root,root) %{_sbindir}/xenpmd
649 %attr(755,root,root) %{_sbindir}/xenstored
650 %attr(755,root,root) %{_sbindir}/xentop
651 %attr(755,root,root) %{_sbindir}/xentrace
652 %attr(755,root,root) %{_sbindir}/xentrace_setmask
653 %attr(755,root,root) %{_sbindir}/xentrace_setsize
654 %attr(755,root,root) %{_sbindir}/xenwatchdogd
655 %attr(755,root,root) %{_sbindir}/xl
656 %dir %{_libdir}/%{name}
657 %dir %{_libdir}/%{name}/bin
658 %attr(744,root,root) %{_libdir}/%{name}/bin/*
659 %dir %{_libdir}/%{name}/boot
660 %if %{with stubdom}
661 %if %{with qemu_traditional}
662 %{_libdir}/%{name}/boot/ioemu-stubdom.gz
663 %endif
664 %ifarch %{ix86} %{x8664}
665 %{_libdir}/%{name}/boot/pv-grub-x86_32.gz
666 %endif
667 %ifarch %{x8664}
668 %{_libdir}/%{name}/boot/pv-grub-x86_64.gz
669 %endif
670 %{_libdir}/%{name}/boot/vtpm-stubdom.gz
671 %{_libdir}/%{name}/boot/vtpmmgr-stubdom.gz
672 %{_libdir}/%{name}/boot/xenstore-stubdom.gz
673 %endif
674 %attr(744,root,root) %{_libdir}/%{name}/boot/hvmloader
675 %{_mandir}/man1/xenstore-chmod.1*
676 %{_mandir}/man1/xenstore-ls.1*
677 %{_mandir}/man1/xenstore.1*
678 %{_mandir}/man1/xentop.1*
679 %{_mandir}/man1/xentrace_format.1*
680 %{_mandir}/man1/xl.1*
681 %{_mandir}/man5/xl.cfg.5*
682 %{_mandir}/man5/xl.conf.5*
683 %{_mandir}/man5/xlcpupool.cfg.5*
684 %{_mandir}/man8/xentrace.8*
685 %{_sharedstatedir}/xen
686 %{_sharedstatedir}/xenstored
687 %dir /var/run/xenstored
688 %{systemdtmpfilesdir}/xen.conf
689 %{systemdtmpfilesdir}/xenstored.conf
690 %dir %attr(0700,root,root) /var/log/xen
691 %dir %attr(0700,root,root) /var/log/xen/console
692 %if %{with qemu_traditional}
693 %{_datadir}/xen
694 %endif
695
696 %files guest
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/xen-detect
699 %attr(755,root,root) %{_bindir}/xenstore*
700
701 %files libs
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
704 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
705 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
706 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
707 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
709 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.6
711 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.6
713 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
714 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.6
715 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
717 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
718 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
719 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.6
721 %dir %{_libdir}/fs
722 %dir %{_libdir}/fs/ext2fs-lib
723 %dir %{_libdir}/fs/fat
724 %dir %{_libdir}/fs/iso9660
725 %dir %{_libdir}/fs/reiserfs
726 %dir %{_libdir}/fs/ufs
727 %dir %{_libdir}/fs/xfs
728 %dir %{_libdir}/fs/zfs
729 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
730
731 %files libs-guest
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
735
736 %files devel
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libblktapctl.so
739 %attr(755,root,root) %{_libdir}/libfsimage.so
740 %attr(755,root,root) %{_libdir}/libvhd.so
741 %attr(755,root,root) %{_libdir}/libxenctrl.so
742 %attr(755,root,root) %{_libdir}/libxenguest.so
743 %attr(755,root,root) %{_libdir}/libxenlight.so
744 %attr(755,root,root) %{_libdir}/libxenstat.so
745 %attr(755,root,root) %{_libdir}/libxenstore.so
746 %attr(755,root,root) %{_libdir}/libxenvchan.so
747 %attr(755,root,root) %{_libdir}/libxlutil.so
748 %{_includedir}/_libxl_list.h
749 %{_includedir}/_libxl_types.h
750 %{_includedir}/_libxl_types_json.h
751 %{_includedir}/fsimage*.h
752 %{_includedir}/libxenvchan.h
753 %{_includedir}/libxl*.h
754 %{_includedir}/xen*.h
755 %{_includedir}/xs*.h
756 %{_includedir}/xen
757 %{_includedir}/xenstore-compat
758 %{_npkgconfigdir}/xenlight.pc
759 %{_npkgconfigdir}/xlutil.pc
760
761 %files static
762 %defattr(644,root,root,755)
763 %{_libdir}/libblktapctl.a
764 %{_libdir}/libvhd.a
765 %{_libdir}/libxenctrl.a
766 %{_libdir}/libxenguest.a
767 %{_libdir}/libxenlight.a
768 %{_libdir}/libxenvchan.a
769 %{_libdir}/libxenstat.a
770 %{_libdir}/libxenstore.a
771 %{_libdir}/libxlutil.a
772
773 %if %{with ocaml}
774 %files -n ocaml-xen
775 %defattr(644,root,root,755)
776 %doc tools/ocaml/LICENSE
777 %attr(755,root,root) %{_sbindir}/oxenstored
778 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
779 %dir %{_libdir}/ocaml/site-lib/xenbus
780 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
781 %dir %{_libdir}/ocaml/site-lib/xenctrl
782 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
783 %dir %{_libdir}/ocaml/site-lib/xeneventchn
784 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
785 %dir %{_libdir}/ocaml/site-lib/xenlight
786 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
787 %dir %{_libdir}/ocaml/site-lib/xenmmap
788 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
789 %dir %{_libdir}/ocaml/site-lib/xentoollog
790 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xentoollog/dllxentoollog_stubs.so
791
792 %files -n ocaml-xen-devel
793 %defattr(644,root,root,755)
794 %{_libdir}/ocaml/site-lib/xenbus/META
795 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
796 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
797 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
798 %{_libdir}/ocaml/site-lib/xenctrl/META
799 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
800 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
801 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
802 %{_libdir}/ocaml/site-lib/xeneventchn/META
803 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
804 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
805 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
806 %{_libdir}/ocaml/site-lib/xenmmap/META
807 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
808 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
809 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
810 %{_libdir}/ocaml/site-lib/xenlight/META
811 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
812 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
813 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
814 %dir %{_libdir}/ocaml/site-lib/xenstore
815 %{_libdir}/ocaml/site-lib/xenstore/META
816 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
817 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
818 %{_libdir}/ocaml/site-lib/xentoollog/META
819 %{_libdir}/ocaml/site-lib/xentoollog/libxentoollog_stubs.a
820 %{_libdir}/ocaml/site-lib/xentoollog/xentoollog.a
821 %{_libdir}/ocaml/site-lib/xentoollog/*.cm[aixo]*
822 %endif
823
824 %files -n python-xen
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{py_sitedir}/fsimage.so
827 %dir %{py_sitedir}/xen/lowlevel
828 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
829 %{py_sitedir}/xen/migration
830 %{py_sitedir}/grub
831 %if "%{py_ver}" > "2.4"
832 %{py_sitedir}/pygrub-0.3-py*.egg-info
833 %{py_sitedir}/xen-3.0-py*.egg-info
834 %endif
835
836 %files -n python-xen-guest
837 %defattr(644,root,root,755)
838 %dir %{py_sitedir}/xen
839 %{py_sitedir}/xen/__init__.py*
840 %dir %{py_sitedir}/xen/lowlevel
841 %{py_sitedir}/xen/lowlevel/__init__.py*
842 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
843
844 %files -n bash-completion-%{name}
845 %defattr(644,root,root,755)
846 /etc/bash_completion.d/xl.sh
847
848 %if %{with efi}
849 %files efi
850 %defattr(644,root,root,755)
851 %dir %{_libdir}/efi
852 %{_libdir}/efi/*.efi
853 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
854 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
855 %endif
This page took 0.092078 seconds and 4 git commands to generate.