]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
Drop unused /etc/sysconfig/xencommons file
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 # Conditional build:
13 %bcond_without  opengl          # OpenGL support in Xen qemu
14 %bcond_without  sdl             # SDL support in Xen qemu
15 %bcond_without  bluetooth       # bluetooth support in Xen qemu
16 %bcond_without  brlapi          # brlapi support in Xen qemu
17 %bcond_without  ocaml           # Ocaml libraries for Xen tools
18 %bcond_without  efi             # EFI hypervisor
19 %bcond_without  hypervisor      # Xen hypervisor build
20 %bcond_without  stubdom         # stubdom build
21
22 %ifnarch %{x8664} arm
23 %undefine       with_hypervisor
24 %endif
25 %ifnarch %{x8664}
26 %undefine       with_efi
27 %endif
28 %ifnarch %{ix86} %{x8664}
29 %undefine       with_stubdom
30 %endif
31
32 # from Config.mk:
33 %define seabios_version         1.6.3.2
34
35 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
36 Summary:        Xen - a virtual machine monitor
37 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
38 Name:           xen
39 Version:        4.3.0
40 Release:        1
41 License:        GPL v2, interface parts on BSD-like
42 Group:          Applications/System
43 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
44 # Source0-md5:  7b18cfb58f1ac2ce39cf35a1867f0c0a
45 # used by stubdoms
46 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
47 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
48 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
49 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
50 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
51 # Source12-md5: debc62758716a169df9f62e6ab2bc634
52 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
53 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
54 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
55 # Source14-md5: cd3f3eb54446be6003156158d51f4884
56 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
57 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
58 # http://xenbits.xen.org/git-http/seabios.git/
59 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
60 Source16:       seabios-%{seabios_version}.tar.xz
61 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
62 Source30:       proc-xen.mount
63 Source31:       var-lib-xenstored.mount
64 Source32:       blktapctrl.service
65 Source33:       blktapctrl.sysconfig
66 Source34:       xenconsoled.service
67 Source35:       xenconsoled.sysconfig
68 Source36:       xenstored.service
69 Source37:       xenstored.sysconfig
70 Source38:       xenstored.tmpfiles
71 Source39:       xend.service
72 Source40:       xend.tmpfiles
73 Source41:       xen-watchdog.service
74 Source42:       xen-dom0-modules-load.conf
75 Source43:       xendomains.sh
76 Source44:       xendomains.service
77 # sysvinit scripts
78 Source50:       xend.init
79 Source51:       xenconsoled.init
80 Source52:       xenstored.init
81 Source53:       xen-watchdog.init
82 Source54:       xendomains.init
83 Source55:       xen.logrotate
84 Source56:       xen.tmpfiles
85 Source57:       xen.cfg
86 Source58:       xen.efi-boot-update
87 Source59:       vif-openvswitch
88 Source60:       xen-init-list
89 Source61:       xen-toolstack
90 Patch0:         %{name}-python_scripts.patch
91 Patch1:         %{name}-symbols.patch
92 Patch2:         %{name}-curses.patch
93 Patch3:         pygrubfix.patch
94 Patch4:         xend.catchbt.patch
95 Patch5:         xend-pci-loop.patch
96 Patch6:         %{name}-dumpdir.patch
97 # Warning: this disables ingress filtering implemented in xen scripts!
98 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
99 Patch8:         %{name}-configure-xend.patch
100 Patch9:         %{name}-initscript.patch
101 Patch10:        %{name}-qemu.patch
102 Patch11:        %{name}-ulong.patch
103 Patch12:        %{name}-doc.patch
104 Patch13:        %{name}-paths.patch
105 URL:            http://www.xen.org/products/xenhyp.html
106 %{?with_opengl:BuildRequires:   OpenGL-devel}
107 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
108 %ifarch %{ix86} %{x8664}
109 BuildRequires:  acpica
110 BuildRequires:  bcc
111 BuildRequires:  bin86
112 %endif
113 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
114 %{?with_brlapi:BuildRequires:   brlapi-devel}
115 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
116 BuildRequires:  bzip2-devel
117 BuildRequires:  ceph-devel
118 BuildRequires:  curl-devel
119 BuildRequires:  cyrus-sasl-devel >= 2
120 BuildRequires:  e2fsprogs-devel
121 BuildRequires:  gcc >= 6:4.1
122 BuildRequires:  gettext-devel
123 BuildRequires:  glib2-devel >= 1:2.12
124 BuildRequires:  glusterfs-devel >= 3.4
125 BuildRequires:  gnutls-devel
126 BuildRequires:  latex2html >= 2008
127 BuildRequires:  libaio-devel
128 BuildRequires:  libcap-devel
129 BuildRequires:  libcap-ng-devel
130 BuildRequires:  libiscsi-devel
131 BuildRequires:  libjpeg-devel
132 BuildRequires:  libpng-devel
133 BuildRequires:  libseccomp-devel >= 1.0.0
134 BuildRequires:  libuuid-devel
135 BuildRequires:  lzo-devel >= 2
136 BuildRequires:  ncurses-devel
137 %if %{with ocaml}
138 BuildRequires:  ocaml >= 3.04-7
139 BuildRequires:  ocaml-findlib
140 %endif
141 BuildRequires:  nss-devel >= 3.12.8
142 BuildRequires:  openssl-devel
143 BuildRequires:  pciutils-devel
144 BuildRequires:  perl-base
145 BuildRequires:  perl-tools-pod
146 BuildRequires:  pixman-devel
147 BuildRequires:  pkgconfig
148 BuildRequires:  python-devel
149 BuildRequires:  rpm-pythonprov
150 BuildRequires:  rpmbuild(macros) >= 1.647
151 BuildRequires:  spice-protocol >= 0.12.2
152 BuildRequires:  spice-server-devel >= 0.12.0
153 BuildRequires:  texi2html
154 BuildRequires:  texlive-dvips
155 BuildRequires:  texlive-latex-psnfss
156 BuildRequires:  texlive-xetex
157 BuildRequires:  transfig
158 BuildRequires:  usbredir-devel >= 0.5.3
159 BuildRequires:  vde2-devel
160 BuildRequires:  which
161 # for xfsctl (<xfs/xfs.h>)
162 BuildRequires:  xfsprogs-devel
163 BuildRequires:  xorg-lib-libX11-devel
164 BuildRequires:  xorg-lib-libXext-devel
165 BuildRequires:  xz-devel
166 BuildRequires:  yajl-devel
167 BuildRequires:  zlib-devel
168 # FIXME: see qemu configure comments on top of spec
169 %{!?with_opengl:BuildConflicts: OpenGL-devel}
170 %{!?with_sdl:BuildConflicts:    SDL-devel}
171 %{!?with_sdl:BuildConflicts:    SDL-devel}
172 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
173 %{!?with_brlapi:BuildConflicts: brlapi-devel}
174 Requires(post,preun):   /sbin/chkconfig
175 Requires(post,preun,postun):    systemd-units >= 38
176 Requires:       %{name}-libs = %{version}-%{release}
177 Requires:       ZopeInterface
178 Requires:       bridge-utils
179 Requires:       coreutils
180 Requires:       diffutils
181 Requires:       gawk
182 Requires:       iptables
183 Requires:       losetup
184 Requires:       net-tools
185 Requires:       python-%{name} = %{version}-%{release}
186 Requires:       rc-scripts
187 Requires:       sed
188 Requires:       systemd-units >= 38
189 Requires:       util-linux
190 Requires:       which
191 Requires:       %{name}-guest = %{version}-%{release}
192 Obsoletes:      xen-doc
193 Obsoletes:      xen-udev
194 ExclusiveArch:  %{ix86} %{x8664} arm
195 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
196
197 # some PPC/SPARC boot images in ELF format
198 %define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\)
199
200 %description
201 This package contains the Xen hypervisor and Xen tools, needed to run
202 virtual machines on x86 systems, together with the kernel-xen*
203 packages. Information on how to use Xen can be found at the Xen
204 project pages.
205
206 Virtualisation can be used to run multiple versions or multiple Linux
207 distributions on one system, or to test untrusted applications in a
208 sandboxed environment. Note that the Xen technology is still in
209 development, and this RPM has received extremely little testing. Don't
210 be surprised if this RPM eats your data, drinks your coffee or makes
211 fun of you in front of your friends.
212
213 %description -l pl.UTF-8
214 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
215 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
216 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
217 projektu.
218
219 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
220 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
221 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
222 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
223 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
224 się wyśmiewał w obecności przyjaciół.
225
226 %package guest
227 Summary:        Xen tools for virtual machines
228 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
229 Group:          Applications/System
230 Requires:       %{name}-libs-guest = %{version}-%{release}
231
232 %description guest
233 Xen utilities for both dom0 and domU virtual domains.
234
235 %description guest -l pl.UTF-8
236 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
237
238 %package libs
239 Summary:        Xen libraries
240 Summary(pl.UTF-8):      Biblioteki Xena
241 Group:          Libraries
242 Requires:       %{name}-libs-guest = %{version}-%{release}
243
244 %description libs
245 Xen libraries.
246
247 %description libs -l pl.UTF-8
248 Biblioteki Xena.
249
250 %package libs-guest
251 Summary:        Xen libraries for virtual machines
252 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
253 Group:          Libraries
254
255 %description libs-guest
256 Xen libraries for both dom0 and domU virtual machines.
257
258 %description libs-guest -l pl.UTF-8
259 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
260
261 %package devel
262 Summary:        Header files for Xen
263 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
264 Group:          Development/Libraries
265 Requires:       %{name}-libs = %{version}-%{release}
266
267 %description devel
268 Header files for Xen.
269
270 %description devel -l pl.UTF-8
271 Pliki nagłówkowe Xena.
272
273 %package static
274 Summary:        Static Xen libraries
275 Summary(pl.UTF-8):      Statyczne biblioteki Xena
276 Group:          Development/Libraries
277 Requires:       %{name}-devel = %{version}-%{release}
278
279 %description static
280 Static Xen libraries.
281
282 %description static -l pl.UTF-8
283 Statyczne biblioteki Xena.
284
285 %package xend
286 Summary:        xend daemon
287 Summary(pl.UTF-8):      Demon xend
288 Group:          Daemons
289 Requires(post,preun,postun):    systemd-units >= 38
290 Requires:       systemd-units >= 38
291
292 %description xend
293 xend daemon.
294
295 %description xend -l pl.UTF-8
296 Demon xend.
297
298 %package -n ocaml-xen
299 Summary:        OCaml bindings for Xen
300 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
301 License:        LGPL v2.1 with linking exception
302 Group:          Libraries
303 Requires:       %{name}-libs = %{version}-%{release}
304 %if %{with ocaml}
305 %requires_eq    ocaml-runtime
306 %endif
307
308 %description -n ocaml-xen
309 OCaml bindings for Xen.
310
311 %description -n ocaml-xen -l pl.UTF-8
312 Wiązania OCamla dla Xena.
313
314 %package -n ocaml-xen-devel
315 Summary:        OCaml bindings for Xen - development files
316 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
317 License:        LGPL v2.1 with linking exception
318 Group:          Development/Libraries
319 Requires:       ocaml-xen = %{version}-%{release}
320 %if %{with ocaml}
321 %requires_eq    ocaml
322 %endif
323
324 %description -n ocaml-xen-devel
325 OCaml bindings for Xen - development files.
326
327 %description -n ocaml-xen-devel -l pl.UTF-8
328 Wiązania OCamla dla Xena - pliki programistyczne.
329
330 %package -n python-xen
331 Summary:        Xen Python modules
332 Summary(pl.UTF-8):      Moduły Pythona dla Xena
333 Group:          Libraries
334 Requires:       %{name}-libs = %{version}-%{release}
335 Conflicts:      xen < 3.2.1-0.3
336
337 %description -n python-xen
338 Xen Python modules.
339
340 %description -n python-xen -l pl.UTF-8
341 Moduły Pythona dla Xena.
342
343 %package -n python-xen-guest
344 Summary:        Xen Python modules for virtual machines
345 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
346 Group:          Libraries
347 Requires:       %{name}-libs-guest = %{version}-%{release}
348 Conflicts:      xen < 3.2.1-0.3
349
350 %description -n python-xen-guest
351 Xen Python modules for both dom0 and domU virtual machines.
352
353 %description -n python-xen-guest -l pl.UTF-8
354 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
355
356 %package -n bash-completion-%{name}
357 Summary:    bash-completion for Xen (xl)
358 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
359 Group:      Applications/Shells
360 Requires:   %{name} = %{version}-%{release}
361 Requires:   bash-completion
362
363 %description -n bash-completion-%{name}
364 This package provides bash-completion for Xen (xl).
365
366 %description -n bash-completion-%{name} -l pl.UTF-8
367 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
368
369 %package efi
370 Summary:        Xen hypervisor binary for EFI
371 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
372 Group:          Applications/System
373 Requires:       %{name}-libs-guest = %{version}-%{release}
374
375 %description efi
376 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
377 firmware without help from any additional bootloader.
378
379 %description efi -l pl.UTF-8
380 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
381 (U)EFI, bez potrzeby oddzielnego bootloadera.
382
383 %prep
384 %setup -q -a 16
385 %patch0 -p1
386 %patch1 -p1
387 %patch2 -p1
388 %patch3 -p1
389 %patch4 -p1
390 %patch5 -p1
391 %patch6 -p1
392 %patch7 -p1
393 %patch8 -p1
394 %patch9 -p1
395 %patch10 -p1
396 %patch11 -p1
397 %patch12 -p1
398 %patch13 -p1
399
400 # stubdom sources
401 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
402 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
403
404 # do not allow fetching anything via git
405 echo GIT=/bin/false >> Config.mk
406
407 %build
408 # if gold is used then bioses and grub doesn't build
409 install -d our-ld
410 ln -s /usr/bin/ld.bfd our-ld/ld
411 export PATH=$(pwd)/our-ld:$PATH
412
413 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
414 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
415
416 # NOTE:
417 # - there is a quoting bug (in tools/driver/Makefile) that causes
418 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
419 #   anyway (see configure), gcrypt is optional
420 # - prevent libiconv from being detected (not needed with glibc)
421 %configure \
422         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
423         ac_cv_lib_iconv_libiconv_open=no \
424         --disable-debug
425
426 %{__make} dist-xen dist-tools dist-docs \
427         %{!?with_ocaml:OCAML_TOOLS=n} \
428         CC="%{__cc}" \
429         CXX="%{__cxx}" \
430         V=1
431
432 unset CFLAGS
433 unset CXXFLAGS
434
435 %if %{with stubdom}
436 %{__make} -j1 dist-stubdom \
437         %{!?with_ocaml:OCAML_TOOLS=n} \
438         CC="%{__cc}" \
439         CXX="%{__cxx}" \
440         V=1
441 %endif
442
443 %install
444 rm -rf $RPM_BUILD_ROOT
445 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
446         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
447
448 %if %{with efi}
449 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
450 %endif
451
452 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
453         %{!?with_ocaml:OCAML_TOOLS=n} \
454         DESTDIR=$RPM_BUILD_ROOT \
455         HOTPLUGS=install-udev
456
457 %if "%{_lib}" == "lib64"
458 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
459 %endif
460
461 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
462 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
463 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
464 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
465 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
466 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
467 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
468 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
469 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
470 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
471 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
472 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
473 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
474 install %{SOURCE43} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xendomains.sh
475 install %{SOURCE44} $RPM_BUILD_ROOT%{systemdunitdir}/xendomains.service
476 # sysvinit scripts
477 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
478 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
479 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
480 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
481 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
482 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
483 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
484 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
485 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
486
487 install %{SOURCE60} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xen-init-list
488 install %{SOURCE61} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xen-toolstack
489
490 %if %{with efi}
491 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
492 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
493                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
494 %endif
495
496 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
497
498 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
499
500 # for %%doc
501 install -d _doc
502 for tool in blktap blktap2 pygrub xenmon ; do
503         cp -p tools/$tool/README _doc/README.$tool
504 done
505 cp -al tools/qemu-xen/docs _doc/qemu-xen
506
507 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
508 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
509
510 %py_postclean
511
512 # seems not needed, the path is wrong anyway
513 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
514
515 # remove unneeded files
516 %if %{with hypervisor}
517 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.3.gz
518 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
519 %endif
520 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
521 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
522
523 %clean
524 rm -rf $RPM_BUILD_ROOT
525
526 %post
527 /sbin/chkconfig --add xen-watchdog
528 /sbin/chkconfig --add xenconsoled
529 /sbin/chkconfig --add xenstored
530 /sbin/chkconfig --add xendomains
531 NORESTART=1
532 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service
533
534 %preun
535 if [ "$1" = "0" ]; then
536         %service xendomains stop
537         /sbin/chkconfig --del xendomains
538
539         %service xenconsoled stop
540         /sbin/chkconfig --del xenconsoled
541
542         %service xenstored stop
543         /sbin/chkconfig --del xenstored
544
545         %service xen-watchdog stop
546         /sbin/chkconfig --del xen-watchdog
547 fi
548 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service
549
550 %postun
551 %systemd_reload
552
553 %post xend
554 /sbin/chkconfig --add xend
555 %systemd_post xend.service
556
557 %preun xend
558 if [ "$1" = "0" ]; then
559         %service xend stop
560         /sbin/chkconfig --del xend
561 fi
562 %systemd_preun xend.service
563
564 %postun xend
565 %systemd_reload
566
567 %post   libs -p /sbin/ldconfig
568 %postun libs -p /sbin/ldconfig
569
570 %post   libs-guest -p /sbin/ldconfig
571 %postun libs-guest -p /sbin/ldconfig
572
573 %post efi
574 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
575
576 %files
577 %defattr(644,root,root,755)
578 %doc COPYING README* docs/misc/* docs/html/* _doc/*
579 %if %{with hypervisor}
580 /boot/%{name}-syms-%{version}
581 /boot/%{name}-%{version}.gz
582 /boot/%{name}.gz
583 %endif
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
585 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
586 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
588 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
589 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
590 %attr(754,root,root) /etc/rc.d/init.d/xenstored
591 %attr(754,root,root) /etc/rc.d/init.d/xendomains
592 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
593 %{systemdunitdir}/proc-xen.mount
594 %{systemdunitdir}/var-lib-xenstored.mount
595 %{systemdunitdir}/xen-watchdog.service
596 %{systemdunitdir}/xenconsoled.service
597 %{systemdunitdir}/xenstored.service
598 %{systemdunitdir}/xendomains.service
599 %dir %{_sysconfdir}/xen
600 %dir %{_sysconfdir}/xen/auto
601 %dir %{_sysconfdir}/xen/examples
602 %dir %{_sysconfdir}/xen/scripts
603 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
604 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
605 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
606 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
607 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
608 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
609 %attr(755,root,root) %{_bindir}/pygrub
610 %attr(755,root,root) %{_bindir}/qemu-img-xen
611 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
612 %attr(755,root,root) %{_bindir}/remus
613 %attr(755,root,root) %{_bindir}/xencons
614 %attr(755,root,root) %{_bindir}/xencov_split
615 %attr(755,root,root) %{_bindir}/xentrace*
616 %attr(755,root,root) %{_sbindir}/blktapctrl
617 %attr(755,root,root) %{_sbindir}/flask-*
618 %attr(755,root,root) %{_sbindir}/gdbsx
619 %attr(755,root,root) %{_sbindir}/gtrace*
620 %attr(755,root,root) %{_sbindir}/img2qcow
621 %attr(755,root,root) %{_sbindir}/kdd
622 %attr(755,root,root) %{_sbindir}/lock-util
623 %attr(755,root,root) %{_sbindir}/qcow-create
624 %attr(755,root,root) %{_sbindir}/qcow2raw
625 %attr(755,root,root) %{_sbindir}/tap-ctl
626 %attr(755,root,root) %{_sbindir}/tapdisk*
627 %attr(755,root,root) %{_sbindir}/td-util
628 %attr(755,root,root) %{_sbindir}/vhd-*
629 %attr(755,root,root) %{_sbindir}/xen-*
630 %attr(755,root,root) %{_sbindir}/xenbaked
631 %attr(755,root,root) %{_sbindir}/xenconsoled
632 %attr(755,root,root) %{_sbindir}/xencov
633 %attr(755,root,root) %{_sbindir}/xenlockprof
634 %attr(755,root,root) %{_sbindir}/xenmon.py
635 %attr(755,root,root) %{_sbindir}/xenperf
636 %attr(755,root,root) %{_sbindir}/xenpm
637 %attr(755,root,root) %{_sbindir}/xenpmd
638 %attr(755,root,root) %{_sbindir}/xenstored
639 %attr(755,root,root) %{_sbindir}/xentop
640 %attr(755,root,root) %{_sbindir}/xentrace_setmask
641 %attr(755,root,root) %{_sbindir}/xenwatchdogd
642 %attr(755,root,root) %{_sbindir}/xl
643 %attr(755,root,root) %{_sbindir}/xsview
644 %dir %{_libdir}/%{name}
645 %dir %{_libdir}/%{name}/bin
646 %attr(744,root,root) %{_libdir}/%{name}/bin/*
647 %if "%{_lib}" != "lib"
648 %dir %{_prefix}/lib/%{name}
649 %dir %{_prefix}/lib/%{name}/bin
650 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/*
651 %endif
652 %dir %{_prefix}/lib/%{name}/boot
653 %if %{with stubdom}
654 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
655 %ifarch %{ix86} %{x8664}
656 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
657 %endif
658 %ifarch %{x8664}
659 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
660 %endif
661 %{_prefix}/lib/%{name}/boot/vtpm-stubdom.gz
662 %{_prefix}/lib/%{name}/boot/vtpmmgr-stubdom.gz
663 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
664 %endif
665 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
666 %{_datadir}/xen
667 %{_mandir}/man1/xentop.1*
668 %{_mandir}/man1/xentrace_format.1*
669 %{_mandir}/man1/xl.1*
670 %{_mandir}/man1/xm.1*
671 %{_mandir}/man5/xend-config.sxp.5*
672 %{_mandir}/man5/xl.cfg.5*
673 %{_mandir}/man5/xl.conf.5*
674 %{_mandir}/man5/xlcpupool.cfg.5*
675 %{_mandir}/man5/xmdomain.cfg.5*
676 %{_mandir}/man8/xentrace.8*
677 %{_sharedstatedir}/xen
678 %{_sharedstatedir}/xenstored
679 %dir /var/run/xenstored
680 %{systemdtmpfilesdir}/xenstored.conf
681 %{systemdtmpfilesdir}/xen.conf
682 %dir %attr(0700,root,root) /var/log/xen
683 %dir %attr(0700,root,root) /var/log/xen/console
684 %{_datadir}/qemu-xen
685
686 %files guest
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/xen-detect
689 %attr(755,root,root) %{_bindir}/xenstore*
690
691 %files libs
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
694 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
695 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
696 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
697 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
698 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
699 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
700 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
701 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
702 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.3
703 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
704 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.3
705 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
706 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.3
707 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
709 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
711 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.3
713 %dir %{_libdir}/fs
714 %dir %{_libdir}/fs/ext2fs-lib
715 %dir %{_libdir}/fs/fat
716 %dir %{_libdir}/fs/iso9660
717 %dir %{_libdir}/fs/reiserfs
718 %dir %{_libdir}/fs/ufs
719 %dir %{_libdir}/fs/xfs
720 %dir %{_libdir}/fs/zfs
721 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
722
723 %files libs-guest
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
727
728 %files devel
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/libblktap.so
731 %attr(755,root,root) %{_libdir}/libblktapctl.so
732 %attr(755,root,root) %{_libdir}/libfsimage.so
733 %attr(755,root,root) %{_libdir}/libvhd.so
734 %attr(755,root,root) %{_libdir}/libxenctrl.so
735 %attr(755,root,root) %{_libdir}/libxenguest.so
736 %attr(755,root,root) %{_libdir}/libxenlight.so
737 %attr(755,root,root) %{_libdir}/libxenstat.so
738 %attr(755,root,root) %{_libdir}/libxenstore.so
739 %attr(755,root,root) %{_libdir}/libxenvchan.so
740 %attr(755,root,root) %{_libdir}/libxlutil.so
741 %{_includedir}/_libxl_list.h
742 %{_includedir}/_libxl_types.h
743 %{_includedir}/_libxl_types_json.h
744 %{_includedir}/blktaplib.h
745 %{_includedir}/fsimage*.h
746 %{_includedir}/libxenvchan.h
747 %{_includedir}/libxl*.h
748 %{_includedir}/xen*.h
749 %{_includedir}/xs*.h
750 %{_includedir}/xen
751 %{_includedir}/xenstore-compat
752
753 %files static
754 %defattr(644,root,root,755)
755 %{_libdir}/libblktap.a
756 %{_libdir}/libblktapctl.a
757 %{_libdir}/libvhd.a
758 %{_libdir}/libxenctrl.a
759 %{_libdir}/libxenguest.a
760 %{_libdir}/libxenlight.a
761 %{_libdir}/libxenvchan.a
762 %{_libdir}/libxenstat.a
763 %{_libdir}/libxenstore.a
764 %{_libdir}/libxlutil.a
765
766 %files xend
767 %defattr(644,root,root,755)
768 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
769 %{systemdunitdir}/blktapctrl.service
770 %{systemdunitdir}/xend.service
771 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
772 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
773 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
774 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
775 %attr(755,root,root) %{_sbindir}/xend
776 %attr(755,root,root) %{_sbindir}/xm
777 %dir %attr(700,root,root) /var/run/xend
778 %{systemdtmpfilesdir}/xend.conf
779
780 %if %{with ocaml}
781 %files -n ocaml-xen
782 %defattr(644,root,root,755)
783 %doc tools/ocaml/LICENSE
784 %attr(755,root,root) %{_sbindir}/oxenstored
785 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
786 %dir %{_libdir}/ocaml/site-lib/xenbus
787 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
788 %dir %{_libdir}/ocaml/site-lib/xenctrl
789 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
790 %dir %{_libdir}/ocaml/site-lib/xeneventchn
791 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
792 %dir %{_libdir}/ocaml/site-lib/xenlight
793 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
794 %dir %{_libdir}/ocaml/site-lib/xenmmap
795 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
796
797 %files -n ocaml-xen-devel
798 %defattr(644,root,root,755)
799 %{_libdir}/ocaml/site-lib/xenbus/META
800 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
801 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
802 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
803 %{_libdir}/ocaml/site-lib/xenctrl/META
804 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
805 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
806 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
807 %{_libdir}/ocaml/site-lib/xeneventchn/META
808 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
809 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
810 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
811 %{_libdir}/ocaml/site-lib/xenmmap/META
812 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
813 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
814 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
815 %{_libdir}/ocaml/site-lib/xenlight/META
816 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
817 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
818 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
819 %dir %{_libdir}/ocaml/site-lib/xenstore
820 %{_libdir}/ocaml/site-lib/xenstore/META
821 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
822 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
823 %endif
824
825 %files -n python-xen
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{py_sitedir}/fsimage.so
828 %{py_sitedir}/grub
829 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
830 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
831 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
832 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
833 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
834 %{py_sitedir}/xen/remus
835 %{py_sitedir}/xen/sv
836 %{py_sitedir}/xen/util
837 %{py_sitedir}/xen/web
838 %{py_sitedir}/xen/xend
839 %{py_sitedir}/xen/xm
840 %{py_sitedir}/xen/xsview
841 %if "%{py_ver}" > "2.4"
842 %{py_sitedir}/pygrub-0.3-py*.egg-info
843 %{py_sitedir}/xen-3.0-py*.egg-info
844 %endif
845
846 %files -n python-xen-guest
847 %defattr(644,root,root,755)
848 %dir %{py_sitedir}/xen
849 %{py_sitedir}/xen/__init__.py*
850 %dir %{py_sitedir}/xen/lowlevel
851 %{py_sitedir}/xen/lowlevel/__init__.py*
852 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
853
854 %files -n bash-completion-%{name}
855 %defattr(644,root,root,755)
856 /etc/bash_completion.d/xl.sh
857
858 %if %{with efi}
859 %files efi
860 %defattr(644,root,root,755)
861 %dir %{_libdir}/efi
862 %{_libdir}/efi/*.efi
863 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
864 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
865 %endif
This page took 0.327902 seconds and 4 git commands to generate.