]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
Version: 4.2.1
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.1
33 Release:        1
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  0d48cbe1767b82aba12517898d4e0408
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Patch0:         %{name}-python_scripts.patch
77 Patch1:         %{name}-symbols.patch
78 Patch2:         %{name}-curses.patch
79 Patch3:         pygrubfix.patch
80 Patch4:         xend.catchbt.patch
81 Patch5:         xend-pci-loop.patch
82 Patch6:         xen-dumpdir.patch
83 # Warning: this disables ingress filtering implemented in xen scripts!
84 Patch7:         xen-net-disable-iptables-on-bridge.patch
85 Patch8:         xen-configure-xend.patch
86 Patch9:         xen-initscript.patch
87 Patch10:        xen-quemu-softloat-c99.patch
88 Patch11:        xen-qemu.patch
89 Patch12:        xen-scripts-locking.patch
90 Patch13:        xen-close_lockfd_after_lock_attempt.patch
91 URL:            http://www.xen.org/products/xenhyp.html
92 %{?with_opengl:BuildRequires:   OpenGL-devel}
93 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
94 %ifarch %{ix86} %{x8664}
95 BuildRequires:  acpica
96 BuildRequires:  bcc
97 %endif
98 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
99 %{?with_brlapi:BuildRequires:   brlapi-devel}
100 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
101 BuildRequires:  bzip2-devel
102 BuildRequires:  ceph-devel
103 BuildRequires:  curl-devel
104 BuildRequires:  cyrus-sasl-devel >= 2
105 BuildRequires:  e2fsprogs-devel
106 BuildRequires:  gcc >= 5:3.4
107 BuildRequires:  gettext-devel
108 BuildRequires:  glib2-devel >= 1:2.12
109 BuildRequires:  gnutls-devel
110 BuildRequires:  latex2html >= 2008
111 BuildRequires:  libaio-devel
112 BuildRequires:  libiscsi-devel
113 BuildRequires:  libjpeg-devel
114 BuildRequires:  libpng-devel
115 BuildRequires:  libuuid-devel
116 BuildRequires:  lzo-devel >= 2
117 BuildRequires:  ncurses-devel
118 %if %{with ocaml}
119 BuildRequires:  ocaml >= 3.04-7
120 BuildRequires:  ocaml-findlib
121 %endif
122 BuildRequires:  nss-devel >= 3.12.8
123 BuildRequires:  openssl-devel
124 BuildRequires:  pciutils-devel
125 BuildRequires:  perl-base
126 BuildRequires:  pkgconfig
127 BuildRequires:  python-devel
128 BuildRequires:  rpm-pythonprov
129 BuildRequires:  rpmbuild(macros) >= 1.647
130 BuildRequires:  spice-protocol >= 0.6.0
131 BuildRequires:  spice-server-devel >= 0.6.0
132 BuildRequires:  texi2html
133 BuildRequires:  texlive-dvips
134 BuildRequires:  texlive-latex-psnfss
135 BuildRequires:  texlive-xetex
136 BuildRequires:  usbredir-devel
137 BuildRequires:  vde2-devel
138 BuildRequires:  which
139 # for xfsctl (<xfs/xfs.h>)
140 BuildRequires:  xfsprogs-devel
141 BuildRequires:  xorg-lib-libX11-devel
142 BuildRequires:  xorg-lib-libXext-devel
143 BuildRequires:  xz-devel
144 BuildRequires:  yajl-devel
145 BuildRequires:  zlib-devel
146 # FIXME: see qemu configure comments on top of spec
147 %{!?with_opengl:BuildConflicts: OpenGL-devel}
148 %{!?with_sdl:BuildConflicts:    SDL-devel}
149 %{!?with_sdl:BuildConflicts:    SDL-devel}
150 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
151 %{!?with_brlapi:BuildConflicts: brlapi-devel}
152 Requires(post,preun):   /sbin/chkconfig
153 Requires(post,preun,postun):    systemd-units >= 38
154 Requires:       %{name}-libs = %{version}-%{release}
155 Requires:       ZopeInterface
156 Requires:       bridge-utils
157 Requires:       coreutils
158 Requires:       diffutils
159 Requires:       gawk
160 Requires:       iptables
161 Requires:       losetup
162 Requires:       net-tools
163 Requires:       python-%{name} = %{version}-%{release}
164 Requires:       rc-scripts
165 Requires:       sed
166 Requires:       systemd-units >= 38
167 Requires:       util-linux
168 Requires:       which
169 Requires:       %{name}-guest = %{version}-%{release}
170 Obsoletes:      xen-doc
171 Obsoletes:      xen-udev
172 ExclusiveArch:  %{ix86} %{x8664}
173 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
174
175 # some PPC/SPARC boot images in ELF format
176 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
177
178 %description
179 This package contains the Xen hypervisor and Xen tools, needed to run
180 virtual machines on x86 systems, together with the kernel-xen*
181 packages. Information on how to use Xen can be found at the Xen
182 project pages.
183
184 Virtualisation can be used to run multiple versions or multiple Linux
185 distributions on one system, or to test untrusted applications in a
186 sandboxed environment. Note that the Xen technology is still in
187 development, and this RPM has received extremely little testing. Don't
188 be surprised if this RPM eats your data, drinks your coffee or makes
189 fun of you in front of your friends.
190
191 %description -l pl.UTF-8
192 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
193 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
194 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
195 projektu.
196
197 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
198 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
199 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
200 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
201 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
202 się wyśmiewał w obecności przyjaciół.
203
204 %package guest
205 Summary:        Xen tools for virtual machines
206 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
207 Group:          Applications/System
208 Requires:       %{name}-libs-guest = %{version}-%{release}
209
210 %description guest
211 Xen utilities for both dom0 and domU virtual domains.
212
213 %description guest -l pl.UTF-8
214 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
215
216 %package libs
217 Summary:        Xen libraries
218 Summary(pl.UTF-8):      Biblioteki Xena
219 Group:          Libraries
220 Requires:       %{name}-libs-guest = %{version}-%{release}
221
222 %description libs
223 Xen libraries.
224
225 %description libs -l pl.UTF-8
226 Biblioteki Xena.
227
228 %package libs-guest
229 Summary:        Xen libraries for virtual machines
230 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
231 Group:          Libraries
232
233 %description libs-guest
234 Xen libraries for both dom0 and domU virtual machines.
235
236 %description libs-guest -l pl.UTF-8
237 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
238
239 %package devel
240 Summary:        Header files for Xen
241 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
242 Group:          Development/Libraries
243 Requires:       %{name}-libs = %{version}-%{release}
244
245 %description devel
246 Header files for Xen.
247
248 %description devel -l pl.UTF-8
249 Pliki nagłówkowe Xena.
250
251 %package static
252 Summary:        Static Xen libraries
253 Summary(pl.UTF-8):      Statyczne biblioteki Xena
254 Group:          Development/Libraries
255 Requires:       %{name}-devel = %{version}-%{release}
256
257 %description static
258 Static Xen libraries.
259
260 %description static -l pl.UTF-8
261 Statyczne biblioteki Xena.
262
263 %package xend
264 Summary:        xend daemon
265 Summary(pl.UTF-8):      Demon xend
266 Group:          Daemons
267 Requires(post,preun,postun):    systemd-units >= 38
268 Requires:       systemd-units >= 38
269
270 %description xend
271 xend daemon.
272
273 %description xend -l pl.UTF-8
274 Demon xend.
275
276 %package -n ocaml-xen
277 Summary:        OCaml bindings for Xen
278 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
279 License:        LGPL v2.1 with linking exception
280 Group:          Libraries
281 Requires:       %{name}-libs = %{version}-%{release}
282 %if %{with ocaml}
283 %requires_eq    ocaml-runtime
284 %endif
285
286 %description -n ocaml-xen
287 OCaml bindings for Xen.
288
289 %description -n ocaml-xen -l pl.UTF-8
290 Wiązania OCamla dla Xena.
291
292 %package -n ocaml-xen-devel
293 Summary:        OCaml bindings for Xen - development files
294 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
295 License:        LGPL v2.1 with linking exception
296 Group:          Development/Libraries
297 Requires:       ocaml-xen = %{version}-%{release}
298 %if %{with ocaml}
299 %requires_eq    ocaml
300 %endif
301
302 %description -n ocaml-xen-devel
303 OCaml bindings for Xen - development files.
304
305 %description -n ocaml-xen-devel -l pl.UTF-8
306 Wiązania OCamla dla Xena - pliki programistyczne.
307
308 %package -n python-xen
309 Summary:        Xen Python modules
310 Summary(pl.UTF-8):      Moduły Pythona dla Xena
311 Group:          Libraries
312 Requires:       %{name}-libs = %{version}-%{release}
313 Conflicts:      xen < 3.2.1-0.3
314
315 %description -n python-xen
316 Xen Python modules.
317
318 %description -n python-xen -l pl.UTF-8
319 Moduły Pythona dla Xena.
320
321 %package -n python-xen-guest
322 Summary:        Xen Python modules for virtual machines
323 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
324 Group:          Libraries
325 Requires:       %{name}-libs-guest = %{version}-%{release}
326 Conflicts:      xen < 3.2.1-0.3
327
328 %description -n python-xen-guest
329 Xen Python modules for both dom0 and domU virtual machines.
330
331 %description -n python-xen-guest -l pl.UTF-8
332 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
333
334 %package -n bash-completion-%{name}
335 Summary:    bash-completion for Xen (xl)
336 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
337 Group:      Applications/Shells
338 Requires:   %{name} = %{version}-%{release}
339 Requires:   bash-completion
340
341 %description -n bash-completion-%{name}
342 This package provides bash-completion for Xen (xl).
343
344 %description -n bash-completion-%{name} -l pl.UTF-8
345 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
346
347 %package efi
348 Summary:        Xen hypervisor binary for EFI
349 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
350 Group:          Applications/System
351 Requires:       %{name}-libs-guest = %{version}-%{release}
352
353 %description efi
354 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
355 firmware without help from any additional bootloader.
356
357 %description efi -l pl.UTF-8
358 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
359 (U)EFI, bez potrzeby oddzielnego bootloadera.
360
361 %prep
362 %setup -q -a 16
363 %patch0 -p1
364 %patch1 -p1
365 %patch2 -p1
366 %patch3 -p1
367 %patch4 -p1
368 %patch5 -p1
369 %patch6 -p1
370 %patch7 -p1
371 %patch8 -p1
372 %patch9 -p1
373 %patch10 -p1
374 %patch11 -p1
375 %patch12 -p1
376 %patch13 -p1
377
378 # stubdom sources
379 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
380 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
381
382 # do not allow fetching anything via git
383 echo GIT=/bin/false >> Config.mk
384
385 %build
386 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
387 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
388
389 # NOTE:
390 # - there is a quoting bug (in tools/driver/Makefile) that causes
391 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
392 #   anyway (see configure), gcrypt is optional
393 # - prevent libiconv from being detected (not needed with glibc)
394 cd tools
395 %configure \
396         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
397         ac_cv_lib_iconv_libiconv_open=no \
398         --disable-debug
399 cd ..
400
401 %{__make} dist-xen dist-tools dist-docs \
402         %{!?with_ocaml:OCAML_TOOLS=n} \
403         prefix=%{_prefix} \
404         CC="%{__cc}" \
405         CXX="%{__cxx}" \
406         V=1
407
408 unset CFLAGS
409 unset CXXFLAGS
410
411 %{__make} -j1 dist-stubdom \
412         %{!?with_ocaml:OCAML_TOOLS=n} \
413         CC="%{__cc}" \
414         CXX="%{__cxx}" \
415         V=1
416
417 %install
418 rm -rf $RPM_BUILD_ROOT
419 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
420         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
421
422 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
423         %{!?with_ocaml:OCAML_TOOLS=n} \
424         prefix=%{_prefix} \
425         DESTDIR=$RPM_BUILD_ROOT \
426         HOTPLUGS=install-udev
427
428 %if "%{_lib}" == "lib64"
429 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
430 %endif
431
432 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
433 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
434 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
435 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
436 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
437 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
438 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
439 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
440 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
441 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
442 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
443 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
444 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
445 # sysvinit scripts
446 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
447 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
448 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
449 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
450 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
451 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
452 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
453 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
454
455 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
456
457 # for %%doc
458 install -d _doc
459 for tool in blktap blktap2 pygrub xenmon ; do
460         cp -p tools/$tool/README _doc/README.$tool
461 done
462 cp -al tools/qemu-xen/docs _doc/qemu-xen
463
464 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
465 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
466
467 %py_postclean
468
469 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
470 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
471 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
472 # seems not needed, the path is wrong anyway
473 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
474
475 # remove unneeded files
476 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
477 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
478 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
479 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
480 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
481
482 %clean
483 rm -rf $RPM_BUILD_ROOT
484
485 %post
486 /sbin/chkconfig --add xen-watchdog
487 /sbin/chkconfig --add xenconsoled
488 /sbin/chkconfig --add xenstored
489 /sbin/chkconfig --add xendomains
490 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
491
492 %preun
493 if [ "$1" = "0" ]; then
494         %service xendomains stop
495         /sbin/chkconfig --del xendomains
496
497         %service xenconsoled stop
498         /sbin/chkconfig --del xenconsoled
499
500         %service xenstored stop
501         /sbin/chkconfig --del xenstored
502
503         %service xen-watchdog stop
504         /sbin/chkconfig --del xen-watchdog
505 fi
506 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
507
508 %postun
509 %systemd_reload
510
511 %post xend
512 /sbin/chkconfig --add xend
513 %systemd_post xend.service
514
515 %preun xend
516 if [ "$1" = "0" ]; then
517         %service xend stop
518         /sbin/chkconfig --del xend
519 fi
520 %systemd_preun xend.service
521
522 %postun xend
523 %systemd_reload
524
525 %post   libs -p /sbin/ldconfig
526 %postun libs -p /sbin/ldconfig
527
528 %post   libs-guest -p /sbin/ldconfig
529 %postun libs-guest -p /sbin/ldconfig
530
531 %files
532 %defattr(644,root,root,755)
533 %doc COPYING README* docs/misc/* 
534 %doc docs/html/*
535 %doc tools/qemu-xen-dir/*.html
536 %doc _doc/*
537 /boot/%{name}-syms-%{version}
538 /boot/%{name}-%{version}.gz
539 /boot/%{name}.gz
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
542 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
543 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
544 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
545 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
546 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
547 %attr(754,root,root) /etc/rc.d/init.d/xenstored
548 %attr(754,root,root) /etc/rc.d/init.d/xendomains
549 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
550 %{systemdunitdir}/proc-xen.mount
551 %{systemdunitdir}/var-lib-xenstored.mount
552 %{systemdunitdir}/xen-watchdog.service
553 %{systemdunitdir}/xenconsoled.service
554 %{systemdunitdir}/xenstored.service
555 %dir %{_sysconfdir}/xen
556 %dir %{_sysconfdir}/xen/auto
557 %dir %{_sysconfdir}/xen/examples
558 %dir %{_sysconfdir}/xen/scripts
559 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
564 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
565 %attr(755,root,root) %{_bindir}/pygrub
566 %attr(755,root,root) %{_bindir}/qemu-img-xen
567 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
568 %attr(755,root,root) %{_bindir}/remus
569 %attr(755,root,root) %{_bindir}/xencons
570 %attr(755,root,root) %{_bindir}/xentrace*
571 %attr(755,root,root) %{_sbindir}/blktapctrl
572 %attr(755,root,root) %{_sbindir}/flask-*
573 %attr(755,root,root) %{_sbindir}/gdbsx
574 %attr(755,root,root) %{_sbindir}/gtrace*
575 %attr(755,root,root) %{_sbindir}/img2qcow
576 %attr(755,root,root) %{_sbindir}/kdd
577 %attr(755,root,root) %{_sbindir}/lock-util
578 %attr(755,root,root) %{_sbindir}/qcow-create
579 %attr(755,root,root) %{_sbindir}/qcow2raw
580 %attr(755,root,root) %{_sbindir}/tap-ctl
581 %attr(755,root,root) %{_sbindir}/tapdisk*
582 %attr(755,root,root) %{_sbindir}/td-util
583 %attr(755,root,root) %{_sbindir}/vhd-*
584 %attr(755,root,root) %{_sbindir}/xen-*
585 %attr(755,root,root) %{_sbindir}/xenbaked
586 %attr(755,root,root) %{_sbindir}/xenconsoled
587 %attr(755,root,root) %{_sbindir}/xenlockprof
588 %attr(755,root,root) %{_sbindir}/xenmon.py
589 %attr(755,root,root) %{_sbindir}/xenperf
590 %attr(755,root,root) %{_sbindir}/xenpm
591 %attr(755,root,root) %{_sbindir}/xenpmd
592 %attr(755,root,root) %{_sbindir}/xenstored
593 %attr(755,root,root) %{_sbindir}/xentop
594 %attr(755,root,root) %{_sbindir}/xentrace_setmask
595 %attr(755,root,root) %{_sbindir}/xenwatchdogd
596 %attr(755,root,root) %{_sbindir}/xl
597 %attr(755,root,root) %{_sbindir}/xsview
598 %dir %{_libdir}/%{name}
599 %dir %{_libdir}/%{name}/bin
600 %attr(744,root,root) %{_libdir}/%{name}/bin/*
601 %if "%{_lib}" != "lib"
602 %dir %{_prefix}/lib/%{name}
603 %dir %{_prefix}/lib/%{name}/bin
604 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
605 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
606 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
607 %endif
608 %dir %{_prefix}/lib/%{name}/boot
609 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
610 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
611 %ifarch %{x8664}
612 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
613 %endif
614 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
615 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
616 %{_datadir}/xen
617 %{_mandir}/man1/qemu-img-xen.1*
618 %{_mandir}/man1/xentop.1*
619 %{_mandir}/man1/xentrace_format.1*
620 %{_mandir}/man1/xl.1*
621 %{_mandir}/man1/xm.1*
622 %{_mandir}/man5/xend-config.sxp.5*
623 %{_mandir}/man5/xl.cfg.5*
624 %{_mandir}/man5/xl.conf.5*
625 %{_mandir}/man5/xlcpupool.cfg.5*
626 %{_mandir}/man5/xmdomain.cfg.5*
627 %{_mandir}/man8/qemu-nbd-xen.8*
628 %{_mandir}/man8/xentrace.8*
629 %{_sharedstatedir}/xen
630 %{_sharedstatedir}/xenstored
631 %dir /var/run/xenstored
632 %{systemdtmpfilesdir}/xenstored.conf
633 %{systemdtmpfilesdir}/xen.conf
634 %dir %attr(0700,root,root) /var/log/xen
635 %dir %attr(0700,root,root) /var/log/xen/console
636 %{_datadir}/qemu-xen
637
638 %files guest
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_bindir}/xen-detect
641 %attr(755,root,root) %{_bindir}/xenstore*
642
643 %files libs
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
647 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
649 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
651 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
653 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
655 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
656 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
657 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
659 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
661 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
663 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
665 %dir %{_libdir}/fs
666 %dir %{_libdir}/fs/ext2fs-lib
667 %dir %{_libdir}/fs/fat
668 %dir %{_libdir}/fs/iso9660
669 %dir %{_libdir}/fs/reiserfs
670 %dir %{_libdir}/fs/ufs
671 %dir %{_libdir}/fs/xfs
672 %dir %{_libdir}/fs/zfs
673 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
674
675 %files libs-guest
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
678 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
679
680 %files devel
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/libblktap.so
683 %attr(755,root,root) %{_libdir}/libblktapctl.so
684 %attr(755,root,root) %{_libdir}/libfsimage.so
685 %attr(755,root,root) %{_libdir}/libvhd.so
686 %attr(755,root,root) %{_libdir}/libxenctrl.so
687 %attr(755,root,root) %{_libdir}/libxenguest.so
688 %attr(755,root,root) %{_libdir}/libxenlight.so
689 %attr(755,root,root) %{_libdir}/libxenstat.so
690 %attr(755,root,root) %{_libdir}/libxenstore.so
691 %attr(755,root,root) %{_libdir}/libxenvchan.so
692 %attr(755,root,root) %{_libdir}/libxlutil.so
693 %{_includedir}/_libxl_list.h
694 %{_includedir}/_libxl_types.h
695 %{_includedir}/_libxl_types_json.h
696 %{_includedir}/blktaplib.h
697 %{_includedir}/fsimage*.h
698 %{_includedir}/libxenvchan.h
699 %{_includedir}/libxl*.h
700 %{_includedir}/xen*.h
701 %{_includedir}/xs*.h
702 %{_includedir}/xen
703 %{_includedir}/xenstore-compat
704
705 %files static
706 %defattr(644,root,root,755)
707 %{_libdir}/libblktap.a
708 %{_libdir}/libblktapctl.a
709 %{_libdir}/libvhd.a
710 %{_libdir}/libxenctrl.a
711 %{_libdir}/libxenguest.a
712 %{_libdir}/libxenlight.a
713 %{_libdir}/libxenvchan.a
714 %{_libdir}/libxenstat.a
715 %{_libdir}/libxenstore.a
716 %{_libdir}/libxlutil.a
717
718 %files xend
719 %defattr(644,root,root,755)
720 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
721 %{systemdunitdir}/blktapctrl.service
722 %{systemdunitdir}/xend.service
723 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
724 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
725 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
726 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
727 %attr(755,root,root) %{_sbindir}/xend
728 %attr(755,root,root) %{_sbindir}/xm
729 %dir %attr(700,root,root) /var/run/xend
730 %{systemdtmpfilesdir}/xend.conf
731
732 %if %{with ocaml}
733 %files -n ocaml-xen
734 %defattr(644,root,root,755)
735 %doc tools/ocaml/LICENSE
736 %attr(755,root,root) %{_sbindir}/oxenstored
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
738 %dir %{_libdir}/ocaml/site-lib/xenbus
739 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
740 %dir %{_libdir}/ocaml/site-lib/xenctrl
741 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
742 %dir %{_libdir}/ocaml/site-lib/xeneventchn
743 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
744 %dir %{_libdir}/ocaml/site-lib/xenlight
745 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
746 %dir %{_libdir}/ocaml/site-lib/xenmmap
747 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
748
749 %files -n ocaml-xen-devel
750 %defattr(644,root,root,755)
751 %{_libdir}/ocaml/site-lib/xenbus/META
752 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
753 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
754 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
755 %{_libdir}/ocaml/site-lib/xenctrl/META
756 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
757 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
758 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
759 %{_libdir}/ocaml/site-lib/xeneventchn/META
760 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
761 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
762 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
763 %{_libdir}/ocaml/site-lib/xenmmap/META
764 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
765 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
766 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
767 %{_libdir}/ocaml/site-lib/xenlight/META
768 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
769 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
770 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
771 %dir %{_libdir}/ocaml/site-lib/xenstore
772 %{_libdir}/ocaml/site-lib/xenstore/META
773 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
774 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
775 %endif
776
777 %files -n python-xen
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{py_sitedir}/fsimage.so
780 %{py_sitedir}/grub
781 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
782 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
783 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
784 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
785 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
786 %{py_sitedir}/xen/remus
787 %{py_sitedir}/xen/sv
788 %{py_sitedir}/xen/util
789 %{py_sitedir}/xen/web
790 %{py_sitedir}/xen/xend
791 %{py_sitedir}/xen/xm
792 %{py_sitedir}/xen/xsview
793 %if "%{py_ver}" > "2.4"
794 %{py_sitedir}/pygrub-0.3-py*.egg-info
795 %{py_sitedir}/xen-3.0-py*.egg-info
796 %endif
797
798 %files -n python-xen-guest
799 %defattr(644,root,root,755)
800 %dir %{py_sitedir}/xen
801 %{py_sitedir}/xen/__init__.py*
802 %dir %{py_sitedir}/xen/lowlevel
803 %{py_sitedir}/xen/lowlevel/__init__.py*
804 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
805
806 %files -n bash-completion-%{name}
807 %defattr(644,root,root,755)
808 /etc/bash_completion.d/xl.sh
809
810 %if %{with efi}
811 %files efi
812 %defattr(644,root,root,755)
813 %dir %{_libdir}/efi
814 %{_libdir}/efi/*.efi
815 %endif
This page took 0.956535 seconds and 4 git commands to generate.