]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- added ulong patch (one more build fix for current glibc/linux)
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.1
33 Release:        2
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  0d48cbe1767b82aba12517898d4e0408
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Source57:       xen.cfg
77 Source58:       xen.efi-boot-update
78 Patch0:         %{name}-python_scripts.patch
79 Patch1:         %{name}-symbols.patch
80 Patch2:         %{name}-curses.patch
81 Patch3:         pygrubfix.patch
82 Patch4:         xend.catchbt.patch
83 Patch5:         xend-pci-loop.patch
84 Patch6:         %{name}-dumpdir.patch
85 # Warning: this disables ingress filtering implemented in xen scripts!
86 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
87 Patch8:         %{name}-configure-xend.patch
88 Patch9:         %{name}-initscript.patch
89 Patch10:        %{name}-quemu-softloat-c99.patch
90 Patch11:        %{name}-qemu.patch
91 Patch12:        %{name}-scripts-locking.patch
92 Patch13:        %{name}-close_lockfd_after_lock_attempt.patch
93 Patch14:        %{name}-librt.patch
94 Patch15:        %{name}-ulong.patch
95 URL:            http://www.xen.org/products/xenhyp.html
96 %{?with_opengl:BuildRequires:   OpenGL-devel}
97 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
98 %ifarch %{ix86} %{x8664}
99 BuildRequires:  acpica
100 BuildRequires:  bcc
101 %endif
102 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
103 %{?with_brlapi:BuildRequires:   brlapi-devel}
104 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
105 BuildRequires:  bzip2-devel
106 BuildRequires:  ceph-devel
107 BuildRequires:  curl-devel
108 BuildRequires:  cyrus-sasl-devel >= 2
109 BuildRequires:  e2fsprogs-devel
110 BuildRequires:  gcc >= 5:3.4
111 BuildRequires:  gettext-devel
112 BuildRequires:  glib2-devel >= 1:2.12
113 BuildRequires:  gnutls-devel
114 BuildRequires:  latex2html >= 2008
115 BuildRequires:  libaio-devel
116 BuildRequires:  libiscsi-devel
117 BuildRequires:  libjpeg-devel
118 BuildRequires:  libpng-devel
119 BuildRequires:  libuuid-devel
120 BuildRequires:  lzo-devel >= 2
121 BuildRequires:  ncurses-devel
122 %if %{with ocaml}
123 BuildRequires:  ocaml >= 3.04-7
124 BuildRequires:  ocaml-findlib
125 %endif
126 BuildRequires:  nss-devel >= 3.12.8
127 BuildRequires:  openssl-devel
128 BuildRequires:  pciutils-devel
129 BuildRequires:  perl-base
130 BuildRequires:  pkgconfig
131 BuildRequires:  python-devel
132 BuildRequires:  rpm-pythonprov
133 BuildRequires:  rpmbuild(macros) >= 1.647
134 BuildRequires:  spice-protocol >= 0.6.0
135 BuildRequires:  spice-server-devel >= 0.6.0
136 BuildRequires:  texi2html
137 BuildRequires:  texlive-dvips
138 BuildRequires:  texlive-latex-psnfss
139 BuildRequires:  texlive-xetex
140 BuildRequires:  usbredir-devel
141 BuildRequires:  vde2-devel
142 BuildRequires:  which
143 # for xfsctl (<xfs/xfs.h>)
144 BuildRequires:  xfsprogs-devel
145 BuildRequires:  xorg-lib-libX11-devel
146 BuildRequires:  xorg-lib-libXext-devel
147 BuildRequires:  xz-devel
148 BuildRequires:  yajl-devel
149 BuildRequires:  zlib-devel
150 # FIXME: see qemu configure comments on top of spec
151 %{!?with_opengl:BuildConflicts: OpenGL-devel}
152 %{!?with_sdl:BuildConflicts:    SDL-devel}
153 %{!?with_sdl:BuildConflicts:    SDL-devel}
154 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
155 %{!?with_brlapi:BuildConflicts: brlapi-devel}
156 Requires(post,preun):   /sbin/chkconfig
157 Requires(post,preun,postun):    systemd-units >= 38
158 Requires:       %{name}-libs = %{version}-%{release}
159 Requires:       ZopeInterface
160 Requires:       bridge-utils
161 Requires:       coreutils
162 Requires:       diffutils
163 Requires:       gawk
164 Requires:       iptables
165 Requires:       losetup
166 Requires:       net-tools
167 Requires:       python-%{name} = %{version}-%{release}
168 Requires:       rc-scripts
169 Requires:       sed
170 Requires:       systemd-units >= 38
171 Requires:       util-linux
172 Requires:       which
173 Requires:       %{name}-guest = %{version}-%{release}
174 Obsoletes:      xen-doc
175 Obsoletes:      xen-udev
176 ExclusiveArch:  %{ix86} %{x8664}
177 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
178
179 # some PPC/SPARC boot images in ELF format
180 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
181
182 %description
183 This package contains the Xen hypervisor and Xen tools, needed to run
184 virtual machines on x86 systems, together with the kernel-xen*
185 packages. Information on how to use Xen can be found at the Xen
186 project pages.
187
188 Virtualisation can be used to run multiple versions or multiple Linux
189 distributions on one system, or to test untrusted applications in a
190 sandboxed environment. Note that the Xen technology is still in
191 development, and this RPM has received extremely little testing. Don't
192 be surprised if this RPM eats your data, drinks your coffee or makes
193 fun of you in front of your friends.
194
195 %description -l pl.UTF-8
196 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
197 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
198 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
199 projektu.
200
201 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
202 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
203 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
204 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
205 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
206 się wyśmiewał w obecności przyjaciół.
207
208 %package guest
209 Summary:        Xen tools for virtual machines
210 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
211 Group:          Applications/System
212 Requires:       %{name}-libs-guest = %{version}-%{release}
213
214 %description guest
215 Xen utilities for both dom0 and domU virtual domains.
216
217 %description guest -l pl.UTF-8
218 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
219
220 %package libs
221 Summary:        Xen libraries
222 Summary(pl.UTF-8):      Biblioteki Xena
223 Group:          Libraries
224 Requires:       %{name}-libs-guest = %{version}-%{release}
225
226 %description libs
227 Xen libraries.
228
229 %description libs -l pl.UTF-8
230 Biblioteki Xena.
231
232 %package libs-guest
233 Summary:        Xen libraries for virtual machines
234 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
235 Group:          Libraries
236
237 %description libs-guest
238 Xen libraries for both dom0 and domU virtual machines.
239
240 %description libs-guest -l pl.UTF-8
241 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
242
243 %package devel
244 Summary:        Header files for Xen
245 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
246 Group:          Development/Libraries
247 Requires:       %{name}-libs = %{version}-%{release}
248
249 %description devel
250 Header files for Xen.
251
252 %description devel -l pl.UTF-8
253 Pliki nagłówkowe Xena.
254
255 %package static
256 Summary:        Static Xen libraries
257 Summary(pl.UTF-8):      Statyczne biblioteki Xena
258 Group:          Development/Libraries
259 Requires:       %{name}-devel = %{version}-%{release}
260
261 %description static
262 Static Xen libraries.
263
264 %description static -l pl.UTF-8
265 Statyczne biblioteki Xena.
266
267 %package xend
268 Summary:        xend daemon
269 Summary(pl.UTF-8):      Demon xend
270 Group:          Daemons
271 Requires(post,preun,postun):    systemd-units >= 38
272 Requires:       systemd-units >= 38
273
274 %description xend
275 xend daemon.
276
277 %description xend -l pl.UTF-8
278 Demon xend.
279
280 %package -n ocaml-xen
281 Summary:        OCaml bindings for Xen
282 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
283 License:        LGPL v2.1 with linking exception
284 Group:          Libraries
285 Requires:       %{name}-libs = %{version}-%{release}
286 %if %{with ocaml}
287 %requires_eq    ocaml-runtime
288 %endif
289
290 %description -n ocaml-xen
291 OCaml bindings for Xen.
292
293 %description -n ocaml-xen -l pl.UTF-8
294 Wiązania OCamla dla Xena.
295
296 %package -n ocaml-xen-devel
297 Summary:        OCaml bindings for Xen - development files
298 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
299 License:        LGPL v2.1 with linking exception
300 Group:          Development/Libraries
301 Requires:       ocaml-xen = %{version}-%{release}
302 %if %{with ocaml}
303 %requires_eq    ocaml
304 %endif
305
306 %description -n ocaml-xen-devel
307 OCaml bindings for Xen - development files.
308
309 %description -n ocaml-xen-devel -l pl.UTF-8
310 Wiązania OCamla dla Xena - pliki programistyczne.
311
312 %package -n python-xen
313 Summary:        Xen Python modules
314 Summary(pl.UTF-8):      Moduły Pythona dla Xena
315 Group:          Libraries
316 Requires:       %{name}-libs = %{version}-%{release}
317 Conflicts:      xen < 3.2.1-0.3
318
319 %description -n python-xen
320 Xen Python modules.
321
322 %description -n python-xen -l pl.UTF-8
323 Moduły Pythona dla Xena.
324
325 %package -n python-xen-guest
326 Summary:        Xen Python modules for virtual machines
327 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
328 Group:          Libraries
329 Requires:       %{name}-libs-guest = %{version}-%{release}
330 Conflicts:      xen < 3.2.1-0.3
331
332 %description -n python-xen-guest
333 Xen Python modules for both dom0 and domU virtual machines.
334
335 %description -n python-xen-guest -l pl.UTF-8
336 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
337
338 %package -n bash-completion-%{name}
339 Summary:    bash-completion for Xen (xl)
340 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
341 Group:      Applications/Shells
342 Requires:   %{name} = %{version}-%{release}
343 Requires:   bash-completion
344
345 %description -n bash-completion-%{name}
346 This package provides bash-completion for Xen (xl).
347
348 %description -n bash-completion-%{name} -l pl.UTF-8
349 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
350
351 %package efi
352 Summary:        Xen hypervisor binary for EFI
353 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
354 Group:          Applications/System
355 Requires:       %{name}-libs-guest = %{version}-%{release}
356
357 %description efi
358 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
359 firmware without help from any additional bootloader.
360
361 %description efi -l pl.UTF-8
362 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
363 (U)EFI, bez potrzeby oddzielnego bootloadera.
364
365 %prep
366 %setup -q -a 16
367 %patch0 -p1
368 %patch1 -p1
369 %patch2 -p1
370 %patch3 -p1
371 %patch4 -p1
372 %patch5 -p1
373 %patch6 -p1
374 %patch7 -p1
375 %patch8 -p1
376 %patch9 -p1
377 %patch10 -p1
378 %patch11 -p1
379 %patch12 -p1
380 %patch13 -p1
381 %patch14 -p1
382 %patch15 -p1
383
384 # stubdom sources
385 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
386 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
387
388 # do not allow fetching anything via git
389 echo GIT=/bin/false >> Config.mk
390
391 %build
392 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
393 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
394
395 # NOTE:
396 # - there is a quoting bug (in tools/driver/Makefile) that causes
397 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
398 #   anyway (see configure), gcrypt is optional
399 # - prevent libiconv from being detected (not needed with glibc)
400 cd tools
401 %configure \
402         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
403         ac_cv_lib_iconv_libiconv_open=no \
404         --disable-debug
405 cd ..
406
407 %{__make} dist-xen dist-tools dist-docs \
408         %{!?with_ocaml:OCAML_TOOLS=n} \
409         prefix=%{_prefix} \
410         CC="%{__cc}" \
411         CXX="%{__cxx}" \
412         V=1
413
414 unset CFLAGS
415 unset CXXFLAGS
416
417 %{__make} -j1 dist-stubdom \
418         %{!?with_ocaml:OCAML_TOOLS=n} \
419         CC="%{__cc}" \
420         CXX="%{__cxx}" \
421         V=1
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
426         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
427         $RPM_BUILD_ROOT/etc/efi-boot/update.d
428
429 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
430         %{!?with_ocaml:OCAML_TOOLS=n} \
431         prefix=%{_prefix} \
432         DESTDIR=$RPM_BUILD_ROOT \
433         HOTPLUGS=install-udev
434
435 %if "%{_lib}" == "lib64"
436 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
437 %endif
438
439 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
440 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
441 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
442 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
443 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
444 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
445 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
446 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
447 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
448 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
449 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
450 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
451 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
452 # sysvinit scripts
453 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
454 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
455 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
456 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
457 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
458 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
459 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
460 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
461
462 %if %{with efi}
463 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
464 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
465                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
466 %endif
467
468 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
469
470 # for %%doc
471 install -d _doc
472 for tool in blktap blktap2 pygrub xenmon ; do
473         cp -p tools/$tool/README _doc/README.$tool
474 done
475 cp -al tools/qemu-xen/docs _doc/qemu-xen
476
477 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
478 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
479
480 %py_postclean
481
482 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
483 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
484 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
485 # seems not needed, the path is wrong anyway
486 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
487
488 # remove unneeded files
489 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
490 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
491 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
492 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
493 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
494
495 %clean
496 rm -rf $RPM_BUILD_ROOT
497
498 %post
499 /sbin/chkconfig --add xen-watchdog
500 /sbin/chkconfig --add xenconsoled
501 /sbin/chkconfig --add xenstored
502 /sbin/chkconfig --add xendomains
503 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
504
505 %preun
506 if [ "$1" = "0" ]; then
507         %service xendomains stop
508         /sbin/chkconfig --del xendomains
509
510         %service xenconsoled stop
511         /sbin/chkconfig --del xenconsoled
512
513         %service xenstored stop
514         /sbin/chkconfig --del xenstored
515
516         %service xen-watchdog stop
517         /sbin/chkconfig --del xen-watchdog
518 fi
519 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
520
521 %postun
522 %systemd_reload
523
524 %post xend
525 /sbin/chkconfig --add xend
526 %systemd_post xend.service
527
528 %preun xend
529 if [ "$1" = "0" ]; then
530         %service xend stop
531         /sbin/chkconfig --del xend
532 fi
533 %systemd_preun xend.service
534
535 %postun xend
536 %systemd_reload
537
538 %post   libs -p /sbin/ldconfig
539 %postun libs -p /sbin/ldconfig
540
541 %post   libs-guest -p /sbin/ldconfig
542 %postun libs-guest -p /sbin/ldconfig
543
544 %post efi
545 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
546
547 %files
548 %defattr(644,root,root,755)
549 %doc COPYING README* docs/misc/* 
550 %doc docs/html/*
551 %doc tools/qemu-xen-dir/*.html
552 %doc _doc/*
553 /boot/%{name}-syms-%{version}
554 /boot/%{name}-%{version}.gz
555 /boot/%{name}.gz
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
557 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
561 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
562 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
563 %attr(754,root,root) /etc/rc.d/init.d/xenstored
564 %attr(754,root,root) /etc/rc.d/init.d/xendomains
565 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
566 %{systemdunitdir}/proc-xen.mount
567 %{systemdunitdir}/var-lib-xenstored.mount
568 %{systemdunitdir}/xen-watchdog.service
569 %{systemdunitdir}/xenconsoled.service
570 %{systemdunitdir}/xenstored.service
571 %dir %{_sysconfdir}/xen
572 %dir %{_sysconfdir}/xen/auto
573 %dir %{_sysconfdir}/xen/examples
574 %dir %{_sysconfdir}/xen/scripts
575 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
576 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
578 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
579 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
580 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
581 %attr(755,root,root) %{_bindir}/pygrub
582 %attr(755,root,root) %{_bindir}/qemu-img-xen
583 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
584 %attr(755,root,root) %{_bindir}/remus
585 %attr(755,root,root) %{_bindir}/xencons
586 %attr(755,root,root) %{_bindir}/xentrace*
587 %attr(755,root,root) %{_sbindir}/blktapctrl
588 %attr(755,root,root) %{_sbindir}/flask-*
589 %attr(755,root,root) %{_sbindir}/gdbsx
590 %attr(755,root,root) %{_sbindir}/gtrace*
591 %attr(755,root,root) %{_sbindir}/img2qcow
592 %attr(755,root,root) %{_sbindir}/kdd
593 %attr(755,root,root) %{_sbindir}/lock-util
594 %attr(755,root,root) %{_sbindir}/qcow-create
595 %attr(755,root,root) %{_sbindir}/qcow2raw
596 %attr(755,root,root) %{_sbindir}/tap-ctl
597 %attr(755,root,root) %{_sbindir}/tapdisk*
598 %attr(755,root,root) %{_sbindir}/td-util
599 %attr(755,root,root) %{_sbindir}/vhd-*
600 %attr(755,root,root) %{_sbindir}/xen-*
601 %attr(755,root,root) %{_sbindir}/xenbaked
602 %attr(755,root,root) %{_sbindir}/xenconsoled
603 %attr(755,root,root) %{_sbindir}/xenlockprof
604 %attr(755,root,root) %{_sbindir}/xenmon.py
605 %attr(755,root,root) %{_sbindir}/xenperf
606 %attr(755,root,root) %{_sbindir}/xenpm
607 %attr(755,root,root) %{_sbindir}/xenpmd
608 %attr(755,root,root) %{_sbindir}/xenstored
609 %attr(755,root,root) %{_sbindir}/xentop
610 %attr(755,root,root) %{_sbindir}/xentrace_setmask
611 %attr(755,root,root) %{_sbindir}/xenwatchdogd
612 %attr(755,root,root) %{_sbindir}/xl
613 %attr(755,root,root) %{_sbindir}/xsview
614 %dir %{_libdir}/%{name}
615 %dir %{_libdir}/%{name}/bin
616 %attr(744,root,root) %{_libdir}/%{name}/bin/*
617 %if "%{_lib}" != "lib"
618 %dir %{_prefix}/lib/%{name}
619 %dir %{_prefix}/lib/%{name}/bin
620 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
621 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
622 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
623 %endif
624 %dir %{_prefix}/lib/%{name}/boot
625 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
626 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
627 %ifarch %{x8664}
628 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
629 %endif
630 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
631 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
632 %{_datadir}/xen
633 %{_mandir}/man1/qemu-img-xen.1*
634 %{_mandir}/man1/xentop.1*
635 %{_mandir}/man1/xentrace_format.1*
636 %{_mandir}/man1/xl.1*
637 %{_mandir}/man1/xm.1*
638 %{_mandir}/man5/xend-config.sxp.5*
639 %{_mandir}/man5/xl.cfg.5*
640 %{_mandir}/man5/xl.conf.5*
641 %{_mandir}/man5/xlcpupool.cfg.5*
642 %{_mandir}/man5/xmdomain.cfg.5*
643 %{_mandir}/man8/qemu-nbd-xen.8*
644 %{_mandir}/man8/xentrace.8*
645 %{_sharedstatedir}/xen
646 %{_sharedstatedir}/xenstored
647 %dir /var/run/xenstored
648 %{systemdtmpfilesdir}/xenstored.conf
649 %{systemdtmpfilesdir}/xen.conf
650 %dir %attr(0700,root,root) /var/log/xen
651 %dir %attr(0700,root,root) /var/log/xen/console
652 %{_datadir}/qemu-xen
653
654 %files guest
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/xen-detect
657 %attr(755,root,root) %{_bindir}/xenstore*
658
659 %files libs
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
663 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
665 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
667 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
669 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
671 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
672 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
673 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
675 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
677 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
678 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
679 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
680 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
681 %dir %{_libdir}/fs
682 %dir %{_libdir}/fs/ext2fs-lib
683 %dir %{_libdir}/fs/fat
684 %dir %{_libdir}/fs/iso9660
685 %dir %{_libdir}/fs/reiserfs
686 %dir %{_libdir}/fs/ufs
687 %dir %{_libdir}/fs/xfs
688 %dir %{_libdir}/fs/zfs
689 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
690
691 %files libs-guest
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
694 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
695
696 %files devel
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libblktap.so
699 %attr(755,root,root) %{_libdir}/libblktapctl.so
700 %attr(755,root,root) %{_libdir}/libfsimage.so
701 %attr(755,root,root) %{_libdir}/libvhd.so
702 %attr(755,root,root) %{_libdir}/libxenctrl.so
703 %attr(755,root,root) %{_libdir}/libxenguest.so
704 %attr(755,root,root) %{_libdir}/libxenlight.so
705 %attr(755,root,root) %{_libdir}/libxenstat.so
706 %attr(755,root,root) %{_libdir}/libxenstore.so
707 %attr(755,root,root) %{_libdir}/libxenvchan.so
708 %attr(755,root,root) %{_libdir}/libxlutil.so
709 %{_includedir}/_libxl_list.h
710 %{_includedir}/_libxl_types.h
711 %{_includedir}/_libxl_types_json.h
712 %{_includedir}/blktaplib.h
713 %{_includedir}/fsimage*.h
714 %{_includedir}/libxenvchan.h
715 %{_includedir}/libxl*.h
716 %{_includedir}/xen*.h
717 %{_includedir}/xs*.h
718 %{_includedir}/xen
719 %{_includedir}/xenstore-compat
720
721 %files static
722 %defattr(644,root,root,755)
723 %{_libdir}/libblktap.a
724 %{_libdir}/libblktapctl.a
725 %{_libdir}/libvhd.a
726 %{_libdir}/libxenctrl.a
727 %{_libdir}/libxenguest.a
728 %{_libdir}/libxenlight.a
729 %{_libdir}/libxenvchan.a
730 %{_libdir}/libxenstat.a
731 %{_libdir}/libxenstore.a
732 %{_libdir}/libxlutil.a
733
734 %files xend
735 %defattr(644,root,root,755)
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
737 %{systemdunitdir}/blktapctrl.service
738 %{systemdunitdir}/xend.service
739 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
740 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
741 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
742 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
743 %attr(755,root,root) %{_sbindir}/xend
744 %attr(755,root,root) %{_sbindir}/xm
745 %dir %attr(700,root,root) /var/run/xend
746 %{systemdtmpfilesdir}/xend.conf
747
748 %if %{with ocaml}
749 %files -n ocaml-xen
750 %defattr(644,root,root,755)
751 %doc tools/ocaml/LICENSE
752 %attr(755,root,root) %{_sbindir}/oxenstored
753 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
754 %dir %{_libdir}/ocaml/site-lib/xenbus
755 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
756 %dir %{_libdir}/ocaml/site-lib/xenctrl
757 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
758 %dir %{_libdir}/ocaml/site-lib/xeneventchn
759 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
760 %dir %{_libdir}/ocaml/site-lib/xenlight
761 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
762 %dir %{_libdir}/ocaml/site-lib/xenmmap
763 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
764
765 %files -n ocaml-xen-devel
766 %defattr(644,root,root,755)
767 %{_libdir}/ocaml/site-lib/xenbus/META
768 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
769 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
770 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
771 %{_libdir}/ocaml/site-lib/xenctrl/META
772 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
773 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
774 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
775 %{_libdir}/ocaml/site-lib/xeneventchn/META
776 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
777 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
778 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
779 %{_libdir}/ocaml/site-lib/xenmmap/META
780 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
781 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
782 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
783 %{_libdir}/ocaml/site-lib/xenlight/META
784 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
785 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
786 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
787 %dir %{_libdir}/ocaml/site-lib/xenstore
788 %{_libdir}/ocaml/site-lib/xenstore/META
789 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
790 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
791 %endif
792
793 %files -n python-xen
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{py_sitedir}/fsimage.so
796 %{py_sitedir}/grub
797 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
798 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
799 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
800 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
801 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
802 %{py_sitedir}/xen/remus
803 %{py_sitedir}/xen/sv
804 %{py_sitedir}/xen/util
805 %{py_sitedir}/xen/web
806 %{py_sitedir}/xen/xend
807 %{py_sitedir}/xen/xm
808 %{py_sitedir}/xen/xsview
809 %if "%{py_ver}" > "2.4"
810 %{py_sitedir}/pygrub-0.3-py*.egg-info
811 %{py_sitedir}/xen-3.0-py*.egg-info
812 %endif
813
814 %files -n python-xen-guest
815 %defattr(644,root,root,755)
816 %dir %{py_sitedir}/xen
817 %{py_sitedir}/xen/__init__.py*
818 %dir %{py_sitedir}/xen/lowlevel
819 %{py_sitedir}/xen/lowlevel/__init__.py*
820 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
821
822 %files -n bash-completion-%{name}
823 %defattr(644,root,root,755)
824 /etc/bash_completion.d/xl.sh
825
826 %if %{with efi}
827 %files efi
828 %defattr(644,root,root,755)
829 %dir %{_libdir}/efi
830 %{_libdir}/efi/*.efi
831 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
832 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
833 %endif
This page took 1.342962 seconds and 4 git commands to generate.