]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- added librt patch (qemu build fix for glibc 2.17)
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.1
33 Release:        1
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  0d48cbe1767b82aba12517898d4e0408
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Source57:       xen.cfg
77 Source58:       xen.efi-boot-update
78 Patch0:         %{name}-python_scripts.patch
79 Patch1:         %{name}-symbols.patch
80 Patch2:         %{name}-curses.patch
81 Patch3:         pygrubfix.patch
82 Patch4:         xend.catchbt.patch
83 Patch5:         xend-pci-loop.patch
84 Patch6:         %{name}-dumpdir.patch
85 # Warning: this disables ingress filtering implemented in xen scripts!
86 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
87 Patch8:         %{name}-configure-xend.patch
88 Patch9:         %{name}-initscript.patch
89 Patch10:        %{name}-quemu-softloat-c99.patch
90 Patch11:        %{name}-qemu.patch
91 Patch12:        %{name}-scripts-locking.patch
92 Patch13:        %{name}-close_lockfd_after_lock_attempt.patch
93 Patch14:        %{name}-librt.patch
94 URL:            http://www.xen.org/products/xenhyp.html
95 %{?with_opengl:BuildRequires:   OpenGL-devel}
96 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
97 %ifarch %{ix86} %{x8664}
98 BuildRequires:  acpica
99 BuildRequires:  bcc
100 %endif
101 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
102 %{?with_brlapi:BuildRequires:   brlapi-devel}
103 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
104 BuildRequires:  bzip2-devel
105 BuildRequires:  ceph-devel
106 BuildRequires:  curl-devel
107 BuildRequires:  cyrus-sasl-devel >= 2
108 BuildRequires:  e2fsprogs-devel
109 BuildRequires:  gcc >= 5:3.4
110 BuildRequires:  gettext-devel
111 BuildRequires:  glib2-devel >= 1:2.12
112 BuildRequires:  gnutls-devel
113 BuildRequires:  latex2html >= 2008
114 BuildRequires:  libaio-devel
115 BuildRequires:  libiscsi-devel
116 BuildRequires:  libjpeg-devel
117 BuildRequires:  libpng-devel
118 BuildRequires:  libuuid-devel
119 BuildRequires:  lzo-devel >= 2
120 BuildRequires:  ncurses-devel
121 %if %{with ocaml}
122 BuildRequires:  ocaml >= 3.04-7
123 BuildRequires:  ocaml-findlib
124 %endif
125 BuildRequires:  nss-devel >= 3.12.8
126 BuildRequires:  openssl-devel
127 BuildRequires:  pciutils-devel
128 BuildRequires:  perl-base
129 BuildRequires:  pkgconfig
130 BuildRequires:  python-devel
131 BuildRequires:  rpm-pythonprov
132 BuildRequires:  rpmbuild(macros) >= 1.647
133 BuildRequires:  spice-protocol >= 0.6.0
134 BuildRequires:  spice-server-devel >= 0.6.0
135 BuildRequires:  texi2html
136 BuildRequires:  texlive-dvips
137 BuildRequires:  texlive-latex-psnfss
138 BuildRequires:  texlive-xetex
139 BuildRequires:  usbredir-devel
140 BuildRequires:  vde2-devel
141 BuildRequires:  which
142 # for xfsctl (<xfs/xfs.h>)
143 BuildRequires:  xfsprogs-devel
144 BuildRequires:  xorg-lib-libX11-devel
145 BuildRequires:  xorg-lib-libXext-devel
146 BuildRequires:  xz-devel
147 BuildRequires:  yajl-devel
148 BuildRequires:  zlib-devel
149 # FIXME: see qemu configure comments on top of spec
150 %{!?with_opengl:BuildConflicts: OpenGL-devel}
151 %{!?with_sdl:BuildConflicts:    SDL-devel}
152 %{!?with_sdl:BuildConflicts:    SDL-devel}
153 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
154 %{!?with_brlapi:BuildConflicts: brlapi-devel}
155 Requires(post,preun):   /sbin/chkconfig
156 Requires(post,preun,postun):    systemd-units >= 38
157 Requires:       %{name}-libs = %{version}-%{release}
158 Requires:       ZopeInterface
159 Requires:       bridge-utils
160 Requires:       coreutils
161 Requires:       diffutils
162 Requires:       gawk
163 Requires:       iptables
164 Requires:       losetup
165 Requires:       net-tools
166 Requires:       python-%{name} = %{version}-%{release}
167 Requires:       rc-scripts
168 Requires:       sed
169 Requires:       systemd-units >= 38
170 Requires:       util-linux
171 Requires:       which
172 Requires:       %{name}-guest = %{version}-%{release}
173 Obsoletes:      xen-doc
174 Obsoletes:      xen-udev
175 ExclusiveArch:  %{ix86} %{x8664}
176 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
177
178 # some PPC/SPARC boot images in ELF format
179 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
180
181 %description
182 This package contains the Xen hypervisor and Xen tools, needed to run
183 virtual machines on x86 systems, together with the kernel-xen*
184 packages. Information on how to use Xen can be found at the Xen
185 project pages.
186
187 Virtualisation can be used to run multiple versions or multiple Linux
188 distributions on one system, or to test untrusted applications in a
189 sandboxed environment. Note that the Xen technology is still in
190 development, and this RPM has received extremely little testing. Don't
191 be surprised if this RPM eats your data, drinks your coffee or makes
192 fun of you in front of your friends.
193
194 %description -l pl.UTF-8
195 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
196 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
197 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
198 projektu.
199
200 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
201 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
202 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
203 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
204 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
205 się wyśmiewał w obecności przyjaciół.
206
207 %package guest
208 Summary:        Xen tools for virtual machines
209 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
210 Group:          Applications/System
211 Requires:       %{name}-libs-guest = %{version}-%{release}
212
213 %description guest
214 Xen utilities for both dom0 and domU virtual domains.
215
216 %description guest -l pl.UTF-8
217 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
218
219 %package libs
220 Summary:        Xen libraries
221 Summary(pl.UTF-8):      Biblioteki Xena
222 Group:          Libraries
223 Requires:       %{name}-libs-guest = %{version}-%{release}
224
225 %description libs
226 Xen libraries.
227
228 %description libs -l pl.UTF-8
229 Biblioteki Xena.
230
231 %package libs-guest
232 Summary:        Xen libraries for virtual machines
233 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
234 Group:          Libraries
235
236 %description libs-guest
237 Xen libraries for both dom0 and domU virtual machines.
238
239 %description libs-guest -l pl.UTF-8
240 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
241
242 %package devel
243 Summary:        Header files for Xen
244 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
245 Group:          Development/Libraries
246 Requires:       %{name}-libs = %{version}-%{release}
247
248 %description devel
249 Header files for Xen.
250
251 %description devel -l pl.UTF-8
252 Pliki nagłówkowe Xena.
253
254 %package static
255 Summary:        Static Xen libraries
256 Summary(pl.UTF-8):      Statyczne biblioteki Xena
257 Group:          Development/Libraries
258 Requires:       %{name}-devel = %{version}-%{release}
259
260 %description static
261 Static Xen libraries.
262
263 %description static -l pl.UTF-8
264 Statyczne biblioteki Xena.
265
266 %package xend
267 Summary:        xend daemon
268 Summary(pl.UTF-8):      Demon xend
269 Group:          Daemons
270 Requires(post,preun,postun):    systemd-units >= 38
271 Requires:       systemd-units >= 38
272
273 %description xend
274 xend daemon.
275
276 %description xend -l pl.UTF-8
277 Demon xend.
278
279 %package -n ocaml-xen
280 Summary:        OCaml bindings for Xen
281 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
282 License:        LGPL v2.1 with linking exception
283 Group:          Libraries
284 Requires:       %{name}-libs = %{version}-%{release}
285 %if %{with ocaml}
286 %requires_eq    ocaml-runtime
287 %endif
288
289 %description -n ocaml-xen
290 OCaml bindings for Xen.
291
292 %description -n ocaml-xen -l pl.UTF-8
293 Wiązania OCamla dla Xena.
294
295 %package -n ocaml-xen-devel
296 Summary:        OCaml bindings for Xen - development files
297 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
298 License:        LGPL v2.1 with linking exception
299 Group:          Development/Libraries
300 Requires:       ocaml-xen = %{version}-%{release}
301 %if %{with ocaml}
302 %requires_eq    ocaml
303 %endif
304
305 %description -n ocaml-xen-devel
306 OCaml bindings for Xen - development files.
307
308 %description -n ocaml-xen-devel -l pl.UTF-8
309 Wiązania OCamla dla Xena - pliki programistyczne.
310
311 %package -n python-xen
312 Summary:        Xen Python modules
313 Summary(pl.UTF-8):      Moduły Pythona dla Xena
314 Group:          Libraries
315 Requires:       %{name}-libs = %{version}-%{release}
316 Conflicts:      xen < 3.2.1-0.3
317
318 %description -n python-xen
319 Xen Python modules.
320
321 %description -n python-xen -l pl.UTF-8
322 Moduły Pythona dla Xena.
323
324 %package -n python-xen-guest
325 Summary:        Xen Python modules for virtual machines
326 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
327 Group:          Libraries
328 Requires:       %{name}-libs-guest = %{version}-%{release}
329 Conflicts:      xen < 3.2.1-0.3
330
331 %description -n python-xen-guest
332 Xen Python modules for both dom0 and domU virtual machines.
333
334 %description -n python-xen-guest -l pl.UTF-8
335 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
336
337 %package -n bash-completion-%{name}
338 Summary:    bash-completion for Xen (xl)
339 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
340 Group:      Applications/Shells
341 Requires:   %{name} = %{version}-%{release}
342 Requires:   bash-completion
343
344 %description -n bash-completion-%{name}
345 This package provides bash-completion for Xen (xl).
346
347 %description -n bash-completion-%{name} -l pl.UTF-8
348 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
349
350 %package efi
351 Summary:        Xen hypervisor binary for EFI
352 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
353 Group:          Applications/System
354 Requires:       %{name}-libs-guest = %{version}-%{release}
355
356 %description efi
357 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
358 firmware without help from any additional bootloader.
359
360 %description efi -l pl.UTF-8
361 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
362 (U)EFI, bez potrzeby oddzielnego bootloadera.
363
364 %prep
365 %setup -q -a 16
366 %patch0 -p1
367 %patch1 -p1
368 %patch2 -p1
369 %patch3 -p1
370 %patch4 -p1
371 %patch5 -p1
372 %patch6 -p1
373 %patch7 -p1
374 %patch8 -p1
375 %patch9 -p1
376 %patch10 -p1
377 %patch11 -p1
378 %patch12 -p1
379 %patch13 -p1
380 %patch14 -p1
381
382 # stubdom sources
383 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
384 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
385
386 # do not allow fetching anything via git
387 echo GIT=/bin/false >> Config.mk
388
389 %build
390 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
391 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
392
393 # NOTE:
394 # - there is a quoting bug (in tools/driver/Makefile) that causes
395 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
396 #   anyway (see configure), gcrypt is optional
397 # - prevent libiconv from being detected (not needed with glibc)
398 cd tools
399 %configure \
400         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
401         ac_cv_lib_iconv_libiconv_open=no \
402         --disable-debug
403 cd ..
404
405 %{__make} dist-xen dist-tools dist-docs \
406         %{!?with_ocaml:OCAML_TOOLS=n} \
407         prefix=%{_prefix} \
408         CC="%{__cc}" \
409         CXX="%{__cxx}" \
410         V=1
411
412 unset CFLAGS
413 unset CXXFLAGS
414
415 %{__make} -j1 dist-stubdom \
416         %{!?with_ocaml:OCAML_TOOLS=n} \
417         CC="%{__cc}" \
418         CXX="%{__cxx}" \
419         V=1
420
421 %install
422 rm -rf $RPM_BUILD_ROOT
423 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
424         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
425         $RPM_BUILD_ROOT/etc/efi-boot/update.d
426
427 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
428         %{!?with_ocaml:OCAML_TOOLS=n} \
429         prefix=%{_prefix} \
430         DESTDIR=$RPM_BUILD_ROOT \
431         HOTPLUGS=install-udev
432
433 %if "%{_lib}" == "lib64"
434 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
435 %endif
436
437 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
438 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
439 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
440 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
441 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
442 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
443 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
444 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
445 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
446 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
447 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
448 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
449 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
450 # sysvinit scripts
451 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
452 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
453 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
454 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
455 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
456 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
457 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
458 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
459
460 %if %{with efi}
461 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
462 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
463                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
464 %endif
465
466 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
467
468 # for %%doc
469 install -d _doc
470 for tool in blktap blktap2 pygrub xenmon ; do
471         cp -p tools/$tool/README _doc/README.$tool
472 done
473 cp -al tools/qemu-xen/docs _doc/qemu-xen
474
475 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
476 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
477
478 %py_postclean
479
480 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
481 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
482 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
483 # seems not needed, the path is wrong anyway
484 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
485
486 # remove unneeded files
487 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
488 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
489 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
490 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
491 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
492
493 %clean
494 rm -rf $RPM_BUILD_ROOT
495
496 %post
497 /sbin/chkconfig --add xen-watchdog
498 /sbin/chkconfig --add xenconsoled
499 /sbin/chkconfig --add xenstored
500 /sbin/chkconfig --add xendomains
501 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
502
503 %preun
504 if [ "$1" = "0" ]; then
505         %service xendomains stop
506         /sbin/chkconfig --del xendomains
507
508         %service xenconsoled stop
509         /sbin/chkconfig --del xenconsoled
510
511         %service xenstored stop
512         /sbin/chkconfig --del xenstored
513
514         %service xen-watchdog stop
515         /sbin/chkconfig --del xen-watchdog
516 fi
517 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
518
519 %postun
520 %systemd_reload
521
522 %post xend
523 /sbin/chkconfig --add xend
524 %systemd_post xend.service
525
526 %preun xend
527 if [ "$1" = "0" ]; then
528         %service xend stop
529         /sbin/chkconfig --del xend
530 fi
531 %systemd_preun xend.service
532
533 %postun xend
534 %systemd_reload
535
536 %post   libs -p /sbin/ldconfig
537 %postun libs -p /sbin/ldconfig
538
539 %post   libs-guest -p /sbin/ldconfig
540 %postun libs-guest -p /sbin/ldconfig
541
542 %post efi
543 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
544
545 %files
546 %defattr(644,root,root,755)
547 %doc COPYING README* docs/misc/* 
548 %doc docs/html/*
549 %doc tools/qemu-xen-dir/*.html
550 %doc _doc/*
551 /boot/%{name}-syms-%{version}
552 /boot/%{name}-%{version}.gz
553 /boot/%{name}.gz
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
557 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
559 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
560 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
561 %attr(754,root,root) /etc/rc.d/init.d/xenstored
562 %attr(754,root,root) /etc/rc.d/init.d/xendomains
563 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
564 %{systemdunitdir}/proc-xen.mount
565 %{systemdunitdir}/var-lib-xenstored.mount
566 %{systemdunitdir}/xen-watchdog.service
567 %{systemdunitdir}/xenconsoled.service
568 %{systemdunitdir}/xenstored.service
569 %dir %{_sysconfdir}/xen
570 %dir %{_sysconfdir}/xen/auto
571 %dir %{_sysconfdir}/xen/examples
572 %dir %{_sysconfdir}/xen/scripts
573 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
576 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
578 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
579 %attr(755,root,root) %{_bindir}/pygrub
580 %attr(755,root,root) %{_bindir}/qemu-img-xen
581 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
582 %attr(755,root,root) %{_bindir}/remus
583 %attr(755,root,root) %{_bindir}/xencons
584 %attr(755,root,root) %{_bindir}/xentrace*
585 %attr(755,root,root) %{_sbindir}/blktapctrl
586 %attr(755,root,root) %{_sbindir}/flask-*
587 %attr(755,root,root) %{_sbindir}/gdbsx
588 %attr(755,root,root) %{_sbindir}/gtrace*
589 %attr(755,root,root) %{_sbindir}/img2qcow
590 %attr(755,root,root) %{_sbindir}/kdd
591 %attr(755,root,root) %{_sbindir}/lock-util
592 %attr(755,root,root) %{_sbindir}/qcow-create
593 %attr(755,root,root) %{_sbindir}/qcow2raw
594 %attr(755,root,root) %{_sbindir}/tap-ctl
595 %attr(755,root,root) %{_sbindir}/tapdisk*
596 %attr(755,root,root) %{_sbindir}/td-util
597 %attr(755,root,root) %{_sbindir}/vhd-*
598 %attr(755,root,root) %{_sbindir}/xen-*
599 %attr(755,root,root) %{_sbindir}/xenbaked
600 %attr(755,root,root) %{_sbindir}/xenconsoled
601 %attr(755,root,root) %{_sbindir}/xenlockprof
602 %attr(755,root,root) %{_sbindir}/xenmon.py
603 %attr(755,root,root) %{_sbindir}/xenperf
604 %attr(755,root,root) %{_sbindir}/xenpm
605 %attr(755,root,root) %{_sbindir}/xenpmd
606 %attr(755,root,root) %{_sbindir}/xenstored
607 %attr(755,root,root) %{_sbindir}/xentop
608 %attr(755,root,root) %{_sbindir}/xentrace_setmask
609 %attr(755,root,root) %{_sbindir}/xenwatchdogd
610 %attr(755,root,root) %{_sbindir}/xl
611 %attr(755,root,root) %{_sbindir}/xsview
612 %dir %{_libdir}/%{name}
613 %dir %{_libdir}/%{name}/bin
614 %attr(744,root,root) %{_libdir}/%{name}/bin/*
615 %if "%{_lib}" != "lib"
616 %dir %{_prefix}/lib/%{name}
617 %dir %{_prefix}/lib/%{name}/bin
618 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
619 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
620 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
621 %endif
622 %dir %{_prefix}/lib/%{name}/boot
623 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
624 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
625 %ifarch %{x8664}
626 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
627 %endif
628 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
629 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
630 %{_datadir}/xen
631 %{_mandir}/man1/qemu-img-xen.1*
632 %{_mandir}/man1/xentop.1*
633 %{_mandir}/man1/xentrace_format.1*
634 %{_mandir}/man1/xl.1*
635 %{_mandir}/man1/xm.1*
636 %{_mandir}/man5/xend-config.sxp.5*
637 %{_mandir}/man5/xl.cfg.5*
638 %{_mandir}/man5/xl.conf.5*
639 %{_mandir}/man5/xlcpupool.cfg.5*
640 %{_mandir}/man5/xmdomain.cfg.5*
641 %{_mandir}/man8/qemu-nbd-xen.8*
642 %{_mandir}/man8/xentrace.8*
643 %{_sharedstatedir}/xen
644 %{_sharedstatedir}/xenstored
645 %dir /var/run/xenstored
646 %{systemdtmpfilesdir}/xenstored.conf
647 %{systemdtmpfilesdir}/xen.conf
648 %dir %attr(0700,root,root) /var/log/xen
649 %dir %attr(0700,root,root) /var/log/xen/console
650 %{_datadir}/qemu-xen
651
652 %files guest
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_bindir}/xen-detect
655 %attr(755,root,root) %{_bindir}/xenstore*
656
657 %files libs
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
661 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
663 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
665 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
667 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
669 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
671 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
672 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
673 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
675 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
677 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
678 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
679 %dir %{_libdir}/fs
680 %dir %{_libdir}/fs/ext2fs-lib
681 %dir %{_libdir}/fs/fat
682 %dir %{_libdir}/fs/iso9660
683 %dir %{_libdir}/fs/reiserfs
684 %dir %{_libdir}/fs/ufs
685 %dir %{_libdir}/fs/xfs
686 %dir %{_libdir}/fs/zfs
687 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
688
689 %files libs-guest
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
692 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
693
694 %files devel
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libblktap.so
697 %attr(755,root,root) %{_libdir}/libblktapctl.so
698 %attr(755,root,root) %{_libdir}/libfsimage.so
699 %attr(755,root,root) %{_libdir}/libvhd.so
700 %attr(755,root,root) %{_libdir}/libxenctrl.so
701 %attr(755,root,root) %{_libdir}/libxenguest.so
702 %attr(755,root,root) %{_libdir}/libxenlight.so
703 %attr(755,root,root) %{_libdir}/libxenstat.so
704 %attr(755,root,root) %{_libdir}/libxenstore.so
705 %attr(755,root,root) %{_libdir}/libxenvchan.so
706 %attr(755,root,root) %{_libdir}/libxlutil.so
707 %{_includedir}/_libxl_list.h
708 %{_includedir}/_libxl_types.h
709 %{_includedir}/_libxl_types_json.h
710 %{_includedir}/blktaplib.h
711 %{_includedir}/fsimage*.h
712 %{_includedir}/libxenvchan.h
713 %{_includedir}/libxl*.h
714 %{_includedir}/xen*.h
715 %{_includedir}/xs*.h
716 %{_includedir}/xen
717 %{_includedir}/xenstore-compat
718
719 %files static
720 %defattr(644,root,root,755)
721 %{_libdir}/libblktap.a
722 %{_libdir}/libblktapctl.a
723 %{_libdir}/libvhd.a
724 %{_libdir}/libxenctrl.a
725 %{_libdir}/libxenguest.a
726 %{_libdir}/libxenlight.a
727 %{_libdir}/libxenvchan.a
728 %{_libdir}/libxenstat.a
729 %{_libdir}/libxenstore.a
730 %{_libdir}/libxlutil.a
731
732 %files xend
733 %defattr(644,root,root,755)
734 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
735 %{systemdunitdir}/blktapctrl.service
736 %{systemdunitdir}/xend.service
737 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
738 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
739 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
740 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
741 %attr(755,root,root) %{_sbindir}/xend
742 %attr(755,root,root) %{_sbindir}/xm
743 %dir %attr(700,root,root) /var/run/xend
744 %{systemdtmpfilesdir}/xend.conf
745
746 %if %{with ocaml}
747 %files -n ocaml-xen
748 %defattr(644,root,root,755)
749 %doc tools/ocaml/LICENSE
750 %attr(755,root,root) %{_sbindir}/oxenstored
751 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
752 %dir %{_libdir}/ocaml/site-lib/xenbus
753 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
754 %dir %{_libdir}/ocaml/site-lib/xenctrl
755 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
756 %dir %{_libdir}/ocaml/site-lib/xeneventchn
757 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
758 %dir %{_libdir}/ocaml/site-lib/xenlight
759 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
760 %dir %{_libdir}/ocaml/site-lib/xenmmap
761 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
762
763 %files -n ocaml-xen-devel
764 %defattr(644,root,root,755)
765 %{_libdir}/ocaml/site-lib/xenbus/META
766 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
767 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
768 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
769 %{_libdir}/ocaml/site-lib/xenctrl/META
770 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
771 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
772 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
773 %{_libdir}/ocaml/site-lib/xeneventchn/META
774 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
775 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
776 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
777 %{_libdir}/ocaml/site-lib/xenmmap/META
778 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
779 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
780 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
781 %{_libdir}/ocaml/site-lib/xenlight/META
782 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
783 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
784 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
785 %dir %{_libdir}/ocaml/site-lib/xenstore
786 %{_libdir}/ocaml/site-lib/xenstore/META
787 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
788 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
789 %endif
790
791 %files -n python-xen
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{py_sitedir}/fsimage.so
794 %{py_sitedir}/grub
795 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
796 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
797 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
798 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
799 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
800 %{py_sitedir}/xen/remus
801 %{py_sitedir}/xen/sv
802 %{py_sitedir}/xen/util
803 %{py_sitedir}/xen/web
804 %{py_sitedir}/xen/xend
805 %{py_sitedir}/xen/xm
806 %{py_sitedir}/xen/xsview
807 %if "%{py_ver}" > "2.4"
808 %{py_sitedir}/pygrub-0.3-py*.egg-info
809 %{py_sitedir}/xen-3.0-py*.egg-info
810 %endif
811
812 %files -n python-xen-guest
813 %defattr(644,root,root,755)
814 %dir %{py_sitedir}/xen
815 %{py_sitedir}/xen/__init__.py*
816 %dir %{py_sitedir}/xen/lowlevel
817 %{py_sitedir}/xen/lowlevel/__init__.py*
818 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
819
820 %files -n bash-completion-%{name}
821 %defattr(644,root,root,755)
822 /etc/bash_completion.d/xl.sh
823
824 %if %{with efi}
825 %files efi
826 %defattr(644,root,root,755)
827 %dir %{_libdir}/efi
828 %{_libdir}/efi/*.efi
829 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
830 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
831 %endif
This page took 0.10714 seconds and 4 git commands to generate.