]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- updated to 20050420 snap
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        3
8 Release:        0.20050420.1
9 Epoch:          0
10 Group:          Development/Libraries
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/%{name}-unstable-src.tgz
13 # Source0-md5:  4430e618e2c55c2f0e198c5970bc175c
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 URL:            http://sourceforge.net/projects/xen/
17 BuildRequires:  curl-devel
18 BuildRequires:  python-devel
19 BuildRequires:  python-Twisted
20 BuildRequires:  bridge-utils
21 BuildRequires:  transfig
22 BuildRequires:  libidn-devel
23 BuildRequires:  zlib-devel
24 BuildRequires:  X11-devel
25 BuildRequires:  ncurses-devel
26 ExclusiveArch:  %{ix86}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This package contains the Xen hypervisor and Xen tools, needed to run
31 virtual machines on x86 systems, together with the kernel-xen*
32 packages. Information on how to use Xen can be found at the Xen
33 project pages.
34
35 Virtualisation can be used to run multiple versions or multiple Linux
36 distributions on one system, or to test untrusted applications in a
37 sandboxed environment. Note that the Xen technology is still in
38 development, and this RPM has received extremely little testing. Don't
39 be surprised if this RPM eats your data, drinks your coffee or makes
40 fun of you in front of your friends.
41
42 %description -l pl
43 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
44 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
45 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
46 projektu.
47
48 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
49 dystrybucji Linuksa na jednym systemie lub do testowaania nie
50 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
51 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
52 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
53 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
54
55 %package devel
56 Summary:        Header files for xen
57 Summary(pl):    Pliki nag³ówkowe xena
58 Group:          Development/Libraries
59 Requires:       %{name} = %{epoch}:%{version}-%{release}
60
61 %description devel
62 Header files for xen.
63
64 %description devel -l pl
65 Pliki nag³ówkowe xena.
66
67 %package static
68 Summary:        Static xen libraries
69 Summary(pl):    Statyczne biblioteki xena
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static xen libraries.
75
76 %description static -l pl
77 Statyczne biblioteki xena.
78
79 %prep
80 %setup -q -n xen-unstable
81 chmod -R u+w .
82 echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
83
84 %build
85 CFLAGS="%{rpmcflags}" \
86 CXXFLAGS="%{rpmcflags}" \
87 %{__make} xen tools docs \
88         CC="%{__cc}" \
89         CXX="%{__cxx}"
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install-xen install-tools install-docs \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
98 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
99 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
100
101 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
102
103 #install -d $RPM_BUILD_ROOT%{_mandir}
104 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
105
106 #install -d doc-html-install/{interface,user}
107 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
108 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
109
110 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
111
112 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
113 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
114 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 /sbin/ldconfig
121 /sbin/chkconfig --add xend
122 /sbin/chkconfig --add xendomains
123
124 %postun -p /sbin/ldconfig
125
126 %preun
127 if [ "$1" = "0" ]; then
128 #       if [ -f /var/lock/subsys/xend ]; then
129 #               /etc/rc.d/init.d/xend stop 1>&2
130 #       fi
131         /sbin/chkconfig --del xend
132 #       if [ -f /var/lock/subsys/xendomains ]; then
133 #               /etc/rc.d/init.d/xendomains stop 1>&2
134 #       fi
135         /sbin/chkconfig --del xendomains
136 fi
137
138 %files
139 %defattr(644,root,root,755)
140 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
141 %doc COPYING ChangeLog README docs/misc/*
142 /boot/%{name}-syms
143 /boot/%{name}.gz
144 %attr(754,root,root) /etc/rc.d/init.d/*
145 %dir %{_sysconfdir}/xen
146 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
147 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
148 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
149 %dir %{_sysconfdir}/xen/auto
150 %dir %{_sysconfdir}/xen/scripts
151 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
152 %attr(755,root,root) %{_bindir}/*
153 %attr(755,root,root) %{_sbindir}/*
154 %attr(755,root,root) %{_libdir}/lib*.so.*
155 %{_libdir}/python/%{name}
156 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
157 %{_mandir}/man?/*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_includedir}/*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/lib*.a
This page took 0.062872 seconds and 4 git commands to generate.