]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- removed obsolete systemd service files
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - verify upstream systemd .services vs SOURCES
4 #    at least patch to use PLD-specific 
5 #  - check if other tools/libs are not usable in domU, move them to -guest
6 #    packages if so
7 #  - pass bconds to qemu configure script (tricky, as the script is called from
8 #    Xen Makefiles)
9 #  - fix %doc - some files are installed in docdir both by make install and %d,
10 #    other are installed once
11 #  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
12 #
13 # Conditional build:
14 %bcond_without  qemu_traditional        # without qemu-xen-traditional
15 %bcond_without  opengl                  # OpenGL support in Xen qemu
16 %bcond_without  sdl                     # SDL support in Xen qemu
17 %bcond_without  bluetooth               # bluetooth support in Xen qemu
18 %bcond_without  brlapi                  # brlapi support in Xen qemu
19 %bcond_without  ocaml                   # Ocaml libraries for Xen tools
20 %bcond_without  efi                     # EFI hypervisor
21 %bcond_without  hypervisor              # Xen hypervisor build
22 %bcond_without  stubdom                 # stubdom build
23 %bcond_without  xsm                     # XSM security module (by default, Flask)
24
25 %ifnarch %{x8664} arm
26 %undefine       with_hypervisor
27 %endif
28 %ifnarch %{x8664}
29 %undefine       with_efi
30 %endif
31 %ifnarch %{ix86} %{x8664}
32 %undefine       with_stubdom
33 %endif
34
35 # from ./stubdom/configure.ac
36 %define polarssl_version        1.1.4
37 %define tpm_emulator_version    0.7.4
38 %define gmp_version             4.3.2
39
40 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
41 Summary:        Xen - a virtual machine monitor
42 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
43 Name:           xen
44 Version:        4.6.1
45 Release:        0.1
46 License:        GPL v2, interface parts on BSD-like
47 Group:          Applications/System
48 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
49 # Source0-md5:  df2d854c3c90ffeefaf71e7f868fb326
50 # used by stubdoms
51 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
52 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
53 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
54 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
55 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
56 # Source12-md5: debc62758716a169df9f62e6ab2bc634
57 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
58 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
59 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
60 # Source14-md5: cd3f3eb54446be6003156158d51f4884
61 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
62 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
63 Source17:       %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
64 # Source17-md5: 7b72caf22b01464ee7d6165f2fd85f44
65 Source18:       http://xenbits.xen.org/xen-extfiles/tpm_emulator-%{tpm_emulator_version}.tar.gz
66 # Source18-md5: e26becb8a6a2b6695f6b3e8097593db8
67 Source19:       ftp://ftp.gmplib.org/pub/gmp-%{gmp_version}/gmp-%{gmp_version}.tar.bz2
68 # Source19-md5: dd60683d7057917e34630b4a787932e8
69 #Source34:      xenconsoled.service
70 # XXX: upstream xenconsoled expects xencommons
71 Source35:       xenconsoled.sysconfig
72 #Source36:      xenstored.service
73 # XXX: upstream xenstored expects xencommons
74 Source37:       xenstored.sysconfig
75 Source38:       xenstored.tmpfiles
76 Source43:       xendomains.sh
77 # sysvinit scripts
78 Source46:       xen-qemu-dom0-disk-backend.init
79 Source51:       xenconsoled.init
80 Source52:       xenstored.init
81 Source53:       xen-watchdog.init
82 Source54:       xendomains.init
83 Source55:       xen.logrotate
84 Source56:       xen.tmpfiles
85 Source57:       xen.cfg
86 Source58:       xen.efi-boot-update
87 Source59:       vif-openvswitch
88 Source60:       xen-init-list
89 Source61:       xen-toolstack
90 Patch0:         %{name}-python_scripts.patch
91 Patch1:         %{name}-symbols.patch
92 Patch2:         %{name}-curses.patch
93 Patch3:         pygrubfix.patch
94 # Warning: this disables ingress filtering implemented in xen scripts!
95 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
96 Patch9:         %{name}-gawk.patch
97 Patch10:        %{name}-qemu.patch
98 Patch12:        %{name}-doc.patch
99 Patch13:        %{name}-paths.patch
100 Patch14:        %{name}-no_fetcher.patch
101 Patch15:        odd-glib2-fix.patch
102 Patch16:        %{name}-gmp-abi.patch
103 Patch18:        %{name}-make.patch
104 Patch19:        %{name}-no_Werror.patch
105 # http://git.alpinelinux.org/cgit/aports/plain/main/xen/gnutls-3.4.0.patch
106 Patch20:        %{name}-gnutls-3.4.patch
107 Patch21:        %{name}-grep-typo.patch
108 Patch22:        %{name}-stubdom-build.patch
109 Patch23:        link.patch
110 URL:            http://www.xen.org/products/xenhyp.html
111 BuildRequires:  autoconf >= 2.67
112 %ifarch %{ix86} %{x8664}
113 BuildRequires:  acpica
114 BuildRequires:  bcc
115 BuildRequires:  bin86
116 %endif
117 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
118 BuildRequires:  bzip2-devel
119 %if %{with xsm}
120 BuildRequires:  checkpolicy
121 %endif
122 BuildRequires:  curl-devel
123 BuildRequires:  cyrus-sasl-devel >= 2
124 BuildRequires:  e2fsprogs-devel
125 BuildRequires:  gcc >= 6:4.1
126 %ifarch %{x8664}
127 BuildRequires:  gcc-multilib-32 >= 6:4.1
128 %endif
129 BuildRequires:  gettext-tools
130 BuildRequires:  glib2-devel >= 1:2.12
131 BuildRequires:  gnutls-devel
132 BuildRequires:  keyutils-devel
133 BuildRequires:  latex2html >= 2008
134 BuildRequires:  libaio-devel
135 BuildRequires:  libcap-devel
136 %ifarch arm aarch64
137 BuildRequires:  libfdt-devel
138 %endif
139 BuildRequires:  libjpeg-devel
140 BuildRequires:  libnl-devel >= 3.2.8
141 BuildRequires:  libpng-devel
142 BuildRequires:  libuuid-devel
143 BuildRequires:  lzo-devel >= 2
144 BuildRequires:  ncurses-devel
145 %if %{with ocaml}
146 BuildRequires:  ocaml >= 3.11.0
147 BuildRequires:  ocaml-findlib
148 %endif
149 BuildRequires:  nss-devel >= 3.12.8
150 BuildRequires:  openssl-devel
151 BuildRequires:  pciutils-devel
152 BuildRequires:  perl-base
153 BuildRequires:  perl-tools-pod
154 BuildRequires:  pkgconfig
155 BuildRequires:  python-devel
156 BuildRequires:  rpm-pythonprov
157 BuildRequires:  rpmbuild(macros) >= 1.647
158 BuildRequires:  seabios
159 BuildRequires:  texi2html
160 BuildRequires:  texlive-dvips
161 BuildRequires:  texlive-latex-psnfss
162 BuildRequires:  texlive-xetex
163 BuildRequires:  transfig
164 BuildRequires:  which
165 # for xfsctl (<xfs/xfs.h>)
166 BuildRequires:  xfsprogs-devel
167 BuildRequires:  xz-devel
168 BuildRequires:  yajl-devel
169 BuildRequires:  zlib-devel
170 %if %{with qemu_traditional}
171 %{?with_opengl:BuildRequires:   OpenGL-devel}
172 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
173 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
174 %{?with_brlapi:BuildRequires:   brlapi-devel}
175 BuildRequires:  vde2-devel
176 BuildRequires:  xorg-lib-libX11-devel
177 BuildRequires:  xorg-lib-libXext-devel
178 %endif
179 %if %{with qemu_traditional}
180 # FIXME: see qemu configure comments on top of spec
181 %{!?with_opengl:BuildConflicts: OpenGL-devel}
182 %{!?with_sdl:BuildConflicts:    SDL-devel}
183 %{!?with_sdl:BuildConflicts:    SDL-devel}
184 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
185 %{!?with_brlapi:BuildConflicts: brlapi-devel}
186 %endif
187 Requires(post,preun):   /sbin/chkconfig
188 Requires(post,preun,postun):    systemd-units >= 38
189 Requires:       %{name}-libs = %{version}-%{release}
190 Requires:       ZopeInterface
191 Requires:       bridge-utils
192 Requires:       coreutils
193 Requires:       diffutils
194 Requires:       gawk
195 Requires:       iptables
196 Requires:       losetup
197 Requires:       net-tools
198 Requires:       python-%{name} = %{version}-%{release}
199 Requires:       rc-scripts
200 Requires:       sed
201 Requires:       systemd-units >= 38
202 Requires:       util-linux
203 Requires:       which
204 Requires:       %{name}-guest = %{version}-%{release}
205 Obsoletes:      xen-doc
206 Obsoletes:      xen-udev
207 Obsoletes:      xen-xend
208 ExclusiveArch:  %{ix86} %{x8664} arm
209 %ifarch %{ix86} %{x8664}
210 # for HVM
211 Suggests:       qemu-system-x86
212 %endif
213 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
214
215 # some PPC/SPARC boot images in ELF format
216 %define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\|s390-ccw.img\\)
217
218 %description
219 This package contains the Xen hypervisor and Xen tools, needed to run
220 virtual machines on x86 systems, together with the kernel-xen*
221 packages. Information on how to use Xen can be found at the Xen
222 project pages.
223
224 Virtualisation can be used to run multiple versions or multiple Linux
225 distributions on one system, or to test untrusted applications in a
226 sandboxed environment. Note that the Xen technology is still in
227 development, and this RPM has received extremely little testing. Don't
228 be surprised if this RPM eats your data, drinks your coffee or makes
229 fun of you in front of your friends.
230
231 %description -l pl.UTF-8
232 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
233 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
234 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
235 projektu.
236
237 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
238 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
239 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
240 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
241 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
242 się wyśmiewał w obecności przyjaciół.
243
244 %package guest
245 Summary:        Xen tools for virtual machines
246 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
247 Group:          Applications/System
248 Requires:       %{name}-libs-guest = %{version}-%{release}
249
250 %description guest
251 Xen utilities for both dom0 and domU virtual domains.
252
253 %description guest -l pl.UTF-8
254 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
255
256 %package libs
257 Summary:        Xen libraries
258 Summary(pl.UTF-8):      Biblioteki Xena
259 Group:          Libraries
260 Requires:       %{name}-libs-guest = %{version}-%{release}
261
262 %description libs
263 Xen libraries.
264
265 %description libs -l pl.UTF-8
266 Biblioteki Xena.
267
268 %package libs-guest
269 Summary:        Xen libraries for virtual machines
270 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
271 Group:          Libraries
272
273 %description libs-guest
274 Xen libraries for both dom0 and domU virtual machines.
275
276 %description libs-guest -l pl.UTF-8
277 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
278
279 %package devel
280 Summary:        Header files for Xen
281 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
282 Group:          Development/Libraries
283 Requires:       %{name}-libs = %{version}-%{release}
284
285 %description devel
286 Header files for Xen.
287
288 %description devel -l pl.UTF-8
289 Pliki nagłówkowe Xena.
290
291 %package static
292 Summary:        Static Xen libraries
293 Summary(pl.UTF-8):      Statyczne biblioteki Xena
294 Group:          Development/Libraries
295 Requires:       %{name}-devel = %{version}-%{release}
296
297 %description static
298 Static Xen libraries.
299
300 %description static -l pl.UTF-8
301 Statyczne biblioteki Xena.
302
303 %package -n ocaml-xen
304 Summary:        OCaml bindings for Xen
305 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
306 License:        LGPL v2.1 with linking exception
307 Group:          Libraries
308 Requires:       %{name}-libs = %{version}-%{release}
309 %if %{with ocaml}
310 %requires_eq    ocaml-runtime
311 %endif
312
313 %description -n ocaml-xen
314 OCaml bindings for Xen.
315
316 %description -n ocaml-xen -l pl.UTF-8
317 Wiązania OCamla dla Xena.
318
319 %package -n ocaml-xen-devel
320 Summary:        OCaml bindings for Xen - development files
321 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
322 License:        LGPL v2.1 with linking exception
323 Group:          Development/Libraries
324 Requires:       ocaml-xen = %{version}-%{release}
325 %if %{with ocaml}
326 %requires_eq    ocaml
327 %endif
328
329 %description -n ocaml-xen-devel
330 OCaml bindings for Xen - development files.
331
332 %description -n ocaml-xen-devel -l pl.UTF-8
333 Wiązania OCamla dla Xena - pliki programistyczne.
334
335 %package -n python-xen
336 Summary:        Xen Python modules
337 Summary(pl.UTF-8):      Moduły Pythona dla Xena
338 Group:          Libraries
339 Requires:       %{name}-libs = %{version}-%{release}
340 Conflicts:      xen < 3.2.1-0.3
341
342 %description -n python-xen
343 Xen Python modules.
344
345 %description -n python-xen -l pl.UTF-8
346 Moduły Pythona dla Xena.
347
348 %package -n python-xen-guest
349 Summary:        Xen Python modules for virtual machines
350 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
351 Group:          Libraries
352 Requires:       %{name}-libs-guest = %{version}-%{release}
353 Conflicts:      xen < 3.2.1-0.3
354
355 %description -n python-xen-guest
356 Xen Python modules for both dom0 and domU virtual machines.
357
358 %description -n python-xen-guest -l pl.UTF-8
359 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
360
361 %package -n bash-completion-%{name}
362 Summary:        bash-completion for Xen (xl)
363 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
364 Group:          Applications/Shells
365 Requires:       %{name} = %{version}-%{release}
366 Requires:       bash-completion
367
368 %description -n bash-completion-%{name}
369 This package provides bash-completion for Xen (xl).
370
371 %description -n bash-completion-%{name} -l pl.UTF-8
372 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
373
374 %package efi
375 Summary:        Xen hypervisor binary for EFI
376 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
377 Group:          Applications/System
378 Requires:       %{name}-libs-guest = %{version}-%{release}
379
380 %description efi
381 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
382 firmware without help from any additional bootloader.
383
384 %description efi -l pl.UTF-8
385 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
386 (U)EFI, bez potrzeby oddzielnego bootloadera.
387
388 %prep
389 %setup -q
390 %patch0 -p1
391 %patch1 -p1
392 %patch2 -p1
393 %patch3 -p1
394 %patch7 -p1
395 %patch9 -p1
396 %patch10 -p1
397 %patch12 -p1
398 %patch13 -p1
399 %patch14 -p1
400 %patch15 -p1
401 %patch16 -p1
402 %patch18 -p1
403 %patch19 -p1
404 %patch20 -p1
405 %patch21 -p1
406 %patch22 -p1
407 %patch23 -p1
408
409 # stubdom sources
410 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
411 ln -s %{SOURCE17} %{SOURCE18} %{SOURCE19} stubdom
412 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
413
414 # do not allow fetching anything via git
415 echo GIT=/bin/false >> Config.mk
416
417 %build
418 # based on the 'autoconf.sh' from the sources
419 %{__autoconf}
420 cd tools
421 %{__autoconf}
422 %{__autoheader}
423 cd ../stubdom
424 %{__autoconf}
425 cd ../docs
426 %{__autoconf}
427 cd ..
428
429 # if gold is used then bioses and grub doesn't build
430 install -d our-ld
431 ln -f -s /usr/bin/ld.bfd our-ld/ld
432 export PATH=$(pwd)/our-ld:$PATH
433
434 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
435 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
436
437 # NOTE on ac_cv_*:
438 # - use openssl (libcrypto) instead of libgcrypt as openssl is obligatory anyway
439 # - prevent libiconv from being detected (not needed with glibc)
440 %configure \
441         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
442         ac_cv_lib_gcrypt_gcry_md_hash_buffer=no \
443         ac_cv_lib_iconv_libiconv_open=no \
444         --disable-debug \
445         %{__enable_disable qemu_traditional qemu-traditional} \
446         --with-system-seabios=/usr/share/seabios/bios.bin \
447 %ifarch %{x8664}
448         --with-system-qemu=/usr/bin/qemu-system-x86_64 \
449 %else
450         --with-system-qemu=/usr/bin/qemu-system-i386 \
451 %endif
452         --with-systemd=%{systemdunitdir}
453
454 %{__make} -j1 dist-xen dist-tools dist-docs \
455         %{!?with_ocaml:OCAML_TOOLS=n} \
456         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
457         CC="%{__cc}" \
458         CXX="%{__cxx}" \
459         V=1
460
461 unset CFLAGS
462 unset CXXFLAGS
463
464 %if %{with stubdom}
465 %{__make} -j1 dist-stubdom \
466         %{!?with_ocaml:OCAML_TOOLS=n} \
467         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
468         CC="%{__cc}" \
469         CXX="%{__cxx}" \
470         V=1
471 %endif
472
473 %install
474 rm -rf $RPM_BUILD_ROOT
475 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
476         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
477
478 %if %{with efi}
479 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
480 %endif
481
482 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
483         %{!?with_ocaml:OCAML_TOOLS=n} \
484         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
485         DESTDIR=$RPM_BUILD_ROOT \
486         HOTPLUGS=install-udev
487
488 #install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
489 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
490 #install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
491 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
492 install %{SOURCE43} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xendomains.sh
493 # sysvinit scripts
494 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
495 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
496 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
497 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
498 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
499 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
500 install %{SOURCE46} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-qemu-dom0-disk-backend
501 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
502 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
503 install -d $RPM_BUILD_ROOT/var/run/xenstored
504 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
505
506 install %{SOURCE60} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-init-list
507 install %{SOURCE61} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-toolstack
508
509 %if %{with efi}
510 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
511 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
512                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
513 %endif
514
515 mv $RPM_BUILD_ROOT/etc/xen/{xlexample*,examples}
516
517 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
518
519 # for %%doc
520 install -d _doc
521 for tool in blktap2 pygrub ; do
522         cp -p tools/$tool/README _doc/README.$tool
523 done
524
525 cp -p xen/xen-syms $RPM_BUILD_ROOT/boot/%{name}-syms-%{version}
526
527 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
528 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
529
530 %py_postclean
531
532 # remove unneeded files
533 %if %{with hypervisor}
534 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.6.gz
535 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
536 %endif
537 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
538 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
539
540 %clean
541 rm -rf $RPM_BUILD_ROOT
542
543 %post
544 /sbin/chkconfig --add xen-watchdog
545 /sbin/chkconfig --add xenconsoled
546 /sbin/chkconfig --add xenstored
547 /sbin/chkconfig --add xendomains
548 /sbin/chkconfig --add xen-qemu-dom0-disk-backend
549 NORESTART=1
550 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
551
552 %preun
553 if [ "$1" = "0" ]; then
554         %service xendomains stop
555         /sbin/chkconfig --del xendomains
556
557         %service xenconsoled stop
558         /sbin/chkconfig --del xenconsoled
559
560         %service xenstored stop
561         /sbin/chkconfig --del xenstored
562
563         %service xen-watchdog stop
564         /sbin/chkconfig --del xen-watchdog
565
566         %service xen-qemu-dom0-disk-backend stop
567         /sbin/chkconfig --del xen-qemu-dom0-disk-backend
568 fi
569 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
570
571 %postun
572 %systemd_reload
573
574 %post   libs -p /sbin/ldconfig
575 %postun libs -p /sbin/ldconfig
576
577 %post   libs-guest -p /sbin/ldconfig
578 %postun libs-guest -p /sbin/ldconfig
579
580 %post efi
581 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
582
583 %files
584 %defattr(644,root,root,755)
585 %doc COPYING README* docs/misc/* docs/html/* _doc/*
586 %if %{with hypervisor}
587 /boot/%{name}-syms-%{version}
588 /boot/%{name}-%{version}.gz
589 /boot/%{name}.gz
590 %endif
591 %if %{with xsm}
592 /boot/xenpolicy-%{version}
593 %endif
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
595 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
598 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
599 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
600 %attr(754,root,root) /etc/rc.d/init.d/xenstored
601 %attr(754,root,root) /etc/rc.d/init.d/xendomains
602 %attr(754,root,root) /etc/rc.d/init.d/xen-qemu-dom0-disk-backend
603 %{_prefix}/lib/modules-load.d/xen.conf
604 %{systemdunitdir}/proc-xen.mount
605 %{systemdunitdir}/var-lib-xenstored.mount
606 %{systemdunitdir}/xen-init-dom0.service
607 %{systemdunitdir}/xen-watchdog.service
608 %{systemdunitdir}/xenconsoled.service
609 %{systemdunitdir}/xenstored.service
610 %{systemdunitdir}/xenstored.socket
611 %{systemdunitdir}/xenstored_ro.socket
612 %{systemdunitdir}/xendomains.service
613 %{systemdunitdir}/xen-qemu-dom0-disk-backend.service
614 %dir %{_sysconfdir}/xen
615 %dir %{_sysconfdir}/xen/auto
616 %dir %{_sysconfdir}/xen/examples
617 %dir %{_sysconfdir}/xen/scripts
618 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
620 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
622 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
623 %attr(755,root,root) %{_bindir}/pygrub
624 %if %{with qemu_traditional}
625 %attr(755,root,root) %{_bindir}/qemu-img-xen
626 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
627 %endif
628 %attr(755,root,root) %{_bindir}/xenalyze
629 %attr(755,root,root) %{_bindir}/xencons
630 %attr(755,root,root) %{_bindir}/xencov_split
631 %attr(755,root,root) %{_bindir}/xentrace_format
632 %if %{with xsm}
633 %attr(755,root,root) %{_sbindir}/flask-*
634 %endif
635 %attr(755,root,root) %{_sbindir}/gdbsx
636 %attr(755,root,root) %{_sbindir}/gtrace*
637 %attr(755,root,root) %{_sbindir}/img2qcow
638 %attr(755,root,root) %{_sbindir}/kdd
639 %attr(755,root,root) %{_sbindir}/lock-util
640 %attr(755,root,root) %{_sbindir}/qcow-create
641 %attr(755,root,root) %{_sbindir}/qcow2raw
642 %attr(755,root,root) %{_sbindir}/tap-ctl
643 %attr(755,root,root) %{_sbindir}/tapdisk*
644 %attr(755,root,root) %{_sbindir}/td-util
645 %attr(755,root,root) %{_sbindir}/vhd-*
646 %attr(755,root,root) %{_sbindir}/xen-*
647 %attr(755,root,root) %{_sbindir}/xenbaked
648 %attr(755,root,root) %{_sbindir}/xenconsoled
649 %attr(755,root,root) %{_sbindir}/xencov
650 %attr(755,root,root) %{_sbindir}/xenlockprof
651 %attr(755,root,root) %{_sbindir}/xenmon.py
652 %attr(755,root,root) %{_sbindir}/xenperf
653 %attr(755,root,root) %{_sbindir}/xenpm
654 %attr(755,root,root) %{_sbindir}/xenpmd
655 %attr(755,root,root) %{_sbindir}/xenstored
656 %attr(755,root,root) %{_sbindir}/xentop
657 %attr(755,root,root) %{_sbindir}/xentrace
658 %attr(755,root,root) %{_sbindir}/xentrace_setmask
659 %attr(755,root,root) %{_sbindir}/xentrace_setsize
660 %attr(755,root,root) %{_sbindir}/xenwatchdogd
661 %attr(755,root,root) %{_sbindir}/xl
662 %dir %{_libdir}/%{name}
663 %dir %{_libdir}/%{name}/bin
664 %attr(744,root,root) %{_libdir}/%{name}/bin/*
665 %dir %{_libdir}/%{name}/boot
666 %if %{with stubdom}
667 %if %{with qemu_traditional}
668 %{_libdir}/%{name}/boot/ioemu-stubdom.gz
669 %endif
670 %ifarch %{ix86} %{x8664}
671 %{_libdir}/%{name}/boot/pv-grub-x86_32.gz
672 %endif
673 %ifarch %{x8664}
674 %{_libdir}/%{name}/boot/pv-grub-x86_64.gz
675 %endif
676 %{_libdir}/%{name}/boot/vtpm-stubdom.gz
677 %{_libdir}/%{name}/boot/vtpmmgr-stubdom.gz
678 %{_libdir}/%{name}/boot/xenstore-stubdom.gz
679 %endif
680 %attr(744,root,root) %{_libdir}/%{name}/boot/hvmloader
681 %{_mandir}/man1/xenstore-chmod.1*
682 %{_mandir}/man1/xenstore-ls.1*
683 %{_mandir}/man1/xenstore.1*
684 %{_mandir}/man1/xentop.1*
685 %{_mandir}/man1/xentrace_format.1*
686 %{_mandir}/man1/xl.1*
687 %{_mandir}/man5/xl.cfg.5*
688 %{_mandir}/man5/xl.conf.5*
689 %{_mandir}/man5/xlcpupool.cfg.5*
690 %{_mandir}/man8/xentrace.8*
691 %{_sharedstatedir}/xen
692 %{_sharedstatedir}/xenstored
693 %dir /var/run/xenstored
694 %{systemdtmpfilesdir}/xen.conf
695 %{systemdtmpfilesdir}/xenstored.conf
696 %dir %attr(0700,root,root) /var/log/xen
697 %dir %attr(0700,root,root) /var/log/xen/console
698 %if %{with qemu_traditional}
699 %{_datadir}/xen
700 %endif
701
702 %files guest
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_bindir}/xen-detect
705 %attr(755,root,root) %{_bindir}/xenstore*
706
707 %files libs
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
711 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
713 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
714 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
715 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.6
717 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
718 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.6
719 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.6
721 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
723 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
725 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.6
727 %dir %{_libdir}/fs
728 %dir %{_libdir}/fs/ext2fs-lib
729 %dir %{_libdir}/fs/fat
730 %dir %{_libdir}/fs/iso9660
731 %dir %{_libdir}/fs/reiserfs
732 %dir %{_libdir}/fs/ufs
733 %dir %{_libdir}/fs/xfs
734 %dir %{_libdir}/fs/zfs
735 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
736
737 %files libs-guest
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
741
742 %files devel
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libblktapctl.so
745 %attr(755,root,root) %{_libdir}/libfsimage.so
746 %attr(755,root,root) %{_libdir}/libvhd.so
747 %attr(755,root,root) %{_libdir}/libxenctrl.so
748 %attr(755,root,root) %{_libdir}/libxenguest.so
749 %attr(755,root,root) %{_libdir}/libxenlight.so
750 %attr(755,root,root) %{_libdir}/libxenstat.so
751 %attr(755,root,root) %{_libdir}/libxenstore.so
752 %attr(755,root,root) %{_libdir}/libxenvchan.so
753 %attr(755,root,root) %{_libdir}/libxlutil.so
754 %{_includedir}/_libxl_list.h
755 %{_includedir}/_libxl_types.h
756 %{_includedir}/_libxl_types_json.h
757 %{_includedir}/fsimage*.h
758 %{_includedir}/libxenvchan.h
759 %{_includedir}/libxl*.h
760 %{_includedir}/xen*.h
761 %{_includedir}/xs*.h
762 %{_includedir}/xen
763 %{_includedir}/xenstore-compat
764 %{_npkgconfigdir}/xenlight.pc
765 %{_npkgconfigdir}/xlutil.pc
766
767 %files static
768 %defattr(644,root,root,755)
769 %{_libdir}/libblktapctl.a
770 %{_libdir}/libvhd.a
771 %{_libdir}/libxenctrl.a
772 %{_libdir}/libxenguest.a
773 %{_libdir}/libxenlight.a
774 %{_libdir}/libxenvchan.a
775 %{_libdir}/libxenstat.a
776 %{_libdir}/libxenstore.a
777 %{_libdir}/libxlutil.a
778
779 %if %{with ocaml}
780 %files -n ocaml-xen
781 %defattr(644,root,root,755)
782 %doc tools/ocaml/LICENSE
783 %attr(755,root,root) %{_sbindir}/oxenstored
784 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
785 %dir %{_libdir}/ocaml/site-lib/xenbus
786 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
787 %dir %{_libdir}/ocaml/site-lib/xenctrl
788 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
789 %dir %{_libdir}/ocaml/site-lib/xeneventchn
790 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
791 %dir %{_libdir}/ocaml/site-lib/xenlight
792 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
793 %dir %{_libdir}/ocaml/site-lib/xenmmap
794 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
795 %dir %{_libdir}/ocaml/site-lib/xentoollog
796 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xentoollog/dllxentoollog_stubs.so
797
798 %files -n ocaml-xen-devel
799 %defattr(644,root,root,755)
800 %{_libdir}/ocaml/site-lib/xenbus/META
801 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
802 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
803 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
804 %{_libdir}/ocaml/site-lib/xenctrl/META
805 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
806 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
807 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
808 %{_libdir}/ocaml/site-lib/xeneventchn/META
809 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
810 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
811 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
812 %{_libdir}/ocaml/site-lib/xenmmap/META
813 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
814 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
815 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
816 %{_libdir}/ocaml/site-lib/xenlight/META
817 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
818 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
819 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
820 %dir %{_libdir}/ocaml/site-lib/xenstore
821 %{_libdir}/ocaml/site-lib/xenstore/META
822 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
823 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
824 %{_libdir}/ocaml/site-lib/xentoollog/META
825 %{_libdir}/ocaml/site-lib/xentoollog/libxentoollog_stubs.a
826 %{_libdir}/ocaml/site-lib/xentoollog/xentoollog.a
827 %{_libdir}/ocaml/site-lib/xentoollog/*.cm[aixo]*
828 %endif
829
830 %files -n python-xen
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{py_sitedir}/fsimage.so
833 %dir %{py_sitedir}/xen/lowlevel
834 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
835 %{py_sitedir}/xen/migration
836 %{py_sitedir}/grub
837 %if "%{py_ver}" > "2.4"
838 %{py_sitedir}/pygrub-0.3-py*.egg-info
839 %{py_sitedir}/xen-3.0-py*.egg-info
840 %endif
841
842 %files -n python-xen-guest
843 %defattr(644,root,root,755)
844 %dir %{py_sitedir}/xen
845 %{py_sitedir}/xen/__init__.py*
846 %dir %{py_sitedir}/xen/lowlevel
847 %{py_sitedir}/xen/lowlevel/__init__.py*
848 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
849
850 %files -n bash-completion-%{name}
851 %defattr(644,root,root,755)
852 /etc/bash_completion.d/xl.sh
853
854 %if %{with efi}
855 %files efi
856 %defattr(644,root,root,755)
857 %dir %{_libdir}/efi
858 %{_libdir}/efi/*.efi
859 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
860 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
861 %endif
This page took 0.113054 seconds and 4 git commands to generate.