]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- fixed BR
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.6
8 Release:        0.1
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-%{version}-src.tgz
13 # Source0-md5:  fcb4ea295b1ecbf7890d48bf721896a8
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
17 #Requires:      python-Twisted
18 Requires:       python-TwistedWeb
19 Requires:       ZopeInterface
20 BuildRequires:  curl-devel
21 BuildRequires:  python-devel
22 BuildRequires:  python-Twisted
23 BuildRequires:  bridge-utils
24 BuildRequires:  transfig
25 BuildRequires:  libidn-devel
26 BuildRequires:  zlib-devel
27 BuildRequires:  X11-devel
28 BuildRequires:  ncurses-devel
29 BuildRequires:  tetex-format-latex
30 BuildRequires:  tetex-latex-psnfss
31 BuildRequires:  tetex-dvips
32 ExclusiveArch:  %{ix86}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package contains the Xen hypervisor and Xen tools, needed to run
37 virtual machines on x86 systems, together with the kernel-xen*
38 packages. Information on how to use Xen can be found at the Xen
39 project pages.
40
41 Virtualisation can be used to run multiple versions or multiple Linux
42 distributions on one system, or to test untrusted applications in a
43 sandboxed environment. Note that the Xen technology is still in
44 development, and this RPM has received extremely little testing. Don't
45 be surprised if this RPM eats your data, drinks your coffee or makes
46 fun of you in front of your friends.
47
48 %description -l pl
49 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
50 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
51 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
52 projektu.
53
54 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
55 dystrybucji Linuksa na jednym systemie lub do testowaania nie
56 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
57 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
58 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
59 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
60
61 %package devel
62 Summary:        Header files for xen
63 Summary(pl):    Pliki nag³ówkowe xena
64 Group:          Development/Libraries
65 Requires:       %{name} = %{epoch}:%{version}-%{release}
66
67 %description devel
68 Header files for xen.
69
70 %description devel -l pl
71 Pliki nag³ówkowe xena.
72
73 %package static
74 Summary:        Static xen libraries
75 Summary(pl):    Statyczne biblioteki xena
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
78
79 %description static
80 Static xen libraries.
81
82 %description static -l pl
83 Statyczne biblioteki xena.
84
85 %package doc
86 Summary:        Xen documentation
87 Summary(pl):    Dokumentacja xena
88 Group:          Applications/System
89 Requires:       %{name} = %{epoch}:%{version}-%{release}
90
91 %description doc
92 Xen documentation.
93
94 %description doc -l pl
95 Dokumentacja xena.
96
97 %prep
98 %setup -q -n xen-2.0
99 chmod -R u+w .
100 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
101
102 %build
103 CFLAGS="%{rpmcflags}" \
104 CXXFLAGS="%{rpmcflags}" \
105 %{__make} xen tools docs \
106         CC="%{__cc}" \
107         CXX="%{__cxx}"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install-xen install-tools install-docs \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
116 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
117 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
118
119 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
120
121 #install -d $RPM_BUILD_ROOT%{_mandir}
122 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
123
124 #install -d doc-html-install/{interface,user}
125 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
126 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
127
128 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
129
130 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
131 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
132 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
133
134 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
135 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 /sbin/ldconfig
142 /sbin/chkconfig --add xend
143 /sbin/chkconfig --add xendomains
144
145 %postun -p /sbin/ldconfig
146
147 %preun
148 if [ "$1" = "0" ]; then
149 #       if [ -f /var/lock/subsys/xend ]; then
150 #               /etc/rc.d/init.d/xend stop 1>&2
151 #       fi
152         /sbin/chkconfig --del xend
153 #       if [ -f /var/lock/subsys/xendomains ]; then
154 #               /etc/rc.d/init.d/xendomains stop 1>&2
155 #       fi
156         /sbin/chkconfig --del xendomains
157 fi
158
159 %files
160 %defattr(644,root,root,755)
161 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
162 %doc COPYING ChangeLog README docs/misc/*
163 /boot/%{name}-%{version}-syms
164 /boot/%{name}-%{version}.gz
165 /boot/%{name}.gz
166 %attr(754,root,root) /etc/rc.d/init.d/*
167 %dir %{_sysconfdir}/xen
168 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
169 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
170 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
171 %dir %{_sysconfdir}/xen/auto
172 %dir %{_sysconfdir}/xen/scripts
173 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
174 %attr(755,root,root) %{_bindir}/*
175 %attr(755,root,root) %{_sbindir}/*
176 %attr(755,root,root) %{_libdir}/lib*.so.*
177 %{_libdir}/python/%{name}
178 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
179 %{_mandir}/man?/*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/lib*.so
184 %{_includedir}/*
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/lib*.a
189
190 %files doc
191 %defattr(644,root,root,755)
192 %dir %{_datadir}/xen
193 %{_datadir}/xen/*.pdf
This page took 0.054336 seconds and 4 git commands to generate.