]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- Req: losetup
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.6
8 Release:        0.2
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-%{version}-src.tgz
13 # Source0-md5:  fcb4ea295b1ecbf7890d48bf721896a8
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 Patch0:         %{name}-twisted.patch
17 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
18 #Requires:      python-Twisted
19 Requires:       losetup
20 Requires:       python-TwistedWeb
21 Requires:       ZopeInterface
22 BuildRequires:  curl-devel
23 BuildRequires:  python-devel
24 BuildRequires:  python-Twisted
25 BuildRequires:  bridge-utils
26 BuildRequires:  transfig
27 BuildRequires:  libidn-devel
28 BuildRequires:  zlib-devel
29 BuildRequires:  X11-devel
30 BuildRequires:  ncurses-devel
31 BuildRequires:  tetex-format-latex
32 BuildRequires:  tetex-latex-psnfss
33 BuildRequires:  tetex-dvips
34 ExclusiveArch:  %{ix86}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 This package contains the Xen hypervisor and Xen tools, needed to run
39 virtual machines on x86 systems, together with the kernel-xen*
40 packages. Information on how to use Xen can be found at the Xen
41 project pages.
42
43 Virtualisation can be used to run multiple versions or multiple Linux
44 distributions on one system, or to test untrusted applications in a
45 sandboxed environment. Note that the Xen technology is still in
46 development, and this RPM has received extremely little testing. Don't
47 be surprised if this RPM eats your data, drinks your coffee or makes
48 fun of you in front of your friends.
49
50 %description -l pl
51 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
52 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
53 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
54 projektu.
55
56 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
57 dystrybucji Linuksa na jednym systemie lub do testowaania nie
58 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
59 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
60 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
61 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
62
63 %package devel
64 Summary:        Header files for xen
65 Summary(pl):    Pliki nag³ówkowe xena
66 Group:          Development/Libraries
67 Requires:       %{name} = %{epoch}:%{version}-%{release}
68
69 %description devel
70 Header files for xen.
71
72 %description devel -l pl
73 Pliki nag³ówkowe xena.
74
75 %package static
76 Summary:        Static xen libraries
77 Summary(pl):    Statyczne biblioteki xena
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
80
81 %description static
82 Static xen libraries.
83
84 %description static -l pl
85 Statyczne biblioteki xena.
86
87 %package doc
88 Summary:        Xen documentation
89 Summary(pl):    Dokumentacja xena
90 Group:          Applications/System
91 Requires:       %{name} = %{epoch}:%{version}-%{release}
92
93 %description doc
94 Xen documentation.
95
96 %description doc -l pl
97 Dokumentacja xena.
98
99 %prep
100 %setup -q -n xen-2.0
101 %patch0 -p1 
102 chmod -R u+w .
103 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
104
105 %build
106 CFLAGS="%{rpmcflags}" \
107 CXXFLAGS="%{rpmcflags}" \
108 %{__make} xen tools docs \
109         CC="%{__cc}" \
110         CXX="%{__cxx}"
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install-xen install-tools install-docs \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
119 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
120 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
121
122 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
123
124 #install -d $RPM_BUILD_ROOT%{_mandir}
125 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
126
127 #install -d doc-html-install/{interface,user}
128 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
129 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
130
131 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
132
133 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
134 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
135 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
136
137 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
138 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
139
140 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen
141 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/{sv,xend-db}
142 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/xend-db/{domain,vnet}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 /sbin/ldconfig
149 /sbin/chkconfig --add xend
150 /sbin/chkconfig --add xendomains
151
152 %postun -p /sbin/ldconfig
153
154 %preun
155 if [ "$1" = "0" ]; then
156 #       if [ -f /var/lock/subsys/xend ]; then
157 #               /etc/rc.d/init.d/xend stop 1>&2
158 #       fi
159         /sbin/chkconfig --del xend
160 #       if [ -f /var/lock/subsys/xendomains ]; then
161 #               /etc/rc.d/init.d/xendomains stop 1>&2
162 #       fi
163         /sbin/chkconfig --del xendomains
164 fi
165
166 %files
167 %defattr(644,root,root,755)
168 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
169 %doc COPYING ChangeLog README docs/misc/*
170 /boot/%{name}-%{version}-syms
171 /boot/%{name}-%{version}.gz
172 /boot/%{name}.gz
173 %attr(754,root,root) /etc/rc.d/init.d/*
174 %dir %{_sysconfdir}/xen
175 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
176 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
177 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
178 %dir %{_sysconfdir}/xen/auto
179 %dir %{_sysconfdir}/xen/scripts
180 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
181 %attr(755,root,root) %{_bindir}/*
182 %attr(755,root,root) %{_sbindir}/*
183 %attr(755,root,root) %{_libdir}/lib*.so.*
184 %{_libdir}/python/%{name}
185 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
186 %{_mandir}/man?/*
187 %dir %{_sharedstatedir}/xen
188 %dir %{_sharedstatedir}/xen/sv
189 %dir %{_sharedstatedir}/xen/xend-db
190 %dir %{_sharedstatedir}/xen/xend-db/domain
191 %dir %{_sharedstatedir}/xen/xend-db/vnet
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/lib*.so
196 %{_includedir}/*
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/lib*.a
201
202 %files doc
203 %defattr(644,root,root,755)
204 %dir %{_datadir}/xen
205 %{_datadir}/xen/*.pdf
This page took 0.070432 seconds and 4 git commands to generate.