]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- don't look for kernel sy s if hypervisor is not built
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
10 #
11 # Conditional build:
12 %bcond_without  qemu_traditional        # without qemu-xen-traditional
13 %bcond_without  opengl                  # OpenGL support in Xen qemu
14 %bcond_without  sdl                     # SDL support in Xen qemu
15 %bcond_without  bluetooth               # bluetooth support in Xen qemu
16 %bcond_without  brlapi                  # brlapi support in Xen qemu
17 %bcond_without  ocaml                   # Ocaml libraries for Xen tools
18 %bcond_without  efi                     # EFI hypervisor
19 %bcond_without  hypervisor              # Xen hypervisor build
20 %bcond_without  stubdom                 # stubdom build
21 %bcond_without  xsm                     # XSM security module (by default, Flask)
22
23 %ifnarch %{x8664} arm
24 %undefine       with_hypervisor
25 %endif
26 %ifnarch %{x8664}
27 %undefine       with_efi
28 %endif
29 %ifnarch %{ix86} %{x8664}
30 %undefine       with_stubdom
31 %endif
32
33 # from ./stubdom/configure.ac
34 %define polarssl_version        1.1.4
35 %define tpm_emulator_version    0.7.4
36 %define gmp_version             4.3.2
37
38 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
39 Summary:        Xen - a virtual machine monitor
40 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
41 Name:           xen
42 Version:        4.6.1
43 Release:        0.1
44 License:        GPL v2, interface parts on BSD-like
45 Group:          Applications/System
46 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
47 # Source0-md5:  df2d854c3c90ffeefaf71e7f868fb326
48 # used by stubdoms
49 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
50 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
51 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
52 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
53 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
54 # Source12-md5: debc62758716a169df9f62e6ab2bc634
55 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
56 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
57 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
58 # Source14-md5: cd3f3eb54446be6003156158d51f4884
59 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
60 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
61 Source17:       %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
62 # Source17-md5: 7b72caf22b01464ee7d6165f2fd85f44
63 Source18:       http://xenbits.xen.org/xen-extfiles/tpm_emulator-%{tpm_emulator_version}.tar.gz
64 # Source18-md5: e26becb8a6a2b6695f6b3e8097593db8
65 Source19:       ftp://ftp.gmplib.org/pub/gmp-%{gmp_version}/gmp-%{gmp_version}.tar.bz2
66 # Source19-md5: dd60683d7057917e34630b4a787932e8
67 Source35:       xenconsoled.sysconfig
68 Source37:       xenstored.sysconfig
69 Source38:       xenstored.tmpfiles
70 # sysvinit scripts
71 Source46:       xen-qemu-dom0-disk-backend.init
72 Source51:       xenconsoled.init
73 Source52:       xenstored.init
74 Source53:       xen-watchdog.init
75 Source54:       xendomains.init
76 Source55:       xen.logrotate
77 Source56:       xen.tmpfiles
78 Source57:       xen.cfg
79 Source58:       xen.efi-boot-update
80 Source59:       vif-openvswitch
81 Source60:       xen-init-list
82 Source61:       xen-toolstack
83 Patch0:         %{name}-python_scripts.patch
84 Patch1:         %{name}-symbols.patch
85 Patch2:         %{name}-curses.patch
86 Patch3:         pygrubfix.patch
87 # Warning: this disables ingress filtering implemented in xen scripts!
88 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
89 Patch9:         %{name}-gawk.patch
90 Patch10:        %{name}-qemu.patch
91 Patch12:        %{name}-doc.patch
92 Patch13:        %{name}-paths.patch
93 Patch14:        %{name}-no_fetcher.patch
94 Patch15:        odd-glib2-fix.patch
95 Patch16:        %{name}-gmp-abi.patch
96 Patch18:        %{name}-make.patch
97 Patch19:        %{name}-no_Werror.patch
98 # http://git.alpinelinux.org/cgit/aports/plain/main/xen/gnutls-3.4.0.patch
99 Patch20:        %{name}-gnutls-3.4.patch
100 Patch21:        %{name}-grep-typo.patch
101 Patch22:        %{name}-stubdom-build.patch
102 Patch23:        link.patch
103 Patch24:        %{name}-systemd.patch
104 URL:            http://www.xen.org/products/xenhyp.html
105 BuildRequires:  autoconf >= 2.67
106 %ifarch %{ix86} %{x8664}
107 BuildRequires:  acpica
108 BuildRequires:  bcc
109 BuildRequires:  bin86
110 %endif
111 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
112 BuildRequires:  bzip2-devel
113 %if %{with xsm}
114 BuildRequires:  checkpolicy
115 %endif
116 BuildRequires:  curl-devel
117 BuildRequires:  cyrus-sasl-devel >= 2
118 BuildRequires:  e2fsprogs-devel
119 BuildRequires:  gcc >= 6:4.1
120 %ifarch %{x8664}
121 BuildRequires:  gcc-multilib-32 >= 6:4.1
122 %endif
123 BuildRequires:  gettext-tools
124 BuildRequires:  glib2-devel >= 1:2.12
125 BuildRequires:  gnutls-devel
126 BuildRequires:  keyutils-devel
127 BuildRequires:  latex2html >= 2008
128 BuildRequires:  libaio-devel
129 BuildRequires:  libcap-devel
130 %ifarch arm aarch64
131 BuildRequires:  libfdt-devel
132 %endif
133 BuildRequires:  libjpeg-devel
134 BuildRequires:  libnl-devel >= 3.2.8
135 BuildRequires:  libpng-devel
136 BuildRequires:  libuuid-devel
137 BuildRequires:  lzo-devel >= 2
138 BuildRequires:  ncurses-devel
139 %if %{with ocaml}
140 BuildRequires:  ocaml >= 3.11.0
141 BuildRequires:  ocaml-findlib
142 %endif
143 BuildRequires:  nss-devel >= 3.12.8
144 BuildRequires:  openssl-devel
145 BuildRequires:  pciutils-devel
146 BuildRequires:  perl-base
147 BuildRequires:  perl-tools-pod
148 BuildRequires:  pkgconfig
149 BuildRequires:  python-devel
150 BuildRequires:  rpm-pythonprov
151 BuildRequires:  rpmbuild(macros) >= 1.647
152 BuildRequires:  seabios
153 BuildRequires:  texi2html
154 BuildRequires:  texlive-dvips
155 BuildRequires:  texlive-latex-psnfss
156 BuildRequires:  texlive-xetex
157 BuildRequires:  transfig
158 BuildRequires:  which
159 # for xfsctl (<xfs/xfs.h>)
160 BuildRequires:  xfsprogs-devel
161 BuildRequires:  xz-devel
162 BuildRequires:  yajl-devel
163 BuildRequires:  zlib-devel
164 %if %{with qemu_traditional}
165 %{?with_opengl:BuildRequires:   OpenGL-devel}
166 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
167 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
168 %{?with_brlapi:BuildRequires:   brlapi-devel}
169 BuildRequires:  vde2-devel
170 BuildRequires:  xorg-lib-libX11-devel
171 BuildRequires:  xorg-lib-libXext-devel
172 %endif
173 %if %{with qemu_traditional}
174 # FIXME: see qemu configure comments on top of spec
175 %{!?with_opengl:BuildConflicts: OpenGL-devel}
176 %{!?with_sdl:BuildConflicts:    SDL-devel}
177 %{!?with_sdl:BuildConflicts:    SDL-devel}
178 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
179 %{!?with_brlapi:BuildConflicts: brlapi-devel}
180 %endif
181 Requires(post,preun):   /sbin/chkconfig
182 Requires(post,preun,postun):    systemd-units >= 38
183 Requires:       %{name}-libs = %{version}-%{release}
184 Requires:       ZopeInterface
185 Requires:       bridge-utils
186 Requires:       coreutils
187 Requires:       diffutils
188 Requires:       gawk
189 Requires:       iptables
190 Requires:       losetup
191 Requires:       net-tools
192 Requires:       python-%{name} = %{version}-%{release}
193 Requires:       rc-scripts
194 Requires:       sed
195 Requires:       systemd-units >= 38
196 Requires:       util-linux
197 Requires:       which
198 Requires:       %{name}-guest = %{version}-%{release}
199 Obsoletes:      xen-doc
200 Obsoletes:      xen-udev
201 Obsoletes:      xen-xend
202 ExclusiveArch:  %{ix86} %{x8664} arm
203 %ifarch %{ix86} %{x8664}
204 # for HVM
205 Suggests:       qemu-system-x86
206 %endif
207 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
208
209 # some PPC/SPARC boot images in ELF format
210 %define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\|s390-ccw.img\\)
211
212 %description
213 This package contains the Xen hypervisor and Xen tools, needed to run
214 virtual machines on x86 systems, together with the kernel-xen*
215 packages. Information on how to use Xen can be found at the Xen
216 project pages.
217
218 Virtualisation can be used to run multiple versions or multiple Linux
219 distributions on one system, or to test untrusted applications in a
220 sandboxed environment. Note that the Xen technology is still in
221 development, and this RPM has received extremely little testing. Don't
222 be surprised if this RPM eats your data, drinks your coffee or makes
223 fun of you in front of your friends.
224
225 %description -l pl.UTF-8
226 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
227 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
228 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
229 projektu.
230
231 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
232 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
233 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
234 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
235 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
236 się wyśmiewał w obecności przyjaciół.
237
238 %package guest
239 Summary:        Xen tools for virtual machines
240 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
241 Group:          Applications/System
242 Requires:       %{name}-libs-guest = %{version}-%{release}
243
244 %description guest
245 Xen utilities for both dom0 and domU virtual domains.
246
247 %description guest -l pl.UTF-8
248 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
249
250 %package libs
251 Summary:        Xen libraries
252 Summary(pl.UTF-8):      Biblioteki Xena
253 Group:          Libraries
254 Requires:       %{name}-libs-guest = %{version}-%{release}
255
256 %description libs
257 Xen libraries.
258
259 %description libs -l pl.UTF-8
260 Biblioteki Xena.
261
262 %package libs-guest
263 Summary:        Xen libraries for virtual machines
264 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
265 Group:          Libraries
266
267 %description libs-guest
268 Xen libraries for both dom0 and domU virtual machines.
269
270 %description libs-guest -l pl.UTF-8
271 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
272
273 %package devel
274 Summary:        Header files for Xen
275 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
276 Group:          Development/Libraries
277 Requires:       %{name}-libs = %{version}-%{release}
278
279 %description devel
280 Header files for Xen.
281
282 %description devel -l pl.UTF-8
283 Pliki nagłówkowe Xena.
284
285 %package static
286 Summary:        Static Xen libraries
287 Summary(pl.UTF-8):      Statyczne biblioteki Xena
288 Group:          Development/Libraries
289 Requires:       %{name}-devel = %{version}-%{release}
290
291 %description static
292 Static Xen libraries.
293
294 %description static -l pl.UTF-8
295 Statyczne biblioteki Xena.
296
297 %package -n ocaml-xen
298 Summary:        OCaml bindings for Xen
299 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
300 License:        LGPL v2.1 with linking exception
301 Group:          Libraries
302 Requires:       %{name}-libs = %{version}-%{release}
303 %if %{with ocaml}
304 %requires_eq    ocaml-runtime
305 %endif
306
307 %description -n ocaml-xen
308 OCaml bindings for Xen.
309
310 %description -n ocaml-xen -l pl.UTF-8
311 Wiązania OCamla dla Xena.
312
313 %package -n ocaml-xen-devel
314 Summary:        OCaml bindings for Xen - development files
315 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
316 License:        LGPL v2.1 with linking exception
317 Group:          Development/Libraries
318 Requires:       ocaml-xen = %{version}-%{release}
319 %if %{with ocaml}
320 %requires_eq    ocaml
321 %endif
322
323 %description -n ocaml-xen-devel
324 OCaml bindings for Xen - development files.
325
326 %description -n ocaml-xen-devel -l pl.UTF-8
327 Wiązania OCamla dla Xena - pliki programistyczne.
328
329 %package -n python-xen
330 Summary:        Xen Python modules
331 Summary(pl.UTF-8):      Moduły Pythona dla Xena
332 Group:          Libraries
333 Requires:       %{name}-libs = %{version}-%{release}
334 Conflicts:      xen < 3.2.1-0.3
335
336 %description -n python-xen
337 Xen Python modules.
338
339 %description -n python-xen -l pl.UTF-8
340 Moduły Pythona dla Xena.
341
342 %package -n python-xen-guest
343 Summary:        Xen Python modules for virtual machines
344 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
345 Group:          Libraries
346 Requires:       %{name}-libs-guest = %{version}-%{release}
347 Conflicts:      xen < 3.2.1-0.3
348
349 %description -n python-xen-guest
350 Xen Python modules for both dom0 and domU virtual machines.
351
352 %description -n python-xen-guest -l pl.UTF-8
353 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
354
355 %package -n bash-completion-%{name}
356 Summary:        bash-completion for Xen (xl)
357 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
358 Group:          Applications/Shells
359 Requires:       %{name} = %{version}-%{release}
360 Requires:       bash-completion
361
362 %description -n bash-completion-%{name}
363 This package provides bash-completion for Xen (xl).
364
365 %description -n bash-completion-%{name} -l pl.UTF-8
366 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
367
368 %package efi
369 Summary:        Xen hypervisor binary for EFI
370 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
371 Group:          Applications/System
372 Requires:       %{name}-libs-guest = %{version}-%{release}
373
374 %description efi
375 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
376 firmware without help from any additional bootloader.
377
378 %description efi -l pl.UTF-8
379 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
380 (U)EFI, bez potrzeby oddzielnego bootloadera.
381
382 %prep
383 %setup -q
384 %patch0 -p1
385 %patch1 -p1
386 %patch2 -p1
387 %patch3 -p1
388 %patch7 -p1
389 %patch9 -p1
390 %patch10 -p1
391 %patch12 -p1
392 %patch13 -p1
393 %patch14 -p1
394 %patch15 -p1
395 %patch16 -p1
396 %patch18 -p1
397 %patch19 -p1
398 %patch20 -p1
399 %patch21 -p1
400 %patch22 -p1
401 %patch23 -p1
402 %patch24 -p1
403
404 # stubdom sources
405 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
406 ln -s %{SOURCE17} %{SOURCE18} %{SOURCE19} stubdom
407 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
408
409 # do not allow fetching anything via git
410 echo GIT=/bin/false >> Config.mk
411
412 %build
413 # based on the 'autoconf.sh' from the sources
414 %{__autoconf}
415 cd tools
416 %{__autoconf}
417 %{__autoheader}
418 cd ../stubdom
419 %{__autoconf}
420 cd ../docs
421 %{__autoconf}
422 cd ..
423
424 # if gold is used then bioses and grub doesn't build
425 install -d our-ld
426 ln -f -s /usr/bin/ld.bfd our-ld/ld
427 export PATH=$(pwd)/our-ld:$PATH
428
429 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
430 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
431
432 # NOTE on ac_cv_*:
433 # - use openssl (libcrypto) instead of libgcrypt as openssl is obligatory anyway
434 # - prevent libiconv from being detected (not needed with glibc)
435 %configure \
436         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
437         ac_cv_lib_gcrypt_gcry_md_hash_buffer=no \
438         ac_cv_lib_iconv_libiconv_open=no \
439         --disable-debug \
440         %{__enable_disable qemu_traditional qemu-traditional} \
441         --with-system-seabios=/usr/share/seabios/bios.bin \
442 %ifarch %{x8664}
443         --with-system-qemu=/usr/bin/qemu-system-x86_64 \
444 %else
445         --with-system-qemu=/usr/bin/qemu-system-i386 \
446 %endif
447         --with-systemd=%{systemdunitdir}
448
449 %{__make} -j1 dist-xen dist-tools dist-docs \
450         %{!?with_ocaml:OCAML_TOOLS=n} \
451         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
452         CC="%{__cc}" \
453         CXX="%{__cxx}" \
454         V=1
455
456 unset CFLAGS
457 unset CXXFLAGS
458
459 %if %{with stubdom}
460 %{__make} -j1 dist-stubdom \
461         %{!?with_ocaml:OCAML_TOOLS=n} \
462         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
463         CC="%{__cc}" \
464         CXX="%{__cxx}" \
465         V=1
466 %endif
467
468 %install
469 rm -rf $RPM_BUILD_ROOT
470 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
471         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
472
473 %if %{with efi}
474 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
475 %endif
476
477 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
478         %{!?with_ocaml:OCAML_TOOLS=n} \
479         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
480         DESTDIR=$RPM_BUILD_ROOT \
481         HOTPLUGS=install-udev
482
483 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
484 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
485
486 # sysvinit scripts
487 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
488 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
489 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
490 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
491 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
492 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
493 install %{SOURCE46} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-qemu-dom0-disk-backend
494 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
495 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
496 install -d $RPM_BUILD_ROOT/var/run/xenstored
497 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
498
499 install %{SOURCE60} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-init-list
500 install %{SOURCE61} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-toolstack
501
502 %if %{with efi}
503 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
504 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
505                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
506 %endif
507
508 %{__mv} $RPM_BUILD_ROOT/etc/xen/{xlexample*,examples}
509
510 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
511
512 # for %%doc
513 install -d _doc
514 for tool in blktap2 pygrub ; do
515         cp -p tools/$tool/README _doc/README.$tool
516 done
517
518 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
519 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
520
521 %py_postclean
522
523 # remove unneeded files
524 %if %{with hypervisor}
525 %{__mv} xen/xen-syms $RPM_BUILD_ROOT/boot/%{name}-syms-%{version}
526 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.6.gz
527 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
528 %endif
529 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
530 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
531
532 %clean
533 rm -rf $RPM_BUILD_ROOT
534
535 %post
536 /sbin/chkconfig --add xen-watchdog
537 /sbin/chkconfig --add xenconsoled
538 /sbin/chkconfig --add xenstored
539 /sbin/chkconfig --add xendomains
540 /sbin/chkconfig --add xen-qemu-dom0-disk-backend
541 NORESTART=1
542 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
543
544 %preun
545 if [ "$1" = "0" ]; then
546         %service xendomains stop
547         /sbin/chkconfig --del xendomains
548
549         %service xenconsoled stop
550         /sbin/chkconfig --del xenconsoled
551
552         %service xenstored stop
553         /sbin/chkconfig --del xenstored
554
555         %service xen-watchdog stop
556         /sbin/chkconfig --del xen-watchdog
557
558         %service xen-qemu-dom0-disk-backend stop
559         /sbin/chkconfig --del xen-qemu-dom0-disk-backend
560 fi
561 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
562
563 %postun
564 %systemd_reload
565
566 %post   libs -p /sbin/ldconfig
567 %postun libs -p /sbin/ldconfig
568
569 %post   libs-guest -p /sbin/ldconfig
570 %postun libs-guest -p /sbin/ldconfig
571
572 %post efi
573 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
574
575 %files
576 %defattr(644,root,root,755)
577 %doc COPYING README* docs/misc/* docs/html/* _doc/*
578 %if %{with hypervisor}
579 /boot/%{name}-syms-%{version}
580 /boot/%{name}-%{version}.gz
581 /boot/%{name}.gz
582 %endif
583 %if %{with xsm}
584 /boot/xenpolicy-%{version}
585 %endif
586 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
589 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
590 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
591 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
592 %attr(754,root,root) /etc/rc.d/init.d/xenstored
593 %attr(754,root,root) /etc/rc.d/init.d/xendomains
594 %attr(754,root,root) /etc/rc.d/init.d/xen-qemu-dom0-disk-backend
595 %{_prefix}/lib/modules-load.d/xen.conf
596 %{systemdunitdir}/proc-xen.mount
597 %{systemdunitdir}/var-lib-xenstored.mount
598 %{systemdunitdir}/xen-init-dom0.service
599 %{systemdunitdir}/xen-watchdog.service
600 %{systemdunitdir}/xenconsoled.service
601 %{systemdunitdir}/xenstored.service
602 %{systemdunitdir}/xenstored.socket
603 %{systemdunitdir}/xenstored_ro.socket
604 %{systemdunitdir}/xendomains.service
605 %{systemdunitdir}/xen-qemu-dom0-disk-backend.service
606 %dir %{_sysconfdir}/xen
607 %dir %{_sysconfdir}/xen/auto
608 %dir %{_sysconfdir}/xen/examples
609 %dir %{_sysconfdir}/xen/scripts
610 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
611 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
615 %attr(755,root,root) %{_bindir}/pygrub
616 %if %{with qemu_traditional}
617 %attr(755,root,root) %{_bindir}/qemu-img-xen
618 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
619 %endif
620 %attr(755,root,root) %{_bindir}/xenalyze
621 %attr(755,root,root) %{_bindir}/xencons
622 %attr(755,root,root) %{_bindir}/xencov_split
623 %attr(755,root,root) %{_bindir}/xentrace_format
624 %if %{with xsm}
625 %attr(755,root,root) %{_sbindir}/flask-*
626 %endif
627 %attr(755,root,root) %{_sbindir}/gdbsx
628 %attr(755,root,root) %{_sbindir}/gtrace*
629 %attr(755,root,root) %{_sbindir}/img2qcow
630 %attr(755,root,root) %{_sbindir}/kdd
631 %attr(755,root,root) %{_sbindir}/lock-util
632 %attr(755,root,root) %{_sbindir}/qcow-create
633 %attr(755,root,root) %{_sbindir}/qcow2raw
634 %attr(755,root,root) %{_sbindir}/tap-ctl
635 %attr(755,root,root) %{_sbindir}/tapdisk*
636 %attr(755,root,root) %{_sbindir}/td-util
637 %attr(755,root,root) %{_sbindir}/vhd-*
638 %attr(755,root,root) %{_sbindir}/xen-*
639 %attr(755,root,root) %{_sbindir}/xenbaked
640 %attr(755,root,root) %{_sbindir}/xenconsoled
641 %attr(755,root,root) %{_sbindir}/xencov
642 %attr(755,root,root) %{_sbindir}/xenlockprof
643 %attr(755,root,root) %{_sbindir}/xenmon.py
644 %attr(755,root,root) %{_sbindir}/xenperf
645 %attr(755,root,root) %{_sbindir}/xenpm
646 %attr(755,root,root) %{_sbindir}/xenpmd
647 %attr(755,root,root) %{_sbindir}/xenstored
648 %attr(755,root,root) %{_sbindir}/xentop
649 %attr(755,root,root) %{_sbindir}/xentrace
650 %attr(755,root,root) %{_sbindir}/xentrace_setmask
651 %attr(755,root,root) %{_sbindir}/xentrace_setsize
652 %attr(755,root,root) %{_sbindir}/xenwatchdogd
653 %attr(755,root,root) %{_sbindir}/xl
654 %dir %{_libdir}/%{name}
655 %dir %{_libdir}/%{name}/bin
656 %attr(744,root,root) %{_libdir}/%{name}/bin/*
657 %dir %{_libdir}/%{name}/boot
658 %if %{with stubdom}
659 %if %{with qemu_traditional}
660 %{_libdir}/%{name}/boot/ioemu-stubdom.gz
661 %endif
662 %ifarch %{ix86} %{x8664}
663 %{_libdir}/%{name}/boot/pv-grub-x86_32.gz
664 %endif
665 %ifarch %{x8664}
666 %{_libdir}/%{name}/boot/pv-grub-x86_64.gz
667 %endif
668 %{_libdir}/%{name}/boot/vtpm-stubdom.gz
669 %{_libdir}/%{name}/boot/vtpmmgr-stubdom.gz
670 %{_libdir}/%{name}/boot/xenstore-stubdom.gz
671 %endif
672 %attr(744,root,root) %{_libdir}/%{name}/boot/hvmloader
673 %{_mandir}/man1/xentop.1*
674 %{_mandir}/man1/xentrace_format.1*
675 %{_mandir}/man1/xl.1*
676 %{_mandir}/man5/xl.cfg.5*
677 %{_mandir}/man5/xl.conf.5*
678 %{_mandir}/man5/xlcpupool.cfg.5*
679 %{_mandir}/man8/xentrace.8*
680 %{_sharedstatedir}/xen
681 %{_sharedstatedir}/xenstored
682 %dir /var/run/xenstored
683 %{systemdtmpfilesdir}/xen.conf
684 %{systemdtmpfilesdir}/xenstored.conf
685 %dir %attr(0700,root,root) /var/log/xen
686 %dir %attr(0700,root,root) /var/log/xen/console
687 %if %{with qemu_traditional}
688 %{_datadir}/xen
689 %endif
690
691 %files guest
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_bindir}/xen-detect
694 %attr(755,root,root) %{_bindir}/xenstore
695 %attr(755,root,root) %{_bindir}/xenstore-chmod
696 %attr(755,root,root) %{_bindir}/xenstore-control
697 %attr(755,root,root) %{_bindir}/xenstore-exists
698 %attr(755,root,root) %{_bindir}/xenstore-list
699 %attr(755,root,root) %{_bindir}/xenstore-ls
700 %attr(755,root,root) %{_bindir}/xenstore-read
701 %attr(755,root,root) %{_bindir}/xenstore-rm
702 %attr(755,root,root) %{_bindir}/xenstore-watch
703 %attr(755,root,root) %{_bindir}/xenstore-write
704 %{_mandir}/man1/xenstore.1*
705 %{_mandir}/man1/xenstore-chmod.1*
706 %{_mandir}/man1/xenstore-ls.1*
707
708 %files libs
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
711 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
712 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
714 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
716 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.6
718 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.6
720 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
721 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.6
722 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
723 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
724 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
726 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.6
728 %dir %{_libdir}/fs
729 %dir %{_libdir}/fs/ext2fs-lib
730 %dir %{_libdir}/fs/fat
731 %dir %{_libdir}/fs/iso9660
732 %dir %{_libdir}/fs/reiserfs
733 %dir %{_libdir}/fs/ufs
734 %dir %{_libdir}/fs/xfs
735 %dir %{_libdir}/fs/zfs
736 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
737
738 %files libs-guest
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
742
743 %files devel
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/libblktapctl.so
746 %attr(755,root,root) %{_libdir}/libfsimage.so
747 %attr(755,root,root) %{_libdir}/libvhd.so
748 %attr(755,root,root) %{_libdir}/libxenctrl.so
749 %attr(755,root,root) %{_libdir}/libxenguest.so
750 %attr(755,root,root) %{_libdir}/libxenlight.so
751 %attr(755,root,root) %{_libdir}/libxenstat.so
752 %attr(755,root,root) %{_libdir}/libxenstore.so
753 %attr(755,root,root) %{_libdir}/libxenvchan.so
754 %attr(755,root,root) %{_libdir}/libxlutil.so
755 %{_includedir}/_libxl_list.h
756 %{_includedir}/_libxl_types.h
757 %{_includedir}/_libxl_types_json.h
758 %{_includedir}/fsimage*.h
759 %{_includedir}/libxenvchan.h
760 %{_includedir}/libxl*.h
761 %{_includedir}/xen*.h
762 %{_includedir}/xs*.h
763 %{_includedir}/xen
764 %{_includedir}/xenstore-compat
765 %{_npkgconfigdir}/xenlight.pc
766 %{_npkgconfigdir}/xlutil.pc
767
768 %files static
769 %defattr(644,root,root,755)
770 %{_libdir}/libblktapctl.a
771 %{_libdir}/libvhd.a
772 %{_libdir}/libxenctrl.a
773 %{_libdir}/libxenguest.a
774 %{_libdir}/libxenlight.a
775 %{_libdir}/libxenvchan.a
776 %{_libdir}/libxenstat.a
777 %{_libdir}/libxenstore.a
778 %{_libdir}/libxlutil.a
779
780 %if %{with ocaml}
781 %files -n ocaml-xen
782 %defattr(644,root,root,755)
783 %doc tools/ocaml/LICENSE
784 %attr(755,root,root) %{_sbindir}/oxenstored
785 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
786 %dir %{_libdir}/ocaml/site-lib/xenbus
787 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
788 %dir %{_libdir}/ocaml/site-lib/xenctrl
789 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
790 %dir %{_libdir}/ocaml/site-lib/xeneventchn
791 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
792 %dir %{_libdir}/ocaml/site-lib/xenlight
793 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
794 %dir %{_libdir}/ocaml/site-lib/xenmmap
795 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
796 %dir %{_libdir}/ocaml/site-lib/xentoollog
797 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xentoollog/dllxentoollog_stubs.so
798
799 %files -n ocaml-xen-devel
800 %defattr(644,root,root,755)
801 %{_libdir}/ocaml/site-lib/xenbus/META
802 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
803 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
804 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
805 %{_libdir}/ocaml/site-lib/xenctrl/META
806 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
807 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
808 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
809 %{_libdir}/ocaml/site-lib/xeneventchn/META
810 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
811 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
812 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
813 %{_libdir}/ocaml/site-lib/xenmmap/META
814 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
815 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
816 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
817 %{_libdir}/ocaml/site-lib/xenlight/META
818 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
819 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
820 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
821 %dir %{_libdir}/ocaml/site-lib/xenstore
822 %{_libdir}/ocaml/site-lib/xenstore/META
823 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
824 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
825 %{_libdir}/ocaml/site-lib/xentoollog/META
826 %{_libdir}/ocaml/site-lib/xentoollog/libxentoollog_stubs.a
827 %{_libdir}/ocaml/site-lib/xentoollog/xentoollog.a
828 %{_libdir}/ocaml/site-lib/xentoollog/*.cm[aixo]*
829 %endif
830
831 %files -n python-xen
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{py_sitedir}/fsimage.so
834 %dir %{py_sitedir}/xen
835 %dir %{py_sitedir}/xen/lowlevel
836 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
837 %{py_sitedir}/xen/migration
838 %{py_sitedir}/grub
839 %if "%{py_ver}" > "2.4"
840 %{py_sitedir}/pygrub-0.3-py*.egg-info
841 %{py_sitedir}/xen-3.0-py*.egg-info
842 %endif
843
844 %files -n python-xen-guest
845 %defattr(644,root,root,755)
846 %dir %{py_sitedir}/xen
847 %{py_sitedir}/xen/__init__.py*
848 %dir %{py_sitedir}/xen/lowlevel
849 %{py_sitedir}/xen/lowlevel/__init__.py*
850 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
851
852 %files -n bash-completion-%{name}
853 %defattr(644,root,root,755)
854 /etc/bash_completion.d/xl.sh
855
856 %if %{with efi}
857 %files efi
858 %defattr(644,root,root,755)
859 %dir %{_libdir}/efi
860 %{_libdir}/efi/*.efi
861 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
862 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
863 %endif
This page took 0.104191 seconds and 4 git commands to generate.