]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- add support for openvswitch
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.1
33 Release:        3
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  0d48cbe1767b82aba12517898d4e0408
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Source57:       xen.cfg
77 Source58:       xen.efi-boot-update
78 Source59:       vif-openvswitch
79 Patch0:         %{name}-python_scripts.patch
80 Patch1:         %{name}-symbols.patch
81 Patch2:         %{name}-curses.patch
82 Patch3:         pygrubfix.patch
83 Patch4:         xend.catchbt.patch
84 Patch5:         xend-pci-loop.patch
85 Patch6:         %{name}-dumpdir.patch
86 # Warning: this disables ingress filtering implemented in xen scripts!
87 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
88 Patch8:         %{name}-configure-xend.patch
89 Patch9:         %{name}-initscript.patch
90 Patch10:        %{name}-quemu-softloat-c99.patch
91 Patch11:        %{name}-qemu.patch
92 Patch12:        %{name}-scripts-locking.patch
93 Patch13:        %{name}-close_lockfd_after_lock_attempt.patch
94 Patch14:        %{name}-librt.patch
95 Patch15:        %{name}-ulong.patch
96 URL:            http://www.xen.org/products/xenhyp.html
97 %{?with_opengl:BuildRequires:   OpenGL-devel}
98 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
99 %ifarch %{ix86} %{x8664}
100 BuildRequires:  acpica
101 BuildRequires:  bcc
102 %endif
103 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
104 %{?with_brlapi:BuildRequires:   brlapi-devel}
105 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
106 BuildRequires:  bzip2-devel
107 BuildRequires:  ceph-devel
108 BuildRequires:  curl-devel
109 BuildRequires:  cyrus-sasl-devel >= 2
110 BuildRequires:  e2fsprogs-devel
111 BuildRequires:  gcc >= 5:3.4
112 BuildRequires:  gettext-devel
113 BuildRequires:  glib2-devel >= 1:2.12
114 BuildRequires:  gnutls-devel
115 BuildRequires:  latex2html >= 2008
116 BuildRequires:  libaio-devel
117 BuildRequires:  libiscsi-devel
118 BuildRequires:  libjpeg-devel
119 BuildRequires:  libpng-devel
120 BuildRequires:  libuuid-devel
121 BuildRequires:  lzo-devel >= 2
122 BuildRequires:  ncurses-devel
123 %if %{with ocaml}
124 BuildRequires:  ocaml >= 3.04-7
125 BuildRequires:  ocaml-findlib
126 %endif
127 BuildRequires:  nss-devel >= 3.12.8
128 BuildRequires:  openssl-devel
129 BuildRequires:  pciutils-devel
130 BuildRequires:  perl-base
131 BuildRequires:  pkgconfig
132 BuildRequires:  python-devel
133 BuildRequires:  rpm-pythonprov
134 BuildRequires:  rpmbuild(macros) >= 1.647
135 BuildRequires:  spice-protocol >= 0.6.0
136 BuildRequires:  spice-server-devel >= 0.6.0
137 BuildRequires:  texi2html
138 BuildRequires:  texlive-dvips
139 BuildRequires:  texlive-latex-psnfss
140 BuildRequires:  texlive-xetex
141 BuildRequires:  usbredir-devel
142 BuildRequires:  vde2-devel
143 BuildRequires:  which
144 # for xfsctl (<xfs/xfs.h>)
145 BuildRequires:  xfsprogs-devel
146 BuildRequires:  xorg-lib-libX11-devel
147 BuildRequires:  xorg-lib-libXext-devel
148 BuildRequires:  xz-devel
149 BuildRequires:  yajl-devel
150 BuildRequires:  zlib-devel
151 # FIXME: see qemu configure comments on top of spec
152 %{!?with_opengl:BuildConflicts: OpenGL-devel}
153 %{!?with_sdl:BuildConflicts:    SDL-devel}
154 %{!?with_sdl:BuildConflicts:    SDL-devel}
155 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
156 %{!?with_brlapi:BuildConflicts: brlapi-devel}
157 Requires(post,preun):   /sbin/chkconfig
158 Requires(post,preun,postun):    systemd-units >= 38
159 Requires:       %{name}-libs = %{version}-%{release}
160 Requires:       ZopeInterface
161 Requires:       bridge-utils
162 Requires:       coreutils
163 Requires:       diffutils
164 Requires:       gawk
165 Requires:       iptables
166 Requires:       losetup
167 Requires:       net-tools
168 Requires:       python-%{name} = %{version}-%{release}
169 Requires:       rc-scripts
170 Requires:       sed
171 Requires:       systemd-units >= 38
172 Requires:       util-linux
173 Requires:       which
174 Requires:       %{name}-guest = %{version}-%{release}
175 Obsoletes:      xen-doc
176 Obsoletes:      xen-udev
177 ExclusiveArch:  %{ix86} %{x8664}
178 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
179
180 # some PPC/SPARC boot images in ELF format
181 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
182
183 %description
184 This package contains the Xen hypervisor and Xen tools, needed to run
185 virtual machines on x86 systems, together with the kernel-xen*
186 packages. Information on how to use Xen can be found at the Xen
187 project pages.
188
189 Virtualisation can be used to run multiple versions or multiple Linux
190 distributions on one system, or to test untrusted applications in a
191 sandboxed environment. Note that the Xen technology is still in
192 development, and this RPM has received extremely little testing. Don't
193 be surprised if this RPM eats your data, drinks your coffee or makes
194 fun of you in front of your friends.
195
196 %description -l pl.UTF-8
197 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
198 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
199 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
200 projektu.
201
202 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
203 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
204 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
205 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
206 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
207 się wyśmiewał w obecności przyjaciół.
208
209 %package guest
210 Summary:        Xen tools for virtual machines
211 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
212 Group:          Applications/System
213 Requires:       %{name}-libs-guest = %{version}-%{release}
214
215 %description guest
216 Xen utilities for both dom0 and domU virtual domains.
217
218 %description guest -l pl.UTF-8
219 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
220
221 %package libs
222 Summary:        Xen libraries
223 Summary(pl.UTF-8):      Biblioteki Xena
224 Group:          Libraries
225 Requires:       %{name}-libs-guest = %{version}-%{release}
226
227 %description libs
228 Xen libraries.
229
230 %description libs -l pl.UTF-8
231 Biblioteki Xena.
232
233 %package libs-guest
234 Summary:        Xen libraries for virtual machines
235 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
236 Group:          Libraries
237
238 %description libs-guest
239 Xen libraries for both dom0 and domU virtual machines.
240
241 %description libs-guest -l pl.UTF-8
242 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
243
244 %package devel
245 Summary:        Header files for Xen
246 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
247 Group:          Development/Libraries
248 Requires:       %{name}-libs = %{version}-%{release}
249
250 %description devel
251 Header files for Xen.
252
253 %description devel -l pl.UTF-8
254 Pliki nagłówkowe Xena.
255
256 %package static
257 Summary:        Static Xen libraries
258 Summary(pl.UTF-8):      Statyczne biblioteki Xena
259 Group:          Development/Libraries
260 Requires:       %{name}-devel = %{version}-%{release}
261
262 %description static
263 Static Xen libraries.
264
265 %description static -l pl.UTF-8
266 Statyczne biblioteki Xena.
267
268 %package xend
269 Summary:        xend daemon
270 Summary(pl.UTF-8):      Demon xend
271 Group:          Daemons
272 Requires(post,preun,postun):    systemd-units >= 38
273 Requires:       systemd-units >= 38
274
275 %description xend
276 xend daemon.
277
278 %description xend -l pl.UTF-8
279 Demon xend.
280
281 %package -n ocaml-xen
282 Summary:        OCaml bindings for Xen
283 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
284 License:        LGPL v2.1 with linking exception
285 Group:          Libraries
286 Requires:       %{name}-libs = %{version}-%{release}
287 %if %{with ocaml}
288 %requires_eq    ocaml-runtime
289 %endif
290
291 %description -n ocaml-xen
292 OCaml bindings for Xen.
293
294 %description -n ocaml-xen -l pl.UTF-8
295 Wiązania OCamla dla Xena.
296
297 %package -n ocaml-xen-devel
298 Summary:        OCaml bindings for Xen - development files
299 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
300 License:        LGPL v2.1 with linking exception
301 Group:          Development/Libraries
302 Requires:       ocaml-xen = %{version}-%{release}
303 %if %{with ocaml}
304 %requires_eq    ocaml
305 %endif
306
307 %description -n ocaml-xen-devel
308 OCaml bindings for Xen - development files.
309
310 %description -n ocaml-xen-devel -l pl.UTF-8
311 Wiązania OCamla dla Xena - pliki programistyczne.
312
313 %package -n python-xen
314 Summary:        Xen Python modules
315 Summary(pl.UTF-8):      Moduły Pythona dla Xena
316 Group:          Libraries
317 Requires:       %{name}-libs = %{version}-%{release}
318 Conflicts:      xen < 3.2.1-0.3
319
320 %description -n python-xen
321 Xen Python modules.
322
323 %description -n python-xen -l pl.UTF-8
324 Moduły Pythona dla Xena.
325
326 %package -n python-xen-guest
327 Summary:        Xen Python modules for virtual machines
328 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
329 Group:          Libraries
330 Requires:       %{name}-libs-guest = %{version}-%{release}
331 Conflicts:      xen < 3.2.1-0.3
332
333 %description -n python-xen-guest
334 Xen Python modules for both dom0 and domU virtual machines.
335
336 %description -n python-xen-guest -l pl.UTF-8
337 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
338
339 %package -n bash-completion-%{name}
340 Summary:    bash-completion for Xen (xl)
341 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
342 Group:      Applications/Shells
343 Requires:   %{name} = %{version}-%{release}
344 Requires:   bash-completion
345
346 %description -n bash-completion-%{name}
347 This package provides bash-completion for Xen (xl).
348
349 %description -n bash-completion-%{name} -l pl.UTF-8
350 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
351
352 %package efi
353 Summary:        Xen hypervisor binary for EFI
354 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
355 Group:          Applications/System
356 Requires:       %{name}-libs-guest = %{version}-%{release}
357
358 %description efi
359 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
360 firmware without help from any additional bootloader.
361
362 %description efi -l pl.UTF-8
363 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
364 (U)EFI, bez potrzeby oddzielnego bootloadera.
365
366 %prep
367 %setup -q -a 16
368 %patch0 -p1
369 %patch1 -p1
370 %patch2 -p1
371 %patch3 -p1
372 %patch4 -p1
373 %patch5 -p1
374 %patch6 -p1
375 %patch7 -p1
376 %patch8 -p1
377 %patch9 -p1
378 %patch10 -p1
379 %patch11 -p1
380 %patch12 -p1
381 %patch13 -p1
382 %patch14 -p1
383 %patch15 -p1
384
385 # stubdom sources
386 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
387 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
388
389 # do not allow fetching anything via git
390 echo GIT=/bin/false >> Config.mk
391
392 %build
393 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
394 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
395
396 # NOTE:
397 # - there is a quoting bug (in tools/driver/Makefile) that causes
398 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
399 #   anyway (see configure), gcrypt is optional
400 # - prevent libiconv from being detected (not needed with glibc)
401 cd tools
402 %configure \
403         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
404         ac_cv_lib_iconv_libiconv_open=no \
405         --disable-debug
406 cd ..
407
408 %{__make} dist-xen dist-tools dist-docs \
409         %{!?with_ocaml:OCAML_TOOLS=n} \
410         prefix=%{_prefix} \
411         CC="%{__cc}" \
412         CXX="%{__cxx}" \
413         V=1
414
415 unset CFLAGS
416 unset CXXFLAGS
417
418 %{__make} -j1 dist-stubdom \
419         %{!?with_ocaml:OCAML_TOOLS=n} \
420         CC="%{__cc}" \
421         CXX="%{__cxx}" \
422         V=1
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
427         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
428         $RPM_BUILD_ROOT/etc/efi-boot/update.d
429
430 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
431         %{!?with_ocaml:OCAML_TOOLS=n} \
432         prefix=%{_prefix} \
433         DESTDIR=$RPM_BUILD_ROOT \
434         HOTPLUGS=install-udev
435
436 %if "%{_lib}" == "lib64"
437 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
438 %endif
439
440 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
441 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
442 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
443 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
444 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
445 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
446 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
447 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
448 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
449 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
450 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
451 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
452 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
453 # sysvinit scripts
454 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
455 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
456 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
457 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
458 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
459 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
460 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
461 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
462
463 %if %{with efi}
464 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
465 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
466                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
467 %endif
468
469 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
470
471 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
472
473 # for %%doc
474 install -d _doc
475 for tool in blktap blktap2 pygrub xenmon ; do
476         cp -p tools/$tool/README _doc/README.$tool
477 done
478 cp -al tools/qemu-xen/docs _doc/qemu-xen
479
480 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
481 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
482
483 %py_postclean
484
485 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
486 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
487 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
488 # seems not needed, the path is wrong anyway
489 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
490
491 # remove unneeded files
492 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
493 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
494 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
495 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
496 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
497
498 %clean
499 rm -rf $RPM_BUILD_ROOT
500
501 %post
502 /sbin/chkconfig --add xen-watchdog
503 /sbin/chkconfig --add xenconsoled
504 /sbin/chkconfig --add xenstored
505 /sbin/chkconfig --add xendomains
506 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
507
508 %preun
509 if [ "$1" = "0" ]; then
510         %service xendomains stop
511         /sbin/chkconfig --del xendomains
512
513         %service xenconsoled stop
514         /sbin/chkconfig --del xenconsoled
515
516         %service xenstored stop
517         /sbin/chkconfig --del xenstored
518
519         %service xen-watchdog stop
520         /sbin/chkconfig --del xen-watchdog
521 fi
522 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
523
524 %postun
525 %systemd_reload
526
527 %post xend
528 /sbin/chkconfig --add xend
529 %systemd_post xend.service
530
531 %preun xend
532 if [ "$1" = "0" ]; then
533         %service xend stop
534         /sbin/chkconfig --del xend
535 fi
536 %systemd_preun xend.service
537
538 %postun xend
539 %systemd_reload
540
541 %post   libs -p /sbin/ldconfig
542 %postun libs -p /sbin/ldconfig
543
544 %post   libs-guest -p /sbin/ldconfig
545 %postun libs-guest -p /sbin/ldconfig
546
547 %post efi
548 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
549
550 %files
551 %defattr(644,root,root,755)
552 %doc COPYING README* docs/misc/* 
553 %doc docs/html/*
554 %doc tools/qemu-xen-dir/*.html
555 %doc _doc/*
556 /boot/%{name}-syms-%{version}
557 /boot/%{name}-%{version}.gz
558 /boot/%{name}.gz
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
564 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
565 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
566 %attr(754,root,root) /etc/rc.d/init.d/xenstored
567 %attr(754,root,root) /etc/rc.d/init.d/xendomains
568 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
569 %{systemdunitdir}/proc-xen.mount
570 %{systemdunitdir}/var-lib-xenstored.mount
571 %{systemdunitdir}/xen-watchdog.service
572 %{systemdunitdir}/xenconsoled.service
573 %{systemdunitdir}/xenstored.service
574 %dir %{_sysconfdir}/xen
575 %dir %{_sysconfdir}/xen/auto
576 %dir %{_sysconfdir}/xen/examples
577 %dir %{_sysconfdir}/xen/scripts
578 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
579 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
581 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
582 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
583 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
584 %attr(755,root,root) %{_bindir}/pygrub
585 %attr(755,root,root) %{_bindir}/qemu-img-xen
586 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
587 %attr(755,root,root) %{_bindir}/remus
588 %attr(755,root,root) %{_bindir}/xencons
589 %attr(755,root,root) %{_bindir}/xentrace*
590 %attr(755,root,root) %{_sbindir}/blktapctrl
591 %attr(755,root,root) %{_sbindir}/flask-*
592 %attr(755,root,root) %{_sbindir}/gdbsx
593 %attr(755,root,root) %{_sbindir}/gtrace*
594 %attr(755,root,root) %{_sbindir}/img2qcow
595 %attr(755,root,root) %{_sbindir}/kdd
596 %attr(755,root,root) %{_sbindir}/lock-util
597 %attr(755,root,root) %{_sbindir}/qcow-create
598 %attr(755,root,root) %{_sbindir}/qcow2raw
599 %attr(755,root,root) %{_sbindir}/tap-ctl
600 %attr(755,root,root) %{_sbindir}/tapdisk*
601 %attr(755,root,root) %{_sbindir}/td-util
602 %attr(755,root,root) %{_sbindir}/vhd-*
603 %attr(755,root,root) %{_sbindir}/xen-*
604 %attr(755,root,root) %{_sbindir}/xenbaked
605 %attr(755,root,root) %{_sbindir}/xenconsoled
606 %attr(755,root,root) %{_sbindir}/xenlockprof
607 %attr(755,root,root) %{_sbindir}/xenmon.py
608 %attr(755,root,root) %{_sbindir}/xenperf
609 %attr(755,root,root) %{_sbindir}/xenpm
610 %attr(755,root,root) %{_sbindir}/xenpmd
611 %attr(755,root,root) %{_sbindir}/xenstored
612 %attr(755,root,root) %{_sbindir}/xentop
613 %attr(755,root,root) %{_sbindir}/xentrace_setmask
614 %attr(755,root,root) %{_sbindir}/xenwatchdogd
615 %attr(755,root,root) %{_sbindir}/xl
616 %attr(755,root,root) %{_sbindir}/xsview
617 %dir %{_libdir}/%{name}
618 %dir %{_libdir}/%{name}/bin
619 %attr(744,root,root) %{_libdir}/%{name}/bin/*
620 %if "%{_lib}" != "lib"
621 %dir %{_prefix}/lib/%{name}
622 %dir %{_prefix}/lib/%{name}/bin
623 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
624 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
625 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
626 %endif
627 %dir %{_prefix}/lib/%{name}/boot
628 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
629 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
630 %ifarch %{x8664}
631 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
632 %endif
633 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
634 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
635 %{_datadir}/xen
636 %{_mandir}/man1/qemu-img-xen.1*
637 %{_mandir}/man1/xentop.1*
638 %{_mandir}/man1/xentrace_format.1*
639 %{_mandir}/man1/xl.1*
640 %{_mandir}/man1/xm.1*
641 %{_mandir}/man5/xend-config.sxp.5*
642 %{_mandir}/man5/xl.cfg.5*
643 %{_mandir}/man5/xl.conf.5*
644 %{_mandir}/man5/xlcpupool.cfg.5*
645 %{_mandir}/man5/xmdomain.cfg.5*
646 %{_mandir}/man8/qemu-nbd-xen.8*
647 %{_mandir}/man8/xentrace.8*
648 %{_sharedstatedir}/xen
649 %{_sharedstatedir}/xenstored
650 %dir /var/run/xenstored
651 %{systemdtmpfilesdir}/xenstored.conf
652 %{systemdtmpfilesdir}/xen.conf
653 %dir %attr(0700,root,root) /var/log/xen
654 %dir %attr(0700,root,root) /var/log/xen/console
655 %{_datadir}/qemu-xen
656
657 %files guest
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_bindir}/xen-detect
660 %attr(755,root,root) %{_bindir}/xenstore*
661
662 %files libs
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
665 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
666 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
667 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
668 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
669 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
670 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
671 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
672 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
673 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
674 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
675 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
676 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
677 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
678 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
679 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
680 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
681 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
682 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
683 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
684 %dir %{_libdir}/fs
685 %dir %{_libdir}/fs/ext2fs-lib
686 %dir %{_libdir}/fs/fat
687 %dir %{_libdir}/fs/iso9660
688 %dir %{_libdir}/fs/reiserfs
689 %dir %{_libdir}/fs/ufs
690 %dir %{_libdir}/fs/xfs
691 %dir %{_libdir}/fs/zfs
692 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
693
694 %files libs-guest
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
697 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
698
699 %files devel
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/libblktap.so
702 %attr(755,root,root) %{_libdir}/libblktapctl.so
703 %attr(755,root,root) %{_libdir}/libfsimage.so
704 %attr(755,root,root) %{_libdir}/libvhd.so
705 %attr(755,root,root) %{_libdir}/libxenctrl.so
706 %attr(755,root,root) %{_libdir}/libxenguest.so
707 %attr(755,root,root) %{_libdir}/libxenlight.so
708 %attr(755,root,root) %{_libdir}/libxenstat.so
709 %attr(755,root,root) %{_libdir}/libxenstore.so
710 %attr(755,root,root) %{_libdir}/libxenvchan.so
711 %attr(755,root,root) %{_libdir}/libxlutil.so
712 %{_includedir}/_libxl_list.h
713 %{_includedir}/_libxl_types.h
714 %{_includedir}/_libxl_types_json.h
715 %{_includedir}/blktaplib.h
716 %{_includedir}/fsimage*.h
717 %{_includedir}/libxenvchan.h
718 %{_includedir}/libxl*.h
719 %{_includedir}/xen*.h
720 %{_includedir}/xs*.h
721 %{_includedir}/xen
722 %{_includedir}/xenstore-compat
723
724 %files static
725 %defattr(644,root,root,755)
726 %{_libdir}/libblktap.a
727 %{_libdir}/libblktapctl.a
728 %{_libdir}/libvhd.a
729 %{_libdir}/libxenctrl.a
730 %{_libdir}/libxenguest.a
731 %{_libdir}/libxenlight.a
732 %{_libdir}/libxenvchan.a
733 %{_libdir}/libxenstat.a
734 %{_libdir}/libxenstore.a
735 %{_libdir}/libxlutil.a
736
737 %files xend
738 %defattr(644,root,root,755)
739 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
740 %{systemdunitdir}/blktapctrl.service
741 %{systemdunitdir}/xend.service
742 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
743 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
744 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
745 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
746 %attr(755,root,root) %{_sbindir}/xend
747 %attr(755,root,root) %{_sbindir}/xm
748 %dir %attr(700,root,root) /var/run/xend
749 %{systemdtmpfilesdir}/xend.conf
750
751 %if %{with ocaml}
752 %files -n ocaml-xen
753 %defattr(644,root,root,755)
754 %doc tools/ocaml/LICENSE
755 %attr(755,root,root) %{_sbindir}/oxenstored
756 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
757 %dir %{_libdir}/ocaml/site-lib/xenbus
758 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
759 %dir %{_libdir}/ocaml/site-lib/xenctrl
760 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
761 %dir %{_libdir}/ocaml/site-lib/xeneventchn
762 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
763 %dir %{_libdir}/ocaml/site-lib/xenlight
764 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
765 %dir %{_libdir}/ocaml/site-lib/xenmmap
766 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
767
768 %files -n ocaml-xen-devel
769 %defattr(644,root,root,755)
770 %{_libdir}/ocaml/site-lib/xenbus/META
771 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
772 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
773 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
774 %{_libdir}/ocaml/site-lib/xenctrl/META
775 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
776 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
777 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
778 %{_libdir}/ocaml/site-lib/xeneventchn/META
779 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
780 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
781 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
782 %{_libdir}/ocaml/site-lib/xenmmap/META
783 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
784 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
785 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
786 %{_libdir}/ocaml/site-lib/xenlight/META
787 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
788 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
789 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
790 %dir %{_libdir}/ocaml/site-lib/xenstore
791 %{_libdir}/ocaml/site-lib/xenstore/META
792 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
793 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
794 %endif
795
796 %files -n python-xen
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{py_sitedir}/fsimage.so
799 %{py_sitedir}/grub
800 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
801 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
802 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
803 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
804 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
805 %{py_sitedir}/xen/remus
806 %{py_sitedir}/xen/sv
807 %{py_sitedir}/xen/util
808 %{py_sitedir}/xen/web
809 %{py_sitedir}/xen/xend
810 %{py_sitedir}/xen/xm
811 %{py_sitedir}/xen/xsview
812 %if "%{py_ver}" > "2.4"
813 %{py_sitedir}/pygrub-0.3-py*.egg-info
814 %{py_sitedir}/xen-3.0-py*.egg-info
815 %endif
816
817 %files -n python-xen-guest
818 %defattr(644,root,root,755)
819 %dir %{py_sitedir}/xen
820 %{py_sitedir}/xen/__init__.py*
821 %dir %{py_sitedir}/xen/lowlevel
822 %{py_sitedir}/xen/lowlevel/__init__.py*
823 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
824
825 %files -n bash-completion-%{name}
826 %defattr(644,root,root,755)
827 /etc/bash_completion.d/xl.sh
828
829 %if %{with efi}
830 %files efi
831 %defattr(644,root,root,755)
832 %dir %{_libdir}/efi
833 %{_libdir}/efi/*.efi
834 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
835 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
836 %endif
This page took 2.064744 seconds and 4 git commands to generate.