]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- don't restart xen services, especially xendomains
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.2
33 Release:        2
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  f7362b19401a47826f2d8fd603a1782a
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 Source43:       xendomains.sh
69 Source44:       xendomains.service
70 # sysvinit scripts
71 Source50:       xend.init
72 Source51:       xenconsoled.init
73 Source52:       xenstored.init
74 Source53:       xen-watchdog.init
75 Source54:       xendomains.init
76 Source55:       xen.logrotate
77 Source56:       xen.tmpfiles
78 Source57:       xen.cfg
79 Source58:       xen.efi-boot-update
80 Source59:       vif-openvswitch
81 Source60:       xen-init-list
82 Source61:       xen-toolstack
83 Patch0:         %{name}-python_scripts.patch
84 Patch1:         %{name}-symbols.patch
85 Patch2:         %{name}-curses.patch
86 Patch3:         pygrubfix.patch
87 Patch4:         xend.catchbt.patch
88 Patch5:         xend-pci-loop.patch
89 Patch6:         %{name}-dumpdir.patch
90 # Warning: this disables ingress filtering implemented in xen scripts!
91 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
92 Patch8:         %{name}-configure-xend.patch
93 Patch9:         %{name}-initscript.patch
94 Patch10:        %{name}-quemu-softloat-c99.patch
95 Patch11:        %{name}-qemu.patch
96 Patch12:        %{name}-scripts-locking.patch
97 Patch13:        %{name}-close_lockfd_after_lock_attempt.patch
98 Patch14:        %{name}-librt.patch
99 Patch15:        %{name}-ulong.patch
100 Patch16:        %{name}-doc.patch
101 URL:            http://www.xen.org/products/xenhyp.html
102 %{?with_opengl:BuildRequires:   OpenGL-devel}
103 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
104 %ifarch %{ix86} %{x8664}
105 BuildRequires:  acpica
106 BuildRequires:  bcc
107 %endif
108 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
109 %{?with_brlapi:BuildRequires:   brlapi-devel}
110 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
111 BuildRequires:  bzip2-devel
112 BuildRequires:  ceph-devel
113 BuildRequires:  curl-devel
114 BuildRequires:  cyrus-sasl-devel >= 2
115 BuildRequires:  e2fsprogs-devel
116 BuildRequires:  gcc >= 5:3.4
117 BuildRequires:  gettext-devel
118 BuildRequires:  glib2-devel >= 1:2.12
119 BuildRequires:  gnutls-devel
120 BuildRequires:  latex2html >= 2008
121 BuildRequires:  libaio-devel
122 BuildRequires:  libiscsi-devel
123 BuildRequires:  libjpeg-devel
124 BuildRequires:  libpng-devel
125 BuildRequires:  libuuid-devel
126 BuildRequires:  lzo-devel >= 2
127 BuildRequires:  ncurses-devel
128 %if %{with ocaml}
129 BuildRequires:  ocaml >= 3.04-7
130 BuildRequires:  ocaml-findlib
131 %endif
132 BuildRequires:  nss-devel >= 3.12.8
133 BuildRequires:  openssl-devel
134 BuildRequires:  pciutils-devel
135 BuildRequires:  perl-base
136 BuildRequires:  pkgconfig
137 BuildRequires:  python-devel
138 BuildRequires:  rpm-pythonprov
139 BuildRequires:  rpmbuild(macros) >= 1.647
140 BuildRequires:  spice-protocol >= 0.6.0
141 BuildRequires:  spice-server-devel >= 0.6.0
142 BuildRequires:  texi2html
143 BuildRequires:  texlive-dvips
144 BuildRequires:  texlive-latex-psnfss
145 BuildRequires:  texlive-xetex
146 BuildRequires:  usbredir-devel
147 BuildRequires:  vde2-devel
148 BuildRequires:  which
149 # for xfsctl (<xfs/xfs.h>)
150 BuildRequires:  xfsprogs-devel
151 BuildRequires:  xorg-lib-libX11-devel
152 BuildRequires:  xorg-lib-libXext-devel
153 BuildRequires:  xz-devel
154 BuildRequires:  yajl-devel
155 BuildRequires:  zlib-devel
156 # FIXME: see qemu configure comments on top of spec
157 %{!?with_opengl:BuildConflicts: OpenGL-devel}
158 %{!?with_sdl:BuildConflicts:    SDL-devel}
159 %{!?with_sdl:BuildConflicts:    SDL-devel}
160 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
161 %{!?with_brlapi:BuildConflicts: brlapi-devel}
162 Requires(post,preun):   /sbin/chkconfig
163 Requires(post,preun,postun):    systemd-units >= 38
164 Requires:       %{name}-libs = %{version}-%{release}
165 Requires:       ZopeInterface
166 Requires:       bridge-utils
167 Requires:       coreutils
168 Requires:       diffutils
169 Requires:       gawk
170 Requires:       iptables
171 Requires:       losetup
172 Requires:       net-tools
173 Requires:       python-%{name} = %{version}-%{release}
174 Requires:       rc-scripts
175 Requires:       sed
176 Requires:       systemd-units >= 38
177 Requires:       util-linux
178 Requires:       which
179 Requires:       %{name}-guest = %{version}-%{release}
180 Obsoletes:      xen-doc
181 Obsoletes:      xen-udev
182 ExclusiveArch:  %{ix86} %{x8664}
183 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
184
185 # some PPC/SPARC boot images in ELF format
186 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
187
188 %description
189 This package contains the Xen hypervisor and Xen tools, needed to run
190 virtual machines on x86 systems, together with the kernel-xen*
191 packages. Information on how to use Xen can be found at the Xen
192 project pages.
193
194 Virtualisation can be used to run multiple versions or multiple Linux
195 distributions on one system, or to test untrusted applications in a
196 sandboxed environment. Note that the Xen technology is still in
197 development, and this RPM has received extremely little testing. Don't
198 be surprised if this RPM eats your data, drinks your coffee or makes
199 fun of you in front of your friends.
200
201 %description -l pl.UTF-8
202 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
203 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
204 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
205 projektu.
206
207 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
208 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
209 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
210 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
211 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
212 się wyśmiewał w obecności przyjaciół.
213
214 %package guest
215 Summary:        Xen tools for virtual machines
216 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
217 Group:          Applications/System
218 Requires:       %{name}-libs-guest = %{version}-%{release}
219
220 %description guest
221 Xen utilities for both dom0 and domU virtual domains.
222
223 %description guest -l pl.UTF-8
224 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
225
226 %package libs
227 Summary:        Xen libraries
228 Summary(pl.UTF-8):      Biblioteki Xena
229 Group:          Libraries
230 Requires:       %{name}-libs-guest = %{version}-%{release}
231
232 %description libs
233 Xen libraries.
234
235 %description libs -l pl.UTF-8
236 Biblioteki Xena.
237
238 %package libs-guest
239 Summary:        Xen libraries for virtual machines
240 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
241 Group:          Libraries
242
243 %description libs-guest
244 Xen libraries for both dom0 and domU virtual machines.
245
246 %description libs-guest -l pl.UTF-8
247 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
248
249 %package devel
250 Summary:        Header files for Xen
251 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
252 Group:          Development/Libraries
253 Requires:       %{name}-libs = %{version}-%{release}
254
255 %description devel
256 Header files for Xen.
257
258 %description devel -l pl.UTF-8
259 Pliki nagłówkowe Xena.
260
261 %package static
262 Summary:        Static Xen libraries
263 Summary(pl.UTF-8):      Statyczne biblioteki Xena
264 Group:          Development/Libraries
265 Requires:       %{name}-devel = %{version}-%{release}
266
267 %description static
268 Static Xen libraries.
269
270 %description static -l pl.UTF-8
271 Statyczne biblioteki Xena.
272
273 %package xend
274 Summary:        xend daemon
275 Summary(pl.UTF-8):      Demon xend
276 Group:          Daemons
277 Requires(post,preun,postun):    systemd-units >= 38
278 Requires:       systemd-units >= 38
279
280 %description xend
281 xend daemon.
282
283 %description xend -l pl.UTF-8
284 Demon xend.
285
286 %package -n ocaml-xen
287 Summary:        OCaml bindings for Xen
288 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
289 License:        LGPL v2.1 with linking exception
290 Group:          Libraries
291 Requires:       %{name}-libs = %{version}-%{release}
292 %if %{with ocaml}
293 %requires_eq    ocaml-runtime
294 %endif
295
296 %description -n ocaml-xen
297 OCaml bindings for Xen.
298
299 %description -n ocaml-xen -l pl.UTF-8
300 Wiązania OCamla dla Xena.
301
302 %package -n ocaml-xen-devel
303 Summary:        OCaml bindings for Xen - development files
304 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
305 License:        LGPL v2.1 with linking exception
306 Group:          Development/Libraries
307 Requires:       ocaml-xen = %{version}-%{release}
308 %if %{with ocaml}
309 %requires_eq    ocaml
310 %endif
311
312 %description -n ocaml-xen-devel
313 OCaml bindings for Xen - development files.
314
315 %description -n ocaml-xen-devel -l pl.UTF-8
316 Wiązania OCamla dla Xena - pliki programistyczne.
317
318 %package -n python-xen
319 Summary:        Xen Python modules
320 Summary(pl.UTF-8):      Moduły Pythona dla Xena
321 Group:          Libraries
322 Requires:       %{name}-libs = %{version}-%{release}
323 Conflicts:      xen < 3.2.1-0.3
324
325 %description -n python-xen
326 Xen Python modules.
327
328 %description -n python-xen -l pl.UTF-8
329 Moduły Pythona dla Xena.
330
331 %package -n python-xen-guest
332 Summary:        Xen Python modules for virtual machines
333 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
334 Group:          Libraries
335 Requires:       %{name}-libs-guest = %{version}-%{release}
336 Conflicts:      xen < 3.2.1-0.3
337
338 %description -n python-xen-guest
339 Xen Python modules for both dom0 and domU virtual machines.
340
341 %description -n python-xen-guest -l pl.UTF-8
342 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
343
344 %package -n bash-completion-%{name}
345 Summary:    bash-completion for Xen (xl)
346 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
347 Group:      Applications/Shells
348 Requires:   %{name} = %{version}-%{release}
349 Requires:   bash-completion
350
351 %description -n bash-completion-%{name}
352 This package provides bash-completion for Xen (xl).
353
354 %description -n bash-completion-%{name} -l pl.UTF-8
355 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
356
357 %package efi
358 Summary:        Xen hypervisor binary for EFI
359 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
360 Group:          Applications/System
361 Requires:       %{name}-libs-guest = %{version}-%{release}
362
363 %description efi
364 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
365 firmware without help from any additional bootloader.
366
367 %description efi -l pl.UTF-8
368 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
369 (U)EFI, bez potrzeby oddzielnego bootloadera.
370
371 %prep
372 %setup -q -a 16
373 %patch0 -p1
374 %patch1 -p1
375 %patch2 -p1
376 %patch3 -p1
377 %patch4 -p1
378 %patch5 -p1
379 %patch6 -p1
380 %patch7 -p1
381 %patch8 -p1
382 %patch9 -p1
383 %patch10 -p1
384 %patch11 -p1
385 %patch12 -p1
386 %patch13 -p1
387 %patch14 -p1
388 %patch15 -p1
389 %patch16 -p1
390
391 # stubdom sources
392 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
393 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
394
395 # do not allow fetching anything via git
396 echo GIT=/bin/false >> Config.mk
397
398 %build
399 # if gold is used then bioses and grub doesn't build
400 install -d our-ld
401 ln -s /usr/bin/ld.bfd our-ld/ld
402 export PATH=$(pwd)/our-ld:$PATH
403
404 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
405 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
406
407 # NOTE:
408 # - there is a quoting bug (in tools/driver/Makefile) that causes
409 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
410 #   anyway (see configure), gcrypt is optional
411 # - prevent libiconv from being detected (not needed with glibc)
412 cd tools
413 %configure \
414         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
415         ac_cv_lib_iconv_libiconv_open=no \
416         --disable-debug
417 cd ..
418
419 %{__make} dist-xen dist-tools dist-docs \
420         %{!?with_ocaml:OCAML_TOOLS=n} \
421         prefix=%{_prefix} \
422         CC="%{__cc}" \
423         CXX="%{__cxx}" \
424         V=1
425
426 unset CFLAGS
427 unset CXXFLAGS
428
429 %{__make} -j1 dist-stubdom \
430         %{!?with_ocaml:OCAML_TOOLS=n} \
431         CC="%{__cc}" \
432         CXX="%{__cxx}" \
433         V=1
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
438         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
439         $RPM_BUILD_ROOT/etc/efi-boot/update.d
440
441 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
442         %{!?with_ocaml:OCAML_TOOLS=n} \
443         prefix=%{_prefix} \
444         DESTDIR=$RPM_BUILD_ROOT \
445         HOTPLUGS=install-udev
446
447 %if "%{_lib}" == "lib64"
448 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
449 %endif
450
451 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
452 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
453 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
454 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
455 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
456 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
457 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
458 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
459 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
460 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
461 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
462 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
463 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
464 install %{SOURCE43} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xendomains.sh
465 install %{SOURCE44} $RPM_BUILD_ROOT%{systemdunitdir}/xendomains.service
466 # sysvinit scripts
467 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
468 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
469 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
470 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
471 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
472 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
473 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
474 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
475
476 install %{SOURCE60} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xen-init-list
477 install %{SOURCE61} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xen-toolstack
478
479 %if %{with efi}
480 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
481 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
482                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
483 %endif
484
485 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
486
487 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
488
489 # for %%doc
490 install -d _doc
491 for tool in blktap blktap2 pygrub xenmon ; do
492         cp -p tools/$tool/README _doc/README.$tool
493 done
494 cp -al tools/qemu-xen/docs _doc/qemu-xen
495
496 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
497 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
498
499 %py_postclean
500
501 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
502 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
503 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
504 # seems not needed, the path is wrong anyway
505 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
506
507 # remove unneeded files
508 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
509 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
510 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
511 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
512 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
513
514 %clean
515 rm -rf $RPM_BUILD_ROOT
516
517 %post
518 /sbin/chkconfig --add xen-watchdog
519 /sbin/chkconfig --add xenconsoled
520 /sbin/chkconfig --add xenstored
521 /sbin/chkconfig --add xendomains
522 NORESTART=1
523 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service
524
525 %preun
526 if [ "$1" = "0" ]; then
527         %service xendomains stop
528         /sbin/chkconfig --del xendomains
529
530         %service xenconsoled stop
531         /sbin/chkconfig --del xenconsoled
532
533         %service xenstored stop
534         /sbin/chkconfig --del xenstored
535
536         %service xen-watchdog stop
537         /sbin/chkconfig --del xen-watchdog
538 fi
539 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service
540
541 %postun
542 %systemd_reload
543
544 %post xend
545 /sbin/chkconfig --add xend
546 %systemd_post xend.service
547
548 %preun xend
549 if [ "$1" = "0" ]; then
550         %service xend stop
551         /sbin/chkconfig --del xend
552 fi
553 %systemd_preun xend.service
554
555 %postun xend
556 %systemd_reload
557
558 %post   libs -p /sbin/ldconfig
559 %postun libs -p /sbin/ldconfig
560
561 %post   libs-guest -p /sbin/ldconfig
562 %postun libs-guest -p /sbin/ldconfig
563
564 %post efi
565 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
566
567 %files
568 %defattr(644,root,root,755)
569 %doc COPYING README* docs/misc/*
570 %doc docs/html/*
571 %doc tools/qemu-xen-dir/*.html
572 %doc _doc/*
573 /boot/%{name}-syms-%{version}
574 /boot/%{name}-%{version}.gz
575 /boot/%{name}.gz
576 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
578 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
579 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
581 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
582 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
583 %attr(754,root,root) /etc/rc.d/init.d/xenstored
584 %attr(754,root,root) /etc/rc.d/init.d/xendomains
585 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
586 %{systemdunitdir}/proc-xen.mount
587 %{systemdunitdir}/var-lib-xenstored.mount
588 %{systemdunitdir}/xen-watchdog.service
589 %{systemdunitdir}/xenconsoled.service
590 %{systemdunitdir}/xenstored.service
591 %{systemdunitdir}/xendomains.service
592 %dir %{_sysconfdir}/xen
593 %dir %{_sysconfdir}/xen/auto
594 %dir %{_sysconfdir}/xen/examples
595 %dir %{_sysconfdir}/xen/scripts
596 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
598 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
599 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
600 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
601 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
602 %attr(755,root,root) %{_bindir}/pygrub
603 %attr(755,root,root) %{_bindir}/qemu-img-xen
604 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
605 %attr(755,root,root) %{_bindir}/remus
606 %attr(755,root,root) %{_bindir}/xencons
607 %attr(755,root,root) %{_bindir}/xentrace*
608 %attr(755,root,root) %{_sbindir}/blktapctrl
609 %attr(755,root,root) %{_sbindir}/flask-*
610 %attr(755,root,root) %{_sbindir}/gdbsx
611 %attr(755,root,root) %{_sbindir}/gtrace*
612 %attr(755,root,root) %{_sbindir}/img2qcow
613 %attr(755,root,root) %{_sbindir}/kdd
614 %attr(755,root,root) %{_sbindir}/lock-util
615 %attr(755,root,root) %{_sbindir}/qcow-create
616 %attr(755,root,root) %{_sbindir}/qcow2raw
617 %attr(755,root,root) %{_sbindir}/tap-ctl
618 %attr(755,root,root) %{_sbindir}/tapdisk*
619 %attr(755,root,root) %{_sbindir}/td-util
620 %attr(755,root,root) %{_sbindir}/vhd-*
621 %attr(755,root,root) %{_sbindir}/xen-*
622 %attr(755,root,root) %{_sbindir}/xenbaked
623 %attr(755,root,root) %{_sbindir}/xenconsoled
624 %attr(755,root,root) %{_sbindir}/xenlockprof
625 %attr(755,root,root) %{_sbindir}/xenmon.py
626 %attr(755,root,root) %{_sbindir}/xenperf
627 %attr(755,root,root) %{_sbindir}/xenpm
628 %attr(755,root,root) %{_sbindir}/xenpmd
629 %attr(755,root,root) %{_sbindir}/xenstored
630 %attr(755,root,root) %{_sbindir}/xentop
631 %attr(755,root,root) %{_sbindir}/xentrace_setmask
632 %attr(755,root,root) %{_sbindir}/xenwatchdogd
633 %attr(755,root,root) %{_sbindir}/xl
634 %attr(755,root,root) %{_sbindir}/xsview
635 %dir %{_libdir}/%{name}
636 %dir %{_libdir}/%{name}/bin
637 %attr(744,root,root) %{_libdir}/%{name}/bin/*
638 %if "%{_lib}" != "lib"
639 %dir %{_prefix}/lib/%{name}
640 %dir %{_prefix}/lib/%{name}/bin
641 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/*
642 %endif
643 %dir %{_prefix}/lib/%{name}/boot
644 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
645 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
646 %ifarch %{x8664}
647 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
648 %endif
649 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
650 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
651 %{_datadir}/xen
652 %{_mandir}/man1/qemu-img-xen.1*
653 %{_mandir}/man1/xentop.1*
654 %{_mandir}/man1/xentrace_format.1*
655 %{_mandir}/man1/xl.1*
656 %{_mandir}/man1/xm.1*
657 %{_mandir}/man5/xend-config.sxp.5*
658 %{_mandir}/man5/xl.cfg.5*
659 %{_mandir}/man5/xl.conf.5*
660 %{_mandir}/man5/xlcpupool.cfg.5*
661 %{_mandir}/man5/xmdomain.cfg.5*
662 %{_mandir}/man8/qemu-nbd-xen.8*
663 %{_mandir}/man8/xentrace.8*
664 %{_sharedstatedir}/xen
665 %{_sharedstatedir}/xenstored
666 %dir /var/run/xenstored
667 %{systemdtmpfilesdir}/xenstored.conf
668 %{systemdtmpfilesdir}/xen.conf
669 %dir %attr(0700,root,root) /var/log/xen
670 %dir %attr(0700,root,root) /var/log/xen/console
671 %{_datadir}/qemu-xen
672
673 %files guest
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/xen-detect
676 %attr(755,root,root) %{_bindir}/xenstore*
677
678 %files libs
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
681 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
682 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
683 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
684 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
685 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
686 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
687 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
688 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
689 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
690 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
691 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
692 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
693 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
694 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
695 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
696 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
697 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
698 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
699 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
700 %dir %{_libdir}/fs
701 %dir %{_libdir}/fs/ext2fs-lib
702 %dir %{_libdir}/fs/fat
703 %dir %{_libdir}/fs/iso9660
704 %dir %{_libdir}/fs/reiserfs
705 %dir %{_libdir}/fs/ufs
706 %dir %{_libdir}/fs/xfs
707 %dir %{_libdir}/fs/zfs
708 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
709
710 %files libs-guest
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
714
715 %files devel
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/libblktap.so
718 %attr(755,root,root) %{_libdir}/libblktapctl.so
719 %attr(755,root,root) %{_libdir}/libfsimage.so
720 %attr(755,root,root) %{_libdir}/libvhd.so
721 %attr(755,root,root) %{_libdir}/libxenctrl.so
722 %attr(755,root,root) %{_libdir}/libxenguest.so
723 %attr(755,root,root) %{_libdir}/libxenlight.so
724 %attr(755,root,root) %{_libdir}/libxenstat.so
725 %attr(755,root,root) %{_libdir}/libxenstore.so
726 %attr(755,root,root) %{_libdir}/libxenvchan.so
727 %attr(755,root,root) %{_libdir}/libxlutil.so
728 %{_includedir}/_libxl_list.h
729 %{_includedir}/_libxl_types.h
730 %{_includedir}/_libxl_types_json.h
731 %{_includedir}/blktaplib.h
732 %{_includedir}/fsimage*.h
733 %{_includedir}/libxenvchan.h
734 %{_includedir}/libxl*.h
735 %{_includedir}/xen*.h
736 %{_includedir}/xs*.h
737 %{_includedir}/xen
738 %{_includedir}/xenstore-compat
739
740 %files static
741 %defattr(644,root,root,755)
742 %{_libdir}/libblktap.a
743 %{_libdir}/libblktapctl.a
744 %{_libdir}/libvhd.a
745 %{_libdir}/libxenctrl.a
746 %{_libdir}/libxenguest.a
747 %{_libdir}/libxenlight.a
748 %{_libdir}/libxenvchan.a
749 %{_libdir}/libxenstat.a
750 %{_libdir}/libxenstore.a
751 %{_libdir}/libxlutil.a
752
753 %files xend
754 %defattr(644,root,root,755)
755 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
756 %{systemdunitdir}/blktapctrl.service
757 %{systemdunitdir}/xend.service
758 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
759 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
760 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
761 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
762 %attr(755,root,root) %{_sbindir}/xend
763 %attr(755,root,root) %{_sbindir}/xm
764 %dir %attr(700,root,root) /var/run/xend
765 %{systemdtmpfilesdir}/xend.conf
766
767 %if %{with ocaml}
768 %files -n ocaml-xen
769 %defattr(644,root,root,755)
770 %doc tools/ocaml/LICENSE
771 %attr(755,root,root) %{_sbindir}/oxenstored
772 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
773 %dir %{_libdir}/ocaml/site-lib/xenbus
774 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
775 %dir %{_libdir}/ocaml/site-lib/xenctrl
776 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
777 %dir %{_libdir}/ocaml/site-lib/xeneventchn
778 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
779 %dir %{_libdir}/ocaml/site-lib/xenlight
780 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
781 %dir %{_libdir}/ocaml/site-lib/xenmmap
782 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
783
784 %files -n ocaml-xen-devel
785 %defattr(644,root,root,755)
786 %{_libdir}/ocaml/site-lib/xenbus/META
787 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
788 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
789 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
790 %{_libdir}/ocaml/site-lib/xenctrl/META
791 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
792 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
793 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
794 %{_libdir}/ocaml/site-lib/xeneventchn/META
795 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
796 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
797 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
798 %{_libdir}/ocaml/site-lib/xenmmap/META
799 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
800 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
801 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
802 %{_libdir}/ocaml/site-lib/xenlight/META
803 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
804 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
805 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
806 %dir %{_libdir}/ocaml/site-lib/xenstore
807 %{_libdir}/ocaml/site-lib/xenstore/META
808 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
809 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
810 %endif
811
812 %files -n python-xen
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{py_sitedir}/fsimage.so
815 %{py_sitedir}/grub
816 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
817 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
818 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
819 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
820 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
821 %{py_sitedir}/xen/remus
822 %{py_sitedir}/xen/sv
823 %{py_sitedir}/xen/util
824 %{py_sitedir}/xen/web
825 %{py_sitedir}/xen/xend
826 %{py_sitedir}/xen/xm
827 %{py_sitedir}/xen/xsview
828 %if "%{py_ver}" > "2.4"
829 %{py_sitedir}/pygrub-0.3-py*.egg-info
830 %{py_sitedir}/xen-3.0-py*.egg-info
831 %endif
832
833 %files -n python-xen-guest
834 %defattr(644,root,root,755)
835 %dir %{py_sitedir}/xen
836 %{py_sitedir}/xen/__init__.py*
837 %dir %{py_sitedir}/xen/lowlevel
838 %{py_sitedir}/xen/lowlevel/__init__.py*
839 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
840
841 %files -n bash-completion-%{name}
842 %defattr(644,root,root,755)
843 /etc/bash_completion.d/xl.sh
844
845 %if %{with efi}
846 %files efi
847 %defattr(644,root,root,755)
848 %dir %{_libdir}/efi
849 %{_libdir}/efi/*.efi
850 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
851 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
852 %endif
This page took 0.101203 seconds and 4 git commands to generate.