]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- BR: acpica
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - most of the qemu config options aren't detected (curses, NPTL, vde, fdt)
4 #  - package the ocaml stuff
5 #
6 # Conditional build:
7 %bcond_without  hvm             # build with hvm (full virtualization) support
8
9 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
10 Summary:        Xen - a virtual machine monitor
11 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
12 Name:           xen
13 Version:        4.1.2
14 Release:        0.1
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  73561faf3c1b5e36ec5c089b5db848ad
19 # used by stubdoms
20 Source10: %{xen_extfiles_url}/lwip-1.3.0.tar.gz
21 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
22 Source11: %{xen_extfiles_url}/newlib-1.16.0.tar.gz
23 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
24 Source12: %{xen_extfiles_url}/zlib-1.2.3.tar.gz
25 # Source12-md5: debc62758716a169df9f62e6ab2bc634
26 Source13: %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
27 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
28 Source14: %{xen_extfiles_url}/grub-0.97.tar.gz
29 # Source14-md5: cd3f3eb54446be6003156158d51f4884
30 Source15: %{xen_extfiles_url}/ipxe-git-v1.0.0.tar.gz
31 # Source15-md5: fb7df96781d337899066d82059346885
32 Patch0:         %{name}-python_scripts.patch
33 Patch1:         %{name}-symbols.patch
34 Patch2:         %{name}-curses.patch
35 Patch3:         %{name}-gcc.patch
36 Patch4:         %{name}-xz.patch
37 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
38 BuildRequires:  SDL-devel
39 BuildRequires:  acpica
40 %{?with_hvm:BuildRequires:      bcc}
41 BuildRequires:  curl-devel
42 BuildRequires:  e2fsprogs-devel
43 BuildRequires:  gcc >= 5:3.4
44 BuildRequires:  gettext-devel
45 BuildRequires:  latex2html
46 BuildRequires:  libidn-devel
47 BuildRequires:  ncurses-devel
48 BuildRequires:  pciutils-devel
49 BuildRequires:  pkgconfig
50 BuildRequires:  python-devel
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.268
53 #BuildRequires: texlive-dvips
54 #BuildRequires: texlive-latex-data
55 BuildRequires:  texlive-latex-psnfss
56 BuildRequires:  transfig
57 BuildRequires:  which
58 BuildRequires:  zlib-devel
59 Requires(post,preun):   /sbin/chkconfig
60 Requires:       %{name}-libs = %{version}-%{release}
61 Requires:       ZopeInterface
62 Requires:       bridge-utils
63 Requires:       coreutils
64 Requires:       diffutils
65 Requires:       gawk
66 Requires:       iptables
67 Requires:       kernel(xen0)
68 Requires:       losetup
69 Requires:       net-tools
70 Requires:       python-%{name} = %{version}-%{release}
71 Requires:       rc-scripts
72 Requires:       sed
73 Requires:       util-linux
74 Requires:       which
75 Obsoletes:      xen-doc
76 ExclusiveArch:  %{ix86} %{x8664}
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 # some PPC/SPARC boot image in ELF format
80 %define         _noautostrip    .*%{_datadir}/xen/qemu/openbios-.*
81
82 %description
83 This package contains the Xen hypervisor and Xen tools, needed to run
84 virtual machines on x86 systems, together with the kernel-xen*
85 packages. Information on how to use Xen can be found at the Xen
86 project pages.
87
88 Virtualisation can be used to run multiple versions or multiple Linux
89 distributions on one system, or to test untrusted applications in a
90 sandboxed environment. Note that the Xen technology is still in
91 development, and this RPM has received extremely little testing. Don't
92 be surprised if this RPM eats your data, drinks your coffee or makes
93 fun of you in front of your friends.
94
95 %description -l pl.UTF-8
96 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
97 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
98 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
99 projektu.
100
101 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
102 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
103 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
104 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
105 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
106 się wyśmiewał w obecności przyjaciół.
107
108 %package libs
109 Summary:        xen libraries
110 Summary(pl.UTF-8):      Biblioteki xena
111 Group:          Libraries
112
113 %description libs
114 xen libraries.
115
116 %description libs -l pl.UTF-8
117 Biblioteki xena.
118
119 %package devel
120 Summary:        Header files for xen
121 Summary(pl.UTF-8):      Pliki nagłówkowe xena
122 Group:          Development/Libraries
123 Requires:       %{name}-libs = %{version}-%{release}
124
125 %description devel
126 Header files for xen.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe xena.
130
131 %package static
132 Summary:        Static xen libraries
133 Summary(pl.UTF-8):      Statyczne biblioteki xena
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136
137 %description static
138 Static xen libraries.
139
140 %description static -l pl.UTF-8
141 Statyczne biblioteki xena.
142
143 %package udev
144 Summary:        xen udev scripts
145 Summary(pl.UTF-8):      Skrypty udev dla xena
146 Group:          Applications/System
147
148 %description udev
149 xen udev scripts.
150
151 %description udev -l pl.UTF-8
152 Skrypty udev dla xena.
153
154 %package xend
155 Summary:        xend daemon
156 Summary(pl.UTF-8):      Demon xend
157 Group:          Daemons
158
159 %description xend
160 xend daemon.
161
162 %description xend -l pl.UTF-8
163 Demon xend.
164
165 %package -n python-xen
166 Summary:        xen Python modules
167 Summary(pl.UTF-8):      Moduły Pythona dla xena
168 Group:          Libraries
169 Conflicts:      xen < 3.2.1-0.3
170
171 %description -n python-xen
172 xen Python modules.
173
174 %description -n python-xen -l pl.UTF-8
175 Moduły Pythona dla xena.
176
177 %package -n bash-completion-%{name}
178 Summary:    bash-completion for xen
179 Group:      Applications/Shells
180 Requires:   %{name} = %{version}-%{release}
181 Requires:   bash-completion
182
183 %description -n bash-completion-%{name}
184 This package provides bash-completion for xen.
185
186 %prep
187 %setup -q
188 %patch0 -p1
189 %patch1 -p1
190 %patch2 -p1
191 #%%patch3 -p1
192 %patch4 -p1
193
194 %{__rm} -v tools/check/*.orig
195
196 # stubdom sources
197 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
198 ln -s %{PATCH23} stubdom/grub.patches/99grub-ext4-support.patch
199 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
200
201 %build
202 CFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
203 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
204 %{__make} -j1 xen tools \
205         CC="%{__cc}" \
206         CXX="%{__cxx}"
207
208 %install
209 rm -rf $RPM_BUILD_ROOT
210 install -d $RPM_BUILD_ROOT/etc/xen/examples
211
212 %{__make} install-xen install-tools install-stubdom install-docs \
213         CC="%{__cc}" \
214         CXX="%{__cxx}" \
215         DESTDIR=$RPM_BUILD_ROOT
216
217 mv $RPM_BUILD_ROOT/etc/xen/{xmexample*,examples}
218
219 cp -p tools/blktap/README{,.blktap}
220 cp -p tools/xenmon/README{,.xenmon}
221
222 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
223 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
224
225 %py_postclean
226
227 # remove unneeded files
228 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.1.gz
229 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
230 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
231 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
232
233 %clean
234 rm -rf $RPM_BUILD_ROOT
235
236 %post
237 /sbin/chkconfig --add xen-watchdog
238 /sbin/chkconfig --add xencommons
239 /sbin/chkconfig --add xendomains
240
241 %preun
242 if [ "$1" = "0" ]; then
243         %service xendomains stop
244         /sbin/chkconfig --del xendomains
245
246         %service xencommons stop
247         /sbin/chkconfig --del xencommons
248
249         %service xen-watchdog stop
250         /sbin/chkconfig --del xen-watchdog
251 fi
252
253 %post  xend
254 /sbin/chkconfig --add xend
255
256 %preun xend
257 if [ "$1" = "0" ]; then
258         %service xend stop
259         /sbin/chkconfig --del xend
260 fi
261
262 %post   libs -p /sbin/ldconfig
263 %postun libs -p /sbin/ldconfig
264
265 %files
266 %defattr(644,root,root,755)
267 %doc COPYING README* docs/misc/* 
268 %doc docs/html/*
269 %doc tools/blktap/README.blktap tools/xenmon/README.xenmon
270 %doc tools/ioemu-dir/*.html
271 /boot/%{name}-syms-%{version}
272 /boot/%{name}-%{version}.gz
273 /boot/%{name}.gz
274 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
275 %attr(754,root,root) /etc/rc.d/init.d/xencommons
276 %attr(754,root,root) /etc/rc.d/init.d/xendomains
277 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
278 %dir %{_sysconfdir}/xen
279 %dir %{_sysconfdir}/xen/auto
280 %dir %{_sysconfdir}/xen/examples
281 %dir %{_sysconfdir}/xen/scripts
282 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
283 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
284 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
285 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
286 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
287 %attr(755,root,root) %{_bindir}/*
288 %attr(755,root,root) %{_sbindir}/[bfgikloqtv]*
289 %attr(755,root,root) %{_sbindir}/xen??*
290 %attr(755,root,root) %{_sbindir}/xl
291 %attr(755,root,root) %{_sbindir}/xsview
292 %dir %{_libdir}/%{name}
293 %dir %{_libdir}/%{name}/bin
294 %attr(744,root,root) %{_libdir}/%{name}/bin/*
295 %if "%{_lib}" != "lib"
296 %dir %{_prefix}/lib/%{name}
297 %endif
298 %dir %{_prefix}/lib/%{name}/boot
299 %{?with_hvm:%attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader}
300 %{_datadir}/xen
301 %{_mandir}/man?/*
302 %{_sharedstatedir}/xen
303 %{_sharedstatedir}/xenstored
304 %dir /var/run/xenstored
305
306 %files libs
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_libdir}/lib*.so.*
309 %dir %{_libdir}/fs
310 %dir %{_libdir}/fs/ext2fs-lib
311 %dir %{_libdir}/fs/fat
312 %dir %{_libdir}/fs/iso9660
313 %dir %{_libdir}/fs/reiserfs
314 %dir %{_libdir}/fs/ufs
315 %dir %{_libdir}/fs/zfs
316 %attr(755,root,root) %{_libdir}/fs/*/*.so
317
318 %files devel
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_libdir}/lib*.so
321 %{_includedir}/*
322
323 %files static
324 %defattr(644,root,root,755)
325 %{_libdir}/lib*.a
326
327 %files udev
328 %defattr(644,root,root,755)
329 %config(noreplace) %verify(not md5 mtime size) /etc/udev/*
330
331 %files xend
332 %defattr(644,root,root,755)
333 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
334 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
335 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
336 %attr(755,root,root) %{_sbindir}/xend
337 %attr(755,root,root) %{_sbindir}/xm
338 %dir %attr(700,root,root) /var/run/xend
339
340 %files -n python-xen
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{py_sitedir}/fsimage.so
343 %{py_sitedir}/grub
344 %dir %{py_sitedir}/xen
345 %dir %{py_sitedir}/xen/lowlevel
346 %{py_sitedir}/xen/lowlevel/*.py*
347 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/*.so
348 %{py_sitedir}/xen/remus
349 %{py_sitedir}/xen/sv
350 %{py_sitedir}/xen/util
351 %{py_sitedir}/xen/web
352 %{py_sitedir}/xen/xend
353 %{py_sitedir}/xen/xm
354 %{py_sitedir}/xen/xsview
355 %{py_sitedir}/xen/*.py*
356 %if "%{py_ver}" > "2.4"
357 %{py_sitedir}/*.egg-info
358 %endif
359
360 %files -n bash-completion-%{name}
361 %defattr(644,root,root,755)
362 /etc/bash_completion.d/*
This page took 0.064938 seconds and 4 git commands to generate.