]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- BR: which Req: bridge-utils
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.6
8 Release:        0.3
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-%{version}-src.tgz
13 # Source0-md5:  fcb4ea295b1ecbf7890d48bf721896a8
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 Patch0:         %{name}-twisted.patch
17 Patch1:         %{name}-scripts.patch
18 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
19 Requires:       losetup
20 Requires:       python-TwistedWeb
21 Requires:       ZopeInterface
22 Requires:       bridge-utils
23 BuildRequires:  curl-devel
24 BuildRequires:  python-devel
25 BuildRequires:  python-Twisted
26 BuildRequires:  transfig
27 BuildRequires:  libidn-devel
28 BuildRequires:  zlib-devel
29 BuildRequires:  X11-devel
30 BuildRequires:  ncurses-devel
31 BuildRequires:  tetex-format-latex
32 BuildRequires:  tetex-latex-psnfss
33 BuildRequires:  tetex-dvips
34 BuildRequires:  which
35 ExclusiveArch:  %{ix86}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This package contains the Xen hypervisor and Xen tools, needed to run
40 virtual machines on x86 systems, together with the kernel-xen*
41 packages. Information on how to use Xen can be found at the Xen
42 project pages.
43
44 Virtualisation can be used to run multiple versions or multiple Linux
45 distributions on one system, or to test untrusted applications in a
46 sandboxed environment. Note that the Xen technology is still in
47 development, and this RPM has received extremely little testing. Don't
48 be surprised if this RPM eats your data, drinks your coffee or makes
49 fun of you in front of your friends.
50
51 %description -l pl
52 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
53 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
54 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
55 projektu.
56
57 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
58 dystrybucji Linuksa na jednym systemie lub do testowania nie
59 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
60 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
61 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
62 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
63
64 %package devel
65 Summary:        Header files for xen
66 Summary(pl):    Pliki nag³ówkowe xena
67 Group:          Development/Libraries
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69
70 %description devel
71 Header files for xen.
72
73 %description devel -l pl
74 Pliki nag³ówkowe xena.
75
76 %package static
77 Summary:        Static xen libraries
78 Summary(pl):    Statyczne biblioteki xena
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
81
82 %description static
83 Static xen libraries.
84
85 %description static -l pl
86 Statyczne biblioteki xena.
87
88 %package doc
89 Summary:        Xen documentation
90 Summary(pl):    Dokumentacja xena
91 Group:          Applications/System
92 Requires:       %{name} = %{epoch}:%{version}-%{release}
93
94 %description doc
95 Xen documentation.
96
97 %description doc -l pl
98 Dokumentacja xena.
99
100 %prep
101 %setup -q -n xen-2.0
102 %patch0 -p1 
103 %patch1 -p1
104 chmod -R u+w .
105 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
106
107 %build
108 CFLAGS="%{rpmcflags}" \
109 CXXFLAGS="%{rpmcflags}" \
110 %{__make} xen tools docs \
111         CC="%{__cc}" \
112         CXX="%{__cxx}"
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install-xen install-tools install-docs \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
121 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
122 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
123
124 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
125
126 #install -d $RPM_BUILD_ROOT%{_mandir}
127 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
128
129 #install -d doc-html-install/{interface,user}
130 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
131 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
132
133 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
134
135 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
136 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
137 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
138
139 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
140 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
141
142 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen
143 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/{sv,xend-db}
144 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/xend-db/{domain,vnet,migrate}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/ldconfig
151 /sbin/chkconfig --add xend
152 /sbin/chkconfig --add xendomains
153
154 %postun -p /sbin/ldconfig
155
156 %preun
157 if [ "$1" = "0" ]; then
158 #       if [ -f /var/lock/subsys/xend ]; then
159 #               /etc/rc.d/init.d/xend stop 1>&2
160 #       fi
161         /sbin/chkconfig --del xend
162 #       if [ -f /var/lock/subsys/xendomains ]; then
163 #               /etc/rc.d/init.d/xendomains stop 1>&2
164 #       fi
165         /sbin/chkconfig --del xendomains
166 fi
167
168 %files
169 %defattr(644,root,root,755)
170 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
171 %doc COPYING ChangeLog README docs/misc/*
172 /boot/%{name}-%{version}-syms
173 /boot/%{name}-%{version}.gz
174 /boot/%{name}.gz
175 %attr(754,root,root) /etc/rc.d/init.d/*
176 %dir %{_sysconfdir}/xen
177 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
178 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
179 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
180 %dir %{_sysconfdir}/xen/auto
181 %dir %{_sysconfdir}/xen/scripts
182 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
183 %attr(755,root,root) %{_bindir}/*
184 %attr(755,root,root) %{_sbindir}/*
185 %attr(755,root,root) %{_libdir}/lib*.so.*
186 %{_libdir}/python/%{name}
187 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
188 %{_mandir}/man?/*
189 %dir %{_sharedstatedir}/xen
190 %dir %{_sharedstatedir}/xen/sv
191 %dir %{_sharedstatedir}/xen/xend-db
192 %dir %{_sharedstatedir}/xen/xend-db/domain
193 %dir %{_sharedstatedir}/xen/xend-db/vnet
194 %dir %{_sharedstatedir}/xen/xend-db/migrate
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/lib*.so
199 %{_includedir}/*
200
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/lib*.a
204
205 %files doc
206 %defattr(644,root,root,755)
207 %dir %{_datadir}/xen
208 %{_datadir}/xen/*.pdf
This page took 0.082675 seconds and 4 git commands to generate.