]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
Block downloads during the build
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 # Conditional build:
13 %bcond_without  opengl          # OpenGL support in Xen qemu
14 %bcond_without  sdl             # SDL support in Xen qemu
15 %bcond_without  bluetooth       # bluetooth support in Xen qemu
16 %bcond_without  brlapi          # brlapi support in Xen qemu
17 %bcond_without  ocaml           # Ocaml libraries for Xen tools
18 %bcond_without  efi             # EFI hypervisor
19 %bcond_without  hypervisor      # Xen hypervisor build
20 %bcond_without  stubdom         # stubdom build
21
22 %ifnarch %{x8664} arm
23 %undefine       with_hypervisor
24 %endif
25 %ifnarch %{x8664}
26 %undefine       with_efi
27 %endif
28 %ifnarch %{ix86} %{x8664}
29 %undefine       with_stubdom
30 %endif
31
32 # from Config.mk:
33 %define seabios_version         1.6.3.2
34
35 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
36 Summary:        Xen - a virtual machine monitor
37 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
38 Name:           xen
39 Version:        4.3.0
40 Release:        2
41 License:        GPL v2, interface parts on BSD-like
42 Group:          Applications/System
43 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
44 # Source0-md5:  7b18cfb58f1ac2ce39cf35a1867f0c0a
45 # used by stubdoms
46 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
47 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
48 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
49 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
50 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
51 # Source12-md5: debc62758716a169df9f62e6ab2bc634
52 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
53 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
54 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
55 # Source14-md5: cd3f3eb54446be6003156158d51f4884
56 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
57 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
58 # http://xenbits.xen.org/git-http/seabios.git/
59 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
60 Source16:       seabios-%{seabios_version}.tar.xz
61 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
62 Source30:       proc-xen.mount
63 Source31:       var-lib-xenstored.mount
64 Source32:       blktapctrl.service
65 Source33:       blktapctrl.sysconfig
66 Source34:       xenconsoled.service
67 Source35:       xenconsoled.sysconfig
68 Source36:       xenstored.service
69 Source37:       xenstored.sysconfig
70 Source38:       xenstored.tmpfiles
71 Source39:       xend.service
72 Source40:       xend.tmpfiles
73 Source41:       xen-watchdog.service
74 Source42:       xen-dom0-modules-load.conf
75 Source43:       xendomains.sh
76 Source44:       xendomains.service
77 # sysvinit scripts
78 Source50:       xend.init
79 Source51:       xenconsoled.init
80 Source52:       xenstored.init
81 Source53:       xen-watchdog.init
82 Source54:       xendomains.init
83 Source55:       xen.logrotate
84 Source56:       xen.tmpfiles
85 Source57:       xen.cfg
86 Source58:       xen.efi-boot-update
87 Source59:       vif-openvswitch
88 Source60:       xen-init-list
89 Source61:       xen-toolstack
90 Patch0:         %{name}-python_scripts.patch
91 Patch1:         %{name}-symbols.patch
92 Patch2:         %{name}-curses.patch
93 Patch3:         pygrubfix.patch
94 Patch4:         xend.catchbt.patch
95 Patch5:         xend-pci-loop.patch
96 Patch6:         %{name}-dumpdir.patch
97 # Warning: this disables ingress filtering implemented in xen scripts!
98 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
99 Patch8:         %{name}-configure-xend.patch
100 Patch9:         %{name}-initscript.patch
101 Patch10:        %{name}-qemu.patch
102 Patch11:        %{name}-ulong.patch
103 Patch12:        %{name}-doc.patch
104 Patch13:        %{name}-paths.patch
105 Patch14:        %{name}-no_fetcher.patch
106 URL:            http://www.xen.org/products/xenhyp.html
107 %{?with_opengl:BuildRequires:   OpenGL-devel}
108 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
109 %ifarch %{ix86} %{x8664}
110 BuildRequires:  acpica
111 BuildRequires:  autoconf
112 BuildRequires:  bcc
113 BuildRequires:  bin86
114 %endif
115 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
116 %{?with_brlapi:BuildRequires:   brlapi-devel}
117 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
118 BuildRequires:  bzip2-devel
119 BuildRequires:  ceph-devel
120 BuildRequires:  curl-devel
121 BuildRequires:  cyrus-sasl-devel >= 2
122 BuildRequires:  e2fsprogs-devel
123 BuildRequires:  gcc >= 6:4.1
124 BuildRequires:  gettext-devel
125 BuildRequires:  glib2-devel >= 1:2.12
126 BuildRequires:  glusterfs-devel >= 3.4
127 BuildRequires:  gnutls-devel
128 BuildRequires:  latex2html >= 2008
129 BuildRequires:  libaio-devel
130 BuildRequires:  libcap-devel
131 BuildRequires:  libcap-ng-devel
132 BuildRequires:  libiscsi-devel
133 BuildRequires:  libjpeg-devel
134 BuildRequires:  libpng-devel
135 BuildRequires:  libseccomp-devel >= 1.0.0
136 BuildRequires:  libuuid-devel
137 BuildRequires:  lzo-devel >= 2
138 BuildRequires:  ncurses-devel
139 %if %{with ocaml}
140 BuildRequires:  ocaml >= 3.04-7
141 BuildRequires:  ocaml-findlib
142 %endif
143 BuildRequires:  nss-devel >= 3.12.8
144 BuildRequires:  openssl-devel
145 BuildRequires:  pciutils-devel
146 BuildRequires:  perl-base
147 BuildRequires:  perl-tools-pod
148 BuildRequires:  pixman-devel
149 BuildRequires:  pkgconfig
150 BuildRequires:  python-devel
151 BuildRequires:  rpm-pythonprov
152 BuildRequires:  rpmbuild(macros) >= 1.647
153 BuildRequires:  spice-protocol >= 0.12.2
154 BuildRequires:  spice-server-devel >= 0.12.0
155 BuildRequires:  texi2html
156 BuildRequires:  texlive-dvips
157 BuildRequires:  texlive-latex-psnfss
158 BuildRequires:  texlive-xetex
159 BuildRequires:  transfig
160 BuildRequires:  usbredir-devel >= 0.5.3
161 BuildRequires:  vde2-devel
162 BuildRequires:  which
163 # for xfsctl (<xfs/xfs.h>)
164 BuildRequires:  xfsprogs-devel
165 BuildRequires:  xorg-lib-libX11-devel
166 BuildRequires:  xorg-lib-libXext-devel
167 BuildRequires:  xz-devel
168 BuildRequires:  yajl-devel
169 BuildRequires:  zlib-devel
170 # FIXME: see qemu configure comments on top of spec
171 %{!?with_opengl:BuildConflicts: OpenGL-devel}
172 %{!?with_sdl:BuildConflicts:    SDL-devel}
173 %{!?with_sdl:BuildConflicts:    SDL-devel}
174 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
175 %{!?with_brlapi:BuildConflicts: brlapi-devel}
176 Requires(post,preun):   /sbin/chkconfig
177 Requires(post,preun,postun):    systemd-units >= 38
178 Requires:       %{name}-libs = %{version}-%{release}
179 Requires:       ZopeInterface
180 Requires:       bridge-utils
181 Requires:       coreutils
182 Requires:       diffutils
183 Requires:       gawk
184 Requires:       iptables
185 Requires:       losetup
186 Requires:       net-tools
187 Requires:       python-%{name} = %{version}-%{release}
188 Requires:       rc-scripts
189 Requires:       sed
190 Requires:       systemd-units >= 38
191 Requires:       util-linux
192 Requires:       which
193 Requires:       %{name}-guest = %{version}-%{release}
194 Obsoletes:      xen-doc
195 Obsoletes:      xen-udev
196 ExclusiveArch:  %{ix86} %{x8664} arm
197 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
198
199 # some PPC/SPARC boot images in ELF format
200 %define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\)
201
202 %description
203 This package contains the Xen hypervisor and Xen tools, needed to run
204 virtual machines on x86 systems, together with the kernel-xen*
205 packages. Information on how to use Xen can be found at the Xen
206 project pages.
207
208 Virtualisation can be used to run multiple versions or multiple Linux
209 distributions on one system, or to test untrusted applications in a
210 sandboxed environment. Note that the Xen technology is still in
211 development, and this RPM has received extremely little testing. Don't
212 be surprised if this RPM eats your data, drinks your coffee or makes
213 fun of you in front of your friends.
214
215 %description -l pl.UTF-8
216 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
217 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
218 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
219 projektu.
220
221 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
222 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
223 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
224 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
225 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
226 się wyśmiewał w obecności przyjaciół.
227
228 %package guest
229 Summary:        Xen tools for virtual machines
230 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
231 Group:          Applications/System
232 Requires:       %{name}-libs-guest = %{version}-%{release}
233
234 %description guest
235 Xen utilities for both dom0 and domU virtual domains.
236
237 %description guest -l pl.UTF-8
238 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
239
240 %package libs
241 Summary:        Xen libraries
242 Summary(pl.UTF-8):      Biblioteki Xena
243 Group:          Libraries
244 Requires:       %{name}-libs-guest = %{version}-%{release}
245
246 %description libs
247 Xen libraries.
248
249 %description libs -l pl.UTF-8
250 Biblioteki Xena.
251
252 %package libs-guest
253 Summary:        Xen libraries for virtual machines
254 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
255 Group:          Libraries
256
257 %description libs-guest
258 Xen libraries for both dom0 and domU virtual machines.
259
260 %description libs-guest -l pl.UTF-8
261 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
262
263 %package devel
264 Summary:        Header files for Xen
265 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
266 Group:          Development/Libraries
267 Requires:       %{name}-libs = %{version}-%{release}
268
269 %description devel
270 Header files for Xen.
271
272 %description devel -l pl.UTF-8
273 Pliki nagłówkowe Xena.
274
275 %package static
276 Summary:        Static Xen libraries
277 Summary(pl.UTF-8):      Statyczne biblioteki Xena
278 Group:          Development/Libraries
279 Requires:       %{name}-devel = %{version}-%{release}
280
281 %description static
282 Static Xen libraries.
283
284 %description static -l pl.UTF-8
285 Statyczne biblioteki Xena.
286
287 %package xend
288 Summary:        xend daemon
289 Summary(pl.UTF-8):      Demon xend
290 Group:          Daemons
291 Requires(post,preun,postun):    systemd-units >= 38
292 Requires:       systemd-units >= 38
293
294 %description xend
295 xend daemon.
296
297 %description xend -l pl.UTF-8
298 Demon xend.
299
300 %package -n ocaml-xen
301 Summary:        OCaml bindings for Xen
302 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
303 License:        LGPL v2.1 with linking exception
304 Group:          Libraries
305 Requires:       %{name}-libs = %{version}-%{release}
306 %if %{with ocaml}
307 %requires_eq    ocaml-runtime
308 %endif
309
310 %description -n ocaml-xen
311 OCaml bindings for Xen.
312
313 %description -n ocaml-xen -l pl.UTF-8
314 Wiązania OCamla dla Xena.
315
316 %package -n ocaml-xen-devel
317 Summary:        OCaml bindings for Xen - development files
318 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
319 License:        LGPL v2.1 with linking exception
320 Group:          Development/Libraries
321 Requires:       ocaml-xen = %{version}-%{release}
322 %if %{with ocaml}
323 %requires_eq    ocaml
324 %endif
325
326 %description -n ocaml-xen-devel
327 OCaml bindings for Xen - development files.
328
329 %description -n ocaml-xen-devel -l pl.UTF-8
330 Wiązania OCamla dla Xena - pliki programistyczne.
331
332 %package -n python-xen
333 Summary:        Xen Python modules
334 Summary(pl.UTF-8):      Moduły Pythona dla Xena
335 Group:          Libraries
336 Requires:       %{name}-libs = %{version}-%{release}
337 Conflicts:      xen < 3.2.1-0.3
338
339 %description -n python-xen
340 Xen Python modules.
341
342 %description -n python-xen -l pl.UTF-8
343 Moduły Pythona dla Xena.
344
345 %package -n python-xen-guest
346 Summary:        Xen Python modules for virtual machines
347 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
348 Group:          Libraries
349 Requires:       %{name}-libs-guest = %{version}-%{release}
350 Conflicts:      xen < 3.2.1-0.3
351
352 %description -n python-xen-guest
353 Xen Python modules for both dom0 and domU virtual machines.
354
355 %description -n python-xen-guest -l pl.UTF-8
356 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
357
358 %package -n bash-completion-%{name}
359 Summary:    bash-completion for Xen (xl)
360 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
361 Group:      Applications/Shells
362 Requires:   %{name} = %{version}-%{release}
363 Requires:   bash-completion
364
365 %description -n bash-completion-%{name}
366 This package provides bash-completion for Xen (xl).
367
368 %description -n bash-completion-%{name} -l pl.UTF-8
369 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
370
371 %package efi
372 Summary:        Xen hypervisor binary for EFI
373 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
374 Group:          Applications/System
375 Requires:       %{name}-libs-guest = %{version}-%{release}
376
377 %description efi
378 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
379 firmware without help from any additional bootloader.
380
381 %description efi -l pl.UTF-8
382 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
383 (U)EFI, bez potrzeby oddzielnego bootloadera.
384
385 %prep
386 %setup -q -a 16
387 %patch0 -p1
388 %patch1 -p1
389 %patch2 -p1
390 %patch3 -p1
391 %patch4 -p1
392 %patch5 -p1
393 %patch6 -p1
394 %patch7 -p1
395 %patch8 -p1
396 %patch9 -p1
397 %patch10 -p1
398 %patch11 -p1
399 %patch12 -p1
400 %patch13 -p1
401 %patch14 -p1
402
403 # stubdom sources
404 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
405 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
406
407 # do not allow fetching anything via git
408 echo GIT=/bin/false >> Config.mk
409
410 %build
411 # based on the 'autoconf.sh' from the sources
412 %{__autoconf}
413 cd tools
414 %{__autoconf}
415 %{__autoheader}
416 cd ../stubdom
417 %{__autoconf}
418 cd ../docs
419 %{__autoconf}
420 cd ..
421
422 # if gold is used then bioses and grub doesn't build
423 install -d our-ld
424 ln -s /usr/bin/ld.bfd our-ld/ld
425 export PATH=$(pwd)/our-ld:$PATH
426
427 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
428 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
429
430 # NOTE:
431 # - there is a quoting bug (in tools/driver/Makefile) that causes
432 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
433 #   anyway (see configure), gcrypt is optional
434 # - prevent libiconv from being detected (not needed with glibc)
435 %configure \
436         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
437         ac_cv_lib_iconv_libiconv_open=no \
438         --disable-debug
439
440 %{__make} dist-xen dist-tools dist-docs \
441         %{!?with_ocaml:OCAML_TOOLS=n} \
442         CC="%{__cc}" \
443         CXX="%{__cxx}" \
444         V=1
445
446 unset CFLAGS
447 unset CXXFLAGS
448
449 %if %{with stubdom}
450 %{__make} -j1 dist-stubdom \
451         %{!?with_ocaml:OCAML_TOOLS=n} \
452         CC="%{__cc}" \
453         CXX="%{__cxx}" \
454         V=1
455 %endif
456
457 %install
458 rm -rf $RPM_BUILD_ROOT
459 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
460         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
461
462 %if %{with efi}
463 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
464 %endif
465
466 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
467         %{!?with_ocaml:OCAML_TOOLS=n} \
468         DESTDIR=$RPM_BUILD_ROOT \
469         HOTPLUGS=install-udev
470
471 %if "%{_lib}" == "lib64"
472 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
473 %endif
474
475 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
476 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
477 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
478 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
479 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
480 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
481 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
482 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
483 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
484 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
485 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
486 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
487 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
488 install %{SOURCE43} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xendomains.sh
489 install %{SOURCE44} $RPM_BUILD_ROOT%{systemdunitdir}/xendomains.service
490 # sysvinit scripts
491 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
492 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
493 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
494 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
495 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
496 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
497 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
498 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
499 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
500
501 install %{SOURCE60} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xen-init-list
502 install %{SOURCE61} $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/bin/xen-toolstack
503
504 %if %{with efi}
505 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
506 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
507                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
508 %endif
509
510 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
511
512 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
513
514 # for %%doc
515 install -d _doc
516 for tool in blktap blktap2 pygrub xenmon ; do
517         cp -p tools/$tool/README _doc/README.$tool
518 done
519 cp -al tools/qemu-xen/docs _doc/qemu-xen
520
521 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
522 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
523
524 %py_postclean
525
526 # seems not needed, the path is wrong anyway
527 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
528
529 # remove unneeded files
530 %if %{with hypervisor}
531 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.3.gz
532 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
533 %endif
534 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
535 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
536
537 %clean
538 rm -rf $RPM_BUILD_ROOT
539
540 %post
541 /sbin/chkconfig --add xen-watchdog
542 /sbin/chkconfig --add xenconsoled
543 /sbin/chkconfig --add xenstored
544 /sbin/chkconfig --add xendomains
545 NORESTART=1
546 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service
547
548 %preun
549 if [ "$1" = "0" ]; then
550         %service xendomains stop
551         /sbin/chkconfig --del xendomains
552
553         %service xenconsoled stop
554         /sbin/chkconfig --del xenconsoled
555
556         %service xenstored stop
557         /sbin/chkconfig --del xenstored
558
559         %service xen-watchdog stop
560         /sbin/chkconfig --del xen-watchdog
561 fi
562 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service
563
564 %postun
565 %systemd_reload
566
567 %post xend
568 /sbin/chkconfig --add xend
569 %systemd_post xend.service
570
571 %preun xend
572 if [ "$1" = "0" ]; then
573         %service xend stop
574         /sbin/chkconfig --del xend
575 fi
576 %systemd_preun xend.service
577
578 %postun xend
579 %systemd_reload
580
581 %post   libs -p /sbin/ldconfig
582 %postun libs -p /sbin/ldconfig
583
584 %post   libs-guest -p /sbin/ldconfig
585 %postun libs-guest -p /sbin/ldconfig
586
587 %post efi
588 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
589
590 %files
591 %defattr(644,root,root,755)
592 %doc COPYING README* docs/misc/* docs/html/* _doc/*
593 %if %{with hypervisor}
594 /boot/%{name}-syms-%{version}
595 /boot/%{name}-%{version}.gz
596 /boot/%{name}.gz
597 %endif
598 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
599 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
600 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
601 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
602 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
603 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
604 %attr(754,root,root) /etc/rc.d/init.d/xenstored
605 %attr(754,root,root) /etc/rc.d/init.d/xendomains
606 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
607 %{systemdunitdir}/proc-xen.mount
608 %{systemdunitdir}/var-lib-xenstored.mount
609 %{systemdunitdir}/xen-watchdog.service
610 %{systemdunitdir}/xenconsoled.service
611 %{systemdunitdir}/xenstored.service
612 %{systemdunitdir}/xendomains.service
613 %dir %{_sysconfdir}/xen
614 %dir %{_sysconfdir}/xen/auto
615 %dir %{_sysconfdir}/xen/examples
616 %dir %{_sysconfdir}/xen/scripts
617 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
620 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
622 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
623 %attr(755,root,root) %{_bindir}/pygrub
624 %attr(755,root,root) %{_bindir}/qemu-img-xen
625 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
626 %attr(755,root,root) %{_bindir}/remus
627 %attr(755,root,root) %{_bindir}/xencons
628 %attr(755,root,root) %{_bindir}/xencov_split
629 %attr(755,root,root) %{_bindir}/xentrace*
630 %attr(755,root,root) %{_sbindir}/blktapctrl
631 %attr(755,root,root) %{_sbindir}/flask-*
632 %attr(755,root,root) %{_sbindir}/gdbsx
633 %attr(755,root,root) %{_sbindir}/gtrace*
634 %attr(755,root,root) %{_sbindir}/img2qcow
635 %attr(755,root,root) %{_sbindir}/kdd
636 %attr(755,root,root) %{_sbindir}/lock-util
637 %attr(755,root,root) %{_sbindir}/qcow-create
638 %attr(755,root,root) %{_sbindir}/qcow2raw
639 %attr(755,root,root) %{_sbindir}/tap-ctl
640 %attr(755,root,root) %{_sbindir}/tapdisk*
641 %attr(755,root,root) %{_sbindir}/td-util
642 %attr(755,root,root) %{_sbindir}/vhd-*
643 %attr(755,root,root) %{_sbindir}/xen-*
644 %attr(755,root,root) %{_sbindir}/xenbaked
645 %attr(755,root,root) %{_sbindir}/xenconsoled
646 %attr(755,root,root) %{_sbindir}/xencov
647 %attr(755,root,root) %{_sbindir}/xenlockprof
648 %attr(755,root,root) %{_sbindir}/xenmon.py
649 %attr(755,root,root) %{_sbindir}/xenperf
650 %attr(755,root,root) %{_sbindir}/xenpm
651 %attr(755,root,root) %{_sbindir}/xenpmd
652 %attr(755,root,root) %{_sbindir}/xenstored
653 %attr(755,root,root) %{_sbindir}/xentop
654 %attr(755,root,root) %{_sbindir}/xentrace_setmask
655 %attr(755,root,root) %{_sbindir}/xenwatchdogd
656 %attr(755,root,root) %{_sbindir}/xl
657 %attr(755,root,root) %{_sbindir}/xsview
658 %dir %{_libdir}/%{name}
659 %dir %{_libdir}/%{name}/bin
660 %attr(744,root,root) %{_libdir}/%{name}/bin/*
661 %if "%{_lib}" != "lib"
662 %dir %{_prefix}/lib/%{name}
663 %dir %{_prefix}/lib/%{name}/bin
664 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/*
665 %endif
666 %dir %{_prefix}/lib/%{name}/boot
667 %if %{with stubdom}
668 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
669 %ifarch %{ix86} %{x8664}
670 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
671 %endif
672 %ifarch %{x8664}
673 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
674 %endif
675 %{_prefix}/lib/%{name}/boot/vtpm-stubdom.gz
676 %{_prefix}/lib/%{name}/boot/vtpmmgr-stubdom.gz
677 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
678 %endif
679 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
680 %{_datadir}/xen
681 %{_mandir}/man1/xentop.1*
682 %{_mandir}/man1/xentrace_format.1*
683 %{_mandir}/man1/xl.1*
684 %{_mandir}/man1/xm.1*
685 %{_mandir}/man5/xend-config.sxp.5*
686 %{_mandir}/man5/xl.cfg.5*
687 %{_mandir}/man5/xl.conf.5*
688 %{_mandir}/man5/xlcpupool.cfg.5*
689 %{_mandir}/man5/xmdomain.cfg.5*
690 %{_mandir}/man8/xentrace.8*
691 %{_sharedstatedir}/xen
692 %{_sharedstatedir}/xenstored
693 %dir /var/run/xenstored
694 %{systemdtmpfilesdir}/xenstored.conf
695 %{systemdtmpfilesdir}/xen.conf
696 %dir %attr(0700,root,root) /var/log/xen
697 %dir %attr(0700,root,root) /var/log/xen/console
698 %{_datadir}/qemu-xen
699
700 %files guest
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_bindir}/xen-detect
703 %attr(755,root,root) %{_bindir}/xenstore*
704
705 %files libs
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
709 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
711 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
713 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
714 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
715 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.3
717 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
718 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.3
719 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.3
721 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
723 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
725 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.3
727 %dir %{_libdir}/fs
728 %dir %{_libdir}/fs/ext2fs-lib
729 %dir %{_libdir}/fs/fat
730 %dir %{_libdir}/fs/iso9660
731 %dir %{_libdir}/fs/reiserfs
732 %dir %{_libdir}/fs/ufs
733 %dir %{_libdir}/fs/xfs
734 %dir %{_libdir}/fs/zfs
735 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
736
737 %files libs-guest
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
741
742 %files devel
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libblktap.so
745 %attr(755,root,root) %{_libdir}/libblktapctl.so
746 %attr(755,root,root) %{_libdir}/libfsimage.so
747 %attr(755,root,root) %{_libdir}/libvhd.so
748 %attr(755,root,root) %{_libdir}/libxenctrl.so
749 %attr(755,root,root) %{_libdir}/libxenguest.so
750 %attr(755,root,root) %{_libdir}/libxenlight.so
751 %attr(755,root,root) %{_libdir}/libxenstat.so
752 %attr(755,root,root) %{_libdir}/libxenstore.so
753 %attr(755,root,root) %{_libdir}/libxenvchan.so
754 %attr(755,root,root) %{_libdir}/libxlutil.so
755 %{_includedir}/_libxl_list.h
756 %{_includedir}/_libxl_types.h
757 %{_includedir}/_libxl_types_json.h
758 %{_includedir}/blktaplib.h
759 %{_includedir}/fsimage*.h
760 %{_includedir}/libxenvchan.h
761 %{_includedir}/libxl*.h
762 %{_includedir}/xen*.h
763 %{_includedir}/xs*.h
764 %{_includedir}/xen
765 %{_includedir}/xenstore-compat
766
767 %files static
768 %defattr(644,root,root,755)
769 %{_libdir}/libblktap.a
770 %{_libdir}/libblktapctl.a
771 %{_libdir}/libvhd.a
772 %{_libdir}/libxenctrl.a
773 %{_libdir}/libxenguest.a
774 %{_libdir}/libxenlight.a
775 %{_libdir}/libxenvchan.a
776 %{_libdir}/libxenstat.a
777 %{_libdir}/libxenstore.a
778 %{_libdir}/libxlutil.a
779
780 %files xend
781 %defattr(644,root,root,755)
782 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
783 %{systemdunitdir}/blktapctrl.service
784 %{systemdunitdir}/xend.service
785 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
786 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
787 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
788 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
789 %attr(755,root,root) %{_sbindir}/xend
790 %attr(755,root,root) %{_sbindir}/xm
791 %dir %attr(700,root,root) /var/run/xend
792 %{systemdtmpfilesdir}/xend.conf
793
794 %if %{with ocaml}
795 %files -n ocaml-xen
796 %defattr(644,root,root,755)
797 %doc tools/ocaml/LICENSE
798 %attr(755,root,root) %{_sbindir}/oxenstored
799 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
800 %dir %{_libdir}/ocaml/site-lib/xenbus
801 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
802 %dir %{_libdir}/ocaml/site-lib/xenctrl
803 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
804 %dir %{_libdir}/ocaml/site-lib/xeneventchn
805 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
806 %dir %{_libdir}/ocaml/site-lib/xenlight
807 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
808 %dir %{_libdir}/ocaml/site-lib/xenmmap
809 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
810
811 %files -n ocaml-xen-devel
812 %defattr(644,root,root,755)
813 %{_libdir}/ocaml/site-lib/xenbus/META
814 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
815 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
816 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
817 %{_libdir}/ocaml/site-lib/xenctrl/META
818 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
819 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
820 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
821 %{_libdir}/ocaml/site-lib/xeneventchn/META
822 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
823 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
824 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
825 %{_libdir}/ocaml/site-lib/xenmmap/META
826 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
827 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
828 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
829 %{_libdir}/ocaml/site-lib/xenlight/META
830 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
831 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
832 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
833 %dir %{_libdir}/ocaml/site-lib/xenstore
834 %{_libdir}/ocaml/site-lib/xenstore/META
835 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
836 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
837 %endif
838
839 %files -n python-xen
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{py_sitedir}/fsimage.so
842 %{py_sitedir}/grub
843 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
844 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
845 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
846 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
847 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
848 %{py_sitedir}/xen/remus
849 %{py_sitedir}/xen/sv
850 %{py_sitedir}/xen/util
851 %{py_sitedir}/xen/web
852 %{py_sitedir}/xen/xend
853 %{py_sitedir}/xen/xm
854 %{py_sitedir}/xen/xsview
855 %if "%{py_ver}" > "2.4"
856 %{py_sitedir}/pygrub-0.3-py*.egg-info
857 %{py_sitedir}/xen-3.0-py*.egg-info
858 %endif
859
860 %files -n python-xen-guest
861 %defattr(644,root,root,755)
862 %dir %{py_sitedir}/xen
863 %{py_sitedir}/xen/__init__.py*
864 %dir %{py_sitedir}/xen/lowlevel
865 %{py_sitedir}/xen/lowlevel/__init__.py*
866 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
867
868 %files -n bash-completion-%{name}
869 %defattr(644,root,root,755)
870 /etc/bash_completion.d/xl.sh
871
872 %if %{with efi}
873 %files efi
874 %defattr(644,root,root,755)
875 %dir %{_libdir}/efi
876 %{_libdir}/efi/*.efi
877 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
878 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
879 %endif
This page took 0.086645 seconds and 4 git commands to generate.