]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
d0ef127173789bb551319aaec2747b65e8124c71
[packages/xen.git] / xen.spec
1 %define         pyver   2.3
2 Summary:        Xen is a virtual machine monitor
3 Name:           xen
4 Version:        2
5 Release:        20041205
6 Group:          Development/Libraries
7 License:        GPL
8 URL:            http://www.sourceforge.net/projects/xen/
9 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/%{name}-unstable-src.tgz
10 BuildRequires:  curl-devel
11 BuildRequires:  python-devel
12 BuildRequires:  python-Twisted
13 BuildRequires:  bridge-utils
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This package contains the Xen hypervisor and Xen tools, needed to run
18 virtual machines on x86 systems, together with the kernel-xen*
19 packages. Information on how to use Xen can be found at the Xen
20 project pages.
21
22 Virtualisation can be used to run multiple versions or multiple Linux
23 distributions on one system, or to test untrusted applications in a
24 sandboxed environment. Note that the Xen technology is still in
25 development, and this RPM has received extremely little testing. Don't
26 be surprised if this RPM eats your data, drinks your coffee or makes
27 fun of you in front of your friends.
28
29 %prep
30 %setup -q -n xen-unstable
31
32 %build
33 CFLAGS="%{rpmcflags}" %{__make} xen tools docs
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %{__make} prefix=$RPM_BUILD_ROOT \
38         install-xen \
39         install-tools \
40         install-docs
41
42 install -d $RPM_BUILD_ROOT%{_mandir}
43 mv $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
44
45 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc COPYING ChangeLog README docs
53 /boot/%{name}-syms
54 /boot/%{name}.gz
55 %attr(755,root,root) %{_sbindir}/netfix
56 %attr(755,root,root) %{_sbindir}/xend
57 %attr(755,root,root) %{_sbindir}/xensv
58 %attr(755,root,root) %{_sbindir}/xfrd
59 %attr(755,root,root) %{_sbindir}/xm
60 %attr(755,root,root) %{_sbindir}/xenperf
61 %attr(755,root,root) %{_bindir}/xenperf
62 %attr(755,root,root) %{_bindir}/miniterm
63 %attr(755,root,root) %{_bindir}/xencons
64 %attr(755,root,root) %{_bindir}/xentrace
65 %attr(755,root,root) %{_bindir}/xentrace_format
66 %{_includedir}/*.h
67 %dir %{_includedir}/%{name}
68 %{_includedir}/%{name}/*.h
69 %{_includedir}/%{name}/*/*.h
70 %{_libdir}/libxc.so.*
71 %{_libdir}/libxutil.so.*
72 %{_libdir}/libxc.so
73 %{_libdir}/libxutil.so
74 %{_libdir}/libxutil.a
75 %dir %{_libdir}/python%{pyver}/site-packages/%{name}
76 %{_libdir}/python%{pyver}/site-packages/%{name}/*.pyc
77 %{_libdir}/python%{pyver}/site-packages/%{name}/*.py
78 %{_libdir}/python%{pyver}/site-packages/%{name}/*/*.pyc
79 %{_libdir}/python%{pyver}/site-packages/%{name}/*/*.py
80 %{_libdir}/python%{pyver}/site-packages/%{name}/*/*/*.pyc
81 %{_libdir}/python%{pyver}/site-packages/%{name}/*/*/*.py
82 %{_libdir}/python%{pyver}/site-packages/%{name}/lowlevel/*.so
83 %{_mandir}/man?/*.?.gz
84 %dir %{_localstatedir}/%{name}
85 %{_localstatedir}/%{name}/sv/inc/*.css
86 %{_localstatedir}/%{name}/sv/inc/*.js
87 %{_localstatedir}/%{name}/sv/images/*.png
88 %{_localstatedir}/%{name}/sv/images/*.jpg
89 %{_localstatedir}/%{name}/sv/*.rpy
90 %attr(755,root,root) %{_sysconfdir}/init.d/xend
91 %attr(755,root,root) %{_sysconfdir}/init.d/xendomains
92 %dir %{_sysconfdir}/%{name}
93 %{_sysconfdir}/%{name}/scripts/block-enbd
94 %{_sysconfdir}/%{name}/scripts/block-file
95 %{_sysconfdir}/%{name}/scripts/network
96 %{_sysconfdir}/%{name}/scripts/vif-bridge
97 %{_sysconfdir}/%{name}/xend-config.sxp
98 %{_sysconfdir}/%{name}/xmexample1
99 %{_sysconfdir}/%{name}/xmexample2
This page took 0.038115 seconds and 2 git commands to generate.