]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- restore utf8 symbols
[packages/xen.git] / xen.spec
1 #
2 # NOTE:
3 # - this xen-3.3.0 kernel and userspace
4 #   if you are looking for xen-3.0.2 (kernel.spec:LINUX_2_6_16), checkout
5 #   this spec from XEN_3_0_2 branch
6 # - you will also need dom0 enabled kernel
7 #
8 # TODO:
9 # - pldized init scripts
10 # - script for rc-boot
11 # - %%build fails on i686
12 #
13 # Conditional build:
14 %bcond_with     pae             # build with PAE (HIGHMEM64G) support
15 %bcond_with     hvm             # build with hvm (full virtualization) support
16 #
17 %define         major   3.4
18 %define         minor   3
19 Summary:        Xen - a virtual machine monitor
20 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
21 Name:           xen
22 Version:        %{major}.%{minor}
23 Release:        0.1
24 License:        GPL
25 Group:          Applications/System
26 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
27 # Source0-md5:  f8d001eb9e08525c451d38deb93908b1
28 Source1:        %{name}-xend.init
29 Source2:        %{name}-xendomains.init
30 Patch0:         %{name}-python_scripts.patch
31 Patch1:         %{name}-gcc.patch
32 Patch2:         %{name}-symbols.patch
33 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
34 BuildRequires:  SDL-devel
35 %{?with_hvm:BuildRequires:      bcc}
36 BuildRequires:  curl-devel
37 BuildRequires:  e2fsprogs-devel
38 BuildRequires:  gcc >= 5:3.4
39 BuildRequires:  gettext-devel
40 BuildRequires:  latex2html
41 BuildRequires:  libidn-devel
42 BuildRequires:  ncurses-devel
43 BuildRequires:  pciutils-devel
44 BuildRequires:  pkgconfig
45 BuildRequires:  python-devel
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.268
48 BuildRequires:  texlive-dvips
49 #BuildRequires: texlive-latex-data
50 BuildRequires:  texlive-latex-psnfss
51 BuildRequires:  transfig
52 BuildRequires:  which
53 BuildRequires:  zlib-devel
54 Requires(post,preun):   /sbin/chkconfig
55 Requires:       %{name}-libs = %{version}-%{release}
56 Requires:       ZopeInterface
57 Requires:       bridge-utils
58 Requires:       coreutils
59 Requires:       diffutils
60 Requires:       gawk
61 Requires:       iptables
62 Requires:       kernel(xen0)
63 Requires:       losetup
64 Requires:       net-tools
65 Requires:       python-%{name} = %{version}-%{release}
66 Requires:       rc-scripts
67 Requires:       sed
68 Requires:       util-linux
69 Requires:       which
70 Obsoletes:      xen-doc
71 ExclusiveArch:  %{ix86} %{x8664}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # some PPC/SPARC boot image in ELF format
75 %define         _noautostrip    .*%{_datadir}/xen/qemu/openbios-.*
76
77 %ifnarch i686 athlon pentium3 pentium4
78 %undefine       with_pae
79 %endif
80
81 %description
82 This package contains the Xen hypervisor and Xen tools, needed to run
83 virtual machines on x86 systems, together with the kernel-xen*
84 packages. Information on how to use Xen can be found at the Xen
85 project pages.
86
87 Virtualisation can be used to run multiple versions or multiple Linux
88 distributions on one system, or to test untrusted applications in a
89 sandboxed environment. Note that the Xen technology is still in
90 development, and this RPM has received extremely little testing. Don't
91 be surprised if this RPM eats your data, drinks your coffee or makes
92 fun of you in front of your friends.
93
94 %description -l pl.UTF-8
95 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
96 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
97 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
98 projektu.
99
100 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
101 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
102 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
103 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
104 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
105 się wyśmiewał w obecności przyjaciół.
106
107 %package libs
108 Summary:        xen libraries
109 Summary(pl.UTF-8):      Biblioteki xena
110 Group:          Libraries
111
112 %description libs
113 xen libraries.
114
115 %description libs -l pl.UTF-8
116 Biblioteki xena.
117
118 %package devel
119 Summary:        Header files for xen
120 Summary(pl.UTF-8):      Pliki nagłówkowe xena
121 Group:          Development/Libraries
122 Requires:       %{name}-libs = %{version}-%{release}
123
124 %description devel
125 Header files for xen.
126
127 %description devel -l pl.UTF-8
128 Pliki nagłówkowe xena.
129
130 %package static
131 Summary:        Static xen libraries
132 Summary(pl.UTF-8):      Statyczne biblioteki xena
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}-%{release}
135
136 %description static
137 Static xen libraries.
138
139 %description static -l pl.UTF-8
140 Statyczne biblioteki xena.
141
142 %package hotplug
143 Summary:        xen hotplug scripts
144 Summary(pl.UTF-8):      Skrypty hotplug dla xena
145 Group:          Applications/System
146
147 %description hotplug
148 xen hotplug scripts.
149
150 %description hotplug -l pl.UTF-8
151 Skrypty hotplug dla xena.
152
153 %package udev
154 Summary:        xen udev scripts
155 Summary(pl.UTF-8):      Skrypty udev dla xena
156 Group:          Applications/System
157
158 %description udev
159 xen udev scripts.
160
161 %description udev -l pl.UTF-8
162 Skrypty udev dla xena.
163
164 %package -n python-xen
165 Summary:        xen Python modules
166 Summary(pl.UTF-8):      Moduły Pythona dla xena
167 Group:          Libraries
168 Conflicts:      xen < 3.2.1-0.3
169
170 %description -n python-xen
171 xen Python modules.
172
173 %description -n python-xen -l pl.UTF-8
174 Moduły Pythona dla xena.
175
176 %prep
177 %setup -q
178 %patch0 -p1
179 %patch1 -p1
180 %patch2 -p1
181
182 find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs -0 -r -l512 rm -fv
183
184 %build
185 CFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
186 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
187 %{__make} -j1 xen tools \
188         %{?with_pae:XEN_TARGET_X86_PAE=y} \
189         CC="%{__cc}" \
190         CXX="%{__cxx}"
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 install -d $RPM_BUILD_ROOT/var/run/{xen-hotplug,xend,xenstored}
195
196 %{__make} install-xen install-tools install-docs \
197         CC="%{__cc}" \
198         CXX="%{__cxx}" \
199         %{?with_pae:XEN_TARGET_X86_PAE=y} \
200         DESTDIR=$RPM_BUILD_ROOT \
201         XEN_PYTHON_NATIVE_INSTALL=1
202
203 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
204 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
205 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
206
207 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
208 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/save
209
210 cp -a dist/install/etc/udev $RPM_BUILD_ROOT%{_sysconfdir}
211 cp -a dist/install/etc/hotplug $RPM_BUILD_ROOT%{_sysconfdir}
212
213 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
214 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
215
216 %py_postclean
217 # remove unneeded files
218 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
219 rm -rf $RPM_BUILD_ROOT%{_docdir}/xen
220 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
221 rm -rf $RPM_BUILD_ROOT/''etc/init.d
222 rm -f $RPM_BUILD_ROOT/boot/xen-3.2.gz
223 rm -f $RPM_BUILD_ROOT/boot/xen-3.4.gz
224 rm -f $RPM_BUILD_ROOT/boot/xen-3.gz
225 # # strip - Unable to recognise the format of the input file
226 # rm -f $RPM_BUILD_ROOT%{_datadir}/xen/qemu/openbios-sparc32
227 # rm -f $RPM_BUILD_ROOT%{_datadir}/xen/qemu/openbios-sparc64
228
229
230 # conflict with qemu
231 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img.1
232 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post
238 /sbin/chkconfig --add xend
239 /sbin/chkconfig --add xendomains
240
241 %preun
242 if [ "$1" = "0" ]; then
243         %service xend stop
244         /sbin/chkconfig --del xend
245
246         %service xendomains stop
247         /sbin/chkconfig --del xendomains
248 fi
249
250 %post   libs -p /sbin/ldconfig
251 %postun libs -p /sbin/ldconfig
252
253 %files
254 %defattr(644,root,root,755)
255 %doc COPYING README docs/misc/*
256 %doc docs/html/*
257 /boot/%{name}-syms-%{version}
258 /boot/%{name}-%{version}.gz
259 /boot/%{name}.gz
260 %attr(754,root,root) /etc/rc.d/init.d/*
261 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
262 %dir %{_sysconfdir}/xen
263 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/qemu-ifup
264 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
265 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README
266 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[123]
267 %dir %{_sysconfdir}/xen/auto
268 %dir %{_sysconfdir}/xen/scripts
269 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
270 %attr(755,root,root) %{_bindir}/*
271 %attr(755,root,root) %{_sbindir}/*
272 %dir %{_libdir}/%{name}
273 %dir %{_libdir}/%{name}/bin
274 %attr(744,root,root) %{_libdir}/%{name}/bin/*
275 %if "%{_lib}" != "lib"
276 %dir %{_prefix}/lib/%{name}
277 %endif
278 %dir %{_prefix}/lib/%{name}/boot
279 %{?with_hvm:%attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader}
280 %{_datadir}/xen
281 %{_mandir}/man?/*
282 %{_sharedstatedir}/xen
283 %{_sharedstatedir}/xenstored
284 %dir /var/run/xen-hotplug
285 %dir %attr(700,root,root) /var/run/xend
286 %dir /var/run/xenstored
287
288 %files libs
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_libdir}/lib*.so.*
291 %dir %{_libdir}/fs
292 %dir %{_libdir}/fs/ext2fs-lib
293 %dir %{_libdir}/fs/fat
294 %dir %{_libdir}/fs/iso9660
295 %dir %{_libdir}/fs/reiserfs
296 %dir %{_libdir}/fs/ufs
297 %dir %{_libdir}/fs/zfs
298 %attr(755,root,root) %{_libdir}/fs/*/*.so
299
300 %files devel
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/lib*.so
303 %{_includedir}/*
304
305 %files static
306 %defattr(644,root,root,755)
307 %{_libdir}/lib*.a
308
309 %files hotplug
310 %defattr(644,root,root,755)
311 %attr(755,root,root) /etc/hotplug/*
312
313 %files udev
314 %defattr(644,root,root,755)
315 %config(noreplace) %verify(not md5 mtime size) /etc/udev/*
316
317 %files -n python-xen
318 %defattr(644,root,root,755)
319 %attr(755,root,root) %{py_sitedir}/fsimage.so
320 %{py_sitedir}/grub
321 %dir %{py_sitedir}/xen
322 %dir %{py_sitedir}/xen/lowlevel
323 %{py_sitedir}/xen/lowlevel/*.py*
324 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/*.so
325 %{py_sitedir}/xen/sv
326 %{py_sitedir}/xen/util
327 %{py_sitedir}/xen/web
328 %{py_sitedir}/xen/xend
329 %{py_sitedir}/xen/xm
330 %{py_sitedir}/xen/xsview
331 %{py_sitedir}/xen/*.py*
332 %if "%{py_ver}" > "2.4"
333 %{py_sitedir}/*.egg-info
334 %endif
This page took 0.080041 seconds and 3 git commands to generate.