]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- up to 4.6.5
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
10 #
11 # Conditional build:
12 %bcond_without  qemu_traditional        # without qemu-xen-traditional
13 %bcond_without  opengl                  # OpenGL support in Xen qemu
14 %bcond_without  sdl                     # SDL support in Xen qemu
15 %bcond_without  bluetooth               # bluetooth support in Xen qemu
16 %bcond_without  brlapi                  # brlapi support in Xen qemu
17 %bcond_without  ocaml                   # Ocaml libraries for Xen tools
18 %bcond_without  efi                     # EFI hypervisor
19 %bcond_without  hypervisor              # Xen hypervisor build
20 %bcond_without  stubdom                 # stubdom build
21 %bcond_without  xsm                     # XSM security module (by default, Flask)
22
23 %ifnarch %{x8664} arm
24 %undefine       with_hypervisor
25 %endif
26 %ifnarch %{x8664}
27 %undefine       with_efi
28 %endif
29 %ifnarch %{ix86} %{x8664}
30 %undefine       with_stubdom
31 %endif
32
33 # from ./stubdom/configure.ac
34 %define polarssl_version        1.1.4
35 %define tpm_emulator_version    0.7.4
36 %define gmp_version             4.3.2
37
38 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
39 Summary:        Xen - a virtual machine monitor
40 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
41 Name:           xen
42 Version:        4.6.5
43 Release:        1
44 License:        GPL v2, interface parts on BSD-like
45 Group:          Applications/System
46 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
47 # Source0-md5:  63c80317ee662fb237d709d6c4e161c8
48 # used by stubdoms
49 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
50 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
51 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
52 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
53 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
54 # Source12-md5: debc62758716a169df9f62e6ab2bc634
55 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
56 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
57 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
58 # Source14-md5: cd3f3eb54446be6003156158d51f4884
59 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
60 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
61 Source17:       %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
62 # Source17-md5: 7b72caf22b01464ee7d6165f2fd85f44
63 Source18:       http://xenbits.xen.org/xen-extfiles/tpm_emulator-%{tpm_emulator_version}.tar.gz
64 # Source18-md5: e26becb8a6a2b6695f6b3e8097593db8
65 Source19:       ftp://ftp.gmplib.org/pub/gmp-%{gmp_version}/gmp-%{gmp_version}.tar.bz2
66 # Source19-md5: dd60683d7057917e34630b4a787932e8
67 Source35:       xenconsoled.sysconfig
68 Source37:       xenstored.sysconfig
69 Source38:       xenstored.tmpfiles
70 # sysvinit scripts
71 Source46:       xen-qemu-dom0-disk-backend.init
72 Source51:       xenconsoled.init
73 Source52:       xenstored.init
74 Source53:       xen-watchdog.init
75 Source54:       xendomains.init
76 Source55:       xen.logrotate
77 Source56:       xen.tmpfiles
78 Source57:       xen.cfg
79 Source58:       xen.efi-boot-update
80 Source59:       vif-openvswitch
81 Source60:       xen-init-list
82 Source61:       xen-toolstack
83 Patch0:         %{name}-python_scripts.patch
84 Patch1:         %{name}-symbols.patch
85 Patch2:         %{name}-curses.patch
86 Patch3:         pygrubfix.patch
87 # Warning: this disables ingress filtering implemented in xen scripts!
88 Patch7:         %{name}-net-disable-iptables-on-bridge.patch
89 Patch9:         %{name}-gawk.patch
90 Patch10:        %{name}-qemu.patch
91 Patch12:        %{name}-doc.patch
92 Patch13:        %{name}-paths.patch
93 Patch14:        %{name}-no_fetcher.patch
94 Patch15:        odd-glib2-fix.patch
95 Patch16:        %{name}-gmp-abi.patch
96 Patch18:        %{name}-make.patch
97 Patch19:        %{name}-no_Werror.patch
98 Patch22:        %{name}-stubdom-build.patch
99 Patch23:        link.patch
100 Patch24:        %{name}-systemd.patch
101 Patch25:        fix-misleading-indentation.patch
102 Patch26:        deprecated-readdir_r.patch
103 Patch27:        ipxe-build.patch
104 Patch28:        sysmacros.patch
105 Patch29:        unused-function.patch
106 URL:            http://www.xen.org/products/xenhyp.html
107 BuildRequires:  autoconf >= 2.67
108 %ifarch %{ix86} %{x8664}
109 BuildRequires:  acpica
110 BuildRequires:  bcc
111 BuildRequires:  bin86
112 %endif
113 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
114 BuildRequires:  bzip2-devel
115 %if %{with xsm}
116 BuildRequires:  checkpolicy
117 %endif
118 BuildRequires:  curl-devel
119 BuildRequires:  cyrus-sasl-devel >= 2
120 BuildRequires:  e2fsprogs-devel
121 BuildRequires:  gcc >= 6:4.1
122 %ifarch %{x8664}
123 BuildRequires:  gcc-multilib-32 >= 6:4.1
124 %endif
125 BuildRequires:  gettext-tools
126 BuildRequires:  glib2-devel >= 1:2.12
127 BuildRequires:  gnutls-devel
128 BuildRequires:  keyutils-devel
129 BuildRequires:  latex2html >= 2008
130 BuildRequires:  libaio-devel
131 BuildRequires:  libcap-devel
132 %ifarch arm aarch64
133 BuildRequires:  libfdt-devel
134 %endif
135 BuildRequires:  libjpeg-devel
136 BuildRequires:  libnl-devel >= 3.2.8
137 BuildRequires:  libpng-devel
138 BuildRequires:  libuuid-devel
139 BuildRequires:  lzo-devel >= 2
140 BuildRequires:  ncurses-devel
141 %if %{with ocaml}
142 BuildRequires:  ocaml >= 3.11.0
143 BuildRequires:  ocaml-findlib
144 %endif
145 BuildRequires:  nss-devel >= 3.12.8
146 BuildRequires:  openssl-devel
147 BuildRequires:  pciutils-devel
148 BuildRequires:  perl-base
149 BuildRequires:  perl-tools-pod
150 BuildRequires:  pkgconfig
151 BuildRequires:  python-devel
152 BuildRequires:  rpm-pythonprov
153 BuildRequires:  rpmbuild(macros) >= 1.647
154 BuildRequires:  seabios
155 BuildRequires:  texi2html
156 BuildRequires:  texlive-dvips
157 BuildRequires:  texlive-latex-psnfss
158 BuildRequires:  texlive-xetex
159 BuildRequires:  transfig
160 BuildRequires:  which
161 # for xfsctl (<xfs/xfs.h>)
162 BuildRequires:  xfsprogs-devel
163 BuildRequires:  xz-devel
164 BuildRequires:  yajl-devel
165 BuildRequires:  zlib-devel
166 %if %{with qemu_traditional}
167 %{?with_opengl:BuildRequires:   OpenGL-devel}
168 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
169 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
170 %{?with_brlapi:BuildRequires:   brlapi-devel}
171 BuildRequires:  vde2-devel
172 BuildRequires:  xorg-lib-libX11-devel
173 BuildRequires:  xorg-lib-libXext-devel
174 %endif
175 %if %{with qemu_traditional}
176 # FIXME: see qemu configure comments on top of spec
177 %{!?with_opengl:BuildConflicts: OpenGL-devel}
178 %{!?with_sdl:BuildConflicts:    SDL-devel}
179 %{!?with_sdl:BuildConflicts:    SDL-devel}
180 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
181 %{!?with_brlapi:BuildConflicts: brlapi-devel}
182 %endif
183 Requires(post,preun):   /sbin/chkconfig
184 Requires(post,preun,postun):    systemd-units >= 38
185 Requires:       %{name}-libs = %{version}-%{release}
186 Requires:       ZopeInterface
187 Requires:       bridge-utils
188 Requires:       coreutils
189 Requires:       diffutils
190 Requires:       gawk
191 Requires:       iptables
192 Requires:       losetup
193 Requires:       net-tools
194 Requires:       python-%{name} = %{version}-%{release}
195 Requires:       rc-scripts
196 Requires:       sed
197 Requires:       systemd-units >= 38
198 Requires:       util-linux
199 Requires:       which
200 Requires:       %{name}-guest = %{version}-%{release}
201 Obsoletes:      xen-doc
202 Obsoletes:      xen-udev
203 Obsoletes:      xen-xend
204 ExclusiveArch:  %{ix86} %{x8664} arm
205 %ifarch %{ix86} %{x8664}
206 # for HVM
207 Suggests:       qemu-system-x86
208 %endif
209 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
210
211 # some PPC/SPARC boot images in ELF format
212 %define         _noautostrip    .*%{_datadir}/\\(xen\\|qemu-xen\\)/qemu/\\(openbios-.*\\|palcode-clipper\\|s390-ccw.img\\)
213
214 %description
215 This package contains the Xen hypervisor and Xen tools, needed to run
216 virtual machines on x86 systems, together with the kernel-xen*
217 packages. Information on how to use Xen can be found at the Xen
218 project pages.
219
220 Virtualisation can be used to run multiple versions or multiple Linux
221 distributions on one system, or to test untrusted applications in a
222 sandboxed environment. Note that the Xen technology is still in
223 development, and this RPM has received extremely little testing. Don't
224 be surprised if this RPM eats your data, drinks your coffee or makes
225 fun of you in front of your friends.
226
227 %description -l pl.UTF-8
228 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
229 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
230 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
231 projektu.
232
233 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
234 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
235 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
236 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
237 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
238 się wyśmiewał w obecności przyjaciół.
239
240 %package guest
241 Summary:        Xen tools for virtual machines
242 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
243 Group:          Applications/System
244 Requires:       %{name}-libs-guest = %{version}-%{release}
245
246 %description guest
247 Xen utilities for both dom0 and domU virtual domains.
248
249 %description guest -l pl.UTF-8
250 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
251
252 %package libs
253 Summary:        Xen libraries
254 Summary(pl.UTF-8):      Biblioteki Xena
255 Group:          Libraries
256 Requires:       %{name}-libs-guest = %{version}-%{release}
257
258 %description libs
259 Xen libraries.
260
261 %description libs -l pl.UTF-8
262 Biblioteki Xena.
263
264 %package libs-guest
265 Summary:        Xen libraries for virtual machines
266 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
267 Group:          Libraries
268
269 %description libs-guest
270 Xen libraries for both dom0 and domU virtual machines.
271
272 %description libs-guest -l pl.UTF-8
273 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
274
275 %package devel
276 Summary:        Header files for Xen
277 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
278 Group:          Development/Libraries
279 Requires:       %{name}-libs = %{version}-%{release}
280
281 %description devel
282 Header files for Xen.
283
284 %description devel -l pl.UTF-8
285 Pliki nagłówkowe Xena.
286
287 %package static
288 Summary:        Static Xen libraries
289 Summary(pl.UTF-8):      Statyczne biblioteki Xena
290 Group:          Development/Libraries
291 Requires:       %{name}-devel = %{version}-%{release}
292
293 %description static
294 Static Xen libraries.
295
296 %description static -l pl.UTF-8
297 Statyczne biblioteki Xena.
298
299 %package -n ocaml-xen
300 Summary:        OCaml bindings for Xen
301 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
302 License:        LGPL v2.1 with linking exception
303 Group:          Libraries
304 Requires:       %{name}-libs = %{version}-%{release}
305 %if %{with ocaml}
306 %requires_eq    ocaml-runtime
307 %endif
308
309 %description -n ocaml-xen
310 OCaml bindings for Xen.
311
312 %description -n ocaml-xen -l pl.UTF-8
313 Wiązania OCamla dla Xena.
314
315 %package -n ocaml-xen-devel
316 Summary:        OCaml bindings for Xen - development files
317 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
318 License:        LGPL v2.1 with linking exception
319 Group:          Development/Libraries
320 Requires:       ocaml-xen = %{version}-%{release}
321 %if %{with ocaml}
322 %requires_eq    ocaml
323 %endif
324
325 %description -n ocaml-xen-devel
326 OCaml bindings for Xen - development files.
327
328 %description -n ocaml-xen-devel -l pl.UTF-8
329 Wiązania OCamla dla Xena - pliki programistyczne.
330
331 %package -n python-xen
332 Summary:        Xen Python modules
333 Summary(pl.UTF-8):      Moduły Pythona dla Xena
334 Group:          Libraries
335 Requires:       %{name}-libs = %{version}-%{release}
336 Conflicts:      xen < 3.2.1-0.3
337
338 %description -n python-xen
339 Xen Python modules.
340
341 %description -n python-xen -l pl.UTF-8
342 Moduły Pythona dla Xena.
343
344 %package -n python-xen-guest
345 Summary:        Xen Python modules for virtual machines
346 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
347 Group:          Libraries
348 Requires:       %{name}-libs-guest = %{version}-%{release}
349 Conflicts:      xen < 3.2.1-0.3
350
351 %description -n python-xen-guest
352 Xen Python modules for both dom0 and domU virtual machines.
353
354 %description -n python-xen-guest -l pl.UTF-8
355 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
356
357 %package -n bash-completion-%{name}
358 Summary:        bash-completion for Xen (xl)
359 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
360 Group:          Applications/Shells
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       bash-completion
363
364 %description -n bash-completion-%{name}
365 This package provides bash-completion for Xen (xl).
366
367 %description -n bash-completion-%{name} -l pl.UTF-8
368 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
369
370 %package efi
371 Summary:        Xen hypervisor binary for EFI
372 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
373 Group:          Applications/System
374 Requires:       %{name}-libs-guest = %{version}-%{release}
375
376 %description efi
377 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
378 firmware without help from any additional bootloader.
379
380 %description efi -l pl.UTF-8
381 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
382 (U)EFI, bez potrzeby oddzielnego bootloadera.
383
384 %prep
385 %setup -q
386 %patch0 -p1
387 %patch1 -p1
388 %patch2 -p1
389 %patch3 -p1
390 %patch7 -p1
391 %patch9 -p1
392 %patch10 -p1
393 %patch12 -p1
394 %patch13 -p1
395 %patch14 -p1
396 %patch15 -p1
397 %patch16 -p1
398 %patch18 -p1
399 %patch19 -p1
400 %patch22 -p1
401 %patch23 -p1
402 %patch24 -p1
403 %patch25 -p1
404 %patch26 -p1
405 %patch27 -p1
406 %patch28 -p1
407 %patch29 -p1
408
409 # stubdom sources
410 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
411 ln -s %{SOURCE17} %{SOURCE18} %{SOURCE19} stubdom
412 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
413
414 # do not allow fetching anything via git
415 echo GIT=/bin/false >> Config.mk
416
417 %build
418 # based on the 'autoconf.sh' from the sources
419 %{__autoconf}
420 cd tools
421 %{__autoconf}
422 %{__autoheader}
423 cd ../stubdom
424 %{__autoconf}
425 cd ../docs
426 %{__autoconf}
427 cd ..
428
429 # if gold is used then bioses and grub doesn't build
430 install -d our-ld
431 ln -f -s /usr/bin/ld.bfd our-ld/ld
432 export PATH=$(pwd)/our-ld:$PATH
433
434 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
435 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
436
437 # NOTE on ac_cv_*:
438 # - use openssl (libcrypto) instead of libgcrypt as openssl is obligatory anyway
439 # - prevent libiconv from being detected (not needed with glibc)
440 %configure \
441         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
442         ac_cv_lib_gcrypt_gcry_md_hash_buffer=no \
443         ac_cv_lib_iconv_libiconv_open=no \
444         --disable-debug \
445         %{__enable_disable qemu_traditional qemu-traditional} \
446         --with-system-seabios=/usr/share/seabios/bios.bin \
447 %ifarch %{x8664}
448         --with-system-qemu=/usr/bin/qemu-system-x86_64 \
449 %else
450         --with-system-qemu=/usr/bin/qemu-system-i386 \
451 %endif
452         --with-systemd=%{systemdunitdir}
453
454 %{__make} -j1 dist-xen dist-tools dist-docs \
455         %{!?with_ocaml:OCAML_TOOLS=n} \
456         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
457         CC="%{__cc}" \
458         CXX="%{__cxx}" \
459         V=1
460
461 unset CFLAGS
462 unset CXXFLAGS
463
464 %if %{with stubdom}
465 %{__make} -j1 dist-stubdom \
466         %{!?with_ocaml:OCAML_TOOLS=n} \
467         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
468         CC="%{__cc}" \
469         CXX="%{__cxx}" \
470         V=1
471 %endif
472
473 %install
474 rm -rf $RPM_BUILD_ROOT
475 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
476         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
477
478 %if %{with efi}
479 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
480 %endif
481
482 %{__make} -j1 install-xen install-tools %{?with_stubdom:install-stubdom} install-docs \
483         %{!?with_ocaml:OCAML_TOOLS=n} \
484         XSM_ENABLE=%{?with_xsm:y}%{!?with_xsm:n} \
485         DESTDIR=$RPM_BUILD_ROOT \
486         HOTPLUGS=install-udev
487
488 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
489 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
490
491 # sysvinit scripts
492 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
493 %{__rm} $RPM_BUILD_ROOT/etc/sysconfig/xencommons
494 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
495 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
496 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
497 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
498 install %{SOURCE46} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-qemu-dom0-disk-backend
499 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
500 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
501 install -d $RPM_BUILD_ROOT/var/run/xenstored
502 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
503
504 install %{SOURCE60} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-init-list
505 install %{SOURCE61} $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/xen-toolstack
506
507 %if %{with efi}
508 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
509 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
510                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
511 %endif
512
513 %{__mv} $RPM_BUILD_ROOT/etc/xen/{xlexample*,examples}
514
515 install %{SOURCE59} $RPM_BUILD_ROOT%{_sysconfdir}/xen/scripts/vif-openvswitch
516
517 # for %%doc
518 install -d _doc
519 for tool in blktap2 pygrub ; do
520         cp -p tools/$tool/README _doc/README.$tool
521 done
522
523 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
524 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
525
526 %py_postclean
527
528 # remove unneeded files
529 %if %{with hypervisor}
530 %{__mv} xen/xen-syms $RPM_BUILD_ROOT/boot/%{name}-syms-%{version}
531 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.6.gz
532 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
533 %endif
534 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
535 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
536
537 %clean
538 rm -rf $RPM_BUILD_ROOT
539
540 %post
541 /sbin/chkconfig --add xen-watchdog
542 /sbin/chkconfig --add xenconsoled
543 /sbin/chkconfig --add xenstored
544 /sbin/chkconfig --add xendomains
545 /sbin/chkconfig --add xen-qemu-dom0-disk-backend
546 NORESTART=1
547 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
548
549 %preun
550 if [ "$1" = "0" ]; then
551         %service xendomains stop
552         /sbin/chkconfig --del xendomains
553
554         %service xenconsoled stop
555         /sbin/chkconfig --del xenconsoled
556
557         %service xenstored stop
558         /sbin/chkconfig --del xenstored
559
560         %service xen-watchdog stop
561         /sbin/chkconfig --del xen-watchdog
562
563         %service xen-qemu-dom0-disk-backend stop
564         /sbin/chkconfig --del xen-qemu-dom0-disk-backend
565 fi
566 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service xendomains.service xen-qemu-dom0-disk-backend.service
567
568 %postun
569 %systemd_reload
570
571 %post   libs -p /sbin/ldconfig
572 %postun libs -p /sbin/ldconfig
573
574 %post   libs-guest -p /sbin/ldconfig
575 %postun libs-guest -p /sbin/ldconfig
576
577 %post efi
578 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
579
580 %files
581 %defattr(644,root,root,755)
582 %doc COPYING README* docs/misc/* docs/html/* _doc/*
583 %if %{with hypervisor}
584 /boot/%{name}-syms-%{version}
585 /boot/%{name}-%{version}.gz
586 /boot/%{name}.gz
587 %endif
588 %if %{with xsm}
589 /boot/xenpolicy-%{version}
590 %endif
591 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
592 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
593 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
595 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
596 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
597 %attr(754,root,root) /etc/rc.d/init.d/xenstored
598 %attr(754,root,root) /etc/rc.d/init.d/xendomains
599 %attr(754,root,root) /etc/rc.d/init.d/xen-qemu-dom0-disk-backend
600 %{_prefix}/lib/modules-load.d/xen.conf
601 %{systemdunitdir}/proc-xen.mount
602 %{systemdunitdir}/var-lib-xenstored.mount
603 %{systemdunitdir}/xen-init-dom0.service
604 %{systemdunitdir}/xen-watchdog.service
605 %{systemdunitdir}/xenconsoled.service
606 %{systemdunitdir}/xenstored.service
607 %{systemdunitdir}/xenstored.socket
608 %{systemdunitdir}/xenstored_ro.socket
609 %{systemdunitdir}/xendomains.service
610 %{systemdunitdir}/xen-qemu-dom0-disk-backend.service
611 %dir %{_sysconfdir}/xen
612 %dir %{_sysconfdir}/xen/auto
613 %dir %{_sysconfdir}/xen/examples
614 %dir %{_sysconfdir}/xen/scripts
615 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
617 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
620 %attr(755,root,root) %{_bindir}/pygrub
621 %if %{with qemu_traditional}
622 %attr(755,root,root) %{_bindir}/qemu-img-xen
623 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
624 %endif
625 %attr(755,root,root) %{_bindir}/xenalyze
626 %attr(755,root,root) %{_bindir}/xencons
627 %attr(755,root,root) %{_bindir}/xencov_split
628 %attr(755,root,root) %{_bindir}/xentrace_format
629 %if %{with xsm}
630 %attr(755,root,root) %{_sbindir}/flask-*
631 %endif
632 %attr(755,root,root) %{_sbindir}/gdbsx
633 %attr(755,root,root) %{_sbindir}/gtrace*
634 %attr(755,root,root) %{_sbindir}/img2qcow
635 %attr(755,root,root) %{_sbindir}/kdd
636 %attr(755,root,root) %{_sbindir}/lock-util
637 %attr(755,root,root) %{_sbindir}/qcow-create
638 %attr(755,root,root) %{_sbindir}/qcow2raw
639 %attr(755,root,root) %{_sbindir}/tap-ctl
640 %attr(755,root,root) %{_sbindir}/tapdisk*
641 %attr(755,root,root) %{_sbindir}/td-util
642 %attr(755,root,root) %{_sbindir}/vhd-*
643 %attr(755,root,root) %{_sbindir}/xen-*
644 %attr(755,root,root) %{_sbindir}/xenbaked
645 %attr(755,root,root) %{_sbindir}/xenconsoled
646 %attr(755,root,root) %{_sbindir}/xencov
647 %attr(755,root,root) %{_sbindir}/xenlockprof
648 %attr(755,root,root) %{_sbindir}/xenmon.py
649 %attr(755,root,root) %{_sbindir}/xenperf
650 %attr(755,root,root) %{_sbindir}/xenpm
651 %attr(755,root,root) %{_sbindir}/xenpmd
652 %attr(755,root,root) %{_sbindir}/xenstored
653 %attr(755,root,root) %{_sbindir}/xentop
654 %attr(755,root,root) %{_sbindir}/xentrace
655 %attr(755,root,root) %{_sbindir}/xentrace_setmask
656 %attr(755,root,root) %{_sbindir}/xentrace_setsize
657 %attr(755,root,root) %{_sbindir}/xenwatchdogd
658 %attr(755,root,root) %{_sbindir}/xl
659 %dir %{_libdir}/%{name}
660 %dir %{_libdir}/%{name}/bin
661 %attr(744,root,root) %{_libdir}/%{name}/bin/*
662 %dir %{_libdir}/%{name}/boot
663 %if %{with stubdom}
664 %if %{with qemu_traditional}
665 %{_libdir}/%{name}/boot/ioemu-stubdom.gz
666 %endif
667 %ifarch %{ix86} %{x8664}
668 %{_libdir}/%{name}/boot/pv-grub-x86_32.gz
669 %endif
670 %ifarch %{x8664}
671 %{_libdir}/%{name}/boot/pv-grub-x86_64.gz
672 %endif
673 %{_libdir}/%{name}/boot/vtpm-stubdom.gz
674 %{_libdir}/%{name}/boot/vtpmmgr-stubdom.gz
675 %{_libdir}/%{name}/boot/xenstore-stubdom.gz
676 %endif
677 %attr(744,root,root) %{_libdir}/%{name}/boot/hvmloader
678 %{_mandir}/man1/xentop.1*
679 %{_mandir}/man1/xentrace_format.1*
680 %{_mandir}/man1/xl.1*
681 %{_mandir}/man5/xl.cfg.5*
682 %{_mandir}/man5/xl.conf.5*
683 %{_mandir}/man5/xlcpupool.cfg.5*
684 %{_mandir}/man8/xentrace.8*
685 %{_sharedstatedir}/xen
686 %{_sharedstatedir}/xenstored
687 %dir /var/run/xenstored
688 %{systemdtmpfilesdir}/xen.conf
689 %{systemdtmpfilesdir}/xenstored.conf
690 %dir %attr(0700,root,root) /var/log/xen
691 %dir %attr(0700,root,root) /var/log/xen/console
692 %if %{with qemu_traditional}
693 %{_datadir}/xen
694 %endif
695
696 %files guest
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/xen-detect
699 %attr(755,root,root) %{_bindir}/xenstore
700 %attr(755,root,root) %{_bindir}/xenstore-chmod
701 %attr(755,root,root) %{_bindir}/xenstore-control
702 %attr(755,root,root) %{_bindir}/xenstore-exists
703 %attr(755,root,root) %{_bindir}/xenstore-list
704 %attr(755,root,root) %{_bindir}/xenstore-ls
705 %attr(755,root,root) %{_bindir}/xenstore-read
706 %attr(755,root,root) %{_bindir}/xenstore-rm
707 %attr(755,root,root) %{_bindir}/xenstore-watch
708 %attr(755,root,root) %{_bindir}/xenstore-write
709 %{_mandir}/man1/xenstore.1*
710 %{_mandir}/man1/xenstore-chmod.1*
711 %{_mandir}/man1/xenstore-ls.1*
712
713 %files libs
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
716 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
717 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
718 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
719 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
721 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.6
723 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.6
725 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.6
727 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
729 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
731 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.6
733 %dir %{_libdir}/fs
734 %dir %{_libdir}/fs/ext2fs-lib
735 %dir %{_libdir}/fs/fat
736 %dir %{_libdir}/fs/iso9660
737 %dir %{_libdir}/fs/reiserfs
738 %dir %{_libdir}/fs/ufs
739 %dir %{_libdir}/fs/xfs
740 %dir %{_libdir}/fs/zfs
741 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
742
743 %files libs-guest
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
747
748 %files devel
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/libblktapctl.so
751 %attr(755,root,root) %{_libdir}/libfsimage.so
752 %attr(755,root,root) %{_libdir}/libvhd.so
753 %attr(755,root,root) %{_libdir}/libxenctrl.so
754 %attr(755,root,root) %{_libdir}/libxenguest.so
755 %attr(755,root,root) %{_libdir}/libxenlight.so
756 %attr(755,root,root) %{_libdir}/libxenstat.so
757 %attr(755,root,root) %{_libdir}/libxenstore.so
758 %attr(755,root,root) %{_libdir}/libxenvchan.so
759 %attr(755,root,root) %{_libdir}/libxlutil.so
760 %{_includedir}/_libxl_list.h
761 %{_includedir}/_libxl_types.h
762 %{_includedir}/_libxl_types_json.h
763 %{_includedir}/fsimage*.h
764 %{_includedir}/libxenvchan.h
765 %{_includedir}/libxl*.h
766 %{_includedir}/xen*.h
767 %{_includedir}/xs*.h
768 %{_includedir}/xen
769 %{_includedir}/xenstore-compat
770 %{_npkgconfigdir}/xenlight.pc
771 %{_npkgconfigdir}/xlutil.pc
772
773 %files static
774 %defattr(644,root,root,755)
775 %{_libdir}/libblktapctl.a
776 %{_libdir}/libvhd.a
777 %{_libdir}/libxenctrl.a
778 %{_libdir}/libxenguest.a
779 %{_libdir}/libxenlight.a
780 %{_libdir}/libxenvchan.a
781 %{_libdir}/libxenstat.a
782 %{_libdir}/libxenstore.a
783 %{_libdir}/libxlutil.a
784
785 %if %{with ocaml}
786 %files -n ocaml-xen
787 %defattr(644,root,root,755)
788 %doc tools/ocaml/LICENSE
789 %attr(755,root,root) %{_sbindir}/oxenstored
790 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
791 %dir %{_libdir}/ocaml/site-lib/xenbus
792 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
793 %dir %{_libdir}/ocaml/site-lib/xenctrl
794 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
795 %dir %{_libdir}/ocaml/site-lib/xeneventchn
796 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
797 %dir %{_libdir}/ocaml/site-lib/xenlight
798 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
799 %dir %{_libdir}/ocaml/site-lib/xenmmap
800 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
801 %dir %{_libdir}/ocaml/site-lib/xentoollog
802 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xentoollog/dllxentoollog_stubs.so
803
804 %files -n ocaml-xen-devel
805 %defattr(644,root,root,755)
806 %{_libdir}/ocaml/site-lib/xenbus/META
807 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
808 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
809 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
810 %{_libdir}/ocaml/site-lib/xenctrl/META
811 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
812 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
813 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
814 %{_libdir}/ocaml/site-lib/xeneventchn/META
815 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
816 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
817 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
818 %{_libdir}/ocaml/site-lib/xenmmap/META
819 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
820 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
821 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
822 %{_libdir}/ocaml/site-lib/xenlight/META
823 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
824 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
825 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
826 %dir %{_libdir}/ocaml/site-lib/xenstore
827 %{_libdir}/ocaml/site-lib/xenstore/META
828 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
829 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
830 %{_libdir}/ocaml/site-lib/xentoollog/META
831 %{_libdir}/ocaml/site-lib/xentoollog/libxentoollog_stubs.a
832 %{_libdir}/ocaml/site-lib/xentoollog/xentoollog.a
833 %{_libdir}/ocaml/site-lib/xentoollog/*.cm[aixo]*
834 %endif
835
836 %files -n python-xen
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{py_sitedir}/fsimage.so
839 %dir %{py_sitedir}/xen
840 %dir %{py_sitedir}/xen/lowlevel
841 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
842 %{py_sitedir}/xen/migration
843 %{py_sitedir}/grub
844 %if "%{py_ver}" > "2.4"
845 %{py_sitedir}/pygrub-0.3-py*.egg-info
846 %{py_sitedir}/xen-3.0-py*.egg-info
847 %endif
848
849 %files -n python-xen-guest
850 %defattr(644,root,root,755)
851 %dir %{py_sitedir}/xen
852 %{py_sitedir}/xen/__init__.py*
853 %dir %{py_sitedir}/xen/lowlevel
854 %{py_sitedir}/xen/lowlevel/__init__.py*
855 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
856
857 %files -n bash-completion-%{name}
858 %defattr(644,root,root,755)
859 /etc/bash_completion.d/xl.sh
860
861 %if %{with efi}
862 %files efi
863 %defattr(644,root,root,755)
864 %dir %{_libdir}/efi
865 %{_libdir}/efi/*.efi
866 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
867 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
868 %endif
This page took 2.777639 seconds and 3 git commands to generate.