]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- updated to 2.6.1
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.1
13 Release:        1
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
17 # Source0-md5:  045f0edad0988620a4aa36096bb16e28
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-ogl.patch
20 Patch2:         %{name}-ac.patch
21 Patch3:         %{name}-gif0delay.patch
22 URL:            http://www.wxWidgets.org/
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  SDL-devel
25 BuildRequires:  autoconf >= 2.58
26 BuildRequires:  automake
27 BuildRequires:  bakefile >= 0.1.8
28 BuildRequires:  cppunit-devel
29 BuildRequires:  esound-devel
30 BuildRequires:  expat-devel
31 BuildRequires:  flex
32 BuildRequires:  gettext-devel
33 BuildRequires:  gtk+2-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libmng-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtiff-devel
39 BuildRequires:  libtool
40 BuildRequires:  pkgconfig
41 # these are not supported by wxWidgets
42 Obsoletes:      LDAPExplorerTool <= 0.6-1
43 Obsoletes:      abridge <= 0.4.0-1
44 # and these are replaced
45 Obsoletes:      wxGTK
46 Obsoletes:      wxGTK-devel
47 Obsoletes:      wxGTK-gl
48 Obsoletes:      wxGTK-gl-devel
49 Obsoletes:      wxGTK-univ
50 Obsoletes:      wxGTK-univ-devel
51 Obsoletes:      wxGTK-univ-gl
52 Obsoletes:      wxGTK-univ-gl-devel
53 Obsoletes:      wxGTK2-univ
54 Obsoletes:      wxGTK2-univ-devel
55 Obsoletes:      wxGTK2-univ-gl
56 Obsoletes:      wxGTK2-univ-gl-devel
57 Obsoletes:      wxGTK2-univ-unicode
58 Obsoletes:      wxGTK2-univ-unicode-devel
59 Obsoletes:      wxGTK2-univ-unicode-gl
60 Obsoletes:      wxGTK2-univ-unicode-gl-devel
61 Obsoletes:      wxMotif
62 Obsoletes:      wxMotif-devel
63 Obsoletes:      wxMotif-gl
64 Obsoletes:      wxMotif-gl-devel
65 Obsoletes:      wxWidgets-afm
66 Obsoletes:      wxWindows
67 Obsoletes:      wxWindows-afm
68 Obsoletes:      wxwin-afm
69 Obsoletes:      wxwin-common
70 Conflicts:      wxGTK2 < 2.6.0
71 Conflicts:      wxGTK2-unicode < 2.6.0
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     %{_datadir}
75
76 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif/LessTif, MS Windows, Mac) from the same source code.
82
83 %description -l pl
84 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
85 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
86 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
87 Windows, Mac) z tego samego kodu ¼ród³owego.
88
89 %package devel
90 Summary:        wxWidgets header files and development documentation
91 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
92 Group:          X11/Development/Libraries
93 Requires:       libstdc++-devel
94 Obsoletes:      wxWindows-devel
95
96 %description devel
97 Header files and development documentation for the wxWidgets
98 libraries.
99
100 %description devel -l pl
101 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
102
103 %package examples
104 Summary:        wxWidgets example programs
105 Summary(pl):    Przyk³adowe programy wxWidgets
106 Group:          X11/Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108 Obsoletes:      wxWindows-examples
109
110 %description examples
111 wxWidgets example programs.
112
113 %description examples -l pl
114 Przyk³adowe programy wxWidgets.
115
116 %package HelpGen
117 Summary:        Help file generator for wxWidgets programs
118 Summary(pl):    Generator plików pomocy dla programów wxWidgets
119 Group:          Development/Tools
120 Requires:       wxBase = %{version}-%{release}
121 Obsoletes:      wxWindows-HelpGen
122
123 %description HelpGen
124 Help file generator for wxWidgets programs.
125
126 %description HelpGen -l pl
127 Generator plików pomocy dla programów wxWidgets.
128
129 %package -n wxBase
130 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
131 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
132 Group:          X11/Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description -n wxBase
136 wxBase is a collection of C++ classes providing basic data structures
137 (strings, lists, arrays), powerful wxDateTime class for date
138 manipulations, portable wrappers around many OS-specific functions
139 allowing to build the same program under all supported folders,
140 wxThread class for writing multithreaded programs using either Win32
141 or POSIX threads and much more. wxBase currently supports the
142 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
143 HP-UX, ...) and BeOS.
144
145 %description -n wxBase -l pl
146 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
147 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
148 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
149 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
150 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
151 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
152 platformy: Win32, Unix i BeOS.
153
154 %package -n wxBase-devel
155 Summary:        wxBase headers needed for developping with wxBase
156 Summary(pl):    Pliki nag³ówkowe do wxBase
157 Group:          X11/Development/Libraries
158 Requires:       %{name}-devel = %{version}-%{release}
159 Requires:       wxBase = %{version}-%{release}
160
161 %description -n wxBase-devel
162 Header files for wxBase. You need them to develop programs using
163 wxBase.
164
165 %description -n wxBase-devel -l pl
166 Pliki nag³ówkowe do biblioteki wxBase.
167
168 %package -n wxBase-unicode
169 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
170 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
171 Group:          X11/Libraries
172 Requires:       %{name} = %{version}-%{release}
173
174 %description -n wxBase-unicode
175 wxBase is a collection of C++ classes providing basic data structures
176 (strings, lists, arrays), powerful wxDateTime class for date
177 manipulations, portable wrappers around many OS-specific functions
178 allowing to build the same program under all supported folders,
179 wxThread class for writing multithreaded programs using either Win32
180 or POSIX threads and much more. wxBase currently supports the
181 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
182 HP-UX, ...) and BeOS. This version is build with UNICODE support.
183
184 %description -n wxBase-unicode -l pl
185 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
186 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
187 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
188 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
189 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
190 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
191 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
192 UNICODE.
193
194 %package -n wxBase-unicode-devel
195 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
196 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
197 Group:          X11/Development/Libraries
198 Requires:       %{name}-devel = %{version}-%{release}
199 Requires:       wxBase-unicode = %{version}-%{release}
200
201 %description -n wxBase-unicode-devel
202 Header files for wxBase. You need them to develop programs using
203 UNICODE-enabled wxBase.
204
205 %description -n wxBase-unicode-devel -l pl
206 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
207
208 %package -n wxGTK2
209 Summary:        wxGTK2 library
210 Summary(pl):    Biblioteka wxGTK2
211 Group:          X11/Libraries
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      wxGTK2-univ
214
215 %description -n wxGTK2
216 wxWidgets library using GTK2 widgets.
217
218 %description -n wxGTK2 -l pl
219 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
220
221 %package -n wxGTK2-devel
222 Summary:        Header files for wxGTK2 library
223 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
224 Group:          X11/Development/Libraries
225 Requires:       wxBase-devel = %{version}-%{release}
226 Requires:       wxGTK2 = %{version}-%{release}
227 Obsoletes:      wxGTK2-univ-devel
228
229 %description -n wxGTK2-devel
230 Header files for wxWidgets library using GTK2 widgets.
231
232 %description -n wxGTK2-devel -l pl
233 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
234
235 %package -n wxGTK2-gl
236 Summary:        GL canvas library for wxGTK2
237 Summary(pl):    Biblioteka GL dla wxGTK2
238 Group:          X11/Libraries
239 Requires:       wxGTK2 = %{version}-%{release}
240 Requires:       OpenGL
241 Obsoletes:      wxGTK2-univ-gl
242
243 %description -n wxGTK2-gl
244 wxGTK2 GL canvas library.
245
246 %description -n wxGTK2-gl -l pl
247 Biblioteka GL dla wxGTK2.
248
249 %package -n wxGTK2-gl-devel
250 Summary:        Development files for GL canvas library for wxGTK2
251 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
252 Group:          X11/Development/Libraries
253 Requires:       wxGTK2-devel = %{version}-%{release}
254 Requires:       wxGTK2-gl = %{version}-%{release}
255 Requires:       OpenGL-devel
256 Obsoletes:      wxGTK2-univ-gl-devel
257
258 %description -n wxGTK2-gl-devel
259 Development files for wxGTK2 GL canvas library.
260
261 %description -n wxGTK2-gl-devel -l pl
262 Pliki programistyczne biblioteki GL dla wxGTK2.
263
264 %package -n wxGTK2-unicode
265 Summary:        wxGTK2 library with UNICODE support
266 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
267 Group:          X11/Libraries
268 Requires:       %{name} = %{version}-%{release}
269 Obsoletes:      wxGTK2-univ-unicode
270
271 %description -n wxGTK2-unicode
272 wxWidgets library using GTK2 widgets with UNICODE support.
273
274 %description -n wxGTK2-unicode -l pl
275 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
276
277 %package -n wxGTK2-unicode-devel
278 Summary:        Header files for wxGTK2 library with UNICODE support
279 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
280 Group:          X11/Development/Libraries
281 Requires:       wxBase-unicode-devel = %{version}-%{release}
282 Requires:       wxGTK2-unicode = %{version}-%{release}
283 Obsoletes:      wxGTK2-univ-unicode-devel
284
285 %description -n wxGTK2-unicode-devel
286 Header files for wxWidgets library using GTK2 widgets with UNICODE
287 support.
288
289 %description -n wxGTK2-unicode-devel -l pl
290 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
291 obs³ug± UNICODE.
292
293 %package -n wxGTK2-unicode-gl
294 Summary:        GL canvas library for wxGTK2 with UNICODE support
295 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
296 Group:          X11/Libraries
297 Requires:       wxGTK2-unicode = %{version}-%{release}
298 Requires:       OpenGL
299 Obsoletes:      wxGTK2-univ-unicode-gl
300
301 %description -n wxGTK2-unicode-gl
302 GL canvas library for wxGTK2 with UNICODE support.
303
304 %description -n wxGTK2-unicode-gl -l pl
305 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
306
307 %package -n wxGTK2-unicode-gl-devel
308 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
309 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
310 Group:          X11/Development/Libraries
311 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
312 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
313 Requires:       OpenGL-devel
314 Obsoletes:      wxGTK2-univ-unicode-gl-devel
315
316 %description -n wxGTK2-unicode-gl-devel
317 Development files for GL canvas library for wxGTK2 with UNICODE
318 support.
319
320 %description -n wxGTK2-unicode-gl-devel -l pl
321 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
322
323 %package utils
324 Summary:        Misc utils from wxWidgets project
325 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
326 Group:          X11/Development/Tools
327 Requires:       wxX11 = %{version}-%{release}
328 Obsoletes:      wxWindows-utils
329
330 %description utils
331 Misc utils from wxWidgets project: helpviewer, makegen, etc.
332
333 %description utils -l pl
334 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
335
336 %package -n wxX11
337 Summary:        wxUniversal-based wxX11 library
338 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
339 Group:          X11/Libraries
340 Requires:       %{name} = %{version}-%{release}
341 Obsoletes:      wxX11-univ
342
343 %description -n wxX11
344 wxUniversal-based wxX11 library.
345
346 %description -n wxX11 -l pl
347 Oparta na wxUniversal biblioteka wxX11.
348
349 %package -n wxX11-devel
350 Summary:        Header files for wxUniversal-based wxX11 library
351 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
352 Group:          X11/Libraries
353 Requires:       %{name}-devel = %{version}-%{release}
354 Requires:       wxX11 = %{version}-%{release}
355 Obsoletes:      wxX11-univ-devel
356
357 %description -n wxX11-devel
358 Header files for wxUniversal-based wxX11 library.
359
360 %description -n wxX11-devel -l pl
361 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
362
363 %package -n wxX11-gl
364 Summary:        GL canvas library for wxUniversal-based wxX11
365 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
366 Group:          X11/Libraries
367 Requires:       wxX11 = %{version}-%{release}
368 Requires:       OpenGL
369 Obsoletes:      wxX11-univ-gl
370
371 %description -n wxX11-gl
372 GL canvas library for wxUniversal-based wxX11.
373
374 %description -n wxX11-gl -l pl
375 Biblioteka GL dla opartej na wxUniversal wxX11.
376
377 %package -n wxX11-gl-devel
378 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
379 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
380 Group:          X11/Development/Libraries
381 Requires:       wxX11-gl = %{version}-%{release}
382 Requires:       wxX11-devel = %{version}-%{release}
383 Requires:       OpenGL-devel
384 Obsoletes:      wxX11-univ-gl-devel
385
386 %description -n wxX11-gl-devel
387 Development files for GL canvas library for wxUniversal-based wxX11.
388
389 %description -n wxX11-gl-devel -l pl
390 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
391
392 %package -n wxX11-unicode
393 Summary:        wxUniversal-based wxX11 library with UNICODE support
394 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
395 Group:          X11/Libraries
396 Requires:       %{name} = %{version}-%{release}
397 Obsoletes:      wxX11-univ-unicode
398
399 %description -n wxX11-unicode
400 wxUniversal-based wxX11 library with UNICODE support.
401
402 %description -n wxX11-unicode -l pl
403 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
404
405 %package -n wxX11-unicode-devel
406 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
407 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
408 Group:          X11/Development/Libraries
409 Requires:       %{name}-devel = %{version}-%{release}
410 Requires:       wxX11-unicode = %{version}-%{release}
411 Obsoletes:      wxX11-univ-unicode-devel
412
413 %description -n wxX11-unicode-devel
414 Header files for wxUniversal-based wxX11 library with UNICODE support.
415
416 %description -n wxX11-unicode-devel -l pl
417 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
418
419 %package -n wxX11-unicode-gl
420 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
421 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
422 Group:          X11/Libraries
423 Requires:       wxX11-unicode = %{version}-%{release}
424 Requires:       OpenGL
425 Obsoletes:      wxX11-univ-unicode-gl
426
427 %description -n wxX11-unicode-gl
428 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
429
430 %description -n wxX11-unicode-gl -l pl
431 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
432
433 %package -n wxX11-unicode-gl-devel
434 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
435 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
436 Group:          X11/Development/Libraries
437 Requires:       wxX11-unicode-gl = %{version}-%{release}
438 Requires:       wxX11-unicode-devel = %{version}-%{release}
439 Requires:       OpenGL-devel
440 Obsoletes:      wxX11-univ-unicode-gl-devel
441
442 %description -n wxX11-unicode-gl-devel
443 Development files for GL canvas library for wxUniversal-based wxX11
444 with UNICODE support.
445
446 %description -n wxX11-unicode-gl-devel -l pl
447 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
448 obs³ug± UNICODE.
449
450 %prep
451 %setup -q
452 %patch0 -p1
453 %patch1 -p1
454 %patch2 -p1
455 %patch3 -p1
456
457 # bakefile.m4 from 0.1.8
458 tail -n +1518 aclocal.m4 | head -n 1397 > bakefile.m4
459 # AC_BAKEFILE_PROG_* macros
460 tail -n +721 aclocal.m4 | head -n 142 >> bakefile.m4
461
462 %build
463 # if bakefiles rebuild is needed:
464 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.8"
465 #cd build/bakefiles
466 #bakefile_gen -f autoconf
467 #cd ../..
468 #%endif
469 cp -f /usr/share/automake/config.sub .
470 %{__aclocal} -I .
471 %{__autoconf}
472
473 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
474 # avoid adding -s to LDFLAGS
475 LDFLAGS=" "; export LDFLAGS
476 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
477         --enable-plugins \
478         --enable-std_iostreams \
479         --without-sdl \
480         --with-opengl \
481         --enable-calendar \
482         --enable-controls \
483         --enable-tabdialog"
484
485 gui='--with-gtk'
486 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
487         '--enable-unicode' ; do
488         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
489         mkdir $objdir
490         cd $objdir
491         ../%configure \
492                 ${args} \
493                 ${gui} \
494                 --disable-universal \
495                 ${unicode}
496         %{__make}
497         %{__make} -C contrib/src
498         cd ..
499 done
500
501 %if %{with x11}
502 gui='--with-x11'
503 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
504         '--enable-unicode' ; do
505         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
506         mkdir $objdir
507         cd $objdir
508         ../%configure \
509                 ${args} \
510                 ${gui} \
511                 --enable-universal \
512                 ${unicode}
513         %{__make}
514         %{__make} -C contrib/src
515         if echo $objdir| grep -q disable-unicode ; then
516                 %{__make} -C utils
517                 %{__make} -C utils/emulator
518                 %{__make} -C utils/hhp2cached
519                 %{__make} -C contrib/utils
520         fi
521         cd ..
522 done
523 %endif
524
525 cd locale
526 %{__make} allmo
527
528 %install
529 rm -rf $RPM_BUILD_ROOT
530 install -d $RPM_BUILD_ROOT%{_bindir}
531
532 gui='--with-gtk'
533 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
534         '--enable-unicode' ; do
535         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
536         cd $objdir
537         %{__make} install \
538                 prefix=$RPM_BUILD_ROOT%{_prefix} \
539                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
540                 bindir=$RPM_BUILD_ROOT%{_bindir} \
541                 datadir=$RPM_BUILD_ROOT%{_datadir} \
542                 libdir=$RPM_BUILD_ROOT%{_libdir} \
543                 mandir=$RPM_BUILD_ROOT%{_mandir} \
544                 includedir=$RPM_BUILD_ROOT%{_includedir}
545
546         %{__make} -C contrib/src install \
547                 prefix=$RPM_BUILD_ROOT%{_prefix} \
548                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
549                 bindir=$RPM_BUILD_ROOT%{_bindir} \
550                 datadir=$RPM_BUILD_ROOT%{_datadir} \
551                 libdir=$RPM_BUILD_ROOT%{_libdir} \
552                 mandir=$RPM_BUILD_ROOT%{_mandir} \
553                 includedir=$RPM_BUILD_ROOT%{_includedir}
554         cd ..
555 done
556
557 %if %{with x11}
558 gui='--with-x11'
559 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
560         '--enable-unicode' ; do
561         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
562         cd $objdir
563         %{__make} install \
564                 prefix=$RPM_BUILD_ROOT%{_prefix} \
565                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
566                 bindir=$RPM_BUILD_ROOT%{_bindir} \
567                 datadir=$RPM_BUILD_ROOT%{_datadir} \
568                 libdir=$RPM_BUILD_ROOT%{_libdir} \
569                 mandir=$RPM_BUILD_ROOT%{_mandir} \
570                 includedir=$RPM_BUILD_ROOT%{_includedir}
571         if echo $objdir| grep -q disable-unicode ; then
572 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
573                 # TODO: install default config files and default backgrouds
574                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
575                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
576                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
577                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
578 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
579                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
580 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
581 #               install -m644 utils/makegen/templates/* \
582 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
583 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
584 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
585 #               install contrib/utils/wxrcedit/df/* \
586 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
587         fi
588
589         %{__make} -C contrib/src install \
590                 prefix=$RPM_BUILD_ROOT%{_prefix} \
591                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
592                 bindir=$RPM_BUILD_ROOT%{_bindir} \
593                 datadir=$RPM_BUILD_ROOT%{_datadir} \
594                 libdir=$RPM_BUILD_ROOT%{_libdir} \
595                 mandir=$RPM_BUILD_ROOT%{_mandir} \
596                 includedir=$RPM_BUILD_ROOT%{_includedir}
597
598         cd ..
599 done
600 %endif
601
602 set -x
603
604 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
605 do
606         b=`basename $i`
607         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
608 done
609
610 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
611 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
612 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
613
614 %find_lang wxstd
615
616 %clean
617 rm -rf $RPM_BUILD_ROOT
618
619 %post   -n wxBase -p /sbin/ldconfig
620 %postun -n wxBase -p /sbin/ldconfig
621
622 %post   -n wxBase-unicode -p /sbin/ldconfig
623 %postun -n wxBase-unicode -p /sbin/ldconfig
624
625 %post   -n wxGTK2 -p /sbin/ldconfig
626 %postun -n wxGTK2 -p /sbin/ldconfig
627
628 %post   -n wxGTK2-gl -p /sbin/ldconfig
629 %postun -n wxGTK2-gl -p /sbin/ldconfig
630
631 %post   -n wxGTK2-unicode -p /sbin/ldconfig
632 %postun -n wxGTK2-unicode -p /sbin/ldconfig
633
634 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
635 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
636
637 %post   -n wxX11 -p /sbin/ldconfig
638 %postun -n wxX11 -p /sbin/ldconfig
639
640 %post   -n wxX11-unicode -p /sbin/ldconfig
641 %postun -n wxX11-unicode -p /sbin/ldconfig
642
643 %files -f wxstd.lang
644 %defattr(644,root,root,755)
645 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
646
647 %files devel
648 %defattr(644,root,root,755)
649 %doc docs/html
650 %doc docs/tech docs/univ
651 %{_includedir}/wx*
652 %dir %{_libdir}/wx
653 %dir %{_libdir}/wx/include
654 %dir %{_libdir}/wx/config
655 %{_aclocaldir}/*.m4
656
657 %files examples
658 %defattr(644,root,root,755)
659 %{_examplesdir}/%{name}-%{version}
660
661 %if %{with x11}
662 %files HelpGen
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_bindir}/HelpGen
665 %endif
666
667 %if %{with ansi}
668 %files -n wxBase
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/libwx_base-*.so.*.*
671 %attr(755,root,root) %{_libdir}/libwx_base_*.so.*.*
672 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
673
674 %files -n wxBase-devel
675 %defattr(644,root,root,755)
676 %{_libdir}/libwx_base-*.so
677 %{_libdir}/libwx_base_*.so
678 %endif
679
680 %files -n wxBase-unicode
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/libwx_baseu-*.so.*.*
683 %attr(755,root,root) %{_libdir}/libwx_baseu_*.so.*.*
684 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
685
686 %files -n wxBase-unicode-devel
687 %defattr(644,root,root,755)
688 %{_libdir}/libwx_baseu-*.so
689 %{_libdir}/libwx_baseu_*.so
690
691 %if %{with ansi}
692 %files -n wxGTK2
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/libwx_gtk2_*.so.*.*
695 %exclude %{_libdir}/libwx_gtk2_ogl-*.so.*.*
696
697 %files -n wxGTK2-devel
698 %defattr(644,root,root,755)
699 %{_libdir}/libwx_gtk2_*-*.so
700 %exclude %{_libdir}/libwx_gtk2_ogl-*.so
701 %{_libdir}/wx/config/gtk2-ansi-*
702 %{_libdir}/wx/include/gtk2-ansi-*
703 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi-config
704
705 %files -n wxGTK2-gl
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libwx_gtk2_ogl-*.so.*.*
708
709 %files -n wxGTK2-gl-devel
710 %defattr(644,root,root,755)
711 %{_libdir}/libwx_gtk2_ogl-*.so
712 %endif
713
714 %files -n wxGTK2-unicode
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libwx_gtk2u_*-*.so.*.*
717 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
718
719 %files -n wxGTK2-unicode-devel
720 %defattr(644,root,root,755)
721 %{_libdir}/libwx_gtk2u_*-*.so
722 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so
723 %{_libdir}/wx/config/gtk2-unicode-*
724 %{_libdir}/wx/include/gtk2-unicode-*
725 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode-config
726
727 %files -n wxGTK2-unicode-gl
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
730
731 %files -n wxGTK2-unicode-gl-devel
732 %defattr(644,root,root,755)
733 %{_libdir}/libwx_gtk2u_ogl-*.so
734
735 %if %{with x11}
736 %if %{with ansi}
737 %files utils
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_bindir}/*
740 %exclude %{_bindir}/HelpGen
741 %exclude %{_bindir}/wx*-config
742
743 %files -n wxX11
744 %defattr(644,root,root,755)
745 %doc docs/wxX11-readme.txt
746 %attr(755,root,root) %{_libdir}/libwx_x11univ_*-*.so.*.*
747 %exclude %{_libdir}/libwx_x11univ_ogl-*.so.*.*
748
749 %files -n wxX11-devel
750 %defattr(644,root,root,755)
751 %{_libdir}/libwx_x11univ_*-*.so
752 %exclude %{_libdir}/libwx_x11univ_ogl-*.so
753 %{_libdir}/wx/config/x11univ-ansi-*
754 %{_libdir}/wx/include/x11univ-ansi-*
755 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi-config
756
757 %files -n wxX11-gl
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_libdir}/libwx_x11univ_ogl-*.so.*.*
760
761 %files -n wxX11-gl-devel
762 %defattr(644,root,root,755)
763 %{_libdir}/libwx_x11univ_ogl-*.so
764 %endif
765
766 %files -n wxX11-unicode
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libwx_x11univu_*-*.so.*.*
769 %exclude %{_libdir}/libwx_x11univu_ogl-*.so.*.*
770
771 %files -n wxX11-unicode-devel
772 %defattr(644,root,root,755)
773 %{_libdir}/libwx_x11univu_*-*.so
774 %exclude %{_libdir}/libwx_x11univu_ogl-*.so
775 %{_libdir}/wx/config/x11univ-unicode-*
776 %{_libdir}/wx/include/x11univ-unicode-*
777 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode-config
778
779 %files -n wxX11-unicode-gl
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libwx_x11univu_ogl-*.so.*.*
782
783 %files -n wxX11-unicode-gl-devel
784 %defattr(644,root,root,755)
785 %{_libdir}/libwx_x11univu_ogl-*.so
786 %endif
This page took 0.103686 seconds and 4 git commands to generate.