]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- added -intl.patch (fix unicode convert)
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.2
13 Release:        2
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
17 # Source0-md5:  ee0aa211febd992c8540e6c9df749b51
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-ogl.patch
20 Patch2:         %{name}-ac.patch
21 Patch3:         %{name}-gif0delay.patch
22 Patch4:         %{name}-x11unicode.patch
23 Patch5:         %{name}-intl.patch
24 URL:            http://www.wxWidgets.org/
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL-devel
27 BuildRequires:  autoconf >= 2.58
28 BuildRequires:  automake
29 #BuildRequires: bakefile >= 0.1.9
30 BuildRequires:  cppunit-devel
31 BuildRequires:  esound-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  flex
34 BuildRequires:  gettext-devel
35 BuildRequires:  gtk+2-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libmng-devel
38 BuildRequires:  libmspack-devel
39 BuildRequires:  libpng-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtiff-devel
42 BuildRequires:  libtool
43 BuildRequires:  pkgconfig
44 # these are not supported by wxWidgets
45 Obsoletes:      LDAPExplorerTool <= 0.6-1
46 Obsoletes:      abridge <= 0.4.0-1
47 # and these are replaced
48 Obsoletes:      wxGTK
49 Obsoletes:      wxGTK-devel
50 Obsoletes:      wxGTK-gl
51 Obsoletes:      wxGTK-gl-devel
52 Obsoletes:      wxGTK-univ
53 Obsoletes:      wxGTK-univ-devel
54 Obsoletes:      wxGTK-univ-gl
55 Obsoletes:      wxGTK-univ-gl-devel
56 Obsoletes:      wxGTK2-univ
57 Obsoletes:      wxGTK2-univ-devel
58 Obsoletes:      wxGTK2-univ-gl
59 Obsoletes:      wxGTK2-univ-gl-devel
60 Obsoletes:      wxGTK2-univ-unicode
61 Obsoletes:      wxGTK2-univ-unicode-devel
62 Obsoletes:      wxGTK2-univ-unicode-gl
63 Obsoletes:      wxGTK2-univ-unicode-gl-devel
64 Obsoletes:      wxMotif
65 Obsoletes:      wxMotif-devel
66 Obsoletes:      wxMotif-gl
67 Obsoletes:      wxMotif-gl-devel
68 Obsoletes:      wxWidgets-afm
69 Obsoletes:      wxWindows
70 Obsoletes:      wxWindows-afm
71 Obsoletes:      wxwin-afm
72 Obsoletes:      wxwin-common
73 Conflicts:      wxGTK2 < 2.6.0
74 Conflicts:      wxGTK2-unicode < 2.6.0
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _sysconfdir     %{_datadir}
78
79 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
80
81 %description
82 wxWidgets is a free C++ library for cross-platform GUI development.
83 With wxWidgets, you can create applications for different GUIs (GTK+,
84 Motif/LessTif, MS Windows, Mac) from the same source code.
85
86 %description -l pl
87 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
88 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
89 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
90 Windows, Mac) z tego samego kodu ¼ród³owego.
91
92 %package devel
93 Summary:        wxWidgets header files and development documentation
94 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
95 Group:          X11/Development/Libraries
96 Requires:       libstdc++-devel
97 Obsoletes:      wxWindows-devel
98
99 %description devel
100 Header files and development documentation for the wxWidgets
101 libraries.
102
103 %description devel -l pl
104 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
105
106 %package examples
107 Summary:        wxWidgets example programs
108 Summary(pl):    Przyk³adowe programy wxWidgets
109 Group:          X11/Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 Obsoletes:      wxWindows-examples
112
113 %description examples
114 wxWidgets example programs.
115
116 %description examples -l pl
117 Przyk³adowe programy wxWidgets.
118
119 %package HelpGen
120 Summary:        Help file generator for wxWidgets programs
121 Summary(pl):    Generator plików pomocy dla programów wxWidgets
122 Group:          Development/Tools
123 Requires:       wxBase = %{version}-%{release}
124 Obsoletes:      wxWindows-HelpGen
125
126 %description HelpGen
127 Help file generator for wxWidgets programs.
128
129 %description HelpGen -l pl
130 Generator plików pomocy dla programów wxWidgets.
131
132 %package -n wxBase
133 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
134 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
135 Group:          X11/Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description -n wxBase
139 wxBase is a collection of C++ classes providing basic data structures
140 (strings, lists, arrays), powerful wxDateTime class for date
141 manipulations, portable wrappers around many OS-specific functions
142 allowing to build the same program under all supported folders,
143 wxThread class for writing multithreaded programs using either Win32
144 or POSIX threads and much more. wxBase currently supports the
145 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
146 HP-UX, ...) and BeOS.
147
148 %description -n wxBase -l pl
149 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
150 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
151 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
152 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
153 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
154 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
155 platformy: Win32, Unix i BeOS.
156
157 %package -n wxBase-devel
158 Summary:        wxBase headers needed for developping with wxBase
159 Summary(pl):    Pliki nag³ówkowe do wxBase
160 Group:          X11/Development/Libraries
161 Requires:       %{name}-devel = %{version}-%{release}
162 Requires:       wxBase = %{version}-%{release}
163
164 %description -n wxBase-devel
165 Header files for wxBase. You need them to develop programs using
166 wxBase.
167
168 %description -n wxBase-devel -l pl
169 Pliki nag³ówkowe do biblioteki wxBase.
170
171 %package -n wxBase-unicode
172 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
173 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
174 Group:          X11/Libraries
175 Requires:       %{name} = %{version}-%{release}
176
177 %description -n wxBase-unicode
178 wxBase is a collection of C++ classes providing basic data structures
179 (strings, lists, arrays), powerful wxDateTime class for date
180 manipulations, portable wrappers around many OS-specific functions
181 allowing to build the same program under all supported folders,
182 wxThread class for writing multithreaded programs using either Win32
183 or POSIX threads and much more. wxBase currently supports the
184 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
185 HP-UX, ...) and BeOS. This version is build with UNICODE support.
186
187 %description -n wxBase-unicode -l pl
188 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
189 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
190 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
191 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
192 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
193 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
194 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
195 UNICODE.
196
197 %package -n wxBase-unicode-devel
198 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
199 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
200 Group:          X11/Development/Libraries
201 Requires:       %{name}-devel = %{version}-%{release}
202 Requires:       wxBase-unicode = %{version}-%{release}
203
204 %description -n wxBase-unicode-devel
205 Header files for wxBase. You need them to develop programs using
206 UNICODE-enabled wxBase.
207
208 %description -n wxBase-unicode-devel -l pl
209 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
210
211 %package -n wxGTK2
212 Summary:        wxGTK2 library
213 Summary(pl):    Biblioteka wxGTK2
214 Group:          X11/Libraries
215 Requires:       %{name} = %{version}-%{release}
216 Obsoletes:      wxGTK2-univ
217
218 %description -n wxGTK2
219 wxWidgets library using GTK2 widgets.
220
221 %description -n wxGTK2 -l pl
222 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
223
224 %package -n wxGTK2-devel
225 Summary:        Header files for wxGTK2 library
226 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
227 Group:          X11/Development/Libraries
228 Requires:       wxBase-devel = %{version}-%{release}
229 Requires:       wxGTK2 = %{version}-%{release}
230 Obsoletes:      wxGTK2-univ-devel
231
232 %description -n wxGTK2-devel
233 Header files for wxWidgets library using GTK2 widgets.
234
235 %description -n wxGTK2-devel -l pl
236 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
237
238 %package -n wxGTK2-gl
239 Summary:        GL canvas library for wxGTK2
240 Summary(pl):    Biblioteka GL dla wxGTK2
241 Group:          X11/Libraries
242 Requires:       wxGTK2 = %{version}-%{release}
243 Requires:       OpenGL
244 Obsoletes:      wxGTK2-univ-gl
245
246 %description -n wxGTK2-gl
247 wxGTK2 GL canvas library.
248
249 %description -n wxGTK2-gl -l pl
250 Biblioteka GL dla wxGTK2.
251
252 %package -n wxGTK2-gl-devel
253 Summary:        Development files for GL canvas library for wxGTK2
254 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
255 Group:          X11/Development/Libraries
256 Requires:       wxGTK2-devel = %{version}-%{release}
257 Requires:       wxGTK2-gl = %{version}-%{release}
258 Requires:       OpenGL-devel
259 Obsoletes:      wxGTK2-univ-gl-devel
260
261 %description -n wxGTK2-gl-devel
262 Development files for wxGTK2 GL canvas library.
263
264 %description -n wxGTK2-gl-devel -l pl
265 Pliki programistyczne biblioteki GL dla wxGTK2.
266
267 %package -n wxGTK2-unicode
268 Summary:        wxGTK2 library with UNICODE support
269 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
270 Group:          X11/Libraries
271 Requires:       %{name} = %{version}-%{release}
272 Obsoletes:      wxGTK2-univ-unicode
273
274 %description -n wxGTK2-unicode
275 wxWidgets library using GTK2 widgets with UNICODE support.
276
277 %description -n wxGTK2-unicode -l pl
278 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
279
280 %package -n wxGTK2-unicode-devel
281 Summary:        Header files for wxGTK2 library with UNICODE support
282 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
283 Group:          X11/Development/Libraries
284 Requires:       wxBase-unicode-devel = %{version}-%{release}
285 Requires:       wxGTK2-unicode = %{version}-%{release}
286 Obsoletes:      wxGTK2-univ-unicode-devel
287
288 %description -n wxGTK2-unicode-devel
289 Header files for wxWidgets library using GTK2 widgets with UNICODE
290 support.
291
292 %description -n wxGTK2-unicode-devel -l pl
293 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
294 obs³ug± UNICODE.
295
296 %package -n wxGTK2-unicode-gl
297 Summary:        GL canvas library for wxGTK2 with UNICODE support
298 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
299 Group:          X11/Libraries
300 Requires:       wxGTK2-unicode = %{version}-%{release}
301 Requires:       OpenGL
302 Obsoletes:      wxGTK2-univ-unicode-gl
303
304 %description -n wxGTK2-unicode-gl
305 GL canvas library for wxGTK2 with UNICODE support.
306
307 %description -n wxGTK2-unicode-gl -l pl
308 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
309
310 %package -n wxGTK2-unicode-gl-devel
311 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
312 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
313 Group:          X11/Development/Libraries
314 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
315 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
316 Requires:       OpenGL-devel
317 Obsoletes:      wxGTK2-univ-unicode-gl-devel
318
319 %description -n wxGTK2-unicode-gl-devel
320 Development files for GL canvas library for wxGTK2 with UNICODE
321 support.
322
323 %description -n wxGTK2-unicode-gl-devel -l pl
324 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
325
326 %package utils
327 Summary:        Misc utils from wxWidgets project
328 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
329 Group:          X11/Development/Tools
330 Requires:       wxX11 = %{version}-%{release}
331 Obsoletes:      wxWindows-utils
332
333 %description utils
334 Misc utils from wxWidgets project: helpviewer, makegen, etc.
335
336 %description utils -l pl
337 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
338
339 %package -n wxX11
340 Summary:        wxUniversal-based wxX11 library
341 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
342 Group:          X11/Libraries
343 Requires:       %{name} = %{version}-%{release}
344 Obsoletes:      wxX11-univ
345
346 %description -n wxX11
347 wxUniversal-based wxX11 library.
348
349 %description -n wxX11 -l pl
350 Oparta na wxUniversal biblioteka wxX11.
351
352 %package -n wxX11-devel
353 Summary:        Header files for wxUniversal-based wxX11 library
354 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
355 Group:          X11/Libraries
356 Requires:       %{name}-devel = %{version}-%{release}
357 Requires:       wxX11 = %{version}-%{release}
358 Obsoletes:      wxX11-univ-devel
359
360 %description -n wxX11-devel
361 Header files for wxUniversal-based wxX11 library.
362
363 %description -n wxX11-devel -l pl
364 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
365
366 %package -n wxX11-gl
367 Summary:        GL canvas library for wxUniversal-based wxX11
368 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
369 Group:          X11/Libraries
370 Requires:       wxX11 = %{version}-%{release}
371 Requires:       OpenGL
372 Obsoletes:      wxX11-univ-gl
373
374 %description -n wxX11-gl
375 GL canvas library for wxUniversal-based wxX11.
376
377 %description -n wxX11-gl -l pl
378 Biblioteka GL dla opartej na wxUniversal wxX11.
379
380 %package -n wxX11-gl-devel
381 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
382 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
383 Group:          X11/Development/Libraries
384 Requires:       wxX11-gl = %{version}-%{release}
385 Requires:       wxX11-devel = %{version}-%{release}
386 Requires:       OpenGL-devel
387 Obsoletes:      wxX11-univ-gl-devel
388
389 %description -n wxX11-gl-devel
390 Development files for GL canvas library for wxUniversal-based wxX11.
391
392 %description -n wxX11-gl-devel -l pl
393 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
394
395 %package -n wxX11-unicode
396 Summary:        wxUniversal-based wxX11 library with UNICODE support
397 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
398 Group:          X11/Libraries
399 Requires:       %{name} = %{version}-%{release}
400 Obsoletes:      wxX11-univ-unicode
401
402 %description -n wxX11-unicode
403 wxUniversal-based wxX11 library with UNICODE support.
404
405 %description -n wxX11-unicode -l pl
406 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
407
408 %package -n wxX11-unicode-devel
409 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
410 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
411 Group:          X11/Development/Libraries
412 Requires:       %{name}-devel = %{version}-%{release}
413 Requires:       wxX11-unicode = %{version}-%{release}
414 Obsoletes:      wxX11-univ-unicode-devel
415
416 %description -n wxX11-unicode-devel
417 Header files for wxUniversal-based wxX11 library with UNICODE support.
418
419 %description -n wxX11-unicode-devel -l pl
420 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
421
422 %package -n wxX11-unicode-gl
423 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
424 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
425 Group:          X11/Libraries
426 Requires:       wxX11-unicode = %{version}-%{release}
427 Requires:       OpenGL
428 Obsoletes:      wxX11-univ-unicode-gl
429
430 %description -n wxX11-unicode-gl
431 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
432
433 %description -n wxX11-unicode-gl -l pl
434 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
435
436 %package -n wxX11-unicode-gl-devel
437 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
438 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
439 Group:          X11/Development/Libraries
440 Requires:       wxX11-unicode-gl = %{version}-%{release}
441 Requires:       wxX11-unicode-devel = %{version}-%{release}
442 Requires:       OpenGL-devel
443 Obsoletes:      wxX11-univ-unicode-gl-devel
444
445 %description -n wxX11-unicode-gl-devel
446 Development files for GL canvas library for wxUniversal-based wxX11
447 with UNICODE support.
448
449 %description -n wxX11-unicode-gl-devel -l pl
450 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
451 obs³ug± UNICODE.
452
453 %prep
454 %setup -q
455 %patch0 -p1
456 %patch1 -p1
457 %patch2 -p1
458 %patch3 -p1
459 %patch4 -p1
460 %patch5 -p1
461
462 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
463
464 %build
465 # if bakefiles rebuild is needed:
466 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
467 #cd build/bakefiles
468 #bakefile_gen -f autoconf
469 #cd ../..
470 #%endif
471 cp -f /usr/share/automake/config.sub .
472 %{__aclocal} -I build/aclocal
473 %{__autoconf}
474
475 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
476 # avoid adding -s to LDFLAGS
477 LDFLAGS=" "; export LDFLAGS
478 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
479         --enable-plugins \
480         --enable-std_iostreams \
481         --without-sdl \
482         --with-opengl \
483         --enable-calendar \
484         --enable-controls \
485         --enable-tabdialog"
486
487 gui='--with-gtk'
488 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
489         '--enable-unicode' ; do
490         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
491         mkdir $objdir
492         cd $objdir
493         ../%configure \
494                 ${args} \
495                 ${gui} \
496                 --disable-universal \
497                 ${unicode}
498         %{__make}
499         %{__make} -C contrib/src
500         cd ..
501 done
502
503 %if %{with x11}
504 gui='--with-x11'
505 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
506         '--enable-unicode' ; do
507         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
508         mkdir $objdir
509         cd $objdir
510         ../%configure \
511                 ${args} \
512                 ${gui} \
513                 --enable-universal \
514                 ${unicode}
515         %{__make}
516         %{__make} -C contrib/src
517         if echo $objdir| grep -q disable-unicode ; then
518                 %{__make} -C utils
519                 %{__make} -C utils/emulator
520                 %{__make} -C utils/hhp2cached
521                 %{__make} -C contrib/utils
522         fi
523         cd ..
524 done
525 %endif
526
527 cd locale
528 %{__make} allmo
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532 install -d $RPM_BUILD_ROOT%{_bindir}
533
534 gui='--with-gtk'
535 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
536         '--enable-unicode' ; do
537         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
538         cd $objdir
539         %{__make} install \
540                 prefix=$RPM_BUILD_ROOT%{_prefix} \
541                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
542                 bindir=$RPM_BUILD_ROOT%{_bindir} \
543                 datadir=$RPM_BUILD_ROOT%{_datadir} \
544                 libdir=$RPM_BUILD_ROOT%{_libdir} \
545                 mandir=$RPM_BUILD_ROOT%{_mandir} \
546                 includedir=$RPM_BUILD_ROOT%{_includedir}
547
548         %{__make} -C contrib/src install \
549                 prefix=$RPM_BUILD_ROOT%{_prefix} \
550                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
551                 bindir=$RPM_BUILD_ROOT%{_bindir} \
552                 datadir=$RPM_BUILD_ROOT%{_datadir} \
553                 libdir=$RPM_BUILD_ROOT%{_libdir} \
554                 mandir=$RPM_BUILD_ROOT%{_mandir} \
555                 includedir=$RPM_BUILD_ROOT%{_includedir}
556         cd ..
557 done
558
559 %if %{with x11}
560 gui='--with-x11'
561 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
562         '--enable-unicode' ; do
563         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
564         cd $objdir
565         %{__make} install \
566                 prefix=$RPM_BUILD_ROOT%{_prefix} \
567                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
568                 bindir=$RPM_BUILD_ROOT%{_bindir} \
569                 datadir=$RPM_BUILD_ROOT%{_datadir} \
570                 libdir=$RPM_BUILD_ROOT%{_libdir} \
571                 mandir=$RPM_BUILD_ROOT%{_mandir} \
572                 includedir=$RPM_BUILD_ROOT%{_includedir}
573         if echo $objdir| grep -q disable-unicode ; then
574 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
575                 # TODO: install default config files and default backgrouds
576                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
577                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
578                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
579                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
580 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
581                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
582 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
583 #               install -m644 utils/makegen/templates/* \
584 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
585 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
586 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
587 #               install contrib/utils/wxrcedit/df/* \
588 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
589         fi
590
591         %{__make} -C contrib/src install \
592                 prefix=$RPM_BUILD_ROOT%{_prefix} \
593                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
594                 bindir=$RPM_BUILD_ROOT%{_bindir} \
595                 datadir=$RPM_BUILD_ROOT%{_datadir} \
596                 libdir=$RPM_BUILD_ROOT%{_libdir} \
597                 mandir=$RPM_BUILD_ROOT%{_mandir} \
598                 includedir=$RPM_BUILD_ROOT%{_includedir}
599
600         cd ..
601 done
602 %endif
603
604 set -x
605
606 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
607 do
608         b=`basename $i`
609         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
610 done
611
612 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
613 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
614 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
615
616 %find_lang wxstd
617
618 %clean
619 rm -rf $RPM_BUILD_ROOT
620
621 %post   -n wxBase -p /sbin/ldconfig
622 %postun -n wxBase -p /sbin/ldconfig
623
624 %post   -n wxBase-unicode -p /sbin/ldconfig
625 %postun -n wxBase-unicode -p /sbin/ldconfig
626
627 %post   -n wxGTK2 -p /sbin/ldconfig
628 %postun -n wxGTK2 -p /sbin/ldconfig
629
630 %post   -n wxGTK2-gl -p /sbin/ldconfig
631 %postun -n wxGTK2-gl -p /sbin/ldconfig
632
633 %post   -n wxGTK2-unicode -p /sbin/ldconfig
634 %postun -n wxGTK2-unicode -p /sbin/ldconfig
635
636 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
637 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
638
639 %post   -n wxX11 -p /sbin/ldconfig
640 %postun -n wxX11 -p /sbin/ldconfig
641
642 %post   -n wxX11-unicode -p /sbin/ldconfig
643 %postun -n wxX11-unicode -p /sbin/ldconfig
644
645 %define _libf %{?with_debug:d}
646 %define _configf %{?with_debug:-debug-2.6}
647
648
649 %files -f wxstd.lang
650 %defattr(644,root,root,755)
651 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
652
653 %files devel
654 %defattr(644,root,root,755)
655 %doc docs/html
656 %doc docs/tech docs/univ
657 %{_includedir}/wx*
658 %dir %{_libdir}/wx
659 %dir %{_libdir}/wx/include
660 %dir %{_libdir}/wx/config
661 %{_aclocaldir}/*.m4
662
663 %files examples
664 %defattr(644,root,root,755)
665 %{_examplesdir}/%{name}-%{version}
666
667 %if %{with x11}
668 %files HelpGen
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/HelpGen
671 %endif
672
673 %if %{with ansi}
674 %files -n wxBase
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
677 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
678 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
679
680 %files -n wxBase-devel
681 %defattr(644,root,root,755)
682 %{_libdir}/libwx_base%{_libf}-*.so
683 %{_libdir}/libwx_base%{_libf}_*.so
684 %endif
685
686 %files -n wxBase-unicode
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
689 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
690 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
691
692 %files -n wxBase-unicode-devel
693 %defattr(644,root,root,755)
694 %{_libdir}/libwx_baseu%{_libf}-*.so
695 %{_libdir}/libwx_baseu%{_libf}_*.so
696
697 %if %{with ansi}
698 %files -n wxGTK2
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
701 %exclude %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so.*.*
702
703 %files -n wxGTK2-devel
704 %defattr(644,root,root,755)
705 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
706 %exclude %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so
707 %{_libdir}/wx/config/gtk2-ansi-*
708 %{_libdir}/wx/include/gtk2-ansi-*
709 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
710
711 %files -n wxGTK2-gl
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so.*.*
714
715 %files -n wxGTK2-gl-devel
716 %defattr(644,root,root,755)
717 %{_libdir}/libwx_gtk2%{_libf}_ogl-*.so
718 %endif
719
720 %files -n wxGTK2-unicode
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
723 %exclude %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so.*.*
724
725 %files -n wxGTK2-unicode-devel
726 %defattr(644,root,root,755)
727 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
728 %exclude %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so
729 %{_libdir}/wx/config/gtk2-unicode-*
730 %{_libdir}/wx/include/gtk2-unicode-*
731 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
732
733 %files -n wxGTK2-unicode-gl
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so.*.*
736
737 %files -n wxGTK2-unicode-gl-devel
738 %defattr(644,root,root,755)
739 %{_libdir}/libwx_gtk2u%{_libf}_ogl-*.so
740
741 %if %{with x11}
742 %if %{with ansi}
743 %files utils
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_bindir}/*
746 %exclude %{_bindir}/HelpGen
747 %exclude %{_bindir}/wx*-config
748
749 %files -n wxX11
750 %defattr(644,root,root,755)
751 %doc docs/wxX11-readme.txt
752 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
753 %exclude %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so.*.*
754
755 %files -n wxX11-devel
756 %defattr(644,root,root,755)
757 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
758 %exclude %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so
759 %{_libdir}/wx/config/x11univ-ansi-*
760 %{_libdir}/wx/include/x11univ-ansi-*
761 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
762
763 %files -n wxX11-gl
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so.*.*
766
767 %files -n wxX11-gl-devel
768 %defattr(644,root,root,755)
769 %{_libdir}/libwx_x11univ%{_libf}_ogl-*.so
770 %endif
771
772 %files -n wxX11-unicode
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
775 %exclude %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so.*.*
776
777 %files -n wxX11-unicode-devel
778 %defattr(644,root,root,755)
779 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
780 %exclude %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so
781 %{_libdir}/wx/config/x11univ-unicode-*
782 %{_libdir}/wx/include/x11univ-unicode-*
783 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
784
785 %files -n wxX11-unicode-gl
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so.*.*
788
789 %files -n wxX11-unicode-gl-devel
790 %defattr(644,root,root,755)
791 %{_libdir}/libwx_x11univu%{_libf}_ogl-*.so
792 %endif
This page took 0.182567 seconds and 4 git commands to generate.