]> git.pld-linux.org Git - packages/wvstreams.git/commitdiff
- rel 5; patches from FC; use CXXOPTS flags that prevent over optimization problems... auto/th/wvstreams-4.6.1-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 1 Oct 2014 09:38:23 +0000 (11:38 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 1 Oct 2014 09:38:23 +0000 (11:38 +0200)
wvstreams-4.2.2-multilib.patch [new file with mode: 0644]
wvstreams-4.5-noxplctarget.patch [new file with mode: 0644]
wvstreams-4.6.1-gcc47.patch [new file with mode: 0644]
wvstreams-4.6.1-magic.patch [new file with mode: 0644]
wvstreams-4.6.1-make.patch [new file with mode: 0644]
wvstreams-4.6.1-statinclude.patch [new file with mode: 0644]
wvstreams.spec

diff --git a/wvstreams-4.2.2-multilib.patch b/wvstreams-4.2.2-multilib.patch
new file mode 100644 (file)
index 0000000..b9fb8f7
--- /dev/null
@@ -0,0 +1,29 @@
+--- wvstreams-4.5/include/wvautoconf.h.in.multilib
++++ wvstreams-4.5/include/wvautoconf.h.in
+@@ -65,7 +65,7 @@
+ #undef HAVE_LIBCRYPTO
+ /* Whether libc supports __libc_stack_end */
+-#undef HAVE_LIBC_STACK_END
++/* #undef HAVE_LIBC_STACK_END */
+ /* Define to 1 if you have the `pam' library (-lpam). */
+ #undef HAVE_LIBPAM
+@@ -166,7 +166,7 @@
+ #undef HAVE_UNISTD_H
+ /* Define to 1 if you have the <valgrind/memcheck.h> header file. */
+-#undef HAVE_VALGRIND_MEMCHECK_H
++/* #undef HAVE_VALGRIND_MEMCHECK_H */
+ /* Define to 1 if you have the <zlib.h> header file. */
+ #undef HAVE_ZLIB_H
+@@ -201,7 +201,7 @@
+ #undef VERBOSE_PACKAGE_VERSION
+ /* Extra version string. */
+-#undef VER_STRING_EXTRA
++/*#define VER_STRING_EXTRA " (Red Hat Buildsystem)"*/
+ /* Define to enable DBUS support. */
+ #undef WITH_DBUS
diff --git a/wvstreams-4.5-noxplctarget.patch b/wvstreams-4.5-noxplctarget.patch
new file mode 100644 (file)
index 0000000..610ee9e
--- /dev/null
@@ -0,0 +1,11 @@
+diff -urNp wvstreams-4.5-orig/install.mk wvstreams-4.5/install.mk
+--- wvstreams-4.5-orig/install.mk      2008-10-21 17:31:58.000000000 +0200
++++ wvstreams-4.5/install.mk   2008-11-21 16:17:28.000000000 +0100
+@@ -45,3 +45,7 @@ install-uniconfd: uniconf/daemon/uniconf
+ install-wsd: ipstreams/tests/wsd
+       $(INSTALL) -d $(DESTDIR)$(bindir)
+       $(INSTALL_PROGRAM) ipstreams/tests/wsd $(DESTDIR)$(bindir)/
++
++install-xplc: ipstreams/tests/xplctest
++      $(INSTALL) -d $(DESTDIR)$(bindir)
++      $(INSTALL_PROGRAM) ipstreams/tests/xplctest $(DESTDIR)$(bindir)/
diff --git a/wvstreams-4.6.1-gcc47.patch b/wvstreams-4.6.1-gcc47.patch
new file mode 100644 (file)
index 0000000..3d67048
--- /dev/null
@@ -0,0 +1,10 @@
+--- wvstreams-4.6.1-dist/include/wvuid.h       2012-01-05 10:18:58.713661236 +0100
++++ wvstreams-4.6.1/include/wvuid.h    2012-01-05 10:27:42.198435328 +0100
+@@ -7,6 +7,7 @@
+ #ifndef __WVUID_H
+ #define __WVUID_H
++#include <unistd.h>
+ #include "wvstring.h"
+ #if WIN32
diff --git a/wvstreams-4.6.1-magic.patch b/wvstreams-4.6.1-magic.patch
new file mode 100644 (file)
index 0000000..05928a3
--- /dev/null
@@ -0,0 +1,35 @@
+diff -up wvstreams-4.6.1/include/wvtask.h.magic wvstreams-4.6.1/include/wvtask.h
+--- wvstreams-4.6.1/include/wvtask.h.magic     2008-07-14 21:11:35.000000000 +0200
++++ wvstreams-4.6.1/include/wvtask.h   2012-06-03 17:24:47.909187849 +0200
+@@ -45,7 +45,8 @@ class WvTask
+     typedef void TaskFunc(void *userdata);
+     
+     static int taskcount, numtasks, numrunning;
+-    int magic_number, *stack_magic;
++    int volatile magic_number;
++    int *stack_magic;
+     WvString name;
+     int tid;
+     
+@@ -84,7 +85,7 @@ class WvTaskMan
+     static WvTaskMan *singleton;
+     static int links;
+     
+-    static int magic_number;
++    static int volatile magic_number;
+     static WvTaskList all_tasks, free_tasks;
+     
+     static void get_stack(WvTask &task, size_t size);
+diff -up wvstreams-4.6.1/utils/wvtask.cc.magic wvstreams-4.6.1/utils/wvtask.cc
+--- wvstreams-4.6.1/utils/wvtask.cc.magic      2009-05-13 23:42:52.000000000 +0200
++++ wvstreams-4.6.1/utils/wvtask.cc    2012-06-03 14:29:09.729656804 +0200
+@@ -58,7 +58,8 @@ char *alloca ();
+ int WvTask::taskcount, WvTask::numtasks, WvTask::numrunning;
+ WvTaskMan *WvTaskMan::singleton;
+-int WvTaskMan::links, WvTaskMan::magic_number;
++int WvTaskMan::links;
++int volatile WvTaskMan::magic_number;
+ WvTaskList WvTaskMan::all_tasks, WvTaskMan::free_tasks;
+ ucontext_t WvTaskMan::stackmaster_task, WvTaskMan::get_stack_return,
+     WvTaskMan::toplevel;
diff --git a/wvstreams-4.6.1-make.patch b/wvstreams-4.6.1-make.patch
new file mode 100644 (file)
index 0000000..403de64
--- /dev/null
@@ -0,0 +1,51 @@
+diff --git a/Makefile b/Makefile
+index 72c8bef..26cb6df 100644
+--- a/Makefile
++++ b/Makefile
+@@ -235,6 +235,11 @@ TARGETS_A = $(filter %.a,$(TARGETS))
+ all: config.mk $(filter-out $(WV_EXCLUDES), $(TARGETS))
+ TESTS += wvtestmain
++TESTS_DEPS = $(LIBWVSTREAMS)
++ifneq ("$(with_dbus)", "no")
++  TESTS_DEPS += libwvdbus.so
++endif
++$(TESTS): $(TESTS_DEPS)
+ REAL_TESTS = $(filter-out $(TEST_SKIP_OBJS), $(TESTS))
+ $(addsuffix .o,$(REAL_TESTS)):
+diff --git a/wvrules.mk b/wvrules.mk
+index 877f700..921c41b 100644
+--- a/wvrules.mk
++++ b/wvrules.mk
+@@ -158,18 +158,18 @@ endif
+ ../%.o:;      @echo "Object $@ does not exist!"; exit 1
+ /%.a:;                @echo "Library $@ does not exist!"; exit 1
+-%.o: %.c;     $(call wvcc ,$@,$<,$*)
+-%.fpic.o: %.c;        $(call wvcc ,$@,$<,$*,-fPIC)
+-%.o: %.cc;    $(call wvcxx,$@,$<,$*)
+-%.fpic.o: %.cc;       $(call wvcxx,$@,$<,$*,-fPIC)
+-%.o: %.cpp;   $(call wvcxx,$@,$<,$*)
+-%.fpic.o:%.cpp; $(call wvcxx,$@,$<,$*,-fPIC)
+-%.s: %.c;     $(call wvcc ,$@,$<,$*,,-S)
+-%.s: %.cc;    $(call wvcxx,$@,$<,$*,,-S)
+-%.s: %.cpp;   $(call wvcxx,$@,$<,$*,,-S)
+-%.E: %.c;     $(call wvcc,$@,$<,$*,,-E)
+-%.E: %.cc;    $(call wvcxx,$@,$<,$*,,-E)
+-%.E: %.cpp;   $(call wvcxx,$@,$<,$*,,-E)
++%.o: CC %.c;          $(call wvcc ,$@,$<,$*)
++%.fpic.o: CC %.c;     $(call wvcc ,$@,$<,$*,-fPIC)
++%.o: CXX %.cc;                $(call wvcxx,$@,$<,$*)
++%.fpic.o: CXX %.cc;   $(call wvcxx,$@,$<,$*,-fPIC)
++%.o: CXX %.cpp;               $(call wvcxx,$@,$<,$*)
++%.fpic.o: CXX %.cpp;  $(call wvcxx,$@,$<,$*,-fPIC)
++%.s: CC %.c;          $(call wvcc ,$@,$<,$*,,-S)
++%.s: CXX %.cc;                $(call wvcxx,$@,$<,$*,,-S)
++%.s: CXX %.cpp;               $(call wvcxx,$@,$<,$*,,-S)
++%.E: CC %.c;          $(call wvcc,$@,$<,$*,,-E)
++%.E: CXX %.cc;                $(call wvcxx,$@,$<,$*,,-E)
++%.E: CXX %.cpp;               $(call wvcxx,$@,$<,$*,,-E)
+ %.moc: %.h;   $(MOC) -o $@ $<
diff --git a/wvstreams-4.6.1-statinclude.patch b/wvstreams-4.6.1-statinclude.patch
new file mode 100644 (file)
index 0000000..93d3d9e
--- /dev/null
@@ -0,0 +1,24 @@
+diff -urNp wvstreams-4.6.1-orig/include/wvunixdgsocket.h wvstreams-4.6.1/include/wvunixdgsocket.h
+--- wvstreams-4.6.1-orig/include/wvunixdgsocket.h      2008-07-14 21:11:35.000000000 +0200
++++ wvstreams-4.6.1/include/wvunixdgsocket.h   2010-01-13 14:01:13.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <sys/types.h>
+ #include <sys/syslog.h>
+ #include <sys/socket.h>
++#include <sys/stat.h>
+ #include <fcntl.h>
+ #include "wvlog.h"
+diff -urNp wvstreams-4.6.1-orig/streams/wvatomicfile.cc wvstreams-4.6.1/streams/wvatomicfile.cc
+--- wvstreams-4.6.1-orig/streams/wvatomicfile.cc       2009-05-13 23:42:52.000000000 +0200
++++ wvstreams-4.6.1/streams/wvatomicfile.cc    2010-01-13 14:40:30.000000000 +0100
+@@ -11,9 +11,7 @@
+ #include "wvfileutils.h"
+ #include "wvstrutils.h"
+-#ifdef MACOS
+ #include <sys/stat.h>
+-#endif
+ WvAtomicFile::WvAtomicFile(WvStringParm filename, int flags, mode_t create_mode)
+     : tmp_file(WvString::null)
index 4e888f669cfd2819567c2bd9d376d05906a8dfbd..286fb05cafd8af5ec3acbc2a358f11838514a071 100644 (file)
@@ -21,7 +21,7 @@ Summary:      A network programming library written in C++
 Summary(pl.UTF-8):     Biblioteka programowania sieciowego napisana w C++
 Name:          wvstreams
 Version:       4.6.1
-Release:       4
+Release:       5
 License:       LGPL
 Group:         Libraries
 Source0:       http://wvstreams.googlecode.com/files/%{name}-%{version}.tar.gz
@@ -31,6 +31,11 @@ Patch1:              %{name}-cflags.patch
 Patch2:                %{name}-mk.patch
 Patch3:                %{name}-openssl.patch
 Patch4:                %{name}-includes.patch
+Patch5:                %{name}-4.2.2-multilib.patch
+Patch6:                %{name}-4.5-noxplctarget.patch
+Patch7:                %{name}-4.6.1-make.patch
+Patch8:                %{name}-4.6.1-gcc47.patch
+Patch9:                %{name}-4.6.1-magic.patch
 URL:           http://alumnit.ca/wiki/index.php?page=WvStreams
 BuildRequires: autoconf
 BuildRequires: automake
@@ -92,6 +97,11 @@ Statyczna wersja biblioteki wvstreams.
 #%%patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %build
 %configure \
@@ -102,7 +112,9 @@ Statyczna wersja biblioteki wvstreams.
        VPATH=%{_libdir} \
        DEBUG=%{?debug:1}%{!?debug:0} \
        CXX="%{__cxx}" \
-       CFLAGS="%{rpmcflags} -fPIC -DDEBUG=0 \$(OSDEFINE)"
+       VERBOSE=1 \
+       CXXOPTS="%{rpmcxxflags} -fPIC -fpermissive -fno-strict-aliasing -fno-tree-dce -fno-optimize-sibling-calls"
+       COPTS="%{rpmcflags} -fPIC -fPIC -fno-strict-aliasing"
 
 %if %{with doc}
 %{__make} doxygen
This page took 0.144043 seconds and 4 git commands to generate.