]> git.pld-linux.org Git - packages/wpa_supplicant.git/commitdiff
- updated to 2.5
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Nov 2015 19:28:31 +0000 (20:28 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Nov 2015 19:28:31 +0000 (20:28 +0100)
- updated config
- updated generate-libeap-peer patch

wpa_supplicant-0.7.2-generate-libeap-peer.patch
wpa_supplicant.config
wpa_supplicant.spec

index 5f0e1921b309e8780b074a461c11201e0a1ac58d..a719a05290f59416e95b53e8950186a71e10c27f 100644 (file)
@@ -42,9 +42,8 @@ diff --git a/src/eap_peer/Makefile b/src/eap_peer/Makefile
 index 3651056..58c067a 100644
 --- a/src/eap_peer/Makefile
 +++ b/src/eap_peer/Makefile
-@@ -1,11 +1,190 @@
--all:
--      @echo Nothing to be made.
+@@ -1,23 +1,193 @@
+-all: libeap_peer.a
 +LIBEAP_NAME = libeap
 +LIBEAP_CURRENT = 0
 +LIBEAP_REVISION = 0
@@ -84,13 +83,15 @@ index 3651056..58c067a 100644
 +OBJS_both += ../utils/base64.o
 +OBJS_both += ../utils/wpabuf.o
 +OBJS_both += ../utils/eloop.o
-+OBJS_both += ../crypto/md5.o
 +ifneq ($(CONFIG_TLS), openssl)
++OBJS_both += ../crypto/md5.o
 +OBJS_both += ../crypto/sha1.o
 +endif
 +OBJS_both += ../crypto/sha1-tlsprf.o
 +OBJS_both += ../crypto/aes-encblock.o
++ifneq ($(CONFIG_TLS), openssl)
 +OBJS_both += ../crypto/aes-wrap.o
++endif
 +OBJS_both += ../crypto/aes-ctr.o
 +OBJS_both += ../crypto/aes-eax.o
 +OBJS_both += ../crypto/aes-omac1.o
@@ -143,6 +144,7 @@ index 3651056..58c067a 100644
 +override CFLAGS += -DEAP_TLS_OPENSSL
 +OBJS_both += ../crypto/tls_openssl.o
 +OBJS_both += ../crypto/crypto_openssl.o
++OBJS_both += ../crypto/sha256-tlsprf.o
 +LIBS += -lssl -lcrypto
 +override CFLAGS += -DINTERNAL_SHA256
 +endif
@@ -232,15 +234,27 @@ index 3651056..58c067a 100644
 +      rm -f $(DESTDIR)$(LIBDIR)/pkgconfig/libeap0.pc
  
  clean:
--      rm -f *~ *.o *.so *.d *.gcno *.gcda *.gcov
-+      rm -f *~ *.o *.so *.d libeap.a $(LIBEAP) $(OBJS_lib)
+-      rm -f *~ *.o *.so *.d *.gcno *.gcda *.gcov libeap_peer.a
+-
 -install:
 -      if ls *.so >/dev/null 2>&1; then \
 -              install -d $(DESTDIR)$(LIBDIR)/wpa_supplicant && \
 -              cp *.so $(DESTDIR)$(LIBDIR)/wpa_supplicant \
 -      ; fi
-+-include $(OBJS:%.o=%.d)
+-
+-include ../lib.rules
+-
+-CFLAGS += -DIEEE8021X_EAPOL
+-
+-LIB_OBJS= \
+-      eap.o \
+-      eap_methods.o
+-
+-libeap_peer.a: $(LIB_OBJS)
+-      $(AR) crT $@ $?
++      rm -f *~ *.o *.so *.d *.gcno *.gcda *.gcov libeap.a $(LIBEAP) $(OBJS_lib)
+ -include $(OBJS:%.o=%.d)
 diff --git a/src/eap_peer/eap_methods.c b/src/eap_peer/eap_methods.c
 index 3b0af05..092f266 100644
 --- a/src/eap_peer/eap_methods.c
index 9457223d2cc3f05b3ce29e98c3b50c95e96db492..8c5afe003a4fcc8f902ba050ec1df531b03609fa 100644 (file)
@@ -1,39 +1,25 @@
-# Driver interface for Host AP driver
-CONFIG_DRIVER_HOSTAP=y
-
-# Driver interface for Agere driver
-#CONFIG_DRIVER_HERMES=y
-# Change include directories to match with the local setup
-#CFLAGS += -I../../hcf -I../../include -I../../include/hcf
-#CFLAGS += -I../../include/wireless
-
-# Driver interface for madwifi driver
-# Deprecated; use CONFIG_DRIVER_WEXT=y instead.
-#CONFIG_DRIVER_MADWIFI=y
-# Set include directory to the madwifi source tree
-CFLAGS += -I/usr/include/madwifi
-
-# Driver interface for ndiswrapper
-# Deprecated; use CONFIG_DRIVER_WEXT=y instead.
-#CONFIG_DRIVER_NDISWRAPPER=y
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cases, these lines should use += in order not
+# to override previous values of the variables.
 
-# Driver interface for Atmel driver
-CONFIG_DRIVER_ATMEL=y
 
-# Driver interface for old Broadcom driver
-# Please note that the newer Broadcom driver ("hybrid Linux driver") supports
-# Linux wireless extensions and does not need (or even work) with the old
-# driver wrapper. Use CONFIG_DRIVER_WEXT=y with that driver.
-#CONFIG_DRIVER_BROADCOM=y
-# Example path for wlioctl.h; change to match your configuration
-#CFLAGS += -I/opt/WRT54GS/release/src/include
+# Uncomment following two lines and fix the paths if you have installed OpenSSL
+# or GnuTLS in non-default location
+#CFLAGS += -I/usr/local/openssl/include
+#LIBS += -L/usr/local/openssl/lib
 
-# Driver interface for Intel ipw2100/2200 driver
-# Deprecated; use CONFIG_DRIVER_WEXT=y instead.
-CONFIG_DRIVER_IPW=y
+# Some Red Hat versions seem to include kerberos header files from OpenSSL, but
+# the kerberos files are not in the default include path. Following line can be
+# used to fix build issues on such systems (krb5.h not found).
+#CFLAGS += -I/usr/include/kerberos
 
-# Driver interface for Ralink driver
-#CONFIG_DRIVER_RALINK=y
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
 
 # Driver interface for generic Linux wireless extensions
 # Note: WEXT is deprecated in the current Linux kernel version and no new
@@ -46,8 +32,41 @@ CONFIG_DRIVER_WEXT=y
 # Driver interface for Linux drivers using the nl80211 kernel interface
 CONFIG_DRIVER_NL80211=y
 
-# Driver interface for development testing
-#CONFIG_DRIVER_TEST=y
+# driver_nl80211.c requires libnl. If you are compiling it yourself
+# you may need to point hostapd to your version of libnl.
+#
+#CFLAGS += -I$<path to libnl include files>
+#LIBS += -L$<path to libnl library files>
+
+# Use libnl v2.0 (or 3.0) libraries.
+#CONFIG_LIBNL20=y
+
+# Use libnl 3.2 libraries (if this is selected, CONFIG_LIBNL20 is ignored)
+CONFIG_LIBNL32=y
+
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+#LIBS_p += -L/usr/local/lib
+#LIBS_c += -L/usr/local/lib
+
+# Driver interface for Windows NDIS
+#CONFIG_DRIVER_NDIS=y
+#CFLAGS += -I/usr/include/w32api/ddk
+#LIBS += -L/usr/local/lib
+# For native build using mingw
+#CONFIG_NATIVE_WINDOWS=y
+# Additional directories for cross-compilation on Linux host for mingw target
+#CFLAGS += -I/opt/mingw/mingw32/include/ddk
+#LIBS += -L/opt/mingw/mingw32/lib
+#CC=mingw32-gcc
+# By default, driver_ndis uses WinPcap for low-level operations. This can be
+# replaced with the following option which replaces WinPcap calls with NDISUIO.
+# However, this requires that WZC is disabled (net stop wzcsvc) before starting
+# wpa_supplicant.
+# CONFIG_USE_NDISUIO=y
 
 # Driver interface for wired Ethernet drivers
 CONFIG_DRIVER_WIRED=y
@@ -58,6 +77,10 @@ CONFIG_DRIVER_WIRED=y
 # Driver interface for no driver (e.g., WPS ER only)
 #CONFIG_DRIVER_NONE=y
 
+# Solaris libraries
+#LIBS += -lsocket -ldlpi -lnsl
+#LIBS_c += -lsocket
+
 # Enable IEEE 802.1X Supplicant (automatically included if any EAP method is
 # included)
 CONFIG_IEEE8021X_EAPOL=y
@@ -78,10 +101,9 @@ CONFIG_EAP_PEAP=y
 CONFIG_EAP_TTLS=y
 
 # EAP-FAST
-# Note: Default OpenSSL package does not include support for all the
-# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
-# the OpenSSL library must be patched (openssl-0.9.8d-tls-extensions.patch)
-# to add the needed functions.
+# Note: If OpenSSL is used as the TLS library, OpenSSL 1.0 or newer is needed
+# for EAP-FAST support. Older OpenSSL releases would need to be patched, e.g.,
+# with openssl-0.9.8x-tls-extensions.patch, to add the needed functions.
 #CONFIG_EAP_FAST=y
 
 # EAP-GTC
@@ -128,8 +150,6 @@ CONFIG_EAP_GPSK_SHA256=y
 
 # Wi-Fi Protected Setup (WPS)
 #CONFIG_WPS=y
-# Enable WSC 2.0 support
-#CONFIG_WPS2=y
 # Enable WPS external registrar functionality
 #CONFIG_WPS_ER=y
 # Disable credentials for an open network by default when acting as a WPS
@@ -141,6 +161,9 @@ CONFIG_WPS_NFC=y
 # EAP-IKEv2
 #CONFIG_EAP_IKEV2=y
 
+# EAP-EKE
+#CONFIG_EAP_EKE=y
+
 # PKCS#12 (PFX) support (used to read private key and certificate file from
 # a file that usually has extension .p12 or .pfx)
 CONFIG_PKCS12=y
@@ -156,14 +179,19 @@ CONFIG_SMARTCARD=y
 # Support HT overrides (disable HT/HT40, mask MCS rates, etc.)
 #CONFIG_HT_OVERRIDES=y
 
+# Support VHT overrides (disable VHT, mask MCS rates, etc.)
+#CONFIG_VHT_OVERRIDES=y
+
 # Development testing
 #CONFIG_EAPOL_TEST=y
 
 # Select control interface backend for external programs, e.g, wpa_cli:
 # unix = UNIX domain sockets (default for Linux/*BSD)
 # udp = UDP sockets using localhost (127.0.0.1)
+# udp6 = UDP IPv6 sockets using localhost (::1)
 # named_pipe = Windows Named Pipe (default for Windows)
 # udp-remote = UDP sockets with remote access (only for tests systems/purpose)
+# udp6-remote = UDP IPv6 sockets with remote access (only for tests purpose)
 # y = use default (backwards compatibility)
 # If this option is commented out, control interface is not included in the
 # build.
@@ -189,11 +217,6 @@ CONFIG_READLINE=y
 # 35-50 kB in code size.
 #CONFIG_NO_WPA=y
 
-# Remove WPA2 support. This allows WPA to be used, but removes WPA2 code to
-# save about 1 kB in code size when building only WPA-Personal (no EAP support)
-# or 6 kB if building for WPA-Enterprise.
-#CONFIG_NO_WPA2=y
-
 # Remove IEEE 802.11i/WPA-Personal ASCII passphrase support
 # This option can be used to reduce code size by removing support for
 # converting ASCII passphrases into PSK. If this functionality is removed, the
@@ -228,7 +251,7 @@ CONFIG_BACKEND=file
 # main_none = Very basic example (development use only)
 #CONFIG_MAIN=main
 
-# Select wrapper for operatins system and C library specific functions
+# Select wrapper for operating system and C library specific functions
 # unix = UNIX/POSIX like systems (default)
 # win32 = Windows systems
 # none = Empty template
@@ -237,12 +260,14 @@ CONFIG_OS=unix
 # Select event loop implementation
 # eloop = select() loop (default)
 # eloop_win = Windows events and WaitForMultipleObject() loop
-# eloop_none = Empty template
 #CONFIG_ELOOP=eloop
 
 # Should we use poll instead of select? Select is used by default.
 #CONFIG_ELOOP_POLL=y
 
+# Should we use epoll instead of select? Select is used by default.
+CONFIG_ELOOP_EPOLL=y
+
 # Select layer 2 packet implementation
 # linux = Linux packet socket (default)
 # pcap = libpcap/libdnet/WinPcap
@@ -351,6 +376,10 @@ CONFIG_DEBUG_SYSLOG_FACILITY=LOG_DAEMON
 # same file, e.g., using trace-cmd.
 #CONFIG_DEBUG_LINUX_TRACING=y
 
+# Add support for writing debug log to Android logcat instead of standard
+# output
+#CONFIG_ANDROID_LOG=y
+
 # Enable privilege separation (see README 'Privilege separation' for details)
 #CONFIG_PRIVSEP=y
 
@@ -408,7 +437,11 @@ CONFIG_DEBUG_SYSLOG_FACILITY=LOG_DAEMON
 #CONFIG_NO_RANDOM_POOL=y
 
 # IEEE 802.11n (High Throughput) support (mainly for AP mode)
-#CONFIG_IEEE80211N=y
+CONFIG_IEEE80211N=y
+
+# IEEE 802.11ac (Very High Throughput) support (mainly for AP mode)
+# (depends on CONFIG_IEEE80211N)
+CONFIG_IEEE80211AC=y
 
 # Wireless Network Management (IEEE Std 802.11v-2011)
 # Note: This is experimental and not complete implementation.
@@ -423,6 +456,9 @@ CONFIG_DEBUG_SYSLOG_FACILITY=LOG_DAEMON
 # Hotspot 2.0
 CONFIG_HS20=y
 
+# Disable roaming in wpa_supplicant
+#CONFIG_NO_ROAMING=y
+
 # AP mode operations with wpa_supplicant
 # This can be used for controlling AP mode operations with wpa_supplicant. It
 # should be noted that this is mainly aimed at simple cases like
@@ -435,6 +471,14 @@ CONFIG_AP=y
 # more information on P2P operations.
 CONFIG_P2P=y
 
+# Enable TDLS support
+#CONFIG_TDLS=y
+
+# Wi-Fi Direct
+# This can be used to enable Wi-Fi Direct extensions for P2P using an external
+# program to control the additional information exchanges in the messages.
+#CONFIG_WIFI_DISPLAY=y
+
 # Autoscan
 # This can be used to enable automatic scan support in wpa_supplicant.
 # See wpa_supplicant.conf for more information on autoscan usage.
@@ -453,5 +497,11 @@ CONFIG_AUTOSCAN_PERIODIC=y
 # External password backend for testing purposes (developer use)
 #CONFIG_EXT_PASSWORD_TEST=y
 
-# choose libnl 3.2
-CONFIG_LIBNL32=y
+# Enable Fast Session Transfer (FST)
+#CONFIG_FST=y
+
+# Enable CLI commands for FST testing
+#CONFIG_FST_TEST=y
+
+# OS X builds. This is only for building eapol_test.
+#CONFIG_OSX=y
index b8baf00a04e3f3a2d740fa8cb61354f175ca69b6..b252940092536f1e8e4381c4eef177f85cb2e171 100644 (file)
 Summary:       Linux WPA/WPA2/RSN/IEEE 802.1X supplicant
 Summary(pl.UTF-8):     Suplikant WPA/WPA2/RSN/IEEE 802.1X dla Linuksa
 Name:          wpa_supplicant
-Version:       2.3
-Release:       2
+Version:       2.5
+Release:       1
 License:       GPL v2
 Group:         Networking
 Source0:       http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
-# Source0-md5: f2ed8fef72cf63d8d446a2d0a6da630a
+# Source0-md5: 96ff75c3a514f1f324560a2376f13110
 Source1:       %{name}.config
 Source2:       %{name}-wpa_gui.desktop
 Source3:       %{name}.tmpfiles
This page took 0.141621 seconds and 4 git commands to generate.