]> git.pld-linux.org Git - packages/wlroots.git/blob - wlroots.spec
BR: xorg-xserver-Xwayland-devel; explicitly enable xwayland; rel 2
[packages/wlroots.git] / wlroots.spec
1 Summary:        A modular Wayland compositor library
2 Name:           wlroots
3 Version:        0.13.0
4 Release:        2
5 License:        MIT
6 Group:          Libraries
7 Source0:        https://github.com/swaywm/wlroots/releases/download/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  614bfd6dfb47e86699d0215646519ad6
9 Patch0:         x32.patch
10 URL:            https://github.com/swaywm/wlroots
11 BuildRequires:  EGL-devel
12 BuildRequires:  Mesa-libgbm-devel >= 17.1.0
13 BuildRequires:  OpenGLESv2-devel
14 BuildRequires:  libdrm-devel >= 2.4.95
15 BuildRequires:  libinput-devel >= 1.14.0
16 BuildRequires:  libuuid-devel
17 BuildRequires:  libxcb-devel
18 BuildRequires:  meson >= 0.56.0
19 BuildRequires:  ninja
20 BuildRequires:  pixman-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.736
23 BuildRequires:  systemd-devel >= 237
24 BuildRequires:  udev-devel
25 BuildRequires:  wayland-devel >= 1.19
26 BuildRequires:  wayland-protocols >= 1.17
27 BuildRequires:  xcb-util-wm-devel
28 BuildRequires:  xorg-lib-libxkbcommon-devel
29 BuildRequires:  xorg-xserver-Xwayland-devel
30 Requires:       Mesa-libgbm >= 17.1.0
31 Requires:       libdrm >= 2.4.95
32 Requires:       libinput >= 1.14.0
33 Requires:       wayland >= 1.18
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Pluggable, composable, unopinionated modules for building a Wayland
38 compositor; or about 50,000 lines of code you were going to write
39 anyway.
40 - wlroots provides backends that abstract the underlying display and
41   input hardware, including KMS/DRM, libinput, Wayland, X11, and
42   headless backends, plus any custom backends you choose to write, which
43   can all be created or destroyed at runtime and used in concert with
44   each other.
45 - wlroots provides unopinionated, mostly standalone implementations of
46   many Wayland interfaces, both from wayland.xml and various protocol
47   extensions. We also promote the standardization of portable extensions
48   across many compositors.
49 - wlroots provides several powerful, standalone, and optional tools
50   that implement components common to many compositors, such as the
51   arrangement of outputs in physical space.
52 - wlroots provides an Xwayland abstraction that allows you to have
53   excellent Xwayland support without worrying about writing your own X11
54   window manager on top of writing your compositor.
55 - wlroots provides a renderer abstraction that simple compositors can
56   use to avoid writing GL code directly, but which steps out of the way
57   when your needs demand custom rendering code.
58
59 %package devel
60 Summary:        Header files for wlroots library
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       EGL-devel
64 Requires:       Mesa-libgbm-devel >= 17.1.0
65 Requires:       OpenGLESv2-devel
66 Requires:       libdrm-devel >= 2.4.95
67 Requires:       libinput-devel >= 1.14.0
68 Requires:       libxcb-devel
69 Requires:       pixman-devel
70 Requires:       systemd-devel >= 237
71 Requires:       udev-devel
72 Requires:       wayland-devel >= 1.19
73 Requires:       wayland-protocols >= 1.17
74 Requires:       xcb-util-wm-devel
75 Requires:       xorg-lib-libxkbcommon-devel
76
77 %description devel
78 Header files for wlroots library.
79
80 %package static
81 Summary:        Static wlroots library
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static wlroots library.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %meson build \
94         -Dxwayland=enabled
95 %ninja_build -C build
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %ninja_install -C build
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc CONTRIBUTING.md README.md
110 %attr(755,root,root) %{_libdir}/libwlroots.so.8
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libwlroots.so
115 %{_includedir}/wlr
116 %{_pkgconfigdir}/wlroots.pc
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libwlroots.a
This page took 0.108031 seconds and 3 git commands to generate.