]> git.pld-linux.org Git - packages/wine.git/commitdiff
- added programs package with some winelib programs
authorfilon <filon@sokrates.mimuw.edu.pl>
Wed, 27 Feb 2002 21:39:38 +0000 (21:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- make html docs and move some to devel package
- make this spec %%debug aware
- proper post / preun scripts for wine service
- cosmetics
- release 4

Changed files:
    wine.spec -> 1.63

wine.spec

index 534f621344c0f2f10789959496c212bf1180d928..48a5b1b4207eb328f623a680fd2d3b8e6e695b68 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -4,7 +4,7 @@ Summary(pl):    Program pozwalaj
 Summary(pt_BR):        Executa programas Windows no Linux
 Name:          wine
 Version:       20020122
-Release:       2
+Release:       3
 License:       distributable
 Group:         Applications/Emulators
 Source0:       ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
@@ -25,11 +25,12 @@ BuildRequires:      chpax
 Requires:      OpenGL
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _winedir        %{_datadir}/%{name}
-%define no_install_post_strip 1
+%define                _noautoreqdep           libGL.so.1 libGLU.so.1
+%define                no_install_post_strip   1
+
+%define                _prefix                 /usr/X11R6
+%define                _mandir                 %{_prefix}/man
+%define                _winedir                %{_datadir}/%{name}
 
 %description
 Wine is a program which allows running Microsoft Windows programs
@@ -77,20 +78,40 @@ Wine - pliki nag
 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
+%package programs
+Summary:       Wine - programs
+Summary(pl):   Wine - programy
+Group:         Applications
+Requires:      %{name} = %{version}
+
+%description programs
+Wine - programs
+
+%description programs -l pl
+Wine - programy
+
 %prep
 %setup -q
 %patch -p1
+sed -e "s|winetest||" programs/Makefile.in > .tmp
+mv -f .tmp programs/Makefile.in
 
 %build
 %configure2_13 \
-       --disable-debug \
-       --disable-trace \
+%{!?debug:     --disable-debug} \
+%{!?debug:     --disable-trace} \
        --enable-curses \
        --enable-opengl \
        --with-x
 
 %{__make} depend
 %{__make}
+%{__make} -C programs
+
+(cd documentation
+./db2html-winehq wine-user.sgml
+./db2html-winehq wine-devel.sgml
+./db2html-winehq winelib-user.sgml)
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -111,6 +132,13 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
        mandir=$RPM_BUILD_ROOT%{_mandir} \
        infodir=$RPM_BUILD_ROOT%{_infodir}
 
+%{__make} -C programs install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+        bindir=$RPM_BUILD_ROOT%{_bindir}
+
+(cd $RPM_BUILD_ROOT%{_bindir}
+find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
@@ -140,6 +168,7 @@ EOF
 
 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
 
+%if %{?debug:0}%{!?debug:1}
 echo "Strip executable binaries and shared object files."
 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
 elfexelist=`echo $filelist | xargs -r file | \
@@ -152,19 +181,33 @@ fi
 if [ -n "$elfsharedlist" ]; then
        strip --strip-unneeded -R .note  -R .comment $elfsharedlist
 fi
+%endif
 
 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post
+/sbin/ldconfig
+/sbin/chkconfig --add wine
+echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/wine ]; then
+               /etc/rc.d/init.d/wine stop >&2
+       fi
+       /sbin/chkconfig --del wine
+fi
+
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
-%doc documentation
+%doc *.gz
+%doc documentation/wine-user
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/*.so*
 %{_mandir}/man[15]/*
@@ -174,7 +217,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
 %{_winedir}
 
+%files programs -f programs.list
+%defattr(644,root,root,755)
+%{_bindir}/*.so
+#%%attr(755,root,root) %%{_bindir}/{%%(ls *.so | sed s/\.so/,/g | sed s/,$//)}
+
 %files devel
 %defattr(644,root,root,755)
+%doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
 %{_includedir}/wine
 %{_libdir}/*.a
This page took 0.267394 seconds and 4 git commands to generate.