]> git.pld-linux.org Git - packages/wine.git/commitdiff
- installed ugly workaround for strip removing elf flags (notified binutils
authorMichal Moskal <michal@moskal.me>
Tue, 11 Dec 2001 15:00:50 +0000 (15:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  maintainer)

Changed files:
    wine.spec -> 1.52

wine.spec

index f9ed2b66b18f0bda25365457a857227e2f1655dc..a7daf6c09c07d84a6bf7055d8686d059ea9170f1 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -32,6 +32,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _mandir         %{_prefix}/man
 %define                _winedir        %{_datadir}/%{name}
 
+%define                no_install_post_strip   1
+
 %description
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
@@ -145,10 +147,21 @@ vcr=mciviscd.drv
 MPEGVideo=mciqtz.drv
 EOF
 
-chpax -p $RPM_BUILD_ROOT/%{_bindir}/wine
 
 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
 
+filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
+elfexelist=`echo $filelist | xargs -r file | awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
+elfsharedlist=`echo $filelist | xargs -r file | awk '/LF.*shared object/ {print $1}' | cut -d: -f1`
+if [ -n "$elfexelist" ]; then 
+       strip --remove-section=.note  --remove-section=.comment $elfexelist
+fi
+if [ -n "$elfsharedlist" ]; then 
+       strip --strip-unneeded --remove-section=.note  --remove-section=.comment $elfsharedlist
+fi
+
+chpax -p $RPM_BUILD_ROOT/%{_bindir}/wine
+
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
This page took 0.080286 seconds and 4 git commands to generate.