]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- rel 3; enable 64bit wine
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_with     esd             # build ESD mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # TODO:
11 # - support for CAPI (ISDN support; --with-capi)
12 #
13 # NOTE: wine detects the following SONAMES for dlopen at build time:
14 #   libcrypto,libssl (wininet.dll)
15 #   libcups (winspool.dll.so,wineps.dll.so)
16 #   libcurses/libncurses (wineconsole program)
17 #   libfontconfig (gdi32.dll.so)
18 #   libfreetype (wineps.dll.so,gdi32.dll.so)
19 #   libGL (x11drv.dll.so,ddraw.dll.so)
20 #   libjack (winejack.drv.so - explicit dependency in subpackage)
21 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
22 # thus requires rebuild after change of any of the above.
23 #
24 # JACK requires ALSA
25 %if %{without alsa}
26 %undefine       with_jack
27 %endif
28
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.2.2
35 Release:        3
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  e976d64688e0833061e79efa3eac5d2c
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
42 # Source1-md5:  9c5c335fc077c0558561afaf25a09e51
43 Source2:        %{name}-uninstaller.desktop
44 Patch0:         %{name}-fontcache.patch
45 Patch1:         %{name}-makedep.patch
46 Patch2:         %{name}-ncurses.patch
47 Patch4:         %{name}-disable-valgrind.patch
48 Patch5:         %{name}-ca_certificates.patch
49 Patch6:         %{name}-notarget.patch
50 Patch7:         %{name}-manpaths.patch
51 Patch8:         desktop.patch
52 #PatchX:        %{name}-dga.patch
53 URL:            http://www.winehq.org/
54 BuildRequires:  OpenAL-devel >= 1.1
55 BuildRequires:  OpenGL-GLU-devel
56 %{?with_alsa:BuildRequires:     alsa-lib-devel}
57 %{?with_arts:BuildRequires:     artsc-devel}
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 BuildRequires:  bison
61 %{?with_cups:BuildRequires:     cups-devel}
62 BuildRequires:  docbook-dtd31-sgml
63 BuildRequires:  docbook-utils
64 %{?with_esd:BuildRequires:      esound-devel}
65 BuildRequires:  flex
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  fontforge
68 BuildRequires:  freetype-devel >= 2.0.5
69 BuildRequires:  giflib-devel
70 BuildRequires:  gnutls-devel
71 BuildRequires:  hal-devel
72 BuildRequires:  icoutils
73 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
74 BuildRequires:  lcms-devel
75 BuildRequires:  libgphoto2-devel
76 BuildRequires:  libgsm-devel
77 BuildRequires:  libjpeg-devel
78 BuildRequires:  libmpg123-devel >= 1.5.0
79 BuildRequires:  libtool
80 BuildRequires:  libv4l-devel
81 BuildRequires:  libxslt-devel
82 %{?with_nas:BuildRequires:      nas-devel}
83 BuildRequires:  ncurses-devel
84 # db2* failed previously - probably openjade or opensp bug
85 BuildRequires:  openjade >= 1:1.3.3-0.pre1
86 BuildRequires:  openldap-devel
87 BuildRequires:  opensp >= 1:1.5.1
88 BuildRequires:  openssl-devel >= 0.9.7d
89 BuildRequires:  pkgconfig
90 %{?with_sane:BuildRequires:     sane-backends-devel}
91 BuildRequires:  unixODBC-devel >= 2.2.12-2
92 #BuildRequires: valgrind
93 BuildRequires:  xorg-lib-libXcomposite-devel
94 BuildRequires:  xorg-lib-libXcursor-devel
95 BuildRequires:  xorg-lib-libXi-devel
96 BuildRequires:  xorg-lib-libXinerama-devel
97 BuildRequires:  xorg-lib-libXmu-devel
98 BuildRequires:  xorg-lib-libXrandr-devel
99 BuildRequires:  xorg-lib-libXrender-devel
100 BuildRequires:  xorg-lib-libXxf86dga-devel
101 BuildRequires:  xorg-lib-libXxf86vm-devel
102 Requires:       libfreetype.so.6
103 Suggests:       binfmt-detector
104 Suggests:       ca-certificates
105 Conflicts:      ca-certificates < 20080809-4
106 # for printing needs lpr
107 Suggests:       cups-clients
108 # for winelauncher
109 Suggests:       xorg-app-xmessage
110 # for ntlm_auth
111 Suggests:       samba-common >= 1:3.0.25
112 # link to wine/ntdll.dll.so, without any SONAME
113 Provides:       libntdll.dll.so
114 Obsoletes:      wine-doc-pdf
115 Obsoletes:      wine-drv-arts
116 ExclusiveArch:  %{ix86} %{x8664}
117 ExcludeArch:    i386
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
121 %define         no_install_post_strip   1
122
123 %define         _winedir                %{_datadir}/%{name}
124
125 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
126
127 %undefine       debuginfocflags
128
129 %description
130 Wine is a program which allows running Microsoft Windows programs
131 (including DOS, Windows 3.x and Win32 executables) on Unix. It
132 consists of a program loader which loads and executes a Microsoft
133 Windows binary, and a library that implements Windows API calls using
134 their Unix or X11 equivalents. The library may also be used for
135 porting Win32 code into native Unix executables.
136
137 %description -l es.UTF-8
138 Ejecuta programas Windows en Linux.
139
140 %description -l pl.UTF-8
141 Wine jest programem dzięki któremu można uruchamiać programy napisane
142 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
143 loadera, który pozwala wczytywać i uruchamiać programy w formacie
144 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
145 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
146 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
147
148 %description -l pt_BR.UTF-8
149 O Wine é um programa que permite rodar programas MS-Windows no X11.
150 Ele consiste de um carregador de programa, que carrega e executa um
151 binário MS-Windows, e de uma biblioteca de emulação que traduz as
152 chamadas da API para as equivalentes Unix/X11.
153
154 %package devel
155 Summary:        Wine - header files
156 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
157 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
158 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
159 Group:          Development/Libraries
160 Requires:       %{name} = %{epoch}:%{version}-%{release}
161
162 %description devel
163 Wine - header files.
164
165 %description devel -l es.UTF-8
166 Biblioteca de desarrollo de wine.
167
168 %description devel -l pl.UTF-8
169 Wine - pliki nagłówkowe.
170
171 %description devel -l pt_BR.UTF-8
172 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
173 WINE.
174
175 %package programs
176 Summary:        Wine - programs
177 Summary(pl.UTF-8):      Wine - programy
178 Group:          Applications
179 Requires:       %{name} = %{epoch}:%{version}-%{release}
180
181 %description programs
182 Wine - programs.
183
184 %description programs -l pl.UTF-8
185 Wine - programy.
186
187 %package dll-d3d
188 Summary:        Direct3D implementation DLLs for Wine
189 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
190 Group:          Applications/Emulators
191 Requires:       %{name} = %{epoch}:%{version}-%{release}
192 Requires:       OpenGL
193
194 %description dll-d3d
195 Direct3D implementation DLLs for Wine (through OpenGL).
196
197 %description dll-d3d -l pl.UTF-8
198 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
199
200 %package dll-gl
201 Summary:        OpenGL implementation DLLs for Wine
202 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
203 Group:          Applications/Emulators
204 Requires:       %{name} = %{epoch}:%{version}-%{release}
205 Requires:       OpenGL
206
207 %description dll-gl
208 OpenGL implementation DLLs for Wine.
209
210 %description dll-gl -l pl.UTF-8
211 Biblioteki DLL z implementacją OpenGL dla Wine.
212
213 %package dll-twain
214 Summary:        TWAIN implementation DLL for Wine
215 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
216 Group:          Applications/Emulators
217 Requires:       %{name} = %{epoch}:%{version}-%{release}
218
219 %description dll-twain
220 TWAIN implementation DLL for Wine (through SANE).
221
222 %description dll-twain -l pl.UTF-8
223 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
224
225 %package drv-alsa
226 Summary:        ALSA driver for WINE mm.dll implementation
227 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
228 Group:          Applications/Emulators
229 Requires:       %{name} = %{epoch}:%{version}-%{release}
230
231 %description drv-alsa
232 ALSA driver for WINE mm.dll (multimedia system) implementation.
233
234 %description drv-alsa -l pl.UTF-8
235 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
236
237 %package drv-jack
238 Summary:        JACK driver for WINE mm.dll implementation
239 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
240 Group:          Applications/Emulators
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242 Requires:       jack-audio-connection-kit
243 # dlopened by SONAME detected at build time
244 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
245
246 %description drv-jack
247 JACK driver for WINE mm.dll (multimedia system) implementation.
248
249 %description drv-jack -l pl.UTF-8
250 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
251 Wine.
252
253 %package drv-nas
254 Summary:        NAS driver for WINE mm.dll implementation
255 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
256 Group:          Applications/Emulators
257 Requires:       %{name} = %{epoch}:%{version}-%{release}
258
259 %description drv-nas
260 NAS driver for WINE mm.dll (multimedia system) implementation.
261
262 %description drv-nas -l pl.UTF-8
263 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
264
265 %prep
266 %setup -q
267 %patch0 -p1
268 %patch1 -p1
269 %patch2 -p1
270 %patch4 -p1
271 %patch5 -p1
272 %patch6 -p1
273 %patch7 -p1
274 %patch8 -p1
275
276 %build
277 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
278 mv -f oic_winlogo_*.png %{name}.png
279
280 %{__autoconf}
281 %{__autoheader}
282 %configure \
283 %ifarch %{x8664}
284         --enable-win64 \
285 %endif
286         --with%{!?with_alsa:out}-alsa \
287         --with-audioio \
288         --without-capi \
289         --with-cms \
290         --with-coreaudio \
291         --with%{!?with_cups:out}-cups \
292         --with-curses \
293         --with%{!?with_esd:out}-esd \
294         --with-fontconfig \
295         --with-freetype \
296         --with-glu \
297         --with-gnutls \
298         --with-gphoto \
299         --with-gsm \
300         --with-hal \
301         --with%{!?with_jack:out}-jack \
302         --with-jpeg \
303         --with-ldap \
304         --with-mpg123 \
305         --with%{!?with_nas:out}-nas \
306         --with-opengl \
307         --with-openssl \
308         --with-oss \
309         --with-png \
310         --with-pthread \
311         --with%{!?with_sane:out}-sane \
312         --with-xcomposite \
313         --with-xcursor \
314         --with-xinerama \
315         --with-xinput \
316         --with-xml \
317         --with-xrandr \
318         --with-xrender \
319         --with-xshape \
320         --with-xshm \
321         --with-xslt \
322         --with-xxf86vm \
323         --with-x
324 %{__make} depend
325 %{__make}
326
327 %install
328 rm -rf $RPM_BUILD_ROOT
329 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
330 %{__make} install \
331         DESTDIR=$RPM_BUILD_ROOT
332
333 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
334 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
335
336 install -d \
337         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
338         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
339         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
340         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
341         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
342
343 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
344 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
345 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
346
347 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
348 [mci]
349 cdaudio=mcicda.drv
350 sequencer=mciseq.drv
351 waveaudio=mciwave.drv
352 avivideo=mciavi.drv
353 videodisc=mcipionr.drv
354 vcr=mciviscd.drv
355 MPEGVideo=mciqtz.drv
356 EOF
357
358 %if %{?debug:0}%{!?debug:1}
359 echo "Strip executable binaries and shared object files."
360 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
361 elfexelist=`echo $filelist | xargs -r file | \
362         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
363 elfsharedlist=`echo $filelist | xargs -r file | \
364         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
365 if [ -n "$elfexelist" ]; then \
366         strip -R .note -R .comment $elfexelist
367 fi
368 if [ -n "$elfsharedlist" ]; then
369         strip --strip-unneeded -R .note -R .comment $elfsharedlist
370 fi
371 %endif
372
373 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
374
375 dir=$(pwd)
376 > files.so
377 > files.programs
378 cd $RPM_BUILD_ROOT%{_libdir}/wine
379 for f in *.so; do
380         case $f in
381         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
382                 ;;
383         *)
384                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
385         esac
386 done
387 cd -
388
389 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
390 for p in $programs; do
391         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
392         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
393         echo "%{_mandir}/man1/$p.1*" >> files.programs
394         grep -v "$p\.exe\.so$" files.so > files.so.
395         mv -f files.so. files.so
396 done
397
398 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
399 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
400
401 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
402 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
403 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
404
405 %clean
406 rm -rf $RPM_BUILD_ROOT
407
408 %post   -p /sbin/ldconfig
409 %postun -p /sbin/ldconfig
410
411 %triggerpostun -- wine < 1:0.9.12-1.9
412 rm -f /var/lock/subsys/wine
413 if [ -x /sbin/chkconfig ]; then
414         /sbin/chkconfig --del wine
415 fi
416
417 %files -f files.so
418 %defattr(644,root,root,755)
419 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
420 %lang(de) %doc documentation/README.de
421 %lang(es) %doc documentation/README.es
422 %lang(fr) %doc documentation/README.fr
423 %lang(hu) %doc documentation/README.hu
424 %lang(it) %doc documentation/README.it
425 %lang(ko) %doc documentation/README.ko
426 %lang(nb) %doc documentation/README.no
427 %lang(pt) %doc documentation/README.pt
428 %lang(pt_BR) %doc documentation/README.pt_br
429 %lang(ru) %doc documentation/README.ru
430 %lang(sv) %doc documentation/README.sv
431 %lang(tr) %doc documentation/README.tr
432 %attr(755,root,root) %{_bindir}/msiexec
433 %attr(755,root,root) %{_bindir}/wineboot
434 %attr(755,root,root) %{_bindir}/winedbg
435 %attr(755,root,root) %{_bindir}/winecfg
436 %attr(755,root,root) %{_bindir}/wineserver
437 %ifarch %{x8664}
438 %attr(755,root,root) %{_bindir}/wine64
439 %else
440 %attr(755,root,root) %{_bindir}/wine
441 %attr(755,root,root) %{_bindir}/wine-preloader
442 %endif
443 %attr(755,root,root) %{_libdir}/*.so*
444 %dir %{_libdir}/wine
445 %dir %{_libdir}/wine/fakedlls
446 %{_libdir}/wine/fakedlls/*.acm
447 %{_libdir}/wine/fakedlls/*.cpl
448 %{_libdir}/wine/fakedlls/*.dll
449 %{_libdir}/wine/fakedlls/*.drv
450 %{_libdir}/wine/fakedlls/*.ds
451 %{_libdir}/wine/fakedlls/*.exe
452 %{_libdir}/wine/fakedlls/*.ocx
453 %{_libdir}/wine/fakedlls/*.sys
454 %{_libdir}/wine/fakedlls/*.tlb
455 %ifarch %{ix86}
456 %{_libdir}/wine/fakedlls/*.dll16
457 %{_libdir}/wine/fakedlls/*.drv16
458 %{_libdir}/wine/fakedlls/*.exe16
459 %{_libdir}/wine/fakedlls/*.mod16
460 %{_libdir}/wine/fakedlls/*.vxd
461 %endif
462 %{_mandir}/man1/wine.1*
463 %{_mandir}/man1/msiexec.1*
464 %{_mandir}/man1/wineboot.1*
465 %{_mandir}/man1/winecfg.1*
466 %lang(de) %{_mandir}/de/man1/wine.1*
467 %lang(fr) %{_mandir}/fr/man1/wine.1*
468 %{_mandir}/man1/winedbg.1*
469 %{_mandir}/man1/wineserver.1*
470 %lang(de) %{_mandir}/de/man1/wineserver.1*
471 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
472 %{_winedir}
473 %{_desktopdir}/wine.desktop
474 %{_desktopdir}/wine-uninstaller.desktop
475 %{_pixmapsdir}/%{name}.png
476
477 %files programs -f files.programs
478 %defattr(644,root,root,755)
479
480 %files devel
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_bindir}/fnt2bdf
483 %attr(755,root,root) %{_bindir}/function_grep.pl
484 %attr(755,root,root) %{_bindir}/widl
485 %attr(755,root,root) %{_bindir}/winebuild
486 %attr(755,root,root) %{_bindir}/winedump
487 %attr(755,root,root) %{_bindir}/wineg++
488 %attr(755,root,root) %{_bindir}/winegcc
489 %attr(755,root,root) %{_bindir}/winemaker
490 %attr(755,root,root) %{_bindir}/winecpp
491 %attr(755,root,root) %{_bindir}/wmc
492 %attr(755,root,root) %{_bindir}/wrc
493 %{_libdir}/wine/lib*.def
494 # no shared variants, so not separated
495 %{_libdir}/wine/lib*.def.a
496 %{_libdir}/wine/libadsiid.a
497 %{_libdir}/wine/libdx*.a
498 %{_libdir}/wine/libstrmiids.a
499 %{_libdir}/wine/libuuid.a
500 %{_libdir}/wine/libwinecrt0.a
501 %{_includedir}/wine
502 %{_mandir}/man1/widl.1*
503 %{_mandir}/man1/winebuild.1*
504 %{_mandir}/man1/winecpp.1*
505 %{_mandir}/man1/winedump.1*
506 %{_mandir}/man1/winegcc.1*
507 %{_mandir}/man1/wineg++.1*
508 %{_mandir}/man1/winemaker.1*
509 %lang(de) %{_mandir}/de/man1/winemaker.1*
510 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
511 %{_mandir}/man1/wmc.1*
512 %{_mandir}/man1/wrc.1*
513 %{_aclocaldir}/*.m4
514
515 %files dll-d3d
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
518 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
519 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
520
521 %files dll-gl
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
524 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
525
526 %if %{with sane}
527 %files dll-twain
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
530 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
531 %endif
532
533 %if %{with alsa}
534 %files drv-alsa
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
537 %endif
538
539 %if %{with jack}
540 %files drv-jack
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
543 %endif
544
545 %if %{with nas}
546 %files drv-nas
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
549 %endif
550
551 # additional dependencies in *.so not separated (yet?) from main package
552 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
553 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
554 #   ttydrv.dll.so depends on ncurses
This page took 0.05762 seconds and 4 git commands to generate.