]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
'configure' options and dependencies updated
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 %bcond_without  netapi          # don't use the Samba NetAPI library
10 #
11 # NOTE: wine detects the following SONAMES for dlopen at build time:
12 #   libcrypto,libssl (wininet.dll)
13 #   libcups (winspool.dll.so,wineps.dll.so)
14 #   libcurses/libncurses (wineconsole program)
15 #   libfontconfig (gdi32.dll.so)
16 #   libfreetype (wineps.dll.so,gdi32.dll.so)
17 #   libGL (x11drv.dll.so,ddraw.dll.so)
18 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
19 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
20 # thus requires rebuild after change of any of the above.
21
22 # library qualifier in rpm generated deps
23 %ifarch %{x8664} ia64 ppc64 s390x sparc64
24 %define libqual ()(64bit)
25 %else
26 %define libqual %{nil}
27 %endif
28
29 %define         gecko_ver       2.24
30 Summary:        Program that lets you launch Win applications
31 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
32 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
33 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
34 Name:           wine
35 # 1.6.x – stable
36 # 1.7.x – development (DEVEL branch)
37 Version:        1.7.18
38 Release:        0.1
39 Epoch:          1
40 License:        LGPL
41 Group:          Applications/Emulators
42 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
43 # Source0-md5:  b13c19ef69a99f2aa6c0b3fd08ae8d90
44 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
45 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
46 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
47 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
48 Source3:        %{name}-uninstaller.desktop
49 Patch0:         %{name}-gphoto2_bool.patch
50 Patch1:         %{name}-makedep.patch
51 Patch2:         %{name}-ncurses.patch
52 Patch4:         %{name}-disable-valgrind.patch
53 Patch5:         %{name}-ca_certificates.patch
54 Patch6:         %{name}-manpaths.patch
55 Patch7:         desktop.patch
56 Patch8:         %{name}-wine64_man.patch
57 URL:            http://www.winehq.org/
58 BuildRequires:  OpenAL-devel >= 1.1
59 BuildRequires:  ocl-icd-libOpenCL-devel
60 BuildRequires:  OpenGL-GLU-devel
61 BuildRequires:  Mesa-libOSMesa-devel
62 %{?with_alsa:BuildRequires:     alsa-lib-devel}
63 %{?with_arts:BuildRequires:     artsc-devel}
64 BuildRequires:  autoconf
65 BuildRequires:  automake
66 BuildRequires:  bison
67 %{?with_capi:BuildRequires:     capi4k-utils-devel}
68 %{?with_cups:BuildRequires:     cups-devel}
69 BuildRequires:  dbus-devel
70 BuildRequires:  docbook-dtd31-sgml
71 BuildRequires:  docbook-utils
72 BuildRequires:  flex
73 BuildRequires:  fontconfig-devel
74 BuildRequires:  fontforge
75 BuildRequires:  freetype-devel >= 2.0.5
76 BuildRequires:  fslint
77 BuildRequires:  gettext-devel
78 BuildRequires:  giflib-devel
79 BuildRequires:  gnutls-devel
80 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel}
81 BuildRequires:  icoutils
82 BuildRequires:  lcms2-devel
83 BuildRequires:  libgphoto2-devel
84 BuildRequires:  libgsm-devel
85 BuildRequires:  libjpeg-devel
86 BuildRequires:  libmpg123-devel >= 1.5.0
87 BuildRequires:  libtool
88 BuildRequires:  libv4l-devel
89 BuildRequires:  libxslt-devel
90 BuildRequires:  ncurses-devel
91 # db2* failed previously - probably openjade or opensp bug
92 BuildRequires:  libpng-devel >= 1.5
93 BuildRequires:  openjade >= 1:1.3.3-0.pre1
94 %{?with_ldap:BuildRequires:     openldap-devel}
95 BuildRequires:  opensp >= 1:1.5.1
96 BuildRequires:  openssl-devel >= 0.9.7d
97 BuildRequires:  pkgconfig
98 BuildRequires:  prelink
99 BuildRequires:  samba-devel
100 %{?with_sane:BuildRequires:     sane-backends-devel}
101 BuildRequires:  unixODBC-devel >= 2.2.12-2
102 #BuildRequires: valgrind
103 BuildRequires:  xorg-lib-libXcomposite-devel
104 BuildRequires:  xorg-lib-libXcursor-devel
105 BuildRequires:  xorg-lib-libXi-devel
106 BuildRequires:  xorg-lib-libXinerama-devel
107 BuildRequires:  xorg-lib-libXmu-devel
108 BuildRequires:  xorg-lib-libXrandr-devel
109 BuildRequires:  xorg-lib-libXrender-devel
110 BuildRequires:  xorg-lib-libXxf86dga-devel
111 BuildRequires:  xorg-lib-libXxf86vm-devel
112 Requires:       libfreetype.so.6%{libqual}
113 Requires:       libpng16.so.16%{libqual}
114 Requires(post): /sbin/ldconfig
115 Suggests:       binfmt-detector
116 Suggests:       ca-certificates
117 Suggests:       cabextract
118 Conflicts:      ca-certificates < 20080809-4
119 # for printing needs lpr
120 Suggests:       cups-clients
121 # for winelauncher
122 Suggests:       xorg-app-xmessage
123 # for ntlm_auth
124 Suggests:       samba-common >= 1:3.0.25
125 # link to wine/ntdll.dll.so, without any SONAME
126 Provides:       libntdll.dll.so
127 Obsoletes:      wine-doc-pdf
128 Obsoletes:      wine-drv-arts
129 Obsoletes:      wine-drv-jack
130 Obsoletes:      wine-drv-nas
131 ExclusiveArch:  %{ix86} %{x8664}
132 ExcludeArch:    i386
133 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
134
135 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
136 %define         no_install_post_strip   1
137
138 %define         _winedir                %{_datadir}/%{name}
139
140 %description
141 Wine is a program which allows running Microsoft Windows programs
142 (including DOS, Windows 3.x and Win32 executables) on Unix. It
143 consists of a program loader which loads and executes a Microsoft
144 Windows binary, and a library that implements Windows API calls using
145 their Unix or X11 equivalents. The library may also be used for
146 porting Win32 code into native Unix executables.
147
148 %description -l es.UTF-8
149 Ejecuta programas Windows en Linux.
150
151 %description -l pl.UTF-8
152 Wine jest programem dzięki któremu można uruchamiać programy napisane
153 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
154 loadera, który pozwala wczytywać i uruchamiać programy w formacie
155 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
156 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
157 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
158
159 %description -l pt_BR.UTF-8
160 O Wine é um programa que permite rodar programas MS-Windows no X11.
161 Ele consiste de um carregador de programa, que carrega e executa um
162 binário MS-Windows, e de uma biblioteca de emulação que traduz as
163 chamadas da API para as equivalentes Unix/X11.
164
165 %package devel
166 Summary:        Wine - header files
167 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
168 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
169 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
170 Group:          Development/Libraries
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172
173 %description devel
174 Wine - header files.
175
176 %description devel -l es.UTF-8
177 Biblioteca de desarrollo de wine.
178
179 %description devel -l pl.UTF-8
180 Wine - pliki nagłówkowe.
181
182 %description devel -l pt_BR.UTF-8
183 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
184 WINE.
185
186 %package programs
187 Summary:        Wine - programs
188 Summary(pl.UTF-8):      Wine - programy
189 Group:          Applications
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191
192 %description programs
193 Wine - programs.
194
195 %description programs -l pl.UTF-8
196 Wine - programy.
197
198 %package dll-capi
199 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
200 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
201 Group:          Applications/Emulators
202 Requires:       %{name} = %{epoch}:%{version}-%{release}
203
204 %description dll-capi
205 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
206
207 %description dll-capi -l pl.UTF-8
208 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
209 OpenGL).
210
211 %package dll-d3d
212 Summary:        Direct3D implementation DLLs for Wine
213 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
214 Group:          Applications/Emulators
215 Requires:       %{name} = %{epoch}:%{version}-%{release}
216 Requires:       OpenGL
217
218 %description dll-d3d
219 Direct3D implementation DLLs for Wine (through OpenGL).
220
221 %description dll-d3d -l pl.UTF-8
222 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
223
224 %package dll-gl
225 Summary:        OpenGL implementation DLLs for Wine
226 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
227 Group:          Applications/Emulators
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229 Requires:       OpenGL
230
231 %description dll-gl
232 OpenGL implementation DLLs for Wine.
233
234 %description dll-gl -l pl.UTF-8
235 Biblioteki DLL z implementacją OpenGL dla Wine.
236
237 %package dll-twain
238 Summary:        TWAIN implementation DLL for Wine
239 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
240 Group:          Applications/Emulators
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242
243 %description dll-twain
244 TWAIN implementation DLL for Wine (through SANE).
245
246 %description dll-twain -l pl.UTF-8
247 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
248
249 %package dll-ldap
250 Summary:        Win32 LDAP API DLL for Wine
251 Group:          Applications/Emulators
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253
254 %description dll-ldap
255 Lightweight Directory Access Protocol Library.
256
257 %package drv-alsa
258 Summary:        ALSA driver for WINE mm.dll implementation
259 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
260 Group:          Applications/Emulators
261 Requires:       %{name} = %{epoch}:%{version}-%{release}
262
263 %description drv-alsa
264 ALSA driver for WINE mm.dll (multimedia system) implementation.
265
266 %description drv-alsa -l pl.UTF-8
267 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
268
269 %prep
270 %setup -q
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch4 -p1
275 %patch5 -p1
276 %patch6 -p1
277 %patch7 -p1
278 %ifarch %{x8664}
279 %patch8 -p1
280 %endif
281
282 %build
283 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
284 mv -f oic_winlogo_*.png %{name}.png
285
286 %{__autoconf}
287 %{__autoheader}
288 %configure \
289 %ifarch %{x8664}
290         --enable-win64 \
291 %endif
292         --with%{!?with_alsa:out}-alsa \
293         --with%{!?with_capi:out}-capi \
294         --with-cms \
295         --with-coreaudio \
296         --with%{!?with_cups:out}-cups \
297         --with-curses \
298         --with-dbus \
299         --with-fontconfig \
300         --with-freetype \
301         --with-gphoto \
302         --with-glu \
303         --with-gnutls \
304         --with-gsm \
305         --with%{!?with_gstreamer:out}-gstreamer \
306         --without-hal \
307         --with-jpeg \
308         --with%{!?with_ldap:out}-ldap \
309         --with-mpg123 \
310         --with%{!?with_netapi:out}-netapi \
311         --with-openal \
312         --with-opencl \
313         --with-opengl \
314         --with-openssl \
315         --with-osmesa \
316         --with-oss \
317         --with-png \
318         --with-pthread \
319         --with%{!?with_sane:out}-sane \
320         --with-tiff \
321         --with-v4l \
322         --with-xcomposite \
323         --with-xcursor \
324         --with-xinerama \
325         --with-xinput \
326         --with-xinput2 \
327         --with-xml \
328         --with-xrandr \
329         --with-xrender \
330         --with-xshape \
331         --with-xshm \
332         --with-xslt \
333         --with-xxf86vm \
334         --with-x \
335         --with-zlib
336 %{__make} depend
337 %{__make}
338
339 %install
340 rm -rf $RPM_BUILD_ROOT
341 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
342 %{__make} install \
343         DESTDIR=$RPM_BUILD_ROOT
344
345 findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
346
347 install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
348 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
349
350 install -d \
351         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
352         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
353         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
354         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
355         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
356
357 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
358 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
359 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
360
361 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
362 [mci]
363 cdaudio=mcicda.drv
364 sequencer=mciseq.drv
365 waveaudio=mciwave.drv
366 avivideo=mciavi.drv
367 videodisc=mcipionr.drv
368 vcr=mciviscd.drv
369 MPEGVideo=mciqtz.drv
370 EOF
371
372 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
373
374 dir=$(pwd)
375 > files.so
376 > files.programs
377 cd $RPM_BUILD_ROOT%{_libdir}/wine
378 for f in *.so; do
379         case $f in
380         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
381                 ;;
382         *)
383                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
384         esac
385 done
386 cd -
387
388 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
389 for p in $programs; do
390         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
391         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
392         echo "%{_mandir}/man1/$p.1*" >> files.programs
393         grep -v "$p\.exe\.so$" files.so > files.so.
394         mv -f files.so. files.so
395 done
396
397 %ifarch %{x8664}
398 for langdir in "" de/ fr/ pl/ ; do
399 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
400 done
401 %endif
402
403 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
404 %ifnarch %{x8664}
405 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
406 %else
407 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
408 %endif
409
410 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
411 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
412 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
413
414 %clean
415 rm -rf $RPM_BUILD_ROOT
416
417 %post
418 /sbin/ldconfig
419 %update_desktop_database
420
421 %postun -p /sbin/ldconfig
422
423 %triggerpostun -- wine < 1:0.9.12-1.9
424 rm -f /var/lock/subsys/wine
425 if [ -x /sbin/chkconfig ]; then
426         /sbin/chkconfig --del wine
427 fi
428
429 %files -f files.so
430 %defattr(644,root,root,755)
431 %doc README AUTHORS ANNOUNCE
432 %lang(de) %doc documentation/README.de
433 %lang(es) %doc documentation/README.es
434 %lang(fr) %doc documentation/README.fr
435 %lang(hu) %doc documentation/README.hu
436 %lang(it) %doc documentation/README.it
437 %lang(ko) %doc documentation/README.ko
438 %lang(nb) %doc documentation/README.no
439 %lang(pt) %doc documentation/README.pt
440 %lang(pt_BR) %doc documentation/README.pt_br
441 %lang(ru) %doc documentation/README.ru
442 %lang(sv) %doc documentation/README.sv
443 %lang(tr) %doc documentation/README.tr
444 %attr(755,root,root) %{_bindir}/msiexec
445 %ifnarch %{x8664}
446 %attr(755,root,root) %{_bindir}/wine
447 %else
448 %attr(755,root,root) %{_bindir}/wine64
449 %endif
450 %attr(755,root,root) %{_bindir}/wineboot
451 %attr(755,root,root) %{_bindir}/winedbg
452 %attr(755,root,root) %{_bindir}/winecfg
453 %ifnarch %{x8664}
454 %attr(755,root,root) %{_bindir}/wine-preloader
455 %else
456 %attr(755,root,root) %{_bindir}/wine64-preloader
457 %endif
458 %attr(755,root,root) %{_bindir}/wineserver
459 %attr(755,root,root) %{_libdir}/*.so*
460 %dir %{_libdir}/wine
461 %dir %{_libdir}/wine/fakedlls
462 %{_libdir}/wine/fakedlls/*.acm
463 %{_libdir}/wine/fakedlls/*.cpl
464 %{_libdir}/wine/fakedlls/*.dll
465 %ifarch %{ix86}
466 %{_libdir}/wine/fakedlls/*.dll16
467 %endif
468 %{_libdir}/wine/fakedlls/*.drv
469 %ifarch %{ix86}
470 %{_libdir}/wine/fakedlls/*.drv16
471 %endif
472 %{_libdir}/wine/fakedlls/*.ds
473 %{_libdir}/wine/fakedlls/*.exe
474 %ifarch %{ix86}
475 %{_libdir}/wine/fakedlls/*.exe16
476 %{_libdir}/wine/fakedlls/*.mod16
477 %endif
478 %{_libdir}/wine/fakedlls/*.ocx
479 %{_libdir}/wine/fakedlls/*.sys
480 %{_libdir}/wine/fakedlls/*.tlb
481 %ifarch %{ix86}
482 %{_libdir}/wine/fakedlls/*.vxd
483 %endif
484 %ifnarch %{x8664}
485 %{_mandir}/man1/wine.1*
486 %lang(de) %{_mandir}/de/man1/wine.1*
487 %lang(fr) %{_mandir}/fr/man1/wine.1*
488 %lang(pl) %{_mandir}/pl/man1/wine.1*
489 %else
490 %{_mandir}/man1/wine64.1*
491 %lang(de) %{_mandir}/de/man1/wine64.1*
492 %lang(fr) %{_mandir}/fr/man1/wine64.1*
493 %lang(pl) %{_mandir}/pl/man1/wine64.1*
494 %endif
495 %{_mandir}/man1/msiexec.1*
496 %{_mandir}/man1/wineboot.1*
497 %{_mandir}/man1/winecfg.1*
498 %{_mandir}/man1/winedbg.1*
499 %{_mandir}/man1/wineserver.1*
500 %lang(de) %{_mandir}/de/man1/wineserver.1*
501 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
502 %{_winedir}
503 %{_desktopdir}/wine.desktop
504 %{_desktopdir}/wine-uninstaller.desktop
505 %{_pixmapsdir}/%{name}.png
506
507 %files programs -f files.programs
508 %defattr(644,root,root,755)
509
510 %files devel
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_bindir}/fnt2fon
513 %attr(755,root,root) %{_bindir}/function_grep.pl
514 %attr(755,root,root) %{_bindir}/widl
515 %attr(755,root,root) %{_bindir}/winebuild
516 %attr(755,root,root) %{_bindir}/winedump
517 %attr(755,root,root) %{_bindir}/wineg++
518 %attr(755,root,root) %{_bindir}/winegcc
519 %attr(755,root,root) %{_bindir}/winemaker
520 %attr(755,root,root) %{_bindir}/winecpp
521 %attr(755,root,root) %{_bindir}/wmc
522 %attr(755,root,root) %{_bindir}/wrc
523 %{_libdir}/wine/lib*.def
524 # no shared variants, so not separated
525 %{_libdir}/wine/lib*.def.a
526 %{_libdir}/wine/libadsiid.a
527 %{_libdir}/wine/libdx*.a
528 %{_libdir}/wine/libstrmbase.a
529 %{_libdir}/wine/libstrmiids.a
530 %{_libdir}/wine/libuuid.a
531 %{_libdir}/wine/libwinecrt0.a
532 %{_includedir}/wine
533 %{_mandir}/man1/widl.1*
534 %{_mandir}/man1/winebuild.1*
535 %{_mandir}/man1/winecpp.1*
536 %{_mandir}/man1/winedump.1*
537 %{_mandir}/man1/winegcc.1*
538 %{_mandir}/man1/wineg++.1*
539 %{_mandir}/man1/winemaker.1*
540 %lang(de) %{_mandir}/de/man1/winemaker.1*
541 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
542 %{_mandir}/man1/wmc.1*
543 %{_mandir}/man1/wrc.1*
544 %{_aclocaldir}/*.m4
545
546 %files dll-capi
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
549
550 %files dll-d3d
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
553 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
554 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
555
556 %files dll-gl
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
559 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
560
561 %if %{with sane}
562 %files dll-twain
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
565 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
566 %endif
567
568 %if %{with ldap}
569 %files dll-ldap
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
572 %endif
573
574 %if %{with alsa}
575 %files drv-alsa
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
578 %endif
579
580 # additional dependencies in *.so not separated (yet?) from main package
581 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
582 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
583 #   ttydrv.dll.so depends on ncurses
This page took 0.089703 seconds and 4 git commands to generate.