]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
versioning comments updated
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 %bcond_without  netapi          # don't use the Samba NetAPI library
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libGL (winex11.drv.so)
14 #   libOSMesa (gdi32.dll.so)
15 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16 #   libcapi20 (capi2032.dll.so)
17 #   libcups (winspool.drv.so)
18 #   libdbus (mountmgr.sys.so)
19 #   libfontconfig (gdi32.dll.so)
20 #   libfreetype (gdi32.dll.so)
21 #   libgnutls (secur32.dll.so)
22 #   libhal (mountmgr.sys.so)
23 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libpng (windowscodecs.dll.so)
27 #   libsane (sane.ds.so)
28 #   libtiff (windowscodecs.dll.so)
29 #   libv4l1 (qcap.dll.so)
30 #   libxslt (msxml3.dll.so)
31 # thus requires rebuild after change of any of the above.
32
33 # library qualifier in rpm generated deps
34 %ifarch %{x8664} ia64 ppc64 s390x sparc64
35 %define libqual ()(64bit)
36 %else
37 %define libqual %{nil}
38 %endif
39
40 %define         gecko_ver       2.24
41 Summary:        Program that lets you launch Win applications
42 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
43 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
44 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
45 Name:           wine
46 # 1.8.x – stable
47 # 1.9.x – development
48 Version:        1.8
49 Release:        0.1
50 Epoch:          1
51 License:        LGPL
52 Group:          Applications/Emulators
53 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
54 # Source0-md5:  96b51a2f2ae727802d71095354e69fef
55 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
56 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
57 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
58 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
59 Source3:        %{name}-uninstaller.desktop
60 Patch0:         %{name}-gphoto2_bool.patch
61 Patch1:         %{name}-makedep.patch
62 Patch2:         %{name}-ncurses.patch
63 Patch4:         %{name}-disable-valgrind.patch
64 Patch5:         %{name}-ca_certificates.patch
65 Patch6:         desktop.patch
66 Patch7:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-GLX-devel
73 BuildRequires:  Mesa-libOSMesa-devel
74 %{?with_alsa:BuildRequires:     alsa-lib-devel}
75 %{?with_arts:BuildRequires:     artsc-devel}
76 BuildRequires:  autoconf >= 2.62
77 BuildRequires:  automake
78 BuildRequires:  bison
79 %{?with_capi:BuildRequires:     capi4k-utils-devel}
80 %{?with_cups:BuildRequires:     cups-devel}
81 BuildRequires:  dbus-devel
82 BuildRequires:  docbook-dtd31-sgml
83 BuildRequires:  docbook-utils
84 BuildRequires:  flex >= 2.5.33
85 BuildRequires:  fontconfig-devel
86 BuildRequires:  fontforge
87 BuildRequires:  freetype-devel >= 2.0.5
88 # for findup used after make install
89 BuildRequires:  fslint
90 %ifarch %{x8664}
91 BuildRequires:  gcc >= 6:4.4
92 %endif
93 BuildRequires:  gettext-tools
94 BuildRequires:  giflib-devel
95 BuildRequires:  gnutls-devel
96 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
97 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
98 %{?with_hal:BuildRequires:      hal-devel}
99 # for icotool used in build
100 BuildRequires:  icoutils >= 0.29.0
101 BuildRequires:  lcms2-devel >= 2
102 BuildRequires:  libgphoto2-devel
103 BuildRequires:  libgsm-devel
104 BuildRequires:  libjpeg-devel
105 BuildRequires:  libmpg123-devel >= 1.5.0
106 BuildRequires:  libcap-devel
107 BuildRequires:  libpng-devel >= 1.5
108 BuildRequires:  libtiff-devel
109 BuildRequires:  libtool
110 BuildRequires:  libv4l-devel
111 BuildRequires:  libxml2-devel >= 2.0
112 BuildRequires:  libxslt-devel
113 BuildRequires:  ncurses-devel
114 # db2* failed previously - probably openjade or opensp bug
115 BuildRequires:  openjade >= 1:1.3.3-0.pre1
116 %{?with_ldap:BuildRequires:     openldap-devel}
117 BuildRequires:  opensp >= 1:1.5.1
118 BuildRequires:  pkgconfig
119 BuildRequires:  prelink
120 BuildRequires:  samba-devel
121 %{?with_sane:BuildRequires:     sane-backends-devel}
122 BuildRequires:  unixODBC-devel >= 2.2.12-2
123 #BuildRequires: valgrind
124 BuildRequires:  xorg-lib-libX11-devel
125 BuildRequires:  xorg-lib-libXcomposite-devel
126 BuildRequires:  xorg-lib-libXcursor-devel
127 BuildRequires:  xorg-lib-libXext-devel
128 BuildRequires:  xorg-lib-libXi-devel
129 BuildRequires:  xorg-lib-libXinerama-devel
130 BuildRequires:  xorg-lib-libXrandr-devel
131 BuildRequires:  xorg-lib-libXrender-devel
132 BuildRequires:  xorg-lib-libXxf86vm-devel
133 BuildRequires:  zlib-devel
134 Requires:       libfreetype.so.6%{libqual}
135 Requires:       libpng16.so.16%{libqual}
136 Requires(post): /sbin/ldconfig
137 Suggests:       binfmt-detector
138 Suggests:       ca-certificates
139 Suggests:       cabextract
140 Conflicts:      ca-certificates < 20080809-4
141 # for printing needs lpr
142 Suggests:       cups-clients
143 # for winelauncher
144 Suggests:       xorg-app-xmessage
145 # for ntlm_auth
146 Suggests:       samba-common >= 1:3.0.25
147 # link to wine/ntdll.dll.so, without any SONAME
148 Provides:       libntdll.dll.so
149 Obsoletes:      wine-doc-pdf
150 Obsoletes:      wine-drv-arts
151 Obsoletes:      wine-drv-jack
152 Obsoletes:      wine-drv-nas
153 ExclusiveArch:  %{ix86} %{x8664} arm
154 ExcludeArch:    i386
155 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
156
157 %define         no_install_post_strip   1
158
159 %define         _winedir                %{_datadir}/%{name}
160
161 %description
162 Wine is a program which allows running Microsoft Windows programs
163 (including DOS, Windows 3.x and Win32 executables) on Unix. It
164 consists of a program loader which loads and executes a Microsoft
165 Windows binary, and a library that implements Windows API calls using
166 their Unix or X11 equivalents. The library may also be used for
167 porting Win32 code into native Unix executables.
168
169 %description -l es.UTF-8
170 Ejecuta programas Windows en Linux.
171
172 %description -l pl.UTF-8
173 Wine jest programem dzięki któremu można uruchamiać programy napisane
174 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
175 loadera, który pozwala wczytywać i uruchamiać programy w formacie
176 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
177 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
178 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
179
180 %description -l pt_BR.UTF-8
181 O Wine é um programa que permite rodar programas MS-Windows no X11.
182 Ele consiste de um carregador de programa, que carrega e executa um
183 binário MS-Windows, e de uma biblioteca de emulação que traduz as
184 chamadas da API para as equivalentes Unix/X11.
185
186 %package devel
187 Summary:        Wine - header files
188 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
189 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
190 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
191 Group:          Development/Libraries
192 Requires:       %{name} = %{epoch}:%{version}-%{release}
193
194 %description devel
195 Wine - header files.
196
197 %description devel -l es.UTF-8
198 Biblioteca de desarrollo de wine.
199
200 %description devel -l pl.UTF-8
201 Wine - pliki nagłówkowe.
202
203 %description devel -l pt_BR.UTF-8
204 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
205 WINE.
206
207 %package programs
208 Summary:        Wine - programs
209 Summary(pl.UTF-8):      Wine - programy
210 Group:          Applications
211 Requires:       %{name} = %{epoch}:%{version}-%{release}
212
213 %description programs
214 Wine - programs.
215
216 %description programs -l pl.UTF-8
217 Wine - programy.
218
219 %package dll-capi
220 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
221 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
222 Group:          Applications/Emulators
223 Requires:       %{name} = %{epoch}:%{version}-%{release}
224
225 %description dll-capi
226 CAPI 2.0 (ISDN) implementation DLLs for Wine.
227
228 %description dll-capi -l pl.UTF-8
229 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
230
231 %package dll-d3d
232 Summary:        Direct3D implementation DLLs for Wine
233 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
234 Group:          Applications/Emulators
235 Requires:       %{name} = %{epoch}:%{version}-%{release}
236 Requires:       OpenGL
237
238 %description dll-d3d
239 Direct3D implementation DLLs for Wine (through OpenGL).
240
241 %description dll-d3d -l pl.UTF-8
242 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
243
244 %package dll-gl
245 Summary:        OpenGL implementation DLLs for Wine
246 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
247 Group:          Applications/Emulators
248 Requires:       %{name} = %{epoch}:%{version}-%{release}
249 Requires:       OpenGL
250
251 %description dll-gl
252 OpenGL implementation DLLs for Wine.
253
254 %description dll-gl -l pl.UTF-8
255 Biblioteki DLL z implementacją OpenGL dla Wine.
256
257 %package dll-twain
258 Summary:        TWAIN implementation DLL for Wine
259 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
260 Group:          Applications/Emulators
261 Requires:       %{name} = %{epoch}:%{version}-%{release}
262
263 %description dll-twain
264 TWAIN implementation DLL for Wine (through SANE).
265
266 %description dll-twain -l pl.UTF-8
267 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
268
269 %package dll-ldap
270 Summary:        Win32 LDAP API DLL for Wine
271 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
272 Group:          Applications/Emulators
273 Requires:       %{name} = %{epoch}:%{version}-%{release}
274
275 %description dll-ldap
276 Lightweight Directory Access Protocol Library for Wine.
277
278 %description dll-ldap -l pl.UTF-8
279 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
280
281 %package drv-alsa
282 Summary:        ALSA driver for WINE mm.dll implementation
283 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
284 Group:          Applications/Emulators
285 Requires:       %{name} = %{epoch}:%{version}-%{release}
286
287 %description drv-alsa
288 ALSA driver for WINE mm.dll (multimedia system) implementation.
289
290 %description drv-alsa -l pl.UTF-8
291 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
292
293 %prep
294 %setup -q
295 %patch0 -p1
296 %patch1 -p1
297 %patch2 -p1
298 %patch4 -p1
299 %patch5 -p1
300 %patch6 -p1
301 %ifarch %{x8664}
302 %patch7 -p1
303 %endif
304
305 %build
306 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
307 mv -f oic_winlogo_*.png %{name}.png
308
309 %{__autoconf}
310 %{__autoheader}
311 %configure \
312 %ifarch %{x8664}
313         --enable-win64 \
314 %endif
315         --with-alsa%{!?with_alsa:=no} \
316         --with-capi%{!?with_capi:=no} \
317         --with-cms \
318         --with-coreaudio \
319         --with-cups%{!?with_cups:=no} \
320         --with-curses \
321         --with-dbus \
322         --with-fontconfig \
323         --with-freetype \
324         --with-gphoto \
325         --with-glu \
326         --with-gnutls \
327         --with-gsm \
328         %{__with_without gstreamer} \
329         %{__with_without hal} \
330         --with-jpeg \
331         --with-ldap%{!?with_ldap:=no} \
332         --with-mpg123 \
333         --with%{!?with_netapi:out}-netapi \
334         --with-openal \
335         --with-opencl \
336         --with-opengl \
337         --with-osmesa \
338         --with-oss \
339         --with-pcap \
340         --with-png \
341         --with-pthread \
342         --with-pulse \
343         --with%{!?with_sane:out}-sane \
344         --with-tiff \
345         --with-v4l \
346         --with-xcomposite \
347         --with-xcursor \
348         --with-xinerama \
349         --with-xinput \
350         --with-xinput2 \
351         --with-xml \
352         --with-xrandr \
353         --with-xrender \
354         --with-xshape \
355         --with-xshm \
356         --with-xslt \
357         --with-xxf86vm \
358         --with-x \
359         --with-zlib
360 %{__make} depend
361 %{__make}
362
363 %install
364 rm -rf $RPM_BUILD_ROOT
365 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
366 %{__make} install \
367         DESTDIR=$RPM_BUILD_ROOT
368
369 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
370 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
371
372 install -d \
373         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
374         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
375         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
376         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
377         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
378
379 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
380 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
381 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
382
383 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
384 [mci]
385 cdaudio=mcicda.drv
386 sequencer=mciseq.drv
387 waveaudio=mciwave.drv
388 avivideo=mciavi.drv
389 videodisc=mcipionr.drv
390 vcr=mciviscd.drv
391 MPEGVideo=mciqtz.drv
392 EOF
393
394 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
395
396 dir=$(pwd)
397 > files.so
398 > files.programs
399 cd $RPM_BUILD_ROOT%{_libdir}/wine
400 for f in *.so; do
401         case $f in
402         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
403                 ;;
404         *)
405                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
406         esac
407 done
408 cd -
409
410 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
411 for p in $programs; do
412         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
413         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
414         echo "%{_mandir}/man1/$p.1*" >> files.programs
415         grep -v "$p\.exe\.so$" files.so > files.so.
416         mv -f files.so. files.so
417 done
418
419 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
420         mv "$dir" "${dir%.UTF-8}"
421 done
422
423 %ifarch %{x8664}
424 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
425 for lang in de fr pl ; do
426 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
427 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
428 done
429 %else
430 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
431 for lang in de fr pl ; do
432 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
433 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
434 done
435 %endif
436
437 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
438 %ifnarch %{x8664}
439 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
440 %else
441 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
442 %endif
443
444 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
445 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
446 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451 %post
452 /sbin/ldconfig
453 %update_desktop_database
454
455 %postun -p /sbin/ldconfig
456
457 %triggerpostun -- wine < 1:0.9.12-1.9
458 rm -f /var/lock/subsys/wine
459 if [ -x /sbin/chkconfig ]; then
460         /sbin/chkconfig --del wine
461 fi
462
463 %files -f files.so
464 %defattr(644,root,root,755)
465 %doc README AUTHORS ANNOUNCE
466 %lang(de) %doc documentation/README.de
467 %lang(es) %doc documentation/README.es
468 %lang(fr) %doc documentation/README.fr
469 %lang(hu) %doc documentation/README.hu
470 %lang(it) %doc documentation/README.it
471 %lang(ko) %doc documentation/README.ko
472 %lang(nb) %doc documentation/README.no
473 %lang(pt) %doc documentation/README.pt
474 %lang(pt_BR) %doc documentation/README.pt_br
475 %lang(ru) %doc documentation/README.ru
476 %lang(sv) %doc documentation/README.sv
477 %lang(tr) %doc documentation/README.tr
478 %attr(755,root,root) %{_bindir}/msiexec
479 %ifnarch %{x8664}
480 %attr(755,root,root) %{_bindir}/wine
481 %else
482 %attr(755,root,root) %{_bindir}/wine64
483 %endif
484 %attr(755,root,root) %{_bindir}/wineboot
485 %attr(755,root,root) %{_bindir}/winedbg
486 %attr(755,root,root) %{_bindir}/winecfg
487 %ifnarch %{x8664}
488 %attr(755,root,root) %{_bindir}/wine-preloader
489 %else
490 %attr(755,root,root) %{_bindir}/wine64-preloader
491 %endif
492 %attr(755,root,root) %{_bindir}/wineserver
493 %attr(755,root,root) %{_libdir}/*.so*
494 %dir %{_libdir}/wine
495 %dir %{_libdir}/wine/fakedlls
496 %{_libdir}/wine/fakedlls/*.acm
497 %{_libdir}/wine/fakedlls/*.cpl
498 %{_libdir}/wine/fakedlls/*.dll
499 %ifarch %{ix86}
500 %{_libdir}/wine/fakedlls/*.dll16
501 %endif
502 %{_libdir}/wine/fakedlls/*.drv
503 %ifarch %{ix86}
504 %{_libdir}/wine/fakedlls/*.drv16
505 %endif
506 %{_libdir}/wine/fakedlls/*.ds
507 %{_libdir}/wine/fakedlls/*.exe
508 %ifarch %{ix86}
509 %{_libdir}/wine/fakedlls/*.exe16
510 %{_libdir}/wine/fakedlls/*.mod16
511 %endif
512 %{_libdir}/wine/fakedlls/*.ocx
513 %{_libdir}/wine/fakedlls/*.sys
514 %{_libdir}/wine/fakedlls/*.tlb
515 %ifarch %{ix86}
516 %{_libdir}/wine/fakedlls/*.vxd
517 %endif
518 %ifnarch %{x8664}
519 %{_mandir}/man1/wine.1*
520 %lang(de) %{_mandir}/de/man1/wine.1*
521 %lang(fr) %{_mandir}/fr/man1/wine.1*
522 %lang(pl) %{_mandir}/pl/man1/wine.1*
523 %else
524 %{_mandir}/man1/wine64.1*
525 %lang(de) %{_mandir}/de/man1/wine64.1*
526 %lang(fr) %{_mandir}/fr/man1/wine64.1*
527 %lang(pl) %{_mandir}/pl/man1/wine64.1*
528 %endif
529 %{_mandir}/man1/msiexec.1*
530 %{_mandir}/man1/wineboot.1*
531 %{_mandir}/man1/winecfg.1*
532 %{_mandir}/man1/winedbg.1*
533 %{_mandir}/man1/wineserver.1*
534 %lang(de) %{_mandir}/de/man1/wineserver.1*
535 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
536 %{_winedir}
537 %{_desktopdir}/wine.desktop
538 %{_desktopdir}/wine-uninstaller.desktop
539 %{_pixmapsdir}/%{name}.png
540
541 %files programs -f files.programs
542 %defattr(644,root,root,755)
543
544 %files devel
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/sfnt2fon
547 %attr(755,root,root) %{_bindir}/function_grep.pl
548 %attr(755,root,root) %{_bindir}/widl
549 %attr(755,root,root) %{_bindir}/winebuild
550 %attr(755,root,root) %{_bindir}/winedump
551 %attr(755,root,root) %{_bindir}/wineg++
552 %attr(755,root,root) %{_bindir}/winegcc
553 %attr(755,root,root) %{_bindir}/winemaker
554 %attr(755,root,root) %{_bindir}/winecpp
555 %attr(755,root,root) %{_bindir}/wmc
556 %attr(755,root,root) %{_bindir}/wrc
557 %{_libdir}/wine/lib*.def
558 # no shared variants, so not separated
559 %{_libdir}/wine/lib*.def.a
560 %{_libdir}/wine/libadsiid.a
561 %{_libdir}/wine/libdx*.a
562 %{_libdir}/wine/libstrmbase.a
563 %{_libdir}/wine/libstrmiids.a
564 %{_libdir}/wine/libuuid.a
565 %{_libdir}/wine/libwinecrt0.a
566 %{_includedir}/wine
567 %{_mandir}/man1/widl.1*
568 %{_mandir}/man1/winebuild.1*
569 %{_mandir}/man1/winecpp.1*
570 %{_mandir}/man1/winedump.1*
571 %{_mandir}/man1/winegcc.1*
572 %{_mandir}/man1/wineg++.1*
573 %{_mandir}/man1/winemaker.1*
574 %lang(de) %{_mandir}/de/man1/winemaker.1*
575 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
576 %{_mandir}/man1/wmc.1*
577 %{_mandir}/man1/wrc.1*
578 %{_aclocaldir}/*.m4
579
580 %files dll-capi
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
583
584 %files dll-d3d
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
587 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
588 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
589
590 %files dll-gl
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
593 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
594
595 %if %{with sane}
596 %files dll-twain
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
599 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
600 %endif
601
602 %if %{with ldap}
603 %files dll-ldap
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
606 %endif
607
608 %if %{with alsa}
609 %files drv-alsa
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
612 %endif
613
614 # additional dependencies in *.so not separated (yet?) from main package
615 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
616 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.077032 seconds and 4 git commands to generate.