]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
builds now
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 %bcond_without  netapi          # don't use the Samba NetAPI library
10 #
11 # NOTE: wine detects the following SONAMES for dlopen at build time:
12 #   libcrypto,libssl (wininet.dll)
13 #   libcups (winspool.dll.so,wineps.dll.so)
14 #   libcurses/libncurses (wineconsole program)
15 #   libfontconfig (gdi32.dll.so)
16 #   libfreetype (wineps.dll.so,gdi32.dll.so)
17 #   libGL (x11drv.dll.so,ddraw.dll.so)
18 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
19 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
20 # thus requires rebuild after change of any of the above.
21
22 # library qualifier in rpm generated deps
23 %ifarch %{x8664} ia64 ppc64 s390x sparc64
24 %define libqual ()(64bit)
25 %else
26 %define libqual %{nil}
27 %endif
28
29 %define         gecko_ver       2.24
30 Summary:        Program that lets you launch Win applications
31 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
32 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
33 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
34 Name:           wine
35 # 1.6.x – stable
36 # 1.7.x – development (DEVEL branch)
37 Version:        1.7.18
38 Release:        0.1
39 Epoch:          1
40 License:        LGPL
41 Group:          Applications/Emulators
42 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
43 # Source0-md5:  b13c19ef69a99f2aa6c0b3fd08ae8d90
44 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
45 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
46 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
47 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
48 Source3:        %{name}-uninstaller.desktop
49 Patch0:         %{name}-gphoto2_bool.patch
50 Patch1:         %{name}-makedep.patch
51 Patch2:         %{name}-ncurses.patch
52 Patch4:         %{name}-disable-valgrind.patch
53 Patch5:         %{name}-ca_certificates.patch
54 Patch6:         desktop.patch
55 Patch7:         %{name}-wine64_man.patch
56 URL:            http://www.winehq.org/
57 BuildRequires:  OpenAL-devel >= 1.1
58 BuildRequires:  ocl-icd-libOpenCL-devel
59 BuildRequires:  OpenGL-GLU-devel
60 BuildRequires:  Mesa-libOSMesa-devel
61 %{?with_alsa:BuildRequires:     alsa-lib-devel}
62 %{?with_arts:BuildRequires:     artsc-devel}
63 BuildRequires:  autoconf
64 BuildRequires:  automake
65 BuildRequires:  bison
66 %{?with_capi:BuildRequires:     capi4k-utils-devel}
67 %{?with_cups:BuildRequires:     cups-devel}
68 BuildRequires:  dbus-devel
69 BuildRequires:  docbook-dtd31-sgml
70 BuildRequires:  docbook-utils
71 BuildRequires:  flex
72 BuildRequires:  fontconfig-devel
73 BuildRequires:  fontforge
74 BuildRequires:  freetype-devel >= 2.0.5
75 BuildRequires:  fslint
76 BuildRequires:  gettext-devel
77 BuildRequires:  giflib-devel
78 BuildRequires:  gnutls-devel
79 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel}
80 BuildRequires:  icoutils
81 BuildRequires:  lcms2-devel
82 BuildRequires:  libgphoto2-devel
83 BuildRequires:  libgsm-devel
84 BuildRequires:  libjpeg-devel
85 BuildRequires:  libmpg123-devel >= 1.5.0
86 BuildRequires:  libtool
87 BuildRequires:  libv4l-devel
88 BuildRequires:  libxslt-devel
89 BuildRequires:  ncurses-devel
90 # db2* failed previously - probably openjade or opensp bug
91 BuildRequires:  libpng-devel >= 1.5
92 BuildRequires:  openjade >= 1:1.3.3-0.pre1
93 %{?with_ldap:BuildRequires:     openldap-devel}
94 BuildRequires:  opensp >= 1:1.5.1
95 BuildRequires:  openssl-devel >= 0.9.7d
96 BuildRequires:  pkgconfig
97 BuildRequires:  prelink
98 BuildRequires:  samba-devel
99 %{?with_sane:BuildRequires:     sane-backends-devel}
100 BuildRequires:  unixODBC-devel >= 2.2.12-2
101 #BuildRequires: valgrind
102 BuildRequires:  xorg-lib-libXcomposite-devel
103 BuildRequires:  xorg-lib-libXcursor-devel
104 BuildRequires:  xorg-lib-libXi-devel
105 BuildRequires:  xorg-lib-libXinerama-devel
106 BuildRequires:  xorg-lib-libXmu-devel
107 BuildRequires:  xorg-lib-libXrandr-devel
108 BuildRequires:  xorg-lib-libXrender-devel
109 BuildRequires:  xorg-lib-libXxf86dga-devel
110 BuildRequires:  xorg-lib-libXxf86vm-devel
111 Requires:       libfreetype.so.6%{libqual}
112 Requires:       libpng16.so.16%{libqual}
113 Requires(post): /sbin/ldconfig
114 Suggests:       binfmt-detector
115 Suggests:       ca-certificates
116 Suggests:       cabextract
117 Conflicts:      ca-certificates < 20080809-4
118 # for printing needs lpr
119 Suggests:       cups-clients
120 # for winelauncher
121 Suggests:       xorg-app-xmessage
122 # for ntlm_auth
123 Suggests:       samba-common >= 1:3.0.25
124 # link to wine/ntdll.dll.so, without any SONAME
125 Provides:       libntdll.dll.so
126 Obsoletes:      wine-doc-pdf
127 Obsoletes:      wine-drv-arts
128 Obsoletes:      wine-drv-jack
129 Obsoletes:      wine-drv-nas
130 ExclusiveArch:  %{ix86} %{x8664}
131 ExcludeArch:    i386
132 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
133
134 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
135 %define         no_install_post_strip   1
136
137 %define         _winedir                %{_datadir}/%{name}
138
139 %description
140 Wine is a program which allows running Microsoft Windows programs
141 (including DOS, Windows 3.x and Win32 executables) on Unix. It
142 consists of a program loader which loads and executes a Microsoft
143 Windows binary, and a library that implements Windows API calls using
144 their Unix or X11 equivalents. The library may also be used for
145 porting Win32 code into native Unix executables.
146
147 %description -l es.UTF-8
148 Ejecuta programas Windows en Linux.
149
150 %description -l pl.UTF-8
151 Wine jest programem dzięki któremu można uruchamiać programy napisane
152 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
153 loadera, który pozwala wczytywać i uruchamiać programy w formacie
154 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
155 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
156 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
157
158 %description -l pt_BR.UTF-8
159 O Wine é um programa que permite rodar programas MS-Windows no X11.
160 Ele consiste de um carregador de programa, que carrega e executa um
161 binário MS-Windows, e de uma biblioteca de emulação que traduz as
162 chamadas da API para as equivalentes Unix/X11.
163
164 %package devel
165 Summary:        Wine - header files
166 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
167 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
168 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
169 Group:          Development/Libraries
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171
172 %description devel
173 Wine - header files.
174
175 %description devel -l es.UTF-8
176 Biblioteca de desarrollo de wine.
177
178 %description devel -l pl.UTF-8
179 Wine - pliki nagłówkowe.
180
181 %description devel -l pt_BR.UTF-8
182 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
183 WINE.
184
185 %package programs
186 Summary:        Wine - programs
187 Summary(pl.UTF-8):      Wine - programy
188 Group:          Applications
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190
191 %description programs
192 Wine - programs.
193
194 %description programs -l pl.UTF-8
195 Wine - programy.
196
197 %package dll-capi
198 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
199 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
200 Group:          Applications/Emulators
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202
203 %description dll-capi
204 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
205
206 %description dll-capi -l pl.UTF-8
207 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
208 OpenGL).
209
210 %package dll-d3d
211 Summary:        Direct3D implementation DLLs for Wine
212 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
213 Group:          Applications/Emulators
214 Requires:       %{name} = %{epoch}:%{version}-%{release}
215 Requires:       OpenGL
216
217 %description dll-d3d
218 Direct3D implementation DLLs for Wine (through OpenGL).
219
220 %description dll-d3d -l pl.UTF-8
221 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
222
223 %package dll-gl
224 Summary:        OpenGL implementation DLLs for Wine
225 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
226 Group:          Applications/Emulators
227 Requires:       %{name} = %{epoch}:%{version}-%{release}
228 Requires:       OpenGL
229
230 %description dll-gl
231 OpenGL implementation DLLs for Wine.
232
233 %description dll-gl -l pl.UTF-8
234 Biblioteki DLL z implementacją OpenGL dla Wine.
235
236 %package dll-twain
237 Summary:        TWAIN implementation DLL for Wine
238 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
239 Group:          Applications/Emulators
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241
242 %description dll-twain
243 TWAIN implementation DLL for Wine (through SANE).
244
245 %description dll-twain -l pl.UTF-8
246 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
247
248 %package dll-ldap
249 Summary:        Win32 LDAP API DLL for Wine
250 Group:          Applications/Emulators
251 Requires:       %{name} = %{epoch}:%{version}-%{release}
252
253 %description dll-ldap
254 Lightweight Directory Access Protocol Library.
255
256 %package drv-alsa
257 Summary:        ALSA driver for WINE mm.dll implementation
258 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
259 Group:          Applications/Emulators
260 Requires:       %{name} = %{epoch}:%{version}-%{release}
261
262 %description drv-alsa
263 ALSA driver for WINE mm.dll (multimedia system) implementation.
264
265 %description drv-alsa -l pl.UTF-8
266 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
267
268 %prep
269 %setup -q
270 %patch0 -p1
271 %patch1 -p1
272 %patch2 -p1
273 %patch4 -p1
274 %patch5 -p1
275 %patch6 -p1
276 %ifarch %{x8664}
277 %patch7 -p1
278 %endif
279
280 %build
281 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
282 mv -f oic_winlogo_*.png %{name}.png
283
284 %{__autoconf}
285 %{__autoheader}
286 %configure \
287 %ifarch %{x8664}
288         --enable-win64 \
289 %endif
290         --with%{!?with_alsa:out}-alsa \
291         --with%{!?with_capi:out}-capi \
292         --with-cms \
293         --with-coreaudio \
294         --with%{!?with_cups:out}-cups \
295         --with-curses \
296         --with-dbus \
297         --with-fontconfig \
298         --with-freetype \
299         --with-gphoto \
300         --with-glu \
301         --with-gnutls \
302         --with-gsm \
303         --with%{!?with_gstreamer:out}-gstreamer \
304         --without-hal \
305         --with-jpeg \
306         --with%{!?with_ldap:out}-ldap \
307         --with-mpg123 \
308         --with%{!?with_netapi:out}-netapi \
309         --with-openal \
310         --with-opencl \
311         --with-opengl \
312         --with-openssl \
313         --with-osmesa \
314         --with-oss \
315         --with-png \
316         --with-pthread \
317         --with%{!?with_sane:out}-sane \
318         --with-tiff \
319         --with-v4l \
320         --with-xcomposite \
321         --with-xcursor \
322         --with-xinerama \
323         --with-xinput \
324         --with-xinput2 \
325         --with-xml \
326         --with-xrandr \
327         --with-xrender \
328         --with-xshape \
329         --with-xshm \
330         --with-xslt \
331         --with-xxf86vm \
332         --with-x \
333         --with-zlib
334 %{__make} depend
335 %{__make}
336
337 %install
338 rm -rf $RPM_BUILD_ROOT
339 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
340 %{__make} install \
341         DESTDIR=$RPM_BUILD_ROOT
342
343 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
344 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
345
346 install -d \
347         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
348         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
349         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
350         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
351         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
352
353 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
354 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
355 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
356
357 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
358 [mci]
359 cdaudio=mcicda.drv
360 sequencer=mciseq.drv
361 waveaudio=mciwave.drv
362 avivideo=mciavi.drv
363 videodisc=mcipionr.drv
364 vcr=mciviscd.drv
365 MPEGVideo=mciqtz.drv
366 EOF
367
368 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
369
370 dir=$(pwd)
371 > files.so
372 > files.programs
373 cd $RPM_BUILD_ROOT%{_libdir}/wine
374 for f in *.so; do
375         case $f in
376         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
377                 ;;
378         *)
379                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
380         esac
381 done
382 cd -
383
384 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
385 for p in $programs; do
386         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
387         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
388         echo "%{_mandir}/man1/$p.1*" >> files.programs
389         grep -v "$p\.exe\.so$" files.so > files.so.
390         mv -f files.so. files.so
391 done
392
393 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
394         mv "$dir" "${dir%.UTF-8}"
395 done
396
397 %ifarch %{x8664}
398 for langdir in "" de/ fr/ pl/ ; do
399 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
400 done
401 %endif
402
403 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
404 %ifnarch %{x8664}
405 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
406 %else
407 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
408 %endif
409
410 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
411 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
412 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
413
414 %clean
415 rm -rf $RPM_BUILD_ROOT
416
417 %post
418 /sbin/ldconfig
419 %update_desktop_database
420
421 %postun -p /sbin/ldconfig
422
423 %triggerpostun -- wine < 1:0.9.12-1.9
424 rm -f /var/lock/subsys/wine
425 if [ -x /sbin/chkconfig ]; then
426         /sbin/chkconfig --del wine
427 fi
428
429 %files -f files.so
430 %defattr(644,root,root,755)
431 %doc README AUTHORS ANNOUNCE
432 %lang(de) %doc documentation/README.de
433 %lang(es) %doc documentation/README.es
434 %lang(fr) %doc documentation/README.fr
435 %lang(hu) %doc documentation/README.hu
436 %lang(it) %doc documentation/README.it
437 %lang(ko) %doc documentation/README.ko
438 %lang(nb) %doc documentation/README.no
439 %lang(pt) %doc documentation/README.pt
440 %lang(pt_BR) %doc documentation/README.pt_br
441 %lang(ru) %doc documentation/README.ru
442 %lang(sv) %doc documentation/README.sv
443 %lang(tr) %doc documentation/README.tr
444 %attr(755,root,root) %{_bindir}/msiexec
445 %ifnarch %{x8664}
446 %attr(755,root,root) %{_bindir}/wine
447 %else
448 %attr(755,root,root) %{_bindir}/wine64
449 %endif
450 %attr(755,root,root) %{_bindir}/wineboot
451 %attr(755,root,root) %{_bindir}/winedbg
452 %attr(755,root,root) %{_bindir}/winecfg
453 %ifnarch %{x8664}
454 %attr(755,root,root) %{_bindir}/wine-preloader
455 %else
456 %attr(755,root,root) %{_bindir}/wine64-preloader
457 %endif
458 %attr(755,root,root) %{_bindir}/wineserver
459 %attr(755,root,root) %{_libdir}/*.so*
460 %dir %{_libdir}/wine
461 %dir %{_libdir}/wine/fakedlls
462 %{_libdir}/wine/fakedlls/*.acm
463 %{_libdir}/wine/fakedlls/*.cpl
464 %{_libdir}/wine/fakedlls/*.dll
465 %ifarch %{ix86}
466 %{_libdir}/wine/fakedlls/*.dll16
467 %endif
468 %{_libdir}/wine/fakedlls/*.drv
469 %ifarch %{ix86}
470 %{_libdir}/wine/fakedlls/*.drv16
471 %endif
472 %{_libdir}/wine/fakedlls/*.ds
473 %{_libdir}/wine/fakedlls/*.exe
474 %ifarch %{ix86}
475 %{_libdir}/wine/fakedlls/*.exe16
476 %{_libdir}/wine/fakedlls/*.mod16
477 %endif
478 %{_libdir}/wine/fakedlls/*.ocx
479 %{_libdir}/wine/fakedlls/*.sys
480 %{_libdir}/wine/fakedlls/*.tlb
481 %ifarch %{ix86}
482 %{_libdir}/wine/fakedlls/*.vxd
483 %endif
484 %ifnarch %{x8664}
485 %{_mandir}/man1/wine.1*
486 %lang(de) %{_mandir}/de/man1/wine.1*
487 %lang(fr) %{_mandir}/fr/man1/wine.1*
488 %lang(pl) %{_mandir}/pl/man1/wine.1*
489 %else
490 %{_mandir}/man1/wine64.1*
491 %lang(de) %{_mandir}/de/man1/wine64.1*
492 %lang(fr) %{_mandir}/fr/man1/wine64.1*
493 %lang(pl) %{_mandir}/pl/man1/wine64.1*
494 %endif
495 %{_mandir}/man1/msiexec.1*
496 %{_mandir}/man1/wineboot.1*
497 %{_mandir}/man1/winecfg.1*
498 %{_mandir}/man1/winedbg.1*
499 %{_mandir}/man1/wineserver.1*
500 %lang(de) %{_mandir}/de/man1/wineserver.1*
501 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
502 %{_winedir}
503 %{_desktopdir}/wine.desktop
504 %{_desktopdir}/wine-uninstaller.desktop
505 %{_pixmapsdir}/%{name}.png
506
507 %files programs -f files.programs
508 %defattr(644,root,root,755)
509
510 %files devel
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_bindir}/sfnt2fon
513 %attr(755,root,root) %{_bindir}/function_grep.pl
514 %attr(755,root,root) %{_bindir}/widl
515 %attr(755,root,root) %{_bindir}/winebuild
516 %attr(755,root,root) %{_bindir}/winedump
517 %attr(755,root,root) %{_bindir}/wineg++
518 %attr(755,root,root) %{_bindir}/winegcc
519 %attr(755,root,root) %{_bindir}/winemaker
520 %attr(755,root,root) %{_bindir}/winecpp
521 %attr(755,root,root) %{_bindir}/wmc
522 %attr(755,root,root) %{_bindir}/wrc
523 %{_libdir}/wine/lib*.def
524 # no shared variants, so not separated
525 %{_libdir}/wine/lib*.def.a
526 %{_libdir}/wine/libadsiid.a
527 %{_libdir}/wine/libdx*.a
528 %{_libdir}/wine/libstrmbase.a
529 %{_libdir}/wine/libstrmiids.a
530 %{_libdir}/wine/libuuid.a
531 %{_libdir}/wine/libwinecrt0.a
532 %{_includedir}/wine
533 %{_mandir}/man1/widl.1*
534 %{_mandir}/man1/winebuild.1*
535 %{_mandir}/man1/winecpp.1*
536 %{_mandir}/man1/winedump.1*
537 %{_mandir}/man1/winegcc.1*
538 %{_mandir}/man1/wineg++.1*
539 %{_mandir}/man1/winemaker.1*
540 %lang(de) %{_mandir}/de/man1/winemaker.1*
541 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
542 %{_mandir}/man1/wmc.1*
543 %{_mandir}/man1/wrc.1*
544 %{_aclocaldir}/*.m4
545
546 %files dll-capi
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
549
550 %files dll-d3d
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
553 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
554 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
555
556 %files dll-gl
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
559 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
560
561 %if %{with sane}
562 %files dll-twain
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
565 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
566 %endif
567
568 %if %{with ldap}
569 %files dll-ldap
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
572 %endif
573
574 %if %{with alsa}
575 %files drv-alsa
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
578 %endif
579
580 # additional dependencies in *.so not separated (yet?) from main package
581 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
582 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
583 #   ttydrv.dll.so depends on ncurses
This page took 0.12294 seconds and 4 git commands to generate.