]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- without hal
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_with     esd             # build ESD mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 #
11 # TODO:
12 # - support for CAPI (ISDN support; --with-capi)
13 #
14 # NOTE: wine detects the following SONAMES for dlopen at build time:
15 #   libcrypto,libssl (wininet.dll)
16 #   libcups (winspool.dll.so,wineps.dll.so)
17 #   libcurses/libncurses (wineconsole program)
18 #   libfontconfig (gdi32.dll.so)
19 #   libfreetype (wineps.dll.so,gdi32.dll.so)
20 #   libGL (x11drv.dll.so,ddraw.dll.so)
21 #   libjack (winejack.drv.so - explicit dependency in subpackage)
22 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
23 # thus requires rebuild after change of any of the above.
24 #
25 # JACK requires ALSA
26 %if %{without alsa}
27 %undefine       with_jack
28 %endif
29
30 Summary:        Program that lets you launch Win applications
31 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
32 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
33 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
34 Name:           wine
35 Version:        1.2.3
36 Release:        3
37 Epoch:          1
38 License:        LGPL
39 Group:          Applications/Emulators
40 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
41 # Source0-md5:  a18ca677d1e01d1596d6692a8f3997e5
42 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
43 # Source1-md5:  9c5c335fc077c0558561afaf25a09e51
44 Source2:        %{name}-uninstaller.desktop
45 Patch0:         %{name}-fontcache.patch
46 Patch1:         %{name}-makedep.patch
47 Patch2:         %{name}-ncurses.patch
48 Patch4:         %{name}-disable-valgrind.patch
49 Patch5:         %{name}-ca_certificates.patch
50 Patch6:         %{name}-manpaths.patch
51 Patch7:         desktop.patch
52 #PatchX:        %{name}-dga.patch
53 URL:            http://www.winehq.org/
54 BuildRequires:  OpenAL-devel >= 1.1
55 BuildRequires:  OpenGL-GLU-devel
56 %{?with_alsa:BuildRequires:     alsa-lib-devel}
57 %{?with_arts:BuildRequires:     artsc-devel}
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 BuildRequires:  bison
61 %{?with_cups:BuildRequires:     cups-devel}
62 BuildRequires:  docbook-dtd31-sgml
63 BuildRequires:  docbook-utils
64 %{?with_esd:BuildRequires:      esound-devel}
65 BuildRequires:  flex
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  fontforge
68 BuildRequires:  freetype-devel >= 2.0.5
69 BuildRequires:  giflib-devel
70 BuildRequires:  gnutls-devel
71 BuildRequires:  icoutils
72 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
73 BuildRequires:  lcms-devel
74 BuildRequires:  libgphoto2-devel
75 BuildRequires:  libgsm-devel
76 BuildRequires:  libjpeg-devel
77 BuildRequires:  libmpg123-devel >= 1.5.0
78 BuildRequires:  libtool
79 BuildRequires:  libv4l-devel
80 BuildRequires:  libxslt-devel
81 %{?with_nas:BuildRequires:      nas-devel}
82 BuildRequires:  ncurses-devel
83 # db2* failed previously - probably openjade or opensp bug
84 BuildRequires:  openjade >= 1:1.3.3-0.pre1
85 %{?with_ldap:BuildRequires:     openldap-devel}
86 BuildRequires:  opensp >= 1:1.5.1
87 BuildRequires:  openssl-devel >= 0.9.7d
88 BuildRequires:  pkgconfig
89 %{?with_sane:BuildRequires:     sane-backends-devel}
90 BuildRequires:  unixODBC-devel >= 2.2.12-2
91 #BuildRequires: valgrind
92 BuildRequires:  xorg-lib-libXcomposite-devel
93 BuildRequires:  xorg-lib-libXcursor-devel
94 BuildRequires:  xorg-lib-libXi-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXmu-devel
97 BuildRequires:  xorg-lib-libXrandr-devel
98 BuildRequires:  xorg-lib-libXrender-devel
99 BuildRequires:  xorg-lib-libXxf86dga-devel
100 BuildRequires:  xorg-lib-libXxf86vm-devel
101 %ifarch %{x8664}
102 Requires:       libfreetype.so.6()(64bit)
103 %else
104 Requires:       libfreetype.so.6
105 %endif
106 Requires(post): /sbin/ldconfig
107 Suggests:       binfmt-detector
108 Suggests:       ca-certificates
109 Conflicts:      ca-certificates < 20080809-4
110 # for printing needs lpr
111 Suggests:       cups-clients
112 # for winelauncher
113 Suggests:       xorg-app-xmessage
114 # for ntlm_auth
115 Suggests:       samba-common >= 1:3.0.25
116 # link to wine/ntdll.dll.so, without any SONAME
117 Provides:       libntdll.dll.so
118 Obsoletes:      wine-doc-pdf
119 Obsoletes:      wine-drv-arts
120 ExclusiveArch:  %{ix86} %{x8664}
121 ExcludeArch:    i386
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
125 %define         no_install_post_strip   1
126
127 %define         _winedir                %{_datadir}/%{name}
128
129 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
130
131 %undefine       debuginfocflags
132
133 %description
134 Wine is a program which allows running Microsoft Windows programs
135 (including DOS, Windows 3.x and Win32 executables) on Unix. It
136 consists of a program loader which loads and executes a Microsoft
137 Windows binary, and a library that implements Windows API calls using
138 their Unix or X11 equivalents. The library may also be used for
139 porting Win32 code into native Unix executables.
140
141 %description -l es.UTF-8
142 Ejecuta programas Windows en Linux.
143
144 %description -l pl.UTF-8
145 Wine jest programem dzięki któremu można uruchamiać programy napisane
146 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
147 loadera, który pozwala wczytywać i uruchamiać programy w formacie
148 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
149 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
150 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
151
152 %description -l pt_BR.UTF-8
153 O Wine é um programa que permite rodar programas MS-Windows no X11.
154 Ele consiste de um carregador de programa, que carrega e executa um
155 binário MS-Windows, e de uma biblioteca de emulação que traduz as
156 chamadas da API para as equivalentes Unix/X11.
157
158 %package devel
159 Summary:        Wine - header files
160 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
161 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
162 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
163 Group:          Development/Libraries
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165
166 %description devel
167 Wine - header files.
168
169 %description devel -l es.UTF-8
170 Biblioteca de desarrollo de wine.
171
172 %description devel -l pl.UTF-8
173 Wine - pliki nagłówkowe.
174
175 %description devel -l pt_BR.UTF-8
176 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
177 WINE.
178
179 %package programs
180 Summary:        Wine - programs
181 Summary(pl.UTF-8):      Wine - programy
182 Group:          Applications
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description programs
186 Wine - programs.
187
188 %description programs -l pl.UTF-8
189 Wine - programy.
190
191 %package dll-d3d
192 Summary:        Direct3D implementation DLLs for Wine
193 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
194 Group:          Applications/Emulators
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196 Requires:       OpenGL
197
198 %description dll-d3d
199 Direct3D implementation DLLs for Wine (through OpenGL).
200
201 %description dll-d3d -l pl.UTF-8
202 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
203
204 %package dll-gl
205 Summary:        OpenGL implementation DLLs for Wine
206 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
207 Group:          Applications/Emulators
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209 Requires:       OpenGL
210
211 %description dll-gl
212 OpenGL implementation DLLs for Wine.
213
214 %description dll-gl -l pl.UTF-8
215 Biblioteki DLL z implementacją OpenGL dla Wine.
216
217 %package dll-twain
218 Summary:        TWAIN implementation DLL for Wine
219 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
220 Group:          Applications/Emulators
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222
223 %description dll-twain
224 TWAIN implementation DLL for Wine (through SANE).
225
226 %description dll-twain -l pl.UTF-8
227 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
228
229 %package dll-ldap
230 Summary:        Win32 LDAP API DLL for Wine.
231 Group:          Applications/Emulators
232 Requires:       %{name} = %{epoch}:%{version}-%{release}
233
234 %description dll-ldap
235 Lightweight Directory Access Protocol Library.
236
237 %package drv-alsa
238 Summary:        ALSA driver for WINE mm.dll implementation
239 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
240 Group:          Applications/Emulators
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242
243 %description drv-alsa
244 ALSA driver for WINE mm.dll (multimedia system) implementation.
245
246 %description drv-alsa -l pl.UTF-8
247 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
248
249 %package drv-jack
250 Summary:        JACK driver for WINE mm.dll implementation
251 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
252 Group:          Applications/Emulators
253 Requires:       %{name} = %{epoch}:%{version}-%{release}
254 Requires:       jack-audio-connection-kit
255 # dlopened by SONAME detected at build time
256 %ifarch %{x8664}
257 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}()(64bit)}
258 %else
259 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
260 %endif
261
262 %description drv-jack
263 JACK driver for WINE mm.dll (multimedia system) implementation.
264
265 %description drv-jack -l pl.UTF-8
266 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
267 Wine.
268
269 %package drv-nas
270 Summary:        NAS driver for WINE mm.dll implementation
271 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
272 Group:          Applications/Emulators
273 Requires:       %{name} = %{epoch}:%{version}-%{release}
274
275 %description drv-nas
276 NAS driver for WINE mm.dll (multimedia system) implementation.
277
278 %description drv-nas -l pl.UTF-8
279 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
280
281 %prep
282 %setup -q
283 %patch0 -p1
284 %patch1 -p1
285 %patch2 -p1
286 %patch4 -p1
287 %patch5 -p1
288 %patch6 -p1
289 %patch7 -p1
290
291 %build
292 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
293 mv -f oic_winlogo_*.png %{name}.png
294
295 %{__autoconf}
296 %{__autoheader}
297 %configure \
298 %ifarch %{x8664}
299         --enable-win64 \
300 %endif
301         --with%{!?with_alsa:out}-alsa \
302         --with-audioio \
303         --without-capi \
304         --with-cms \
305         --with-coreaudio \
306         --with%{!?with_cups:out}-cups \
307         --with-curses \
308         --with%{!?with_esd:out}-esd \
309         --with-fontconfig \
310         --with-freetype \
311         --with-glu \
312         --with-gnutls \
313         --with-gphoto \
314         --with-gsm \
315         --with%{!?with_jack:out}-jack \
316         --with-jpeg \
317         --with%{!?with_ldap:out}-ldap \
318         --with-mpg123 \
319         --with%{!?with_nas:out}-nas \
320         --with-opengl \
321         --with-openssl \
322         --with-oss \
323         --with-png \
324         --with-pthread \
325         --with%{!?with_sane:out}-sane \
326         --with-xcomposite \
327         --with-xcursor \
328         --with-xinerama \
329         --with-xinput \
330         --with-xml \
331         --with-xrandr \
332         --with-xrender \
333         --with-xshape \
334         --with-xshm \
335         --with-xslt \
336         --with-xxf86vm \
337         --with-x
338 %{__make} depend
339 %{__make}
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
344 %{__make} install \
345         DESTDIR=$RPM_BUILD_ROOT
346
347 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
348 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
349
350 install -d \
351         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
352         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
353         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
354         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
355         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
356
357 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
358 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
359 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
360
361 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
362 [mci]
363 cdaudio=mcicda.drv
364 sequencer=mciseq.drv
365 waveaudio=mciwave.drv
366 avivideo=mciavi.drv
367 videodisc=mcipionr.drv
368 vcr=mciviscd.drv
369 MPEGVideo=mciqtz.drv
370 EOF
371
372 %if %{?debug:0}%{!?debug:1}
373 echo "Strip executable binaries and shared object files."
374 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
375 elfexelist=`echo $filelist | xargs -r file | \
376         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
377 elfsharedlist=`echo $filelist | xargs -r file | \
378         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
379 if [ -n "$elfexelist" ]; then \
380         strip -R .note -R .comment $elfexelist
381 fi
382 if [ -n "$elfsharedlist" ]; then
383         strip --strip-unneeded -R .note -R .comment $elfsharedlist
384 fi
385 %endif
386
387 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
388
389 dir=$(pwd)
390 > files.so
391 > files.programs
392 cd $RPM_BUILD_ROOT%{_libdir}/wine
393 for f in *.so; do
394         case $f in
395         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so|wldap32.dll.so)
396                 ;;
397         *)
398                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
399         esac
400 done
401 cd -
402
403 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
404 for p in $programs; do
405         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
406         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
407         echo "%{_mandir}/man1/$p.1*" >> files.programs
408         grep -v "$p\.exe\.so$" files.so > files.so.
409         mv -f files.so. files.so
410 done
411
412 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
413 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
414
415 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
416 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
417 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
418
419 %clean
420 rm -rf $RPM_BUILD_ROOT
421
422 %post
423  /sbin/ldconfig
424 %update_desktop_database
425
426 %postun -p /sbin/ldconfig
427
428 %triggerpostun -- wine < 1:0.9.12-1.9
429 rm -f /var/lock/subsys/wine
430 if [ -x /sbin/chkconfig ]; then
431         /sbin/chkconfig --del wine
432 fi
433
434 %files -f files.so
435 %defattr(644,root,root,755)
436 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
437 %lang(de) %doc documentation/README.de
438 %lang(es) %doc documentation/README.es
439 %lang(fr) %doc documentation/README.fr
440 %lang(hu) %doc documentation/README.hu
441 %lang(it) %doc documentation/README.it
442 %lang(ko) %doc documentation/README.ko
443 %lang(nb) %doc documentation/README.no
444 %lang(pt) %doc documentation/README.pt
445 %lang(pt_BR) %doc documentation/README.pt_br
446 %lang(ru) %doc documentation/README.ru
447 %lang(sv) %doc documentation/README.sv
448 %lang(tr) %doc documentation/README.tr
449 %attr(755,root,root) %{_bindir}/msiexec
450 %attr(755,root,root) %{_bindir}/wineboot
451 %attr(755,root,root) %{_bindir}/winedbg
452 %attr(755,root,root) %{_bindir}/winecfg
453 %attr(755,root,root) %{_bindir}/wineserver
454 %ifarch %{x8664}
455 %attr(755,root,root) %{_bindir}/wine64
456 %else
457 %attr(755,root,root) %{_bindir}/wine
458 %attr(755,root,root) %{_bindir}/wine-preloader
459 %endif
460 %attr(755,root,root) %{_libdir}/*.so*
461 %dir %{_libdir}/wine
462 %dir %{_libdir}/wine/fakedlls
463 %{_libdir}/wine/fakedlls/*.acm
464 %{_libdir}/wine/fakedlls/*.cpl
465 %{_libdir}/wine/fakedlls/*.dll
466 %{_libdir}/wine/fakedlls/*.drv
467 %{_libdir}/wine/fakedlls/*.ds
468 %{_libdir}/wine/fakedlls/*.exe
469 %{_libdir}/wine/fakedlls/*.ocx
470 %{_libdir}/wine/fakedlls/*.sys
471 %{_libdir}/wine/fakedlls/*.tlb
472 %ifarch %{ix86}
473 %{_libdir}/wine/fakedlls/*.dll16
474 %{_libdir}/wine/fakedlls/*.drv16
475 %{_libdir}/wine/fakedlls/*.exe16
476 %{_libdir}/wine/fakedlls/*.mod16
477 %{_libdir}/wine/fakedlls/*.vxd
478 %endif
479 %{_mandir}/man1/wine.1*
480 %{_mandir}/man1/msiexec.1*
481 %{_mandir}/man1/wineboot.1*
482 %{_mandir}/man1/winecfg.1*
483 %lang(de) %{_mandir}/de/man1/wine.1*
484 %lang(fr) %{_mandir}/fr/man1/wine.1*
485 %{_mandir}/man1/winedbg.1*
486 %{_mandir}/man1/wineserver.1*
487 %lang(de) %{_mandir}/de/man1/wineserver.1*
488 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
489 %{_winedir}
490 %{_desktopdir}/wine.desktop
491 %{_desktopdir}/wine-uninstaller.desktop
492 %{_pixmapsdir}/%{name}.png
493
494 %files programs -f files.programs
495 %defattr(644,root,root,755)
496
497 %files devel
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_bindir}/fnt2bdf
500 %attr(755,root,root) %{_bindir}/function_grep.pl
501 %attr(755,root,root) %{_bindir}/widl
502 %attr(755,root,root) %{_bindir}/winebuild
503 %attr(755,root,root) %{_bindir}/winedump
504 %attr(755,root,root) %{_bindir}/wineg++
505 %attr(755,root,root) %{_bindir}/winegcc
506 %attr(755,root,root) %{_bindir}/winemaker
507 %attr(755,root,root) %{_bindir}/winecpp
508 %attr(755,root,root) %{_bindir}/wmc
509 %attr(755,root,root) %{_bindir}/wrc
510 %{_libdir}/wine/lib*.def
511 # no shared variants, so not separated
512 %{_libdir}/wine/lib*.def.a
513 %{_libdir}/wine/libadsiid.a
514 %{_libdir}/wine/libdx*.a
515 %{_libdir}/wine/libstrmiids.a
516 %{_libdir}/wine/libuuid.a
517 %{_libdir}/wine/libwinecrt0.a
518 %{_includedir}/wine
519 %{_mandir}/man1/widl.1*
520 %{_mandir}/man1/winebuild.1*
521 %{_mandir}/man1/winecpp.1*
522 %{_mandir}/man1/winedump.1*
523 %{_mandir}/man1/winegcc.1*
524 %{_mandir}/man1/wineg++.1*
525 %{_mandir}/man1/winemaker.1*
526 %lang(de) %{_mandir}/de/man1/winemaker.1*
527 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
528 %{_mandir}/man1/wmc.1*
529 %{_mandir}/man1/wrc.1*
530 %{_aclocaldir}/*.m4
531
532 %files dll-d3d
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
535 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
536 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
537
538 %files dll-gl
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
541 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
542
543 %if %{with sane}
544 %files dll-twain
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
547 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
548 %endif
549
550 %if %{with ldap}
551 %files dll-ldap
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
554 %endif
555
556 %if %{with alsa}
557 %files drv-alsa
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
560 %endif
561
562 %if %{with jack}
563 %files drv-jack
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
566 %endif
567
568 %if %{with nas}
569 %files drv-nas
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
572 %endif
573
574 # additional dependencies in *.so not separated (yet?) from main package
575 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
576 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
577 #   ttydrv.dll.so depends on ncurses
This page took 0.08192 seconds and 4 git commands to generate.