]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- dll-ldap subpackage; ldap bcond
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_with     esd             # build ESD mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 #
11 # TODO:
12 # - support for CAPI (ISDN support; --with-capi)
13 #
14 # NOTE: wine detects the following SONAMES for dlopen at build time:
15 #   libcrypto,libssl (wininet.dll)
16 #   libcups (winspool.dll.so,wineps.dll.so)
17 #   libcurses/libncurses (wineconsole program)
18 #   libfontconfig (gdi32.dll.so)
19 #   libfreetype (wineps.dll.so,gdi32.dll.so)
20 #   libGL (x11drv.dll.so,ddraw.dll.so)
21 #   libjack (winejack.drv.so - explicit dependency in subpackage)
22 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
23 # thus requires rebuild after change of any of the above.
24 #
25 # JACK requires ALSA
26 %if %{without alsa}
27 %undefine       with_jack
28 %endif
29
30 Summary:        Program that lets you launch Win applications
31 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
32 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
33 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
34 Name:           wine
35 Version:        1.2.3
36 Release:        3
37 Epoch:          1
38 License:        LGPL
39 Group:          Applications/Emulators
40 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
41 # Source0-md5:  a18ca677d1e01d1596d6692a8f3997e5
42 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
43 # Source1-md5:  9c5c335fc077c0558561afaf25a09e51
44 Source2:        %{name}-uninstaller.desktop
45 Patch0:         %{name}-fontcache.patch
46 Patch1:         %{name}-makedep.patch
47 Patch2:         %{name}-ncurses.patch
48 Patch4:         %{name}-disable-valgrind.patch
49 Patch5:         %{name}-ca_certificates.patch
50 Patch6:         %{name}-manpaths.patch
51 Patch7:         desktop.patch
52 #PatchX:        %{name}-dga.patch
53 URL:            http://www.winehq.org/
54 BuildRequires:  OpenAL-devel >= 1.1
55 BuildRequires:  OpenGL-GLU-devel
56 %{?with_alsa:BuildRequires:     alsa-lib-devel}
57 %{?with_arts:BuildRequires:     artsc-devel}
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 BuildRequires:  bison
61 %{?with_cups:BuildRequires:     cups-devel}
62 BuildRequires:  docbook-dtd31-sgml
63 BuildRequires:  docbook-utils
64 %{?with_esd:BuildRequires:      esound-devel}
65 BuildRequires:  flex
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  fontforge
68 BuildRequires:  freetype-devel >= 2.0.5
69 BuildRequires:  giflib-devel
70 BuildRequires:  gnutls-devel
71 BuildRequires:  hal-devel
72 BuildRequires:  icoutils
73 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
74 BuildRequires:  lcms-devel
75 BuildRequires:  libgphoto2-devel
76 BuildRequires:  libgsm-devel
77 BuildRequires:  libjpeg-devel
78 BuildRequires:  libmpg123-devel >= 1.5.0
79 BuildRequires:  libtool
80 BuildRequires:  libv4l-devel
81 BuildRequires:  libxslt-devel
82 %{?with_nas:BuildRequires:      nas-devel}
83 BuildRequires:  ncurses-devel
84 # db2* failed previously - probably openjade or opensp bug
85 BuildRequires:  openjade >= 1:1.3.3-0.pre1
86 %{?with_ldap:BuildRequires:     openldap-devel}
87 BuildRequires:  opensp >= 1:1.5.1
88 BuildRequires:  openssl-devel >= 0.9.7d
89 BuildRequires:  pkgconfig
90 %{?with_sane:BuildRequires:     sane-backends-devel}
91 BuildRequires:  unixODBC-devel >= 2.2.12-2
92 #BuildRequires: valgrind
93 BuildRequires:  xorg-lib-libXcomposite-devel
94 BuildRequires:  xorg-lib-libXcursor-devel
95 BuildRequires:  xorg-lib-libXi-devel
96 BuildRequires:  xorg-lib-libXinerama-devel
97 BuildRequires:  xorg-lib-libXmu-devel
98 BuildRequires:  xorg-lib-libXrandr-devel
99 BuildRequires:  xorg-lib-libXrender-devel
100 BuildRequires:  xorg-lib-libXxf86dga-devel
101 BuildRequires:  xorg-lib-libXxf86vm-devel
102 %ifarch %{x8664}
103 Requires:       libfreetype.so.6()(64bit)
104 %else
105 Requires:       libfreetype.so.6
106 %endif
107 Requires(post): /sbin/ldconfig
108 Suggests:       binfmt-detector
109 Suggests:       ca-certificates
110 Conflicts:      ca-certificates < 20080809-4
111 # for printing needs lpr
112 Suggests:       cups-clients
113 # for winelauncher
114 Suggests:       xorg-app-xmessage
115 # for ntlm_auth
116 Suggests:       samba-common >= 1:3.0.25
117 # link to wine/ntdll.dll.so, without any SONAME
118 Provides:       libntdll.dll.so
119 Obsoletes:      wine-doc-pdf
120 Obsoletes:      wine-drv-arts
121 ExclusiveArch:  %{ix86} %{x8664}
122 ExcludeArch:    i386
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
126 %define         no_install_post_strip   1
127
128 %define         _winedir                %{_datadir}/%{name}
129
130 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
131
132 %undefine       debuginfocflags
133
134 %description
135 Wine is a program which allows running Microsoft Windows programs
136 (including DOS, Windows 3.x and Win32 executables) on Unix. It
137 consists of a program loader which loads and executes a Microsoft
138 Windows binary, and a library that implements Windows API calls using
139 their Unix or X11 equivalents. The library may also be used for
140 porting Win32 code into native Unix executables.
141
142 %description -l es.UTF-8
143 Ejecuta programas Windows en Linux.
144
145 %description -l pl.UTF-8
146 Wine jest programem dzięki któremu można uruchamiać programy napisane
147 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
148 loadera, który pozwala wczytywać i uruchamiać programy w formacie
149 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
150 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
151 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
152
153 %description -l pt_BR.UTF-8
154 O Wine é um programa que permite rodar programas MS-Windows no X11.
155 Ele consiste de um carregador de programa, que carrega e executa um
156 binário MS-Windows, e de uma biblioteca de emulação que traduz as
157 chamadas da API para as equivalentes Unix/X11.
158
159 %package devel
160 Summary:        Wine - header files
161 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
162 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
163 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
164 Group:          Development/Libraries
165 Requires:       %{name} = %{epoch}:%{version}-%{release}
166
167 %description devel
168 Wine - header files.
169
170 %description devel -l es.UTF-8
171 Biblioteca de desarrollo de wine.
172
173 %description devel -l pl.UTF-8
174 Wine - pliki nagłówkowe.
175
176 %description devel -l pt_BR.UTF-8
177 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
178 WINE.
179
180 %package programs
181 Summary:        Wine - programs
182 Summary(pl.UTF-8):      Wine - programy
183 Group:          Applications
184 Requires:       %{name} = %{epoch}:%{version}-%{release}
185
186 %description programs
187 Wine - programs.
188
189 %description programs -l pl.UTF-8
190 Wine - programy.
191
192 %package dll-d3d
193 Summary:        Direct3D implementation DLLs for Wine
194 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
195 Group:          Applications/Emulators
196 Requires:       %{name} = %{epoch}:%{version}-%{release}
197 Requires:       OpenGL
198
199 %description dll-d3d
200 Direct3D implementation DLLs for Wine (through OpenGL).
201
202 %description dll-d3d -l pl.UTF-8
203 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
204
205 %package dll-gl
206 Summary:        OpenGL implementation DLLs for Wine
207 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
208 Group:          Applications/Emulators
209 Requires:       %{name} = %{epoch}:%{version}-%{release}
210 Requires:       OpenGL
211
212 %description dll-gl
213 OpenGL implementation DLLs for Wine.
214
215 %description dll-gl -l pl.UTF-8
216 Biblioteki DLL z implementacją OpenGL dla Wine.
217
218 %package dll-twain
219 Summary:        TWAIN implementation DLL for Wine
220 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
221 Group:          Applications/Emulators
222 Requires:       %{name} = %{epoch}:%{version}-%{release}
223
224 %description dll-twain
225 TWAIN implementation DLL for Wine (through SANE).
226
227 %description dll-twain -l pl.UTF-8
228 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
229
230 %package dll-ldap
231 Summary:        Win32 LDAP API DLL for Wine.
232 Group:          Applications/Emulators
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234
235 %description dll-ldap
236 Lightweight Directory Access Protocol Library.
237
238 %package drv-alsa
239 Summary:        ALSA driver for WINE mm.dll implementation
240 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
241 Group:          Applications/Emulators
242 Requires:       %{name} = %{epoch}:%{version}-%{release}
243
244 %description drv-alsa
245 ALSA driver for WINE mm.dll (multimedia system) implementation.
246
247 %description drv-alsa -l pl.UTF-8
248 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
249
250 %package drv-jack
251 Summary:        JACK driver for WINE mm.dll implementation
252 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
253 Group:          Applications/Emulators
254 Requires:       %{name} = %{epoch}:%{version}-%{release}
255 Requires:       jack-audio-connection-kit
256 # dlopened by SONAME detected at build time
257 %ifarch %{x8664}
258 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}()(64bit)}
259 %else
260 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
261 %endif
262
263 %description drv-jack
264 JACK driver for WINE mm.dll (multimedia system) implementation.
265
266 %description drv-jack -l pl.UTF-8
267 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
268 Wine.
269
270 %package drv-nas
271 Summary:        NAS driver for WINE mm.dll implementation
272 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
273 Group:          Applications/Emulators
274 Requires:       %{name} = %{epoch}:%{version}-%{release}
275
276 %description drv-nas
277 NAS driver for WINE mm.dll (multimedia system) implementation.
278
279 %description drv-nas -l pl.UTF-8
280 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
281
282 %prep
283 %setup -q
284 %patch0 -p1
285 %patch1 -p1
286 %patch2 -p1
287 %patch4 -p1
288 %patch5 -p1
289 %patch6 -p1
290 %patch7 -p1
291
292 %build
293 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
294 mv -f oic_winlogo_*.png %{name}.png
295
296 %{__autoconf}
297 %{__autoheader}
298 %configure \
299 %ifarch %{x8664}
300         --enable-win64 \
301 %endif
302         --with%{!?with_alsa:out}-alsa \
303         --with-audioio \
304         --without-capi \
305         --with-cms \
306         --with-coreaudio \
307         --with%{!?with_cups:out}-cups \
308         --with-curses \
309         --with%{!?with_esd:out}-esd \
310         --with-fontconfig \
311         --with-freetype \
312         --with-glu \
313         --with-gnutls \
314         --with-gphoto \
315         --with-gsm \
316         --with-hal \
317         --with%{!?with_jack:out}-jack \
318         --with-jpeg \
319         --with%{!?with_ldap:out}-ldap \
320         --with-mpg123 \
321         --with%{!?with_nas:out}-nas \
322         --with-opengl \
323         --with-openssl \
324         --with-oss \
325         --with-png \
326         --with-pthread \
327         --with%{!?with_sane:out}-sane \
328         --with-xcomposite \
329         --with-xcursor \
330         --with-xinerama \
331         --with-xinput \
332         --with-xml \
333         --with-xrandr \
334         --with-xrender \
335         --with-xshape \
336         --with-xshm \
337         --with-xslt \
338         --with-xxf86vm \
339         --with-x
340 %{__make} depend
341 %{__make}
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
346 %{__make} install \
347         DESTDIR=$RPM_BUILD_ROOT
348
349 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
350 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
351
352 install -d \
353         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
354         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
355         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
356         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
357         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
358
359 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
360 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
361 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
362
363 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
364 [mci]
365 cdaudio=mcicda.drv
366 sequencer=mciseq.drv
367 waveaudio=mciwave.drv
368 avivideo=mciavi.drv
369 videodisc=mcipionr.drv
370 vcr=mciviscd.drv
371 MPEGVideo=mciqtz.drv
372 EOF
373
374 %if %{?debug:0}%{!?debug:1}
375 echo "Strip executable binaries and shared object files."
376 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
377 elfexelist=`echo $filelist | xargs -r file | \
378         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
379 elfsharedlist=`echo $filelist | xargs -r file | \
380         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
381 if [ -n "$elfexelist" ]; then \
382         strip -R .note -R .comment $elfexelist
383 fi
384 if [ -n "$elfsharedlist" ]; then
385         strip --strip-unneeded -R .note -R .comment $elfsharedlist
386 fi
387 %endif
388
389 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
390
391 dir=$(pwd)
392 > files.so
393 > files.programs
394 cd $RPM_BUILD_ROOT%{_libdir}/wine
395 for f in *.so; do
396         case $f in
397         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so|wldap32.dll.so)
398                 ;;
399         *)
400                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
401         esac
402 done
403 cd -
404
405 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
406 for p in $programs; do
407         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
408         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
409         echo "%{_mandir}/man1/$p.1*" >> files.programs
410         grep -v "$p\.exe\.so$" files.so > files.so.
411         mv -f files.so. files.so
412 done
413
414 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
415 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
416
417 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
418 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
419 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %post
425  /sbin/ldconfig
426 %update_desktop_database
427
428 %postun -p /sbin/ldconfig
429
430 %triggerpostun -- wine < 1:0.9.12-1.9
431 rm -f /var/lock/subsys/wine
432 if [ -x /sbin/chkconfig ]; then
433         /sbin/chkconfig --del wine
434 fi
435
436 %files -f files.so
437 %defattr(644,root,root,755)
438 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
439 %lang(de) %doc documentation/README.de
440 %lang(es) %doc documentation/README.es
441 %lang(fr) %doc documentation/README.fr
442 %lang(hu) %doc documentation/README.hu
443 %lang(it) %doc documentation/README.it
444 %lang(ko) %doc documentation/README.ko
445 %lang(nb) %doc documentation/README.no
446 %lang(pt) %doc documentation/README.pt
447 %lang(pt_BR) %doc documentation/README.pt_br
448 %lang(ru) %doc documentation/README.ru
449 %lang(sv) %doc documentation/README.sv
450 %lang(tr) %doc documentation/README.tr
451 %attr(755,root,root) %{_bindir}/msiexec
452 %attr(755,root,root) %{_bindir}/wineboot
453 %attr(755,root,root) %{_bindir}/winedbg
454 %attr(755,root,root) %{_bindir}/winecfg
455 %attr(755,root,root) %{_bindir}/wineserver
456 %ifarch %{x8664}
457 %attr(755,root,root) %{_bindir}/wine64
458 %else
459 %attr(755,root,root) %{_bindir}/wine
460 %attr(755,root,root) %{_bindir}/wine-preloader
461 %endif
462 %attr(755,root,root) %{_libdir}/*.so*
463 %dir %{_libdir}/wine
464 %dir %{_libdir}/wine/fakedlls
465 %{_libdir}/wine/fakedlls/*.acm
466 %{_libdir}/wine/fakedlls/*.cpl
467 %{_libdir}/wine/fakedlls/*.dll
468 %{_libdir}/wine/fakedlls/*.drv
469 %{_libdir}/wine/fakedlls/*.ds
470 %{_libdir}/wine/fakedlls/*.exe
471 %{_libdir}/wine/fakedlls/*.ocx
472 %{_libdir}/wine/fakedlls/*.sys
473 %{_libdir}/wine/fakedlls/*.tlb
474 %ifarch %{ix86}
475 %{_libdir}/wine/fakedlls/*.dll16
476 %{_libdir}/wine/fakedlls/*.drv16
477 %{_libdir}/wine/fakedlls/*.exe16
478 %{_libdir}/wine/fakedlls/*.mod16
479 %{_libdir}/wine/fakedlls/*.vxd
480 %endif
481 %{_mandir}/man1/wine.1*
482 %{_mandir}/man1/msiexec.1*
483 %{_mandir}/man1/wineboot.1*
484 %{_mandir}/man1/winecfg.1*
485 %lang(de) %{_mandir}/de/man1/wine.1*
486 %lang(fr) %{_mandir}/fr/man1/wine.1*
487 %{_mandir}/man1/winedbg.1*
488 %{_mandir}/man1/wineserver.1*
489 %lang(de) %{_mandir}/de/man1/wineserver.1*
490 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
491 %{_winedir}
492 %{_desktopdir}/wine.desktop
493 %{_desktopdir}/wine-uninstaller.desktop
494 %{_pixmapsdir}/%{name}.png
495
496 %files programs -f files.programs
497 %defattr(644,root,root,755)
498
499 %files devel
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{_bindir}/fnt2bdf
502 %attr(755,root,root) %{_bindir}/function_grep.pl
503 %attr(755,root,root) %{_bindir}/widl
504 %attr(755,root,root) %{_bindir}/winebuild
505 %attr(755,root,root) %{_bindir}/winedump
506 %attr(755,root,root) %{_bindir}/wineg++
507 %attr(755,root,root) %{_bindir}/winegcc
508 %attr(755,root,root) %{_bindir}/winemaker
509 %attr(755,root,root) %{_bindir}/winecpp
510 %attr(755,root,root) %{_bindir}/wmc
511 %attr(755,root,root) %{_bindir}/wrc
512 %{_libdir}/wine/lib*.def
513 # no shared variants, so not separated
514 %{_libdir}/wine/lib*.def.a
515 %{_libdir}/wine/libadsiid.a
516 %{_libdir}/wine/libdx*.a
517 %{_libdir}/wine/libstrmiids.a
518 %{_libdir}/wine/libuuid.a
519 %{_libdir}/wine/libwinecrt0.a
520 %{_includedir}/wine
521 %{_mandir}/man1/widl.1*
522 %{_mandir}/man1/winebuild.1*
523 %{_mandir}/man1/winecpp.1*
524 %{_mandir}/man1/winedump.1*
525 %{_mandir}/man1/winegcc.1*
526 %{_mandir}/man1/wineg++.1*
527 %{_mandir}/man1/winemaker.1*
528 %lang(de) %{_mandir}/de/man1/winemaker.1*
529 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
530 %{_mandir}/man1/wmc.1*
531 %{_mandir}/man1/wrc.1*
532 %{_aclocaldir}/*.m4
533
534 %files dll-d3d
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
537 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
538 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
539
540 %files dll-gl
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
543 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
544
545 %if %{with sane}
546 %files dll-twain
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
549 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
550 %endif
551
552 %if %{with ldap}
553 %files dll-ldap
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
556 %endif
557
558 %if %{with alsa}
559 %files drv-alsa
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
562 %endif
563
564 %if %{with jack}
565 %files drv-jack
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
568 %endif
569
570 %if %{with nas}
571 %files drv-nas
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
574 %endif
575
576 # additional dependencies in *.so not separated (yet?) from main package
577 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
578 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
579 #   ttydrv.dll.so depends on ncurses
This page took 0.15964 seconds and 4 git commands to generate.