]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- update-desktop-database (.desktop specifies MimeType)
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_with     esd             # build ESD mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # TODO:
11 # - support for CAPI (ISDN support; --with-capi)
12 #
13 # NOTE: wine detects the following SONAMES for dlopen at build time:
14 #   libcrypto,libssl (wininet.dll)
15 #   libcups (winspool.dll.so,wineps.dll.so)
16 #   libcurses/libncurses (wineconsole program)
17 #   libfontconfig (gdi32.dll.so)
18 #   libfreetype (wineps.dll.so,gdi32.dll.so)
19 #   libGL (x11drv.dll.so,ddraw.dll.so)
20 #   libjack (winejack.drv.so - explicit dependency in subpackage)
21 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
22 # thus requires rebuild after change of any of the above.
23 #
24 # JACK requires ALSA
25 %if %{without alsa}
26 %undefine       with_jack
27 %endif
28
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.2.3
35 Release:        2
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  a18ca677d1e01d1596d6692a8f3997e5
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
42 # Source1-md5:  9c5c335fc077c0558561afaf25a09e51
43 Source2:        %{name}-uninstaller.desktop
44 Patch0:         %{name}-fontcache.patch
45 Patch1:         %{name}-makedep.patch
46 Patch2:         %{name}-ncurses.patch
47 Patch4:         %{name}-disable-valgrind.patch
48 Patch5:         %{name}-ca_certificates.patch
49 Patch6:         %{name}-manpaths.patch
50 Patch7:         desktop.patch
51 #PatchX:        %{name}-dga.patch
52 URL:            http://www.winehq.org/
53 BuildRequires:  OpenAL-devel >= 1.1
54 BuildRequires:  OpenGL-GLU-devel
55 %{?with_alsa:BuildRequires:     alsa-lib-devel}
56 %{?with_arts:BuildRequires:     artsc-devel}
57 BuildRequires:  autoconf
58 BuildRequires:  automake
59 BuildRequires:  bison
60 %{?with_cups:BuildRequires:     cups-devel}
61 BuildRequires:  docbook-dtd31-sgml
62 BuildRequires:  docbook-utils
63 %{?with_esd:BuildRequires:      esound-devel}
64 BuildRequires:  flex
65 BuildRequires:  fontconfig-devel
66 BuildRequires:  fontforge
67 BuildRequires:  freetype-devel >= 2.0.5
68 BuildRequires:  giflib-devel
69 BuildRequires:  gnutls-devel
70 BuildRequires:  hal-devel
71 BuildRequires:  icoutils
72 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
73 BuildRequires:  lcms-devel
74 BuildRequires:  libgphoto2-devel
75 BuildRequires:  libgsm-devel
76 BuildRequires:  libjpeg-devel
77 BuildRequires:  libmpg123-devel >= 1.5.0
78 BuildRequires:  libtool
79 BuildRequires:  libv4l-devel
80 BuildRequires:  libxslt-devel
81 %{?with_nas:BuildRequires:      nas-devel}
82 BuildRequires:  ncurses-devel
83 # db2* failed previously - probably openjade or opensp bug
84 BuildRequires:  openjade >= 1:1.3.3-0.pre1
85 BuildRequires:  openldap-devel
86 BuildRequires:  opensp >= 1:1.5.1
87 BuildRequires:  openssl-devel >= 0.9.7d
88 BuildRequires:  pkgconfig
89 %{?with_sane:BuildRequires:     sane-backends-devel}
90 BuildRequires:  unixODBC-devel >= 2.2.12-2
91 #BuildRequires: valgrind
92 BuildRequires:  xorg-lib-libXcomposite-devel
93 BuildRequires:  xorg-lib-libXcursor-devel
94 BuildRequires:  xorg-lib-libXi-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXmu-devel
97 BuildRequires:  xorg-lib-libXrandr-devel
98 BuildRequires:  xorg-lib-libXrender-devel
99 BuildRequires:  xorg-lib-libXxf86dga-devel
100 BuildRequires:  xorg-lib-libXxf86vm-devel
101 %ifarch %{x8664}
102 Requires:       libfreetype.so.6()(64bit)
103 %else
104 Requires:       libfreetype.so.6
105 %endif
106 Requires(post): /sbin/ldconfig
107 Suggests:       binfmt-detector
108 Suggests:       ca-certificates
109 Conflicts:      ca-certificates < 20080809-4
110 # for printing needs lpr
111 Suggests:       cups-clients
112 # for winelauncher
113 Suggests:       xorg-app-xmessage
114 # for ntlm_auth
115 Suggests:       samba-common >= 1:3.0.25
116 # link to wine/ntdll.dll.so, without any SONAME
117 Provides:       libntdll.dll.so
118 Obsoletes:      wine-doc-pdf
119 Obsoletes:      wine-drv-arts
120 ExclusiveArch:  %{ix86} %{x8664}
121 ExcludeArch:    i386
122 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
125 %define         no_install_post_strip   1
126
127 %define         _winedir                %{_datadir}/%{name}
128
129 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
130
131 %undefine       debuginfocflags
132
133 %description
134 Wine is a program which allows running Microsoft Windows programs
135 (including DOS, Windows 3.x and Win32 executables) on Unix. It
136 consists of a program loader which loads and executes a Microsoft
137 Windows binary, and a library that implements Windows API calls using
138 their Unix or X11 equivalents. The library may also be used for
139 porting Win32 code into native Unix executables.
140
141 %description -l es.UTF-8
142 Ejecuta programas Windows en Linux.
143
144 %description -l pl.UTF-8
145 Wine jest programem dzięki któremu można uruchamiać programy napisane
146 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
147 loadera, który pozwala wczytywać i uruchamiać programy w formacie
148 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
149 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
150 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
151
152 %description -l pt_BR.UTF-8
153 O Wine é um programa que permite rodar programas MS-Windows no X11.
154 Ele consiste de um carregador de programa, que carrega e executa um
155 binário MS-Windows, e de uma biblioteca de emulação que traduz as
156 chamadas da API para as equivalentes Unix/X11.
157
158 %package devel
159 Summary:        Wine - header files
160 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
161 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
162 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
163 Group:          Development/Libraries
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165
166 %description devel
167 Wine - header files.
168
169 %description devel -l es.UTF-8
170 Biblioteca de desarrollo de wine.
171
172 %description devel -l pl.UTF-8
173 Wine - pliki nagłówkowe.
174
175 %description devel -l pt_BR.UTF-8
176 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
177 WINE.
178
179 %package programs
180 Summary:        Wine - programs
181 Summary(pl.UTF-8):      Wine - programy
182 Group:          Applications
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description programs
186 Wine - programs.
187
188 %description programs -l pl.UTF-8
189 Wine - programy.
190
191 %package dll-d3d
192 Summary:        Direct3D implementation DLLs for Wine
193 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
194 Group:          Applications/Emulators
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196 Requires:       OpenGL
197
198 %description dll-d3d
199 Direct3D implementation DLLs for Wine (through OpenGL).
200
201 %description dll-d3d -l pl.UTF-8
202 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
203
204 %package dll-gl
205 Summary:        OpenGL implementation DLLs for Wine
206 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
207 Group:          Applications/Emulators
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209 Requires:       OpenGL
210
211 %description dll-gl
212 OpenGL implementation DLLs for Wine.
213
214 %description dll-gl -l pl.UTF-8
215 Biblioteki DLL z implementacją OpenGL dla Wine.
216
217 %package dll-twain
218 Summary:        TWAIN implementation DLL for Wine
219 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
220 Group:          Applications/Emulators
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222
223 %description dll-twain
224 TWAIN implementation DLL for Wine (through SANE).
225
226 %description dll-twain -l pl.UTF-8
227 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
228
229 %package drv-alsa
230 Summary:        ALSA driver for WINE mm.dll implementation
231 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
232 Group:          Applications/Emulators
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234
235 %description drv-alsa
236 ALSA driver for WINE mm.dll (multimedia system) implementation.
237
238 %description drv-alsa -l pl.UTF-8
239 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
240
241 %package drv-jack
242 Summary:        JACK driver for WINE mm.dll implementation
243 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
244 Group:          Applications/Emulators
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246 Requires:       jack-audio-connection-kit
247 # dlopened by SONAME detected at build time
248 %ifarch %{x8664}
249 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}()(64bit)}
250 %else
251 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
252 %endif
253
254 %description drv-jack
255 JACK driver for WINE mm.dll (multimedia system) implementation.
256
257 %description drv-jack -l pl.UTF-8
258 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
259 Wine.
260
261 %package drv-nas
262 Summary:        NAS driver for WINE mm.dll implementation
263 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
264 Group:          Applications/Emulators
265 Requires:       %{name} = %{epoch}:%{version}-%{release}
266
267 %description drv-nas
268 NAS driver for WINE mm.dll (multimedia system) implementation.
269
270 %description drv-nas -l pl.UTF-8
271 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
272
273 %prep
274 %setup -q
275 %patch0 -p1
276 %patch1 -p1
277 %patch2 -p1
278 %patch4 -p1
279 %patch5 -p1
280 %patch6 -p1
281 %patch7 -p1
282
283 %build
284 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
285 mv -f oic_winlogo_*.png %{name}.png
286
287 %{__autoconf}
288 %{__autoheader}
289 %configure \
290 %ifarch %{x8664}
291         --enable-win64 \
292 %endif
293         --with%{!?with_alsa:out}-alsa \
294         --with-audioio \
295         --without-capi \
296         --with-cms \
297         --with-coreaudio \
298         --with%{!?with_cups:out}-cups \
299         --with-curses \
300         --with%{!?with_esd:out}-esd \
301         --with-fontconfig \
302         --with-freetype \
303         --with-glu \
304         --with-gnutls \
305         --with-gphoto \
306         --with-gsm \
307         --with-hal \
308         --with%{!?with_jack:out}-jack \
309         --with-jpeg \
310         --with-ldap \
311         --with-mpg123 \
312         --with%{!?with_nas:out}-nas \
313         --with-opengl \
314         --with-openssl \
315         --with-oss \
316         --with-png \
317         --with-pthread \
318         --with%{!?with_sane:out}-sane \
319         --with-xcomposite \
320         --with-xcursor \
321         --with-xinerama \
322         --with-xinput \
323         --with-xml \
324         --with-xrandr \
325         --with-xrender \
326         --with-xshape \
327         --with-xshm \
328         --with-xslt \
329         --with-xxf86vm \
330         --with-x
331 %{__make} depend
332 %{__make}
333
334 %install
335 rm -rf $RPM_BUILD_ROOT
336 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
337 %{__make} install \
338         DESTDIR=$RPM_BUILD_ROOT
339
340 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
341 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
342
343 install -d \
344         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
345         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
346         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
347         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
348         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
349
350 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
351 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
352 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
353
354 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
355 [mci]
356 cdaudio=mcicda.drv
357 sequencer=mciseq.drv
358 waveaudio=mciwave.drv
359 avivideo=mciavi.drv
360 videodisc=mcipionr.drv
361 vcr=mciviscd.drv
362 MPEGVideo=mciqtz.drv
363 EOF
364
365 %if %{?debug:0}%{!?debug:1}
366 echo "Strip executable binaries and shared object files."
367 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
368 elfexelist=`echo $filelist | xargs -r file | \
369         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
370 elfsharedlist=`echo $filelist | xargs -r file | \
371         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
372 if [ -n "$elfexelist" ]; then \
373         strip -R .note -R .comment $elfexelist
374 fi
375 if [ -n "$elfsharedlist" ]; then
376         strip --strip-unneeded -R .note -R .comment $elfsharedlist
377 fi
378 %endif
379
380 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
381
382 dir=$(pwd)
383 > files.so
384 > files.programs
385 cd $RPM_BUILD_ROOT%{_libdir}/wine
386 for f in *.so; do
387         case $f in
388         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
389                 ;;
390         *)
391                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
392         esac
393 done
394 cd -
395
396 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
397 for p in $programs; do
398         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
399         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
400         echo "%{_mandir}/man1/$p.1*" >> files.programs
401         grep -v "$p\.exe\.so$" files.so > files.so.
402         mv -f files.so. files.so
403 done
404
405 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
406 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
407
408 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
409 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
410 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
411
412 %clean
413 rm -rf $RPM_BUILD_ROOT
414
415 %post
416  /sbin/ldconfig
417 %update_desktop_database
418
419 %postun -p /sbin/ldconfig
420
421 %triggerpostun -- wine < 1:0.9.12-1.9
422 rm -f /var/lock/subsys/wine
423 if [ -x /sbin/chkconfig ]; then
424         /sbin/chkconfig --del wine
425 fi
426
427 %files -f files.so
428 %defattr(644,root,root,755)
429 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
430 %lang(de) %doc documentation/README.de
431 %lang(es) %doc documentation/README.es
432 %lang(fr) %doc documentation/README.fr
433 %lang(hu) %doc documentation/README.hu
434 %lang(it) %doc documentation/README.it
435 %lang(ko) %doc documentation/README.ko
436 %lang(nb) %doc documentation/README.no
437 %lang(pt) %doc documentation/README.pt
438 %lang(pt_BR) %doc documentation/README.pt_br
439 %lang(ru) %doc documentation/README.ru
440 %lang(sv) %doc documentation/README.sv
441 %lang(tr) %doc documentation/README.tr
442 %attr(755,root,root) %{_bindir}/msiexec
443 %attr(755,root,root) %{_bindir}/wineboot
444 %attr(755,root,root) %{_bindir}/winedbg
445 %attr(755,root,root) %{_bindir}/winecfg
446 %attr(755,root,root) %{_bindir}/wineserver
447 %ifarch %{x8664}
448 %attr(755,root,root) %{_bindir}/wine64
449 %else
450 %attr(755,root,root) %{_bindir}/wine
451 %attr(755,root,root) %{_bindir}/wine-preloader
452 %endif
453 %attr(755,root,root) %{_libdir}/*.so*
454 %dir %{_libdir}/wine
455 %dir %{_libdir}/wine/fakedlls
456 %{_libdir}/wine/fakedlls/*.acm
457 %{_libdir}/wine/fakedlls/*.cpl
458 %{_libdir}/wine/fakedlls/*.dll
459 %{_libdir}/wine/fakedlls/*.drv
460 %{_libdir}/wine/fakedlls/*.ds
461 %{_libdir}/wine/fakedlls/*.exe
462 %{_libdir}/wine/fakedlls/*.ocx
463 %{_libdir}/wine/fakedlls/*.sys
464 %{_libdir}/wine/fakedlls/*.tlb
465 %ifarch %{ix86}
466 %{_libdir}/wine/fakedlls/*.dll16
467 %{_libdir}/wine/fakedlls/*.drv16
468 %{_libdir}/wine/fakedlls/*.exe16
469 %{_libdir}/wine/fakedlls/*.mod16
470 %{_libdir}/wine/fakedlls/*.vxd
471 %endif
472 %{_mandir}/man1/wine.1*
473 %{_mandir}/man1/msiexec.1*
474 %{_mandir}/man1/wineboot.1*
475 %{_mandir}/man1/winecfg.1*
476 %lang(de) %{_mandir}/de/man1/wine.1*
477 %lang(fr) %{_mandir}/fr/man1/wine.1*
478 %{_mandir}/man1/winedbg.1*
479 %{_mandir}/man1/wineserver.1*
480 %lang(de) %{_mandir}/de/man1/wineserver.1*
481 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
482 %{_winedir}
483 %{_desktopdir}/wine.desktop
484 %{_desktopdir}/wine-uninstaller.desktop
485 %{_pixmapsdir}/%{name}.png
486
487 %files programs -f files.programs
488 %defattr(644,root,root,755)
489
490 %files devel
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/fnt2bdf
493 %attr(755,root,root) %{_bindir}/function_grep.pl
494 %attr(755,root,root) %{_bindir}/widl
495 %attr(755,root,root) %{_bindir}/winebuild
496 %attr(755,root,root) %{_bindir}/winedump
497 %attr(755,root,root) %{_bindir}/wineg++
498 %attr(755,root,root) %{_bindir}/winegcc
499 %attr(755,root,root) %{_bindir}/winemaker
500 %attr(755,root,root) %{_bindir}/winecpp
501 %attr(755,root,root) %{_bindir}/wmc
502 %attr(755,root,root) %{_bindir}/wrc
503 %{_libdir}/wine/lib*.def
504 # no shared variants, so not separated
505 %{_libdir}/wine/lib*.def.a
506 %{_libdir}/wine/libadsiid.a
507 %{_libdir}/wine/libdx*.a
508 %{_libdir}/wine/libstrmiids.a
509 %{_libdir}/wine/libuuid.a
510 %{_libdir}/wine/libwinecrt0.a
511 %{_includedir}/wine
512 %{_mandir}/man1/widl.1*
513 %{_mandir}/man1/winebuild.1*
514 %{_mandir}/man1/winecpp.1*
515 %{_mandir}/man1/winedump.1*
516 %{_mandir}/man1/winegcc.1*
517 %{_mandir}/man1/wineg++.1*
518 %{_mandir}/man1/winemaker.1*
519 %lang(de) %{_mandir}/de/man1/winemaker.1*
520 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
521 %{_mandir}/man1/wmc.1*
522 %{_mandir}/man1/wrc.1*
523 %{_aclocaldir}/*.m4
524
525 %files dll-d3d
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
528 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
529 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
530
531 %files dll-gl
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
534 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
535
536 %if %{with sane}
537 %files dll-twain
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
540 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
541 %endif
542
543 %if %{with alsa}
544 %files drv-alsa
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
547 %endif
548
549 %if %{with jack}
550 %files drv-jack
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
553 %endif
554
555 %if %{with nas}
556 %files drv-nas
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
559 %endif
560
561 # additional dependencies in *.so not separated (yet?) from main package
562 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
563 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
564 #   ttydrv.dll.so depends on ncurses
This page took 0.094333 seconds and 4 git commands to generate.