]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- install icon properly (not create dir by icon name)
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_with     esd             # build ESD mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # TODO:
11 # - support for CAPI (ISDN support; --with-capi)
12 #
13 # NOTE: wine detects the following SONAMES for dlopen at build time:
14 #   libcrypto,libssl (wininet.dll)
15 #   libcups (winspool.dll.so,wineps.dll.so)
16 #   libcurses/libncurses (wineconsole program)
17 #   libfontconfig (gdi32.dll.so)
18 #   libfreetype (wineps.dll.so,gdi32.dll.so)
19 #   libGL (x11drv.dll.so,ddraw.dll.so)
20 #   libjack (winejack.drv.so - explicit dependency in subpackage)
21 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
22 # thus requires rebuild after change of any of the above.
23 #
24 # JACK requires ALSA
25 %if %{without alsa}
26 %undefine       with_jack
27 %endif
28
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.2.2
35 Release:        2
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  e976d64688e0833061e79efa3eac5d2c
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
42 # Source1-md5:  9c5c335fc077c0558561afaf25a09e51
43 Source2:        %{name}-uninstaller.desktop
44 Patch0:         %{name}-fontcache.patch
45 Patch1:         %{name}-makedep.patch
46 Patch2:         %{name}-ncurses.patch
47 Patch4:         %{name}-disable-valgrind.patch
48 Patch5:         %{name}-ca_certificates.patch
49 Patch6:         %{name}-notarget.patch
50 Patch7:         %{name}-manpaths.patch
51 #PatchX:        %{name}-dga.patch
52 URL:            http://www.winehq.org/
53 BuildRequires:  OpenAL-devel >= 1.1
54 BuildRequires:  OpenGL-GLU-devel
55 %{?with_alsa:BuildRequires:     alsa-lib-devel}
56 %{?with_arts:BuildRequires:     artsc-devel}
57 BuildRequires:  autoconf
58 BuildRequires:  automake
59 BuildRequires:  bison
60 %{?with_cups:BuildRequires:     cups-devel}
61 BuildRequires:  docbook-dtd31-sgml
62 BuildRequires:  docbook-utils
63 %{?with_esd:BuildRequires:      esound-devel}
64 BuildRequires:  flex
65 BuildRequires:  fontconfig-devel
66 BuildRequires:  fontforge
67 BuildRequires:  freetype-devel >= 2.0.5
68 BuildRequires:  giflib-devel
69 BuildRequires:  gnutls-devel
70 BuildRequires:  hal-devel
71 BuildRequires:  icoutils
72 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
73 BuildRequires:  lcms-devel
74 BuildRequires:  libgphoto2-devel
75 BuildRequires:  libgsm-devel
76 BuildRequires:  libjpeg-devel
77 BuildRequires:  libmpg123-devel >= 1.5.0
78 BuildRequires:  libtool
79 BuildRequires:  libv4l-devel
80 BuildRequires:  libxslt-devel
81 %{?with_nas:BuildRequires:      nas-devel}
82 BuildRequires:  ncurses-devel
83 # db2* failed previously - probably openjade or opensp bug
84 BuildRequires:  openjade >= 1:1.3.3-0.pre1
85 BuildRequires:  openldap-devel
86 BuildRequires:  opensp >= 1:1.5.1
87 BuildRequires:  openssl-devel >= 0.9.7d
88 BuildRequires:  pkgconfig
89 %{?with_sane:BuildRequires:     sane-backends-devel}
90 BuildRequires:  unixODBC-devel >= 2.2.12-2
91 #BuildRequires: valgrind
92 BuildRequires:  xorg-lib-libXcomposite-devel
93 BuildRequires:  xorg-lib-libXcursor-devel
94 BuildRequires:  xorg-lib-libXi-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXmu-devel
97 BuildRequires:  xorg-lib-libXrandr-devel
98 BuildRequires:  xorg-lib-libXrender-devel
99 BuildRequires:  xorg-lib-libXxf86dga-devel
100 BuildRequires:  xorg-lib-libXxf86vm-devel
101 Requires:       libfreetype.so.6
102 Suggests:       binfmt-detector
103 Suggests:       ca-certificates
104 Conflicts:      ca-certificates < 20080809-4
105 # for printing needs lpr
106 Suggests:       cups-clients
107 # for winelauncher
108 Suggests:       xorg-app-xmessage
109 # for ntlm_auth
110 Suggests:       samba-common >= 1:3.0.25
111 # link to wine/ntdll.dll.so, without any SONAME
112 Provides:       libntdll.dll.so
113 Obsoletes:      wine-doc-pdf
114 Obsoletes:      wine-drv-arts
115 ExclusiveArch:  %{ix86}
116 ExcludeArch:    i386
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
120 %define         no_install_post_strip   1
121
122 %define         _winedir                %{_datadir}/%{name}
123
124 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
125
126 %undefine       debuginfocflags
127
128 %description
129 Wine is a program which allows running Microsoft Windows programs
130 (including DOS, Windows 3.x and Win32 executables) on Unix. It
131 consists of a program loader which loads and executes a Microsoft
132 Windows binary, and a library that implements Windows API calls using
133 their Unix or X11 equivalents. The library may also be used for
134 porting Win32 code into native Unix executables.
135
136 %description -l es.UTF-8
137 Ejecuta programas Windows en Linux.
138
139 %description -l pl.UTF-8
140 Wine jest programem dzięki któremu można uruchamiać programy napisane
141 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
142 loadera, który pozwala wczytywać i uruchamiać programy w formacie
143 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
144 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
145 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
146
147 %description -l pt_BR.UTF-8
148 O Wine é um programa que permite rodar programas MS-Windows no X11.
149 Ele consiste de um carregador de programa, que carrega e executa um
150 binário MS-Windows, e de uma biblioteca de emulação que traduz as
151 chamadas da API para as equivalentes Unix/X11.
152
153 %package devel
154 Summary:        Wine - header files
155 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
156 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
157 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
158 Group:          Development/Libraries
159 Requires:       %{name} = %{epoch}:%{version}-%{release}
160
161 %description devel
162 Wine - header files.
163
164 %description devel -l es.UTF-8
165 Biblioteca de desarrollo de wine.
166
167 %description devel -l pl.UTF-8
168 Wine - pliki nagłówkowe.
169
170 %description devel -l pt_BR.UTF-8
171 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
172 WINE.
173
174 %package programs
175 Summary:        Wine - programs
176 Summary(pl.UTF-8):      Wine - programy
177 Group:          Applications
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179
180 %description programs
181 Wine - programs.
182
183 %description programs -l pl.UTF-8
184 Wine - programy.
185
186 %package dll-d3d
187 Summary:        Direct3D implementation DLLs for Wine
188 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
189 Group:          Applications/Emulators
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191 Requires:       OpenGL
192
193 %description dll-d3d
194 Direct3D implementation DLLs for Wine (through OpenGL).
195
196 %description dll-d3d -l pl.UTF-8
197 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
198
199 %package dll-gl
200 Summary:        OpenGL implementation DLLs for Wine
201 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
202 Group:          Applications/Emulators
203 Requires:       %{name} = %{epoch}:%{version}-%{release}
204 Requires:       OpenGL
205
206 %description dll-gl
207 OpenGL implementation DLLs for Wine.
208
209 %description dll-gl -l pl.UTF-8
210 Biblioteki DLL z implementacją OpenGL dla Wine.
211
212 %package dll-twain
213 Summary:        TWAIN implementation DLL for Wine
214 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
215 Group:          Applications/Emulators
216 Requires:       %{name} = %{epoch}:%{version}-%{release}
217
218 %description dll-twain
219 TWAIN implementation DLL for Wine (through SANE).
220
221 %description dll-twain -l pl.UTF-8
222 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
223
224 %package drv-alsa
225 Summary:        ALSA driver for WINE mm.dll implementation
226 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
227 Group:          Applications/Emulators
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229
230 %description drv-alsa
231 ALSA driver for WINE mm.dll (multimedia system) implementation.
232
233 %description drv-alsa -l pl.UTF-8
234 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
235
236 %package drv-jack
237 Summary:        JACK driver for WINE mm.dll implementation
238 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
239 Group:          Applications/Emulators
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241 Requires:       jack-audio-connection-kit
242 # dlopened by SONAME detected at build time
243 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
244
245 %description drv-jack
246 JACK driver for WINE mm.dll (multimedia system) implementation.
247
248 %description drv-jack -l pl.UTF-8
249 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
250 Wine.
251
252 %package drv-nas
253 Summary:        NAS driver for WINE mm.dll implementation
254 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
255 Group:          Applications/Emulators
256 Requires:       %{name} = %{epoch}:%{version}-%{release}
257
258 %description drv-nas
259 NAS driver for WINE mm.dll (multimedia system) implementation.
260
261 %description drv-nas -l pl.UTF-8
262 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
263
264 %prep
265 %setup -q
266 %patch0 -p1
267 %patch1 -p1
268 %patch2 -p1
269 %patch4 -p1
270 %patch5 -p1
271 %patch6 -p1
272 %patch7 -p1
273
274 %build
275 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
276 mv -f oic_winlogo_*.png %{name}.png
277
278 %{__autoconf}
279 %{__autoheader}
280 %configure \
281         --with%{!?with_alsa:out}-alsa \
282         --with-audioio \
283         --without-capi \
284         --with-cms \
285         --with-coreaudio \
286         --with%{!?with_cups:out}-cups \
287         --with-curses \
288         --with%{!?with_esd:out}-esd \
289         --with-fontconfig \
290         --with-freetype \
291         --with-glu \
292         --with-gnutls \
293         --with-gphoto \
294         --with-gsm \
295         --with-hal \
296         --with%{!?with_jack:out}-jack \
297         --with-jpeg \
298         --with-ldap \
299         --with-mpg123 \
300         --with%{!?with_nas:out}-nas \
301         --with-opengl \
302         --with-openssl \
303         --with-oss \
304         --with-png \
305         --with-pthread \
306         --with%{!?with_sane:out}-sane \
307         --with-xcomposite \
308         --with-xcursor \
309         --with-xinerama \
310         --with-xinput \
311         --with-xml \
312         --with-xrandr \
313         --with-xrender \
314         --with-xshape \
315         --with-xshm \
316         --with-xslt \
317         --with-xxf86vm \
318         --with-x
319 %{__make} depend
320 %{__make}
321
322 %install
323 rm -rf $RPM_BUILD_ROOT
324 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
325 %{__make} install \
326         DESTDIR=$RPM_BUILD_ROOT
327
328 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
329 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
330
331 install -d \
332         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
333         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
334         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
335         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
336         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
337
338 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
339 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
340 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
341
342 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
343 [mci]
344 cdaudio=mcicda.drv
345 sequencer=mciseq.drv
346 waveaudio=mciwave.drv
347 avivideo=mciavi.drv
348 videodisc=mcipionr.drv
349 vcr=mciviscd.drv
350 MPEGVideo=mciqtz.drv
351 EOF
352
353 %if %{?debug:0}%{!?debug:1}
354 echo "Strip executable binaries and shared object files."
355 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
356 elfexelist=`echo $filelist | xargs -r file | \
357         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
358 elfsharedlist=`echo $filelist | xargs -r file | \
359         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
360 if [ -n "$elfexelist" ]; then \
361         strip -R .note -R .comment $elfexelist
362 fi
363 if [ -n "$elfsharedlist" ]; then
364         strip --strip-unneeded -R .note -R .comment $elfsharedlist
365 fi
366 %endif
367
368 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
369
370 dir=$(pwd)
371 > files.so
372 > files.programs
373 cd $RPM_BUILD_ROOT%{_libdir}/wine
374 for f in *.so; do
375         case $f in
376         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
377                 ;;
378         *)
379                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
380         esac
381 done
382 cd -
383
384 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
385 for p in $programs; do
386         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
387         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
388         echo "%{_mandir}/man1/$p.1*" >> files.programs
389         grep -v "$p\.exe\.so$" files.so > files.so.
390         mv -f files.so. files.so
391 done
392
393 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
394 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
395
396 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
397 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
398 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
399
400 %clean
401 rm -rf $RPM_BUILD_ROOT
402
403 %post   -p /sbin/ldconfig
404 %postun -p /sbin/ldconfig
405
406 %triggerpostun -- wine < 1:0.9.12-1.9
407 rm -f /var/lock/subsys/wine
408 if [ -x /sbin/chkconfig ]; then
409         /sbin/chkconfig --del wine
410 fi
411
412 %files -f files.so
413 %defattr(644,root,root,755)
414 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
415 %lang(de) %doc documentation/README.de
416 %lang(es) %doc documentation/README.es
417 %lang(fr) %doc documentation/README.fr
418 %lang(hu) %doc documentation/README.hu
419 %lang(it) %doc documentation/README.it
420 %lang(ko) %doc documentation/README.ko
421 %lang(nb) %doc documentation/README.no
422 %lang(pt) %doc documentation/README.pt
423 %lang(pt_BR) %doc documentation/README.pt_br
424 %lang(ru) %doc documentation/README.ru
425 %lang(sv) %doc documentation/README.sv
426 %lang(tr) %doc documentation/README.tr
427 %attr(755,root,root) %{_bindir}/msiexec
428 %attr(755,root,root) %{_bindir}/wine
429 %attr(755,root,root) %{_bindir}/wineboot
430 %attr(755,root,root) %{_bindir}/winedbg
431 %attr(755,root,root) %{_bindir}/winecfg
432 %attr(755,root,root) %{_bindir}/wine-preloader
433 %attr(755,root,root) %{_bindir}/wineserver
434 %attr(755,root,root) %{_libdir}/*.so*
435 %dir %{_libdir}/wine
436 %dir %{_libdir}/wine/fakedlls
437 %{_libdir}/wine/fakedlls/*.acm
438 %{_libdir}/wine/fakedlls/*.cpl
439 %{_libdir}/wine/fakedlls/*.dll
440 %{_libdir}/wine/fakedlls/*.dll16
441 %{_libdir}/wine/fakedlls/*.drv
442 %{_libdir}/wine/fakedlls/*.drv16
443 %{_libdir}/wine/fakedlls/*.ds
444 %{_libdir}/wine/fakedlls/*.exe
445 %{_libdir}/wine/fakedlls/*.exe16
446 %{_libdir}/wine/fakedlls/*.mod16
447 %{_libdir}/wine/fakedlls/*.ocx
448 %{_libdir}/wine/fakedlls/*.sys
449 %{_libdir}/wine/fakedlls/*.tlb
450 %{_libdir}/wine/fakedlls/*.vxd
451 %{_mandir}/man1/wine.1*
452 %{_mandir}/man1/msiexec.1*
453 %{_mandir}/man1/wineboot.1*
454 %{_mandir}/man1/winecfg.1*
455 %lang(de) %{_mandir}/de/man1/wine.1*
456 %lang(fr) %{_mandir}/fr/man1/wine.1*
457 %{_mandir}/man1/winedbg.1*
458 %{_mandir}/man1/wineserver.1*
459 %lang(de) %{_mandir}/de/man1/wineserver.1*
460 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
461 %{_winedir}
462 %{_desktopdir}/wine.desktop
463 %{_desktopdir}/wine-uninstaller.desktop
464 %{_pixmapsdir}/%{name}.png
465
466 %files programs -f files.programs
467 %defattr(644,root,root,755)
468
469 %files devel
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_bindir}/fnt2bdf
472 %attr(755,root,root) %{_bindir}/function_grep.pl
473 %attr(755,root,root) %{_bindir}/widl
474 %attr(755,root,root) %{_bindir}/winebuild
475 %attr(755,root,root) %{_bindir}/winedump
476 %attr(755,root,root) %{_bindir}/wineg++
477 %attr(755,root,root) %{_bindir}/winegcc
478 %attr(755,root,root) %{_bindir}/winemaker
479 %attr(755,root,root) %{_bindir}/winecpp
480 %attr(755,root,root) %{_bindir}/wmc
481 %attr(755,root,root) %{_bindir}/wrc
482 %{_libdir}/wine/lib*.def
483 # no shared variants, so not separated
484 %{_libdir}/wine/lib*.def.a
485 %{_libdir}/wine/libadsiid.a
486 %{_libdir}/wine/libdx*.a
487 %{_libdir}/wine/libstrmiids.a
488 %{_libdir}/wine/libuuid.a
489 %{_libdir}/wine/libwinecrt0.a
490 %{_includedir}/wine
491 %{_mandir}/man1/widl.1*
492 %{_mandir}/man1/winebuild.1*
493 %{_mandir}/man1/winecpp.1*
494 %{_mandir}/man1/winedump.1*
495 %{_mandir}/man1/winegcc.1*
496 %{_mandir}/man1/wineg++.1*
497 %{_mandir}/man1/winemaker.1*
498 %lang(de) %{_mandir}/de/man1/winemaker.1*
499 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
500 %{_mandir}/man1/wmc.1*
501 %{_mandir}/man1/wrc.1*
502 %{_aclocaldir}/*.m4
503
504 %files dll-d3d
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
507 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
508 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
509
510 %files dll-gl
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
513 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
514
515 %if %{with sane}
516 %files dll-twain
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
519 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
520 %endif
521
522 %if %{with alsa}
523 %files drv-alsa
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
526 %endif
527
528 %if %{with jack}
529 %files drv-jack
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
532 %endif
533
534 %if %{with nas}
535 %files drv-nas
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
538 %endif
539
540 # additional dependencies in *.so not separated (yet?) from main package
541 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
542 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
543 #   ttydrv.dll.so depends on ncurses
This page took 0.090462 seconds and 4 git commands to generate.