]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- dropped obsoleted -notarget.patch
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_with     esd             # build ESD mm driver
5 %bcond_without  jack            # don't build JACK mm driver
6 %bcond_without  nas             # don't build NAS mm driver
7 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # TODO:
11 # - support for CAPI (ISDN support; --with-capi)
12 #
13 # NOTE: wine detects the following SONAMES for dlopen at build time:
14 #   libcrypto,libssl (wininet.dll)
15 #   libcups (winspool.dll.so,wineps.dll.so)
16 #   libcurses/libncurses (wineconsole program)
17 #   libfontconfig (gdi32.dll.so)
18 #   libfreetype (wineps.dll.so,gdi32.dll.so)
19 #   libGL (x11drv.dll.so,ddraw.dll.so)
20 #   libjack (winejack.drv.so - explicit dependency in subpackage)
21 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
22 # thus requires rebuild after change of any of the above.
23 #
24 # JACK requires ALSA
25 %if %{without alsa}
26 %undefine       with_jack
27 %endif
28
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.2.3
35 Release:        1
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  a18ca677d1e01d1596d6692a8f3997e5
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-1.0.0-x86.cab
42 # Source1-md5:  9c5c335fc077c0558561afaf25a09e51
43 Source2:        %{name}-uninstaller.desktop
44 Patch0:         %{name}-fontcache.patch
45 Patch1:         %{name}-makedep.patch
46 Patch2:         %{name}-ncurses.patch
47 Patch4:         %{name}-disable-valgrind.patch
48 Patch5:         %{name}-ca_certificates.patch
49 Patch6:         %{name}-manpaths.patch
50 Patch7:         desktop.patch
51 #PatchX:        %{name}-dga.patch
52 URL:            http://www.winehq.org/
53 BuildRequires:  OpenAL-devel >= 1.1
54 BuildRequires:  OpenGL-GLU-devel
55 %{?with_alsa:BuildRequires:     alsa-lib-devel}
56 %{?with_arts:BuildRequires:     artsc-devel}
57 BuildRequires:  autoconf
58 BuildRequires:  automake
59 BuildRequires:  bison
60 %{?with_cups:BuildRequires:     cups-devel}
61 BuildRequires:  docbook-dtd31-sgml
62 BuildRequires:  docbook-utils
63 %{?with_esd:BuildRequires:      esound-devel}
64 BuildRequires:  flex
65 BuildRequires:  fontconfig-devel
66 BuildRequires:  fontforge
67 BuildRequires:  freetype-devel >= 2.0.5
68 BuildRequires:  giflib-devel
69 BuildRequires:  gnutls-devel
70 BuildRequires:  hal-devel
71 BuildRequires:  icoutils
72 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
73 BuildRequires:  lcms-devel
74 BuildRequires:  libgphoto2-devel
75 BuildRequires:  libgsm-devel
76 BuildRequires:  libjpeg-devel
77 BuildRequires:  libmpg123-devel >= 1.5.0
78 BuildRequires:  libtool
79 BuildRequires:  libv4l-devel
80 BuildRequires:  libxslt-devel
81 %{?with_nas:BuildRequires:      nas-devel}
82 BuildRequires:  ncurses-devel
83 # db2* failed previously - probably openjade or opensp bug
84 BuildRequires:  openjade >= 1:1.3.3-0.pre1
85 BuildRequires:  openldap-devel
86 BuildRequires:  opensp >= 1:1.5.1
87 BuildRequires:  openssl-devel >= 0.9.7d
88 BuildRequires:  pkgconfig
89 %{?with_sane:BuildRequires:     sane-backends-devel}
90 BuildRequires:  unixODBC-devel >= 2.2.12-2
91 #BuildRequires: valgrind
92 BuildRequires:  xorg-lib-libXcomposite-devel
93 BuildRequires:  xorg-lib-libXcursor-devel
94 BuildRequires:  xorg-lib-libXi-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXmu-devel
97 BuildRequires:  xorg-lib-libXrandr-devel
98 BuildRequires:  xorg-lib-libXrender-devel
99 BuildRequires:  xorg-lib-libXxf86dga-devel
100 BuildRequires:  xorg-lib-libXxf86vm-devel
101 %ifarch %{x8664}
102 Requires:       libfreetype.so.6()(64bit)
103 %else
104 Requires:       libfreetype.so.6
105 %endif
106 Suggests:       binfmt-detector
107 Suggests:       ca-certificates
108 Conflicts:      ca-certificates < 20080809-4
109 # for printing needs lpr
110 Suggests:       cups-clients
111 # for winelauncher
112 Suggests:       xorg-app-xmessage
113 # for ntlm_auth
114 Suggests:       samba-common >= 1:3.0.25
115 # link to wine/ntdll.dll.so, without any SONAME
116 Provides:       libntdll.dll.so
117 Obsoletes:      wine-doc-pdf
118 Obsoletes:      wine-drv-arts
119 ExclusiveArch:  %{ix86} %{x8664}
120 ExcludeArch:    i386
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
124 %define         no_install_post_strip   1
125
126 %define         _winedir                %{_datadir}/%{name}
127
128 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
129
130 %undefine       debuginfocflags
131
132 %description
133 Wine is a program which allows running Microsoft Windows programs
134 (including DOS, Windows 3.x and Win32 executables) on Unix. It
135 consists of a program loader which loads and executes a Microsoft
136 Windows binary, and a library that implements Windows API calls using
137 their Unix or X11 equivalents. The library may also be used for
138 porting Win32 code into native Unix executables.
139
140 %description -l es.UTF-8
141 Ejecuta programas Windows en Linux.
142
143 %description -l pl.UTF-8
144 Wine jest programem dzięki któremu można uruchamiać programy napisane
145 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
146 loadera, który pozwala wczytywać i uruchamiać programy w formacie
147 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
148 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
149 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
150
151 %description -l pt_BR.UTF-8
152 O Wine é um programa que permite rodar programas MS-Windows no X11.
153 Ele consiste de um carregador de programa, que carrega e executa um
154 binário MS-Windows, e de uma biblioteca de emulação que traduz as
155 chamadas da API para as equivalentes Unix/X11.
156
157 %package devel
158 Summary:        Wine - header files
159 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
160 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
161 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
162 Group:          Development/Libraries
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164
165 %description devel
166 Wine - header files.
167
168 %description devel -l es.UTF-8
169 Biblioteca de desarrollo de wine.
170
171 %description devel -l pl.UTF-8
172 Wine - pliki nagłówkowe.
173
174 %description devel -l pt_BR.UTF-8
175 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
176 WINE.
177
178 %package programs
179 Summary:        Wine - programs
180 Summary(pl.UTF-8):      Wine - programy
181 Group:          Applications
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183
184 %description programs
185 Wine - programs.
186
187 %description programs -l pl.UTF-8
188 Wine - programy.
189
190 %package dll-d3d
191 Summary:        Direct3D implementation DLLs for Wine
192 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
193 Group:          Applications/Emulators
194 Requires:       %{name} = %{epoch}:%{version}-%{release}
195 Requires:       OpenGL
196
197 %description dll-d3d
198 Direct3D implementation DLLs for Wine (through OpenGL).
199
200 %description dll-d3d -l pl.UTF-8
201 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
202
203 %package dll-gl
204 Summary:        OpenGL implementation DLLs for Wine
205 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
206 Group:          Applications/Emulators
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 Requires:       OpenGL
209
210 %description dll-gl
211 OpenGL implementation DLLs for Wine.
212
213 %description dll-gl -l pl.UTF-8
214 Biblioteki DLL z implementacją OpenGL dla Wine.
215
216 %package dll-twain
217 Summary:        TWAIN implementation DLL for Wine
218 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
219 Group:          Applications/Emulators
220 Requires:       %{name} = %{epoch}:%{version}-%{release}
221
222 %description dll-twain
223 TWAIN implementation DLL for Wine (through SANE).
224
225 %description dll-twain -l pl.UTF-8
226 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
227
228 %package drv-alsa
229 Summary:        ALSA driver for WINE mm.dll implementation
230 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
231 Group:          Applications/Emulators
232 Requires:       %{name} = %{epoch}:%{version}-%{release}
233
234 %description drv-alsa
235 ALSA driver for WINE mm.dll (multimedia system) implementation.
236
237 %description drv-alsa -l pl.UTF-8
238 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
239
240 %package drv-jack
241 Summary:        JACK driver for WINE mm.dll implementation
242 Summary(pl.UTF-8):      Sterownik JACK-a dla implementacji mm.dll w Wine
243 Group:          Applications/Emulators
244 Requires:       %{name} = %{epoch}:%{version}-%{release}
245 Requires:       jack-audio-connection-kit
246 # dlopened by SONAME detected at build time
247 %ifarch %{x8664}
248 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}()(64bit)}
249 %else
250 %{?with_jack:Requires:  %{getsoname /usr/%{_lib}/libjack.so}}
251 %endif
252
253 %description drv-jack
254 JACK driver for WINE mm.dll (multimedia system) implementation.
255
256 %description drv-jack -l pl.UTF-8
257 Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
258 Wine.
259
260 %package drv-nas
261 Summary:        NAS driver for WINE mm.dll implementation
262 Summary(pl.UTF-8):      Sterownik NAS dla implementacji mm.dll w Wine
263 Group:          Applications/Emulators
264 Requires:       %{name} = %{epoch}:%{version}-%{release}
265
266 %description drv-nas
267 NAS driver for WINE mm.dll (multimedia system) implementation.
268
269 %description drv-nas -l pl.UTF-8
270 Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
271
272 %prep
273 %setup -q
274 %patch0 -p1
275 %patch1 -p1
276 %patch2 -p1
277 %patch4 -p1
278 %patch5 -p1
279 %patch6 -p1
280 %patch7 -p1
281
282 %build
283 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
284 mv -f oic_winlogo_*.png %{name}.png
285
286 %{__autoconf}
287 %{__autoheader}
288 %configure \
289 %ifarch %{x8664}
290         --enable-win64 \
291 %endif
292         --with%{!?with_alsa:out}-alsa \
293         --with-audioio \
294         --without-capi \
295         --with-cms \
296         --with-coreaudio \
297         --with%{!?with_cups:out}-cups \
298         --with-curses \
299         --with%{!?with_esd:out}-esd \
300         --with-fontconfig \
301         --with-freetype \
302         --with-glu \
303         --with-gnutls \
304         --with-gphoto \
305         --with-gsm \
306         --with-hal \
307         --with%{!?with_jack:out}-jack \
308         --with-jpeg \
309         --with-ldap \
310         --with-mpg123 \
311         --with%{!?with_nas:out}-nas \
312         --with-opengl \
313         --with-openssl \
314         --with-oss \
315         --with-png \
316         --with-pthread \
317         --with%{!?with_sane:out}-sane \
318         --with-xcomposite \
319         --with-xcursor \
320         --with-xinerama \
321         --with-xinput \
322         --with-xml \
323         --with-xrandr \
324         --with-xrender \
325         --with-xshape \
326         --with-xshm \
327         --with-xslt \
328         --with-xxf86vm \
329         --with-x
330 %{__make} depend
331 %{__make}
332
333 %install
334 rm -rf $RPM_BUILD_ROOT
335 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
336 %{__make} install \
337         DESTDIR=$RPM_BUILD_ROOT
338
339 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
340 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
341
342 install -d \
343         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
344         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
345         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
346         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
347         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
348
349 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
350 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
351 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
352
353 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
354 [mci]
355 cdaudio=mcicda.drv
356 sequencer=mciseq.drv
357 waveaudio=mciwave.drv
358 avivideo=mciavi.drv
359 videodisc=mcipionr.drv
360 vcr=mciviscd.drv
361 MPEGVideo=mciqtz.drv
362 EOF
363
364 %if %{?debug:0}%{!?debug:1}
365 echo "Strip executable binaries and shared object files."
366 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
367 elfexelist=`echo $filelist | xargs -r file | \
368         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
369 elfsharedlist=`echo $filelist | xargs -r file | \
370         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
371 if [ -n "$elfexelist" ]; then \
372         strip -R .note -R .comment $elfexelist
373 fi
374 if [ -n "$elfsharedlist" ]; then
375         strip --strip-unneeded -R .note -R .comment $elfsharedlist
376 fi
377 %endif
378
379 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
380
381 dir=$(pwd)
382 > files.so
383 > files.programs
384 cd $RPM_BUILD_ROOT%{_libdir}/wine
385 for f in *.so; do
386         case $f in
387         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
388                 ;;
389         *)
390                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
391         esac
392 done
393 cd -
394
395 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
396 for p in $programs; do
397         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
398         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
399         echo "%{_mandir}/man1/$p.1*" >> files.programs
400         grep -v "$p\.exe\.so$" files.so > files.so.
401         mv -f files.so. files.so
402 done
403
404 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
405 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
406
407 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
408 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
409 cp -a %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
410
411 %clean
412 rm -rf $RPM_BUILD_ROOT
413
414 %post   -p /sbin/ldconfig
415 %postun -p /sbin/ldconfig
416
417 %triggerpostun -- wine < 1:0.9.12-1.9
418 rm -f /var/lock/subsys/wine
419 if [ -x /sbin/chkconfig ]; then
420         /sbin/chkconfig --del wine
421 fi
422
423 %files -f files.so
424 %defattr(644,root,root,755)
425 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
426 %lang(de) %doc documentation/README.de
427 %lang(es) %doc documentation/README.es
428 %lang(fr) %doc documentation/README.fr
429 %lang(hu) %doc documentation/README.hu
430 %lang(it) %doc documentation/README.it
431 %lang(ko) %doc documentation/README.ko
432 %lang(nb) %doc documentation/README.no
433 %lang(pt) %doc documentation/README.pt
434 %lang(pt_BR) %doc documentation/README.pt_br
435 %lang(ru) %doc documentation/README.ru
436 %lang(sv) %doc documentation/README.sv
437 %lang(tr) %doc documentation/README.tr
438 %attr(755,root,root) %{_bindir}/msiexec
439 %attr(755,root,root) %{_bindir}/wineboot
440 %attr(755,root,root) %{_bindir}/winedbg
441 %attr(755,root,root) %{_bindir}/winecfg
442 %attr(755,root,root) %{_bindir}/wineserver
443 %ifarch %{x8664}
444 %attr(755,root,root) %{_bindir}/wine64
445 %else
446 %attr(755,root,root) %{_bindir}/wine
447 %attr(755,root,root) %{_bindir}/wine-preloader
448 %endif
449 %attr(755,root,root) %{_libdir}/*.so*
450 %dir %{_libdir}/wine
451 %dir %{_libdir}/wine/fakedlls
452 %{_libdir}/wine/fakedlls/*.acm
453 %{_libdir}/wine/fakedlls/*.cpl
454 %{_libdir}/wine/fakedlls/*.dll
455 %{_libdir}/wine/fakedlls/*.drv
456 %{_libdir}/wine/fakedlls/*.ds
457 %{_libdir}/wine/fakedlls/*.exe
458 %{_libdir}/wine/fakedlls/*.ocx
459 %{_libdir}/wine/fakedlls/*.sys
460 %{_libdir}/wine/fakedlls/*.tlb
461 %ifarch %{ix86}
462 %{_libdir}/wine/fakedlls/*.dll16
463 %{_libdir}/wine/fakedlls/*.drv16
464 %{_libdir}/wine/fakedlls/*.exe16
465 %{_libdir}/wine/fakedlls/*.mod16
466 %{_libdir}/wine/fakedlls/*.vxd
467 %endif
468 %{_mandir}/man1/wine.1*
469 %{_mandir}/man1/msiexec.1*
470 %{_mandir}/man1/wineboot.1*
471 %{_mandir}/man1/winecfg.1*
472 %lang(de) %{_mandir}/de/man1/wine.1*
473 %lang(fr) %{_mandir}/fr/man1/wine.1*
474 %{_mandir}/man1/winedbg.1*
475 %{_mandir}/man1/wineserver.1*
476 %lang(de) %{_mandir}/de/man1/wineserver.1*
477 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
478 %{_winedir}
479 %{_desktopdir}/wine.desktop
480 %{_desktopdir}/wine-uninstaller.desktop
481 %{_pixmapsdir}/%{name}.png
482
483 %files programs -f files.programs
484 %defattr(644,root,root,755)
485
486 %files devel
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_bindir}/fnt2bdf
489 %attr(755,root,root) %{_bindir}/function_grep.pl
490 %attr(755,root,root) %{_bindir}/widl
491 %attr(755,root,root) %{_bindir}/winebuild
492 %attr(755,root,root) %{_bindir}/winedump
493 %attr(755,root,root) %{_bindir}/wineg++
494 %attr(755,root,root) %{_bindir}/winegcc
495 %attr(755,root,root) %{_bindir}/winemaker
496 %attr(755,root,root) %{_bindir}/winecpp
497 %attr(755,root,root) %{_bindir}/wmc
498 %attr(755,root,root) %{_bindir}/wrc
499 %{_libdir}/wine/lib*.def
500 # no shared variants, so not separated
501 %{_libdir}/wine/lib*.def.a
502 %{_libdir}/wine/libadsiid.a
503 %{_libdir}/wine/libdx*.a
504 %{_libdir}/wine/libstrmiids.a
505 %{_libdir}/wine/libuuid.a
506 %{_libdir}/wine/libwinecrt0.a
507 %{_includedir}/wine
508 %{_mandir}/man1/widl.1*
509 %{_mandir}/man1/winebuild.1*
510 %{_mandir}/man1/winecpp.1*
511 %{_mandir}/man1/winedump.1*
512 %{_mandir}/man1/winegcc.1*
513 %{_mandir}/man1/wineg++.1*
514 %{_mandir}/man1/winemaker.1*
515 %lang(de) %{_mandir}/de/man1/winemaker.1*
516 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
517 %{_mandir}/man1/wmc.1*
518 %{_mandir}/man1/wrc.1*
519 %{_aclocaldir}/*.m4
520
521 %files dll-d3d
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
524 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
525 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
526
527 %files dll-gl
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
530 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
531
532 %if %{with sane}
533 %files dll-twain
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
536 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
537 %endif
538
539 %if %{with alsa}
540 %files drv-alsa
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
543 %endif
544
545 %if %{with jack}
546 %files drv-jack
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/wine/winejack.drv.so
549 %endif
550
551 %if %{with nas}
552 %files drv-nas
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/wine/winenas.drv.so
555 %endif
556
557 # additional dependencies in *.so not separated (yet?) from main package
558 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
559 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
560 #   ttydrv.dll.so depends on ncurses
This page took 0.072814 seconds and 4 git commands to generate.