]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
Version: 1.6.2
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # NOTE: wine detects the following SONAMES for dlopen at build time:
11 #   libcrypto,libssl (wininet.dll)
12 #   libcups (winspool.dll.so,wineps.dll.so)
13 #   libcurses/libncurses (wineconsole program)
14 #   libfontconfig (gdi32.dll.so)
15 #   libfreetype (wineps.dll.so,gdi32.dll.so)
16 #   libGL (x11drv.dll.so,ddraw.dll.so)
17 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
18 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
19 # thus requires rebuild after change of any of the above.
20
21 # library qualifier in rpm generated deps
22 %ifarch %{x8664} ia64 ppc64 s390x sparc64
23 %define libqual ()(64bit)
24 %else
25 %define libqual %{nil}
26 %endif
27
28 %define         gecko_ver       2.21
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.6.2
35 Release:        1
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  0f6c56f86befe38e219090915f81f48a
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
42 # Source1-md5:  432eb3a2d05c3f07df67864f53c87c60
43 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
44 # Source2-md5:  580bbabde1ec99ba9caa439c2dbca3f6
45 Source3:        %{name}-uninstaller.desktop
46 Patch0:         %{name}-gphoto2_bool.patch
47 Patch1:         %{name}-makedep.patch
48 Patch2:         %{name}-ncurses.patch
49 Patch4:         %{name}-disable-valgrind.patch
50 Patch5:         %{name}-ca_certificates.patch
51 Patch6:         %{name}-manpaths.patch
52 Patch7:         desktop.patch
53 Patch8:         %{name}-wine64_man.patch
54 URL:            http://www.winehq.org/
55 BuildRequires:  OpenAL-devel >= 1.1
56 BuildRequires:  OpenGL-GLU-devel
57 %{?with_alsa:BuildRequires:     alsa-lib-devel}
58 %{?with_arts:BuildRequires:     artsc-devel}
59 BuildRequires:  autoconf
60 BuildRequires:  automake
61 BuildRequires:  bison
62 %{?with_capi:BuildRequires:     capi4k-utils-devel}
63 %{?with_cups:BuildRequires:     cups-devel}
64 BuildRequires:  docbook-dtd31-sgml
65 BuildRequires:  docbook-utils
66 BuildRequires:  flex
67 BuildRequires:  fontconfig-devel
68 BuildRequires:  fontforge
69 BuildRequires:  freetype-devel >= 2.0.5
70 BuildRequires:  fslint
71 BuildRequires:  gettext-devel
72 BuildRequires:  giflib-devel
73 BuildRequires:  gnutls-devel
74 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel}
75 BuildRequires:  icoutils
76 BuildRequires:  lcms2-devel
77 BuildRequires:  libgphoto2-devel
78 BuildRequires:  libgsm-devel
79 BuildRequires:  libjpeg-devel
80 BuildRequires:  libmpg123-devel >= 1.5.0
81 BuildRequires:  libtool
82 BuildRequires:  libv4l-devel
83 BuildRequires:  libxslt-devel
84 BuildRequires:  ncurses-devel
85 # db2* failed previously - probably openjade or opensp bug
86 BuildRequires:  libpng-devel >= 1.5
87 BuildRequires:  openjade >= 1:1.3.3-0.pre1
88 %{?with_ldap:BuildRequires:     openldap-devel}
89 BuildRequires:  opensp >= 1:1.5.1
90 BuildRequires:  openssl-devel >= 0.9.7d
91 BuildRequires:  pkgconfig
92 BuildRequires:  prelink
93 %{?with_sane:BuildRequires:     sane-backends-devel}
94 BuildRequires:  unixODBC-devel >= 2.2.12-2
95 #BuildRequires: valgrind
96 BuildRequires:  xorg-lib-libXcomposite-devel
97 BuildRequires:  xorg-lib-libXcursor-devel
98 BuildRequires:  xorg-lib-libXi-devel
99 BuildRequires:  xorg-lib-libXinerama-devel
100 BuildRequires:  xorg-lib-libXmu-devel
101 BuildRequires:  xorg-lib-libXrandr-devel
102 BuildRequires:  xorg-lib-libXrender-devel
103 BuildRequires:  xorg-lib-libXxf86dga-devel
104 BuildRequires:  xorg-lib-libXxf86vm-devel
105 Requires:       libfreetype.so.6%{libqual}
106 Requires:       libpng16.so.16%{libqual}
107 Requires(post): /sbin/ldconfig
108 Suggests:       binfmt-detector
109 Suggests:       ca-certificates
110 Suggests:       cabextract
111 Conflicts:      ca-certificates < 20080809-4
112 # for printing needs lpr
113 Suggests:       cups-clients
114 # for winelauncher
115 Suggests:       xorg-app-xmessage
116 # for ntlm_auth
117 Suggests:       samba-common >= 1:3.0.25
118 # link to wine/ntdll.dll.so, without any SONAME
119 Provides:       libntdll.dll.so
120 Obsoletes:      wine-doc-pdf
121 Obsoletes:      wine-drv-arts
122 Obsoletes:      wine-drv-jack
123 Obsoletes:      wine-drv-nas
124 ExclusiveArch:  %{ix86} %{x8664}
125 ExcludeArch:    i386
126 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
128 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
129 %define         no_install_post_strip   1
130
131 %define         _winedir                %{_datadir}/%{name}
132
133 %description
134 Wine is a program which allows running Microsoft Windows programs
135 (including DOS, Windows 3.x and Win32 executables) on Unix. It
136 consists of a program loader which loads and executes a Microsoft
137 Windows binary, and a library that implements Windows API calls using
138 their Unix or X11 equivalents. The library may also be used for
139 porting Win32 code into native Unix executables.
140
141 %description -l es.UTF-8
142 Ejecuta programas Windows en Linux.
143
144 %description -l pl.UTF-8
145 Wine jest programem dzięki któremu można uruchamiać programy napisane
146 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
147 loadera, który pozwala wczytywać i uruchamiać programy w formacie
148 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
149 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
150 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
151
152 %description -l pt_BR.UTF-8
153 O Wine é um programa que permite rodar programas MS-Windows no X11.
154 Ele consiste de um carregador de programa, que carrega e executa um
155 binário MS-Windows, e de uma biblioteca de emulação que traduz as
156 chamadas da API para as equivalentes Unix/X11.
157
158 %package devel
159 Summary:        Wine - header files
160 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
161 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
162 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
163 Group:          Development/Libraries
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165
166 %description devel
167 Wine - header files.
168
169 %description devel -l es.UTF-8
170 Biblioteca de desarrollo de wine.
171
172 %description devel -l pl.UTF-8
173 Wine - pliki nagłówkowe.
174
175 %description devel -l pt_BR.UTF-8
176 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
177 WINE.
178
179 %package programs
180 Summary:        Wine - programs
181 Summary(pl.UTF-8):      Wine - programy
182 Group:          Applications
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description programs
186 Wine - programs.
187
188 %description programs -l pl.UTF-8
189 Wine - programy.
190
191 %package dll-capi
192 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
193 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
194 Group:          Applications/Emulators
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196
197 %description dll-capi
198 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
199
200 %description dll-capi -l pl.UTF-8
201 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
202 OpenGL).
203
204 %package dll-d3d
205 Summary:        Direct3D implementation DLLs for Wine
206 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
207 Group:          Applications/Emulators
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209 Requires:       OpenGL
210
211 %description dll-d3d
212 Direct3D implementation DLLs for Wine (through OpenGL).
213
214 %description dll-d3d -l pl.UTF-8
215 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
216
217 %package dll-gl
218 Summary:        OpenGL implementation DLLs for Wine
219 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
220 Group:          Applications/Emulators
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222 Requires:       OpenGL
223
224 %description dll-gl
225 OpenGL implementation DLLs for Wine.
226
227 %description dll-gl -l pl.UTF-8
228 Biblioteki DLL z implementacją OpenGL dla Wine.
229
230 %package dll-twain
231 Summary:        TWAIN implementation DLL for Wine
232 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
233 Group:          Applications/Emulators
234 Requires:       %{name} = %{epoch}:%{version}-%{release}
235
236 %description dll-twain
237 TWAIN implementation DLL for Wine (through SANE).
238
239 %description dll-twain -l pl.UTF-8
240 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
241
242 %package dll-ldap
243 Summary:        Win32 LDAP API DLL for Wine
244 Group:          Applications/Emulators
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246
247 %description dll-ldap
248 Lightweight Directory Access Protocol Library.
249
250 %package drv-alsa
251 Summary:        ALSA driver for WINE mm.dll implementation
252 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
253 Group:          Applications/Emulators
254 Requires:       %{name} = %{epoch}:%{version}-%{release}
255
256 %description drv-alsa
257 ALSA driver for WINE mm.dll (multimedia system) implementation.
258
259 %description drv-alsa -l pl.UTF-8
260 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
261
262 %prep
263 %setup -q
264 %patch0 -p1
265 %patch1 -p1
266 %patch2 -p1
267 %patch4 -p1
268 %patch5 -p1
269 %patch6 -p1
270 %patch7 -p1
271 %ifarch %{x8664}
272 %patch8 -p1
273 %endif
274
275 %build
276 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
277 mv -f oic_winlogo_*.png %{name}.png
278
279 %{__autoconf}
280 %{__autoheader}
281 %configure \
282 %ifarch %{x8664}
283         --enable-win64 \
284 %endif
285         --with%{!?with_alsa:out}-alsa \
286         --with%{!?with_capi:out}-capi \
287         --with-cms \
288         --with-coreaudio \
289         --with%{!?with_cups:out}-cups \
290         --with-curses \
291         --with-fontconfig \
292         --with-freetype \
293         --with-glu \
294         --with-gnutls \
295         --with-gphoto \
296         --with-gsm \
297         --with%{!?with_gstreamer:out}-gstreamer \
298         --with-jpeg \
299         --with%{!?with_ldap:out}-ldap \
300         --with-mpg123 \
301         --with-opengl \
302         --with-openssl \
303         --with-oss \
304         --with-png \
305         --with-pthread \
306         --with%{!?with_sane:out}-sane \
307         --with-xcomposite \
308         --with-xcursor \
309         --with-xinerama \
310         --with-xinput \
311         --with-xml \
312         --with-xrandr \
313         --with-xrender \
314         --with-xshape \
315         --with-xshm \
316         --with-xslt \
317         --with-xxf86vm \
318         --with-x
319 %{__make} depend
320 %{__make}
321
322 %install
323 rm -rf $RPM_BUILD_ROOT
324 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
325 %{__make} install \
326         DESTDIR=$RPM_BUILD_ROOT
327
328 findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
329
330 install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
331 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
332
333 install -d \
334         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
335         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
336         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
337         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
338         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
339
340 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
341 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
342 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
343
344 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
345 [mci]
346 cdaudio=mcicda.drv
347 sequencer=mciseq.drv
348 waveaudio=mciwave.drv
349 avivideo=mciavi.drv
350 videodisc=mcipionr.drv
351 vcr=mciviscd.drv
352 MPEGVideo=mciqtz.drv
353 EOF
354
355 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
356
357 dir=$(pwd)
358 > files.so
359 > files.programs
360 cd $RPM_BUILD_ROOT%{_libdir}/wine
361 for f in *.so; do
362         case $f in
363         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
364                 ;;
365         *)
366                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
367         esac
368 done
369 cd -
370
371 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
372 for p in $programs; do
373         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
374         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
375         echo "%{_mandir}/man1/$p.1*" >> files.programs
376         grep -v "$p\.exe\.so$" files.so > files.so.
377         mv -f files.so. files.so
378 done
379
380 %ifarch %{x8664}
381 for langdir in "" de/ fr/ pl/ ; do
382 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
383 done
384 %endif
385
386 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
387 %ifnarch %{x8664}
388 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
389 %else
390 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
391 %endif
392
393 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
394 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
395 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
396
397 %clean
398 rm -rf $RPM_BUILD_ROOT
399
400 %post
401 /sbin/ldconfig
402 %update_desktop_database
403
404 %postun -p /sbin/ldconfig
405
406 %triggerpostun -- wine < 1:0.9.12-1.9
407 rm -f /var/lock/subsys/wine
408 if [ -x /sbin/chkconfig ]; then
409         /sbin/chkconfig --del wine
410 fi
411
412 %files -f files.so
413 %defattr(644,root,root,755)
414 %doc README AUTHORS ANNOUNCE
415 %lang(de) %doc documentation/README.de
416 %lang(es) %doc documentation/README.es
417 %lang(fr) %doc documentation/README.fr
418 %lang(hu) %doc documentation/README.hu
419 %lang(it) %doc documentation/README.it
420 %lang(ko) %doc documentation/README.ko
421 %lang(nb) %doc documentation/README.no
422 %lang(pt) %doc documentation/README.pt
423 %lang(pt_BR) %doc documentation/README.pt_br
424 %lang(ru) %doc documentation/README.ru
425 %lang(sv) %doc documentation/README.sv
426 %lang(tr) %doc documentation/README.tr
427 %attr(755,root,root) %{_bindir}/msiexec
428 %ifnarch %{x8664}
429 %attr(755,root,root) %{_bindir}/wine
430 %else
431 %attr(755,root,root) %{_bindir}/wine64
432 %endif
433 %attr(755,root,root) %{_bindir}/wineboot
434 %attr(755,root,root) %{_bindir}/winedbg
435 %attr(755,root,root) %{_bindir}/winecfg
436 %ifnarch %{x8664}
437 %attr(755,root,root) %{_bindir}/wine-preloader
438 %else
439 %attr(755,root,root) %{_bindir}/wine64-preloader
440 %endif
441 %attr(755,root,root) %{_bindir}/wineserver
442 %attr(755,root,root) %{_libdir}/*.so*
443 %dir %{_libdir}/wine
444 %dir %{_libdir}/wine/fakedlls
445 %{_libdir}/wine/fakedlls/*.acm
446 %{_libdir}/wine/fakedlls/*.cpl
447 %{_libdir}/wine/fakedlls/*.dll
448 %ifarch %{ix86}
449 %{_libdir}/wine/fakedlls/*.dll16
450 %endif
451 %{_libdir}/wine/fakedlls/*.drv
452 %ifarch %{ix86}
453 %{_libdir}/wine/fakedlls/*.drv16
454 %endif
455 %{_libdir}/wine/fakedlls/*.ds
456 %{_libdir}/wine/fakedlls/*.exe
457 %ifarch %{ix86}
458 %{_libdir}/wine/fakedlls/*.exe16
459 %{_libdir}/wine/fakedlls/*.mod16
460 %endif
461 %{_libdir}/wine/fakedlls/*.ocx
462 %{_libdir}/wine/fakedlls/*.sys
463 %{_libdir}/wine/fakedlls/*.tlb
464 %ifarch %{ix86}
465 %{_libdir}/wine/fakedlls/*.vxd
466 %endif
467 %ifnarch %{x8664}
468 %{_mandir}/man1/wine.1*
469 %lang(de) %{_mandir}/de/man1/wine.1*
470 %lang(fr) %{_mandir}/fr/man1/wine.1*
471 %lang(pl) %{_mandir}/pl/man1/wine.1*
472 %else
473 %{_mandir}/man1/wine64.1*
474 %lang(de) %{_mandir}/de/man1/wine64.1*
475 %lang(fr) %{_mandir}/fr/man1/wine64.1*
476 %lang(pl) %{_mandir}/pl/man1/wine64.1*
477 %endif
478 %{_mandir}/man1/msiexec.1*
479 %{_mandir}/man1/wineboot.1*
480 %{_mandir}/man1/winecfg.1*
481 %{_mandir}/man1/winedbg.1*
482 %{_mandir}/man1/wineserver.1*
483 %lang(de) %{_mandir}/de/man1/wineserver.1*
484 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
485 %{_winedir}
486 %{_desktopdir}/wine.desktop
487 %{_desktopdir}/wine-uninstaller.desktop
488 %{_pixmapsdir}/%{name}.png
489
490 %files programs -f files.programs
491 %defattr(644,root,root,755)
492
493 %files devel
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_bindir}/fnt2fon
496 %attr(755,root,root) %{_bindir}/function_grep.pl
497 %attr(755,root,root) %{_bindir}/widl
498 %attr(755,root,root) %{_bindir}/winebuild
499 %attr(755,root,root) %{_bindir}/winedump
500 %attr(755,root,root) %{_bindir}/wineg++
501 %attr(755,root,root) %{_bindir}/winegcc
502 %attr(755,root,root) %{_bindir}/winemaker
503 %attr(755,root,root) %{_bindir}/winecpp
504 %attr(755,root,root) %{_bindir}/wmc
505 %attr(755,root,root) %{_bindir}/wrc
506 %{_libdir}/wine/lib*.def
507 # no shared variants, so not separated
508 %{_libdir}/wine/lib*.def.a
509 %{_libdir}/wine/libadsiid.a
510 %{_libdir}/wine/libdx*.a
511 %{_libdir}/wine/libstrmbase.a
512 %{_libdir}/wine/libstrmiids.a
513 %{_libdir}/wine/libuuid.a
514 %{_libdir}/wine/libwinecrt0.a
515 %{_includedir}/wine
516 %{_mandir}/man1/widl.1*
517 %{_mandir}/man1/winebuild.1*
518 %{_mandir}/man1/winecpp.1*
519 %{_mandir}/man1/winedump.1*
520 %{_mandir}/man1/winegcc.1*
521 %{_mandir}/man1/wineg++.1*
522 %{_mandir}/man1/winemaker.1*
523 %lang(de) %{_mandir}/de/man1/winemaker.1*
524 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
525 %{_mandir}/man1/wmc.1*
526 %{_mandir}/man1/wrc.1*
527 %{_aclocaldir}/*.m4
528
529 %files dll-capi
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
532
533 %files dll-d3d
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
536 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
537 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
538
539 %files dll-gl
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
542 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
543
544 %if %{with sane}
545 %files dll-twain
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
548 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
549 %endif
550
551 %if %{with ldap}
552 %files dll-ldap
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
555 %endif
556
557 %if %{with alsa}
558 %files drv-alsa
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
561 %endif
562
563 # additional dependencies in *.so not separated (yet?) from main package
564 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
565 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
566 #   ttydrv.dll.so depends on ncurses
This page took 0.114019 seconds and 4 git commands to generate.