]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
BR: pulseaudio-devel
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 %bcond_without  netapi          # don't use the Samba NetAPI library
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libGL (winex11.drv.so)
14 #   libOSMesa (gdi32.dll.so)
15 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16 #   libcapi20 (capi2032.dll.so)
17 #   libcups (winspool.drv.so)
18 #   libdbus (mountmgr.sys.so)
19 #   libfontconfig (gdi32.dll.so)
20 #   libfreetype (gdi32.dll.so)
21 #   libgnutls (secur32.dll.so)
22 #   libhal (mountmgr.sys.so)
23 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libpng (windowscodecs.dll.so)
27 #   libsane (sane.ds.so)
28 #   libtiff (windowscodecs.dll.so)
29 #   libv4l1 (qcap.dll.so)
30 #   libxslt (msxml3.dll.so)
31 # thus requires rebuild after change of any of the above.
32
33 # library qualifier in rpm generated deps
34 %ifarch %{x8664} ia64 ppc64 s390x sparc64
35 %define libqual ()(64bit)
36 %else
37 %define libqual %{nil}
38 %endif
39
40 %define         gecko_ver       2.24
41 Summary:        Program that lets you launch Win applications
42 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
43 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
44 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
45 Name:           wine
46 # 1.8.x – stable
47 # 1.9.x – development
48 Version:        1.8
49 Release:        0.1
50 Epoch:          1
51 License:        LGPL
52 Group:          Applications/Emulators
53 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
54 # Source0-md5:  96b51a2f2ae727802d71095354e69fef
55 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
56 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
57 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
58 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
59 Source3:        %{name}-uninstaller.desktop
60 Patch0:         %{name}-gphoto2_bool.patch
61 Patch1:         %{name}-makedep.patch
62 Patch2:         %{name}-ncurses.patch
63 Patch4:         %{name}-disable-valgrind.patch
64 Patch5:         %{name}-ca_certificates.patch
65 Patch6:         desktop.patch
66 Patch7:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-GLX-devel
73 BuildRequires:  Mesa-libOSMesa-devel
74 %{?with_alsa:BuildRequires:     alsa-lib-devel}
75 %{?with_arts:BuildRequires:     artsc-devel}
76 BuildRequires:  autoconf >= 2.62
77 BuildRequires:  automake
78 BuildRequires:  bison
79 %{?with_capi:BuildRequires:     capi4k-utils-devel}
80 %{?with_cups:BuildRequires:     cups-devel}
81 BuildRequires:  dbus-devel
82 BuildRequires:  docbook-dtd31-sgml
83 BuildRequires:  docbook-utils
84 BuildRequires:  flex >= 2.5.33
85 BuildRequires:  fontconfig-devel
86 BuildRequires:  fontforge
87 BuildRequires:  freetype-devel >= 2.0.5
88 # for findup used after make install
89 BuildRequires:  fslint
90 %ifarch %{x8664}
91 BuildRequires:  gcc >= 6:4.4
92 %endif
93 BuildRequires:  gettext-tools
94 BuildRequires:  giflib-devel
95 BuildRequires:  gnutls-devel
96 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
97 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
98 %{?with_hal:BuildRequires:      hal-devel}
99 # for icotool used in build
100 BuildRequires:  icoutils >= 0.29.0
101 BuildRequires:  lcms2-devel >= 2
102 BuildRequires:  libgphoto2-devel
103 BuildRequires:  libgsm-devel
104 BuildRequires:  libjpeg-devel
105 BuildRequires:  libmpg123-devel >= 1.5.0
106 BuildRequires:  libcap-devel
107 BuildRequires:  libpng-devel >= 1.5
108 BuildRequires:  libtiff-devel
109 BuildRequires:  libtool
110 BuildRequires:  libv4l-devel
111 BuildRequires:  libxml2-devel >= 2.0
112 BuildRequires:  libxslt-devel
113 BuildRequires:  ncurses-devel
114 # db2* failed previously - probably openjade or opensp bug
115 BuildRequires:  openjade >= 1:1.3.3-0.pre1
116 %{?with_ldap:BuildRequires:     openldap-devel}
117 BuildRequires:  opensp >= 1:1.5.1
118 BuildRequires:  pulseaudio-devel
119 BuildRequires:  pkgconfig
120 BuildRequires:  prelink
121 BuildRequires:  samba-devel
122 %{?with_sane:BuildRequires:     sane-backends-devel}
123 BuildRequires:  unixODBC-devel >= 2.2.12-2
124 #BuildRequires: valgrind
125 BuildRequires:  xorg-lib-libX11-devel
126 BuildRequires:  xorg-lib-libXcomposite-devel
127 BuildRequires:  xorg-lib-libXcursor-devel
128 BuildRequires:  xorg-lib-libXext-devel
129 BuildRequires:  xorg-lib-libXi-devel
130 BuildRequires:  xorg-lib-libXinerama-devel
131 BuildRequires:  xorg-lib-libXrandr-devel
132 BuildRequires:  xorg-lib-libXrender-devel
133 BuildRequires:  xorg-lib-libXxf86vm-devel
134 BuildRequires:  zlib-devel
135 Requires:       libfreetype.so.6%{libqual}
136 Requires:       libpng16.so.16%{libqual}
137 Requires(post): /sbin/ldconfig
138 Suggests:       binfmt-detector
139 Suggests:       ca-certificates
140 Suggests:       cabextract
141 Conflicts:      ca-certificates < 20080809-4
142 # for printing needs lpr
143 Suggests:       cups-clients
144 # for winelauncher
145 Suggests:       xorg-app-xmessage
146 # for ntlm_auth
147 Suggests:       samba-common >= 1:3.0.25
148 # link to wine/ntdll.dll.so, without any SONAME
149 Provides:       libntdll.dll.so
150 Obsoletes:      wine-doc-pdf
151 Obsoletes:      wine-drv-arts
152 Obsoletes:      wine-drv-jack
153 Obsoletes:      wine-drv-nas
154 ExclusiveArch:  %{ix86} %{x8664} arm
155 ExcludeArch:    i386
156 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
157
158 %define         no_install_post_strip   1
159
160 %define         _winedir                %{_datadir}/%{name}
161
162 %description
163 Wine is a program which allows running Microsoft Windows programs
164 (including DOS, Windows 3.x and Win32 executables) on Unix. It
165 consists of a program loader which loads and executes a Microsoft
166 Windows binary, and a library that implements Windows API calls using
167 their Unix or X11 equivalents. The library may also be used for
168 porting Win32 code into native Unix executables.
169
170 %description -l es.UTF-8
171 Ejecuta programas Windows en Linux.
172
173 %description -l pl.UTF-8
174 Wine jest programem dzięki któremu można uruchamiać programy napisane
175 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
176 loadera, który pozwala wczytywać i uruchamiać programy w formacie
177 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
178 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
179 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
180
181 %description -l pt_BR.UTF-8
182 O Wine é um programa que permite rodar programas MS-Windows no X11.
183 Ele consiste de um carregador de programa, que carrega e executa um
184 binário MS-Windows, e de uma biblioteca de emulação que traduz as
185 chamadas da API para as equivalentes Unix/X11.
186
187 %package devel
188 Summary:        Wine - header files
189 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
190 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
191 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
192 Group:          Development/Libraries
193 Requires:       %{name} = %{epoch}:%{version}-%{release}
194
195 %description devel
196 Wine - header files.
197
198 %description devel -l es.UTF-8
199 Biblioteca de desarrollo de wine.
200
201 %description devel -l pl.UTF-8
202 Wine - pliki nagłówkowe.
203
204 %description devel -l pt_BR.UTF-8
205 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
206 WINE.
207
208 %package programs
209 Summary:        Wine - programs
210 Summary(pl.UTF-8):      Wine - programy
211 Group:          Applications
212 Requires:       %{name} = %{epoch}:%{version}-%{release}
213
214 %description programs
215 Wine - programs.
216
217 %description programs -l pl.UTF-8
218 Wine - programy.
219
220 %package dll-capi
221 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
222 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
223 Group:          Applications/Emulators
224 Requires:       %{name} = %{epoch}:%{version}-%{release}
225
226 %description dll-capi
227 CAPI 2.0 (ISDN) implementation DLLs for Wine.
228
229 %description dll-capi -l pl.UTF-8
230 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
231
232 %package dll-d3d
233 Summary:        Direct3D implementation DLLs for Wine
234 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
235 Group:          Applications/Emulators
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237 Requires:       OpenGL
238
239 %description dll-d3d
240 Direct3D implementation DLLs for Wine (through OpenGL).
241
242 %description dll-d3d -l pl.UTF-8
243 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
244
245 %package dll-gl
246 Summary:        OpenGL implementation DLLs for Wine
247 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
248 Group:          Applications/Emulators
249 Requires:       %{name} = %{epoch}:%{version}-%{release}
250 Requires:       OpenGL
251
252 %description dll-gl
253 OpenGL implementation DLLs for Wine.
254
255 %description dll-gl -l pl.UTF-8
256 Biblioteki DLL z implementacją OpenGL dla Wine.
257
258 %package dll-twain
259 Summary:        TWAIN implementation DLL for Wine
260 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
261 Group:          Applications/Emulators
262 Requires:       %{name} = %{epoch}:%{version}-%{release}
263
264 %description dll-twain
265 TWAIN implementation DLL for Wine (through SANE).
266
267 %description dll-twain -l pl.UTF-8
268 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
269
270 %package dll-ldap
271 Summary:        Win32 LDAP API DLL for Wine
272 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
273 Group:          Applications/Emulators
274 Requires:       %{name} = %{epoch}:%{version}-%{release}
275
276 %description dll-ldap
277 Lightweight Directory Access Protocol Library for Wine.
278
279 %description dll-ldap -l pl.UTF-8
280 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
281
282 %package drv-alsa
283 Summary:        ALSA driver for WINE mm.dll implementation
284 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
285 Group:          Applications/Emulators
286 Requires:       %{name} = %{epoch}:%{version}-%{release}
287
288 %description drv-alsa
289 ALSA driver for WINE mm.dll (multimedia system) implementation.
290
291 %description drv-alsa -l pl.UTF-8
292 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
293
294 %prep
295 %setup -q
296 %patch0 -p1
297 %patch1 -p1
298 %patch2 -p1
299 %patch4 -p1
300 %patch5 -p1
301 %patch6 -p1
302 %ifarch %{x8664}
303 %patch7 -p1
304 %endif
305
306 %build
307 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
308 mv -f oic_winlogo_*.png %{name}.png
309
310 %{__autoconf}
311 %{__autoheader}
312 %configure \
313 %ifarch %{x8664}
314         --enable-win64 \
315 %endif
316         --with-alsa%{!?with_alsa:=no} \
317         --with-capi%{!?with_capi:=no} \
318         --with-cms \
319         --with-coreaudio \
320         --with-cups%{!?with_cups:=no} \
321         --with-curses \
322         --with-dbus \
323         --with-fontconfig \
324         --with-freetype \
325         --with-gphoto \
326         --with-glu \
327         --with-gnutls \
328         --with-gsm \
329         %{__with_without gstreamer} \
330         %{__with_without hal} \
331         --with-jpeg \
332         --with-ldap%{!?with_ldap:=no} \
333         --with-mpg123 \
334         --with%{!?with_netapi:out}-netapi \
335         --with-openal \
336         --with-opencl \
337         --with-opengl \
338         --with-osmesa \
339         --with-oss \
340         --with-pcap \
341         --with-png \
342         --with-pthread \
343         --with-pulse \
344         --with%{!?with_sane:out}-sane \
345         --with-tiff \
346         --with-v4l \
347         --with-xcomposite \
348         --with-xcursor \
349         --with-xinerama \
350         --with-xinput \
351         --with-xinput2 \
352         --with-xml \
353         --with-xrandr \
354         --with-xrender \
355         --with-xshape \
356         --with-xshm \
357         --with-xslt \
358         --with-xxf86vm \
359         --with-x \
360         --with-zlib
361 %{__make} depend
362 %{__make}
363
364 %install
365 rm -rf $RPM_BUILD_ROOT
366 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
367 %{__make} install \
368         DESTDIR=$RPM_BUILD_ROOT
369
370 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
371 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
372
373 install -d \
374         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
375         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
376         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
377         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
378         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
379
380 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
381 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
382 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
383
384 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
385 [mci]
386 cdaudio=mcicda.drv
387 sequencer=mciseq.drv
388 waveaudio=mciwave.drv
389 avivideo=mciavi.drv
390 videodisc=mcipionr.drv
391 vcr=mciviscd.drv
392 MPEGVideo=mciqtz.drv
393 EOF
394
395 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
396
397 dir=$(pwd)
398 > files.so
399 > files.programs
400 cd $RPM_BUILD_ROOT%{_libdir}/wine
401 for f in *.so; do
402         case $f in
403         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
404                 ;;
405         *)
406                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
407         esac
408 done
409 cd -
410
411 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
412 for p in $programs; do
413         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
414         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
415         echo "%{_mandir}/man1/$p.1*" >> files.programs
416         grep -v "$p\.exe\.so$" files.so > files.so.
417         mv -f files.so. files.so
418 done
419
420 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
421         mv "$dir" "${dir%.UTF-8}"
422 done
423
424 %ifarch %{x8664}
425 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
426 for lang in de fr pl ; do
427 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
428 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
429 done
430 %else
431 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
432 for lang in de fr pl ; do
433 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
434 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
435 done
436 %endif
437
438 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
439 %ifnarch %{x8664}
440 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
441 %else
442 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
443 %endif
444
445 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
446 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
447 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
448
449 %clean
450 rm -rf $RPM_BUILD_ROOT
451
452 %post
453 /sbin/ldconfig
454 %update_desktop_database
455
456 %postun -p /sbin/ldconfig
457
458 %triggerpostun -- wine < 1:0.9.12-1.9
459 rm -f /var/lock/subsys/wine
460 if [ -x /sbin/chkconfig ]; then
461         /sbin/chkconfig --del wine
462 fi
463
464 %files -f files.so
465 %defattr(644,root,root,755)
466 %doc README AUTHORS ANNOUNCE
467 %lang(de) %doc documentation/README.de
468 %lang(es) %doc documentation/README.es
469 %lang(fr) %doc documentation/README.fr
470 %lang(hu) %doc documentation/README.hu
471 %lang(it) %doc documentation/README.it
472 %lang(ko) %doc documentation/README.ko
473 %lang(nb) %doc documentation/README.no
474 %lang(pt) %doc documentation/README.pt
475 %lang(pt_BR) %doc documentation/README.pt_br
476 %lang(ru) %doc documentation/README.ru
477 %lang(sv) %doc documentation/README.sv
478 %lang(tr) %doc documentation/README.tr
479 %attr(755,root,root) %{_bindir}/msiexec
480 %ifnarch %{x8664}
481 %attr(755,root,root) %{_bindir}/wine
482 %else
483 %attr(755,root,root) %{_bindir}/wine64
484 %endif
485 %attr(755,root,root) %{_bindir}/wineboot
486 %attr(755,root,root) %{_bindir}/winedbg
487 %attr(755,root,root) %{_bindir}/winecfg
488 %ifnarch %{x8664}
489 %attr(755,root,root) %{_bindir}/wine-preloader
490 %else
491 %attr(755,root,root) %{_bindir}/wine64-preloader
492 %endif
493 %attr(755,root,root) %{_bindir}/wineserver
494 %attr(755,root,root) %{_libdir}/*.so*
495 %dir %{_libdir}/wine
496 %dir %{_libdir}/wine/fakedlls
497 %{_libdir}/wine/fakedlls/*.acm
498 %{_libdir}/wine/fakedlls/*.cpl
499 %{_libdir}/wine/fakedlls/*.dll
500 %ifarch %{ix86}
501 %{_libdir}/wine/fakedlls/*.dll16
502 %endif
503 %{_libdir}/wine/fakedlls/*.drv
504 %ifarch %{ix86}
505 %{_libdir}/wine/fakedlls/*.drv16
506 %endif
507 %{_libdir}/wine/fakedlls/*.ds
508 %{_libdir}/wine/fakedlls/*.exe
509 %ifarch %{ix86}
510 %{_libdir}/wine/fakedlls/*.exe16
511 %{_libdir}/wine/fakedlls/*.mod16
512 %endif
513 %{_libdir}/wine/fakedlls/*.ocx
514 %{_libdir}/wine/fakedlls/*.sys
515 %{_libdir}/wine/fakedlls/*.tlb
516 %ifarch %{ix86}
517 %{_libdir}/wine/fakedlls/*.vxd
518 %endif
519 %ifnarch %{x8664}
520 %{_mandir}/man1/wine.1*
521 %lang(de) %{_mandir}/de/man1/wine.1*
522 %lang(fr) %{_mandir}/fr/man1/wine.1*
523 %lang(pl) %{_mandir}/pl/man1/wine.1*
524 %else
525 %{_mandir}/man1/wine64.1*
526 %lang(de) %{_mandir}/de/man1/wine64.1*
527 %lang(fr) %{_mandir}/fr/man1/wine64.1*
528 %lang(pl) %{_mandir}/pl/man1/wine64.1*
529 %endif
530 %{_mandir}/man1/msiexec.1*
531 %{_mandir}/man1/wineboot.1*
532 %{_mandir}/man1/winecfg.1*
533 %{_mandir}/man1/winedbg.1*
534 %{_mandir}/man1/wineserver.1*
535 %lang(de) %{_mandir}/de/man1/wineserver.1*
536 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
537 %{_winedir}
538 %{_desktopdir}/wine.desktop
539 %{_desktopdir}/wine-uninstaller.desktop
540 %{_pixmapsdir}/%{name}.png
541
542 %files programs -f files.programs
543 %defattr(644,root,root,755)
544
545 %files devel
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/sfnt2fon
548 %attr(755,root,root) %{_bindir}/function_grep.pl
549 %attr(755,root,root) %{_bindir}/widl
550 %attr(755,root,root) %{_bindir}/winebuild
551 %attr(755,root,root) %{_bindir}/winedump
552 %attr(755,root,root) %{_bindir}/wineg++
553 %attr(755,root,root) %{_bindir}/winegcc
554 %attr(755,root,root) %{_bindir}/winemaker
555 %attr(755,root,root) %{_bindir}/winecpp
556 %attr(755,root,root) %{_bindir}/wmc
557 %attr(755,root,root) %{_bindir}/wrc
558 %{_libdir}/wine/lib*.def
559 # no shared variants, so not separated
560 %{_libdir}/wine/lib*.def.a
561 %{_libdir}/wine/libadsiid.a
562 %{_libdir}/wine/libdx*.a
563 %{_libdir}/wine/libstrmbase.a
564 %{_libdir}/wine/libstrmiids.a
565 %{_libdir}/wine/libuuid.a
566 %{_libdir}/wine/libwinecrt0.a
567 %{_includedir}/wine
568 %{_mandir}/man1/widl.1*
569 %{_mandir}/man1/winebuild.1*
570 %{_mandir}/man1/winecpp.1*
571 %{_mandir}/man1/winedump.1*
572 %{_mandir}/man1/winegcc.1*
573 %{_mandir}/man1/wineg++.1*
574 %{_mandir}/man1/winemaker.1*
575 %lang(de) %{_mandir}/de/man1/winemaker.1*
576 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
577 %{_mandir}/man1/wmc.1*
578 %{_mandir}/man1/wrc.1*
579 %{_aclocaldir}/*.m4
580
581 %files dll-capi
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
584
585 %files dll-d3d
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
588 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
589 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
590
591 %files dll-gl
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
594 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
595
596 %if %{with sane}
597 %files dll-twain
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
600 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
601 %endif
602
603 %if %{with ldap}
604 %files dll-ldap
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
607 %endif
608
609 %if %{with alsa}
610 %files drv-alsa
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
613 %endif
614
615 # additional dependencies in *.so not separated (yet?) from main package
616 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
617 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.115647 seconds and 4 git commands to generate.