]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- restore library qualifier (lost in r1.404 merge)
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # NOTE: wine detects the following SONAMES for dlopen at build time:
11 #   libcrypto,libssl (wininet.dll)
12 #   libcups (winspool.dll.so,wineps.dll.so)
13 #   libcurses/libncurses (wineconsole program)
14 #   libfontconfig (gdi32.dll.so)
15 #   libfreetype (wineps.dll.so,gdi32.dll.so)
16 #   libGL (x11drv.dll.so,ddraw.dll.so)
17 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
18 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
19 # thus requires rebuild after change of any of the above.
20
21 # library qualifier in rpm generated deps
22 %ifarch %{x8664} ia64 ppc64 s390x sparc64
23 %define libqual ()(64bit)
24 %else
25 %define libqual %{nil}
26 %endif
27
28 %define         gecko_ver       1.4
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.4
35 Release:        1
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  6594ab86a4b1fb2c09dadfb4ea7fc4af
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
42 # Source1-md5:  700aaa08724be1992cffed7b87e79a44
43 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
44 # Source2-md5:  7b4811f667fd01d300fdff68420a9c72
45 Source3:        %{name}-uninstaller.desktop
46 Patch0:         %{name}-fontcache.patch
47 Patch1:         %{name}-makedep.patch
48 Patch2:         %{name}-ncurses.patch
49 Patch4:         %{name}-disable-valgrind.patch
50 Patch5:         %{name}-ca_certificates.patch
51 Patch6:         %{name}-manpaths.patch
52 Patch7:         desktop.patch
53 URL:            http://www.winehq.org/
54 BuildRequires:  OpenAL-devel >= 1.1
55 BuildRequires:  OpenGL-GLU-devel
56 %{?with_alsa:BuildRequires:     alsa-lib-devel}
57 %{?with_arts:BuildRequires:     artsc-devel}
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 BuildRequires:  bison
61 %{?with_capi:BuildRequires:     capi4k-utils-devel}
62 %{?with_cups:BuildRequires:     cups-devel}
63 BuildRequires:  docbook-dtd31-sgml
64 BuildRequires:  docbook-utils
65 BuildRequires:  flex
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  fontforge
68 BuildRequires:  freetype-devel >= 2.0.5
69 BuildRequires:  gettext-devel
70 BuildRequires:  giflib-devel
71 BuildRequires:  gnutls-devel
72 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel}
73 BuildRequires:  icoutils
74 BuildRequires:  lcms-devel
75 BuildRequires:  libgphoto2-devel
76 BuildRequires:  libgsm-devel
77 BuildRequires:  libjpeg-devel
78 BuildRequires:  libmpg123-devel >= 1.5.0
79 BuildRequires:  libtool
80 BuildRequires:  libv4l-devel
81 BuildRequires:  libxslt-devel
82 BuildRequires:  ncurses-devel
83 # db2* failed previously - probably openjade or opensp bug
84 BuildRequires:  libpng-devel >= 1.5
85 BuildRequires:  openjade >= 1:1.3.3-0.pre1
86 %{?with_ldap:BuildRequires:     openldap-devel}
87 BuildRequires:  opensp >= 1:1.5.1
88 BuildRequires:  openssl-devel >= 0.9.7d
89 BuildRequires:  pkgconfig
90 BuildRequires:  prelink
91 %{?with_sane:BuildRequires:     sane-backends-devel}
92 BuildRequires:  unixODBC-devel >= 2.2.12-2
93 #BuildRequires: valgrind
94 BuildRequires:  xorg-lib-libXcomposite-devel
95 BuildRequires:  xorg-lib-libXcursor-devel
96 BuildRequires:  xorg-lib-libXi-devel
97 BuildRequires:  xorg-lib-libXinerama-devel
98 BuildRequires:  xorg-lib-libXmu-devel
99 BuildRequires:  xorg-lib-libXrandr-devel
100 BuildRequires:  xorg-lib-libXrender-devel
101 BuildRequires:  xorg-lib-libXxf86dga-devel
102 BuildRequires:  xorg-lib-libXxf86vm-devel
103 Requires:       libfreetype.so.6%{libqual}
104 Requires:       libpng15.so.15%{libqual}
105 Requires(post): /sbin/ldconfig
106 Suggests:       binfmt-detector
107 Suggests:       ca-certificates
108 Suggests:       cabextract
109 Conflicts:      ca-certificates < 20080809-4
110 # for printing needs lpr
111 Suggests:       cups-clients
112 # for winelauncher
113 Suggests:       xorg-app-xmessage
114 # for ntlm_auth
115 Suggests:       samba-common >= 1:3.0.25
116 # link to wine/ntdll.dll.so, without any SONAME
117 Provides:       libntdll.dll.so
118 Obsoletes:      wine-doc-pdf
119 Obsoletes:      wine-drv-arts
120 Obsoletes:      wine-drv-jack
121 Obsoletes:      wine-drv-nas
122 ExclusiveArch:  %{ix86} %{x8664}
123 ExcludeArch:    i386
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
127 %define         no_install_post_strip   1
128
129 %define         _winedir                %{_datadir}/%{name}
130
131 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
132
133 %undefine       debuginfocflags
134
135 %description
136 Wine is a program which allows running Microsoft Windows programs
137 (including DOS, Windows 3.x and Win32 executables) on Unix. It
138 consists of a program loader which loads and executes a Microsoft
139 Windows binary, and a library that implements Windows API calls using
140 their Unix or X11 equivalents. The library may also be used for
141 porting Win32 code into native Unix executables.
142
143 %description -l es.UTF-8
144 Ejecuta programas Windows en Linux.
145
146 %description -l pl.UTF-8
147 Wine jest programem dzięki któremu można uruchamiać programy napisane
148 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
149 loadera, który pozwala wczytywać i uruchamiać programy w formacie
150 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
151 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
152 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
153
154 %description -l pt_BR.UTF-8
155 O Wine é um programa que permite rodar programas MS-Windows no X11.
156 Ele consiste de um carregador de programa, que carrega e executa um
157 binário MS-Windows, e de uma biblioteca de emulação que traduz as
158 chamadas da API para as equivalentes Unix/X11.
159
160 %package devel
161 Summary:        Wine - header files
162 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
163 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
164 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
165 Group:          Development/Libraries
166 Requires:       %{name} = %{epoch}:%{version}-%{release}
167
168 %description devel
169 Wine - header files.
170
171 %description devel -l es.UTF-8
172 Biblioteca de desarrollo de wine.
173
174 %description devel -l pl.UTF-8
175 Wine - pliki nagłówkowe.
176
177 %description devel -l pt_BR.UTF-8
178 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
179 WINE.
180
181 %package programs
182 Summary:        Wine - programs
183 Summary(pl.UTF-8):      Wine - programy
184 Group:          Applications
185 Requires:       %{name} = %{epoch}:%{version}-%{release}
186
187 %description programs
188 Wine - programs.
189
190 %description programs -l pl.UTF-8
191 Wine - programy.
192
193 %package dll-capi
194 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
195 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
196 Group:          Applications/Emulators
197 Requires:       %{name} = %{epoch}:%{version}-%{release}
198
199 %description dll-capi
200 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
201
202 %description dll-capi -l pl.UTF-8
203 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
204 OpenGL).
205
206 %package dll-d3d
207 Summary:        Direct3D implementation DLLs for Wine
208 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
209 Group:          Applications/Emulators
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 Requires:       OpenGL
212
213 %description dll-d3d
214 Direct3D implementation DLLs for Wine (through OpenGL).
215
216 %description dll-d3d -l pl.UTF-8
217 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
218
219 %package dll-gl
220 Summary:        OpenGL implementation DLLs for Wine
221 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
222 Group:          Applications/Emulators
223 Requires:       %{name} = %{epoch}:%{version}-%{release}
224 Requires:       OpenGL
225
226 %description dll-gl
227 OpenGL implementation DLLs for Wine.
228
229 %description dll-gl -l pl.UTF-8
230 Biblioteki DLL z implementacją OpenGL dla Wine.
231
232 %package dll-twain
233 Summary:        TWAIN implementation DLL for Wine
234 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
235 Group:          Applications/Emulators
236 Requires:       %{name} = %{epoch}:%{version}-%{release}
237
238 %description dll-twain
239 TWAIN implementation DLL for Wine (through SANE).
240
241 %description dll-twain -l pl.UTF-8
242 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
243
244 %package dll-ldap
245 Summary:        Win32 LDAP API DLL for Wine
246 Group:          Applications/Emulators
247 Requires:       %{name} = %{epoch}:%{version}-%{release}
248
249 %description dll-ldap
250 Lightweight Directory Access Protocol Library.
251
252 %package drv-alsa
253 Summary:        ALSA driver for WINE mm.dll implementation
254 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
255 Group:          Applications/Emulators
256 Requires:       %{name} = %{epoch}:%{version}-%{release}
257
258 %description drv-alsa
259 ALSA driver for WINE mm.dll (multimedia system) implementation.
260
261 %description drv-alsa -l pl.UTF-8
262 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
263
264 %prep
265 %setup -q
266 %patch0 -p1
267 %patch1 -p1
268 %patch2 -p1
269 %patch4 -p1
270 %patch5 -p1
271 %patch6 -p1
272 %patch7 -p1
273
274 %build
275 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
276 mv -f oic_winlogo_*.png %{name}.png
277
278 %{__autoconf}
279 %{__autoheader}
280 %configure \
281 %ifarch %{x8664}
282         --enable-win64 \
283 %endif
284         --with%{!?with_alsa:out}-alsa \
285         --with%{!?with_capi:out}-capi \
286         --with-cms \
287         --with-coreaudio \
288         --with%{!?with_cups:out}-cups \
289         --with-curses \
290         --with-fontconfig \
291         --with-freetype \
292         --with-glu \
293         --with-gnutls \
294         --with-gphoto \
295         --with-gsm \
296         --with%{!?with_gstreamer:out}-gstreamer \
297         --with-jpeg \
298         --with%{!?with_ldap:out}-ldap \
299         --with-mpg123 \
300         --with-opengl \
301         --with-openssl \
302         --with-oss \
303         --with-png \
304         --with-pthread \
305         --with%{!?with_sane:out}-sane \
306         --with-xcomposite \
307         --with-xcursor \
308         --with-xinerama \
309         --with-xinput \
310         --with-xml \
311         --with-xrandr \
312         --with-xrender \
313         --with-xshape \
314         --with-xshm \
315         --with-xslt \
316         --with-xxf86vm \
317         --with-x
318 %{__make} depend
319 %{__make}
320
321 %install
322 rm -rf $RPM_BUILD_ROOT
323 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
324 %{__make} install \
325         DESTDIR=$RPM_BUILD_ROOT
326
327 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
328 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
329
330 install -d \
331         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
332         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
333         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
334         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
335         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
336
337 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
338 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
339 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
340
341 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
342 [mci]
343 cdaudio=mcicda.drv
344 sequencer=mciseq.drv
345 waveaudio=mciwave.drv
346 avivideo=mciavi.drv
347 videodisc=mcipionr.drv
348 vcr=mciviscd.drv
349 MPEGVideo=mciqtz.drv
350 EOF
351
352 %if %{?debug:0}%{!?debug:1}
353 echo "Strip executable binaries and shared object files."
354 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
355 elfexelist=`echo $filelist | xargs -r file | \
356         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
357 elfsharedlist=`echo $filelist | xargs -r file | \
358         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
359 if [ -n "$elfexelist" ]; then \
360         strip -R .note -R .comment $elfexelist
361 fi
362 if [ -n "$elfsharedlist" ]; then
363         strip --strip-unneeded -R .note -R .comment $elfsharedlist
364 fi
365 %endif
366
367 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
368
369 dir=$(pwd)
370 > files.so
371 > files.programs
372 cd $RPM_BUILD_ROOT%{_libdir}/wine
373 for f in *.so; do
374         case $f in
375         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wldap32.dll.so)
376                 ;;
377         *)
378                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
379         esac
380 done
381 cd -
382
383 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
384 for p in $programs; do
385         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
386         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
387         echo "%{_mandir}/man1/$p.1*" >> files.programs
388         grep -v "$p\.exe\.so$" files.so > files.so.
389         mv -f files.so. files.so
390 done
391
392 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
393 %ifnarch %{x8664}
394 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
395 %else
396 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
397 %endif
398
399 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
400 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
401 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
402
403 %clean
404 rm -rf $RPM_BUILD_ROOT
405
406 %post
407 /sbin/ldconfig
408 %update_desktop_database
409
410 %postun -p /sbin/ldconfig
411
412 %triggerpostun -- wine < 1:0.9.12-1.9
413 rm -f /var/lock/subsys/wine
414 if [ -x /sbin/chkconfig ]; then
415         /sbin/chkconfig --del wine
416 fi
417
418 %files -f files.so
419 %defattr(644,root,root,755)
420 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
421 %lang(de) %doc documentation/README.de
422 %lang(es) %doc documentation/README.es
423 %lang(fr) %doc documentation/README.fr
424 %lang(hu) %doc documentation/README.hu
425 %lang(it) %doc documentation/README.it
426 %lang(ko) %doc documentation/README.ko
427 %lang(nb) %doc documentation/README.no
428 %lang(pt) %doc documentation/README.pt
429 %lang(pt_BR) %doc documentation/README.pt_br
430 %lang(ru) %doc documentation/README.ru
431 %lang(sv) %doc documentation/README.sv
432 %lang(tr) %doc documentation/README.tr
433 %attr(755,root,root) %{_bindir}/msiexec
434 %ifnarch %{x8664}
435 %attr(755,root,root) %{_bindir}/wine
436 %else
437 %attr(755,root,root) %{_bindir}/wine64
438 %endif
439 %attr(755,root,root) %{_bindir}/wineboot
440 %attr(755,root,root) %{_bindir}/winedbg
441 %attr(755,root,root) %{_bindir}/winecfg
442 %ifnarch %{x8664}
443 %attr(755,root,root) %{_bindir}/wine-preloader
444 %else
445 %attr(755,root,root) %{_bindir}/wine64-preloader
446 %endif
447 %attr(755,root,root) %{_bindir}/wineserver
448 %attr(755,root,root) %{_libdir}/*.so*
449 %dir %{_libdir}/wine
450 %dir %{_libdir}/wine/fakedlls
451 %{_libdir}/wine/fakedlls/*.acm
452 %{_libdir}/wine/fakedlls/*.cpl
453 %{_libdir}/wine/fakedlls/*.dll
454 %ifarch %{ix86}
455 %{_libdir}/wine/fakedlls/*.dll16
456 %endif
457 %{_libdir}/wine/fakedlls/*.drv
458 %ifarch %{ix86}
459 %{_libdir}/wine/fakedlls/*.drv16
460 %endif
461 %{_libdir}/wine/fakedlls/*.ds
462 %{_libdir}/wine/fakedlls/*.exe
463 %ifarch %{ix86}
464 %{_libdir}/wine/fakedlls/*.exe16
465 %{_libdir}/wine/fakedlls/*.mod16
466 %endif
467 %{_libdir}/wine/fakedlls/*.ocx
468 %{_libdir}/wine/fakedlls/*.sys
469 %{_libdir}/wine/fakedlls/*.tlb
470 %ifarch %{ix86}
471 %{_libdir}/wine/fakedlls/*.vxd
472 %endif
473 %{_mandir}/man1/wine.1*
474 %lang(de) %{_mandir}/de/man1/wine*.1*
475 %lang(fr) %{_mandir}/fr/man1/wine*.1*
476 %lang(pl) %{_mandir}/pl/man1/wine*.1*
477 %{_mandir}/man1/msiexec.1*
478 %{_mandir}/man1/wineboot.1*
479 %{_mandir}/man1/winecfg.1*
480 %{_mandir}/man1/winedbg.1*
481 %{_mandir}/man1/wineserver.1*
482 %{_winedir}
483 %{_desktopdir}/wine.desktop
484 %{_desktopdir}/wine-uninstaller.desktop
485 %{_pixmapsdir}/%{name}.png
486
487 %files programs -f files.programs
488 %defattr(644,root,root,755)
489
490 %files devel
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/fnt2bdf
493 %attr(755,root,root) %{_bindir}/function_grep.pl
494 %attr(755,root,root) %{_bindir}/widl
495 %attr(755,root,root) %{_bindir}/winebuild
496 %attr(755,root,root) %{_bindir}/winedump
497 %attr(755,root,root) %{_bindir}/wineg++
498 %attr(755,root,root) %{_bindir}/winegcc
499 %attr(755,root,root) %{_bindir}/winemaker
500 %attr(755,root,root) %{_bindir}/winecpp
501 %attr(755,root,root) %{_bindir}/wmc
502 %attr(755,root,root) %{_bindir}/wrc
503 %{_libdir}/wine/lib*.def
504 # no shared variants, so not separated
505 %{_libdir}/wine/lib*.def.a
506 %{_libdir}/wine/libadsiid.a
507 %{_libdir}/wine/libdx*.a
508 %{_libdir}/wine/libstrmbase.a
509 %{_libdir}/wine/libstrmiids.a
510 %{_libdir}/wine/libuuid.a
511 %{_libdir}/wine/libwinecrt0.a
512 %{_includedir}/wine
513 %{_mandir}/man1/widl.1*
514 %{_mandir}/man1/winebuild.1*
515 %{_mandir}/man1/winecpp.1*
516 %{_mandir}/man1/winedump.1*
517 %{_mandir}/man1/winegcc.1*
518 %{_mandir}/man1/wineg++.1*
519 %{_mandir}/man1/winemaker.1*
520 %lang(de) %{_mandir}/de/man1/winemaker.1*
521 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
522 %{_mandir}/man1/wmc.1*
523 %{_mandir}/man1/wrc.1*
524 %{_aclocaldir}/*.m4
525
526 %files dll-capi
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
529
530 %files dll-d3d
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
533 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
534 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
535
536 %files dll-gl
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
539 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
540
541 %if %{with sane}
542 %files dll-twain
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
545 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
546 %endif
547
548 %if %{with ldap}
549 %files dll-ldap
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
552 %endif
553
554 %if %{with alsa}
555 %files drv-alsa
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
558 %endif
559
560 # additional dependencies in *.so not separated (yet?) from main package
561 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
562 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
563 #   ttydrv.dll.so depends on ncurses
This page took 0.084309 seconds and 4 git commands to generate.