]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- it compiles and works,
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20020228
7 Release:        1.0
8 License:        distributable
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 Exclusivearch:  %{ix86}
18 BuildRequires:  XFree86-devel
19 BuildRequires:  flex
20 BuildRequires:  bison
21 BuildRequires:  ncurses-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  freetype-devel >= 2.0.5
24 BuildRequires:  chpax
25 Requires:       OpenGL
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
29 %define         no_install_post_strip   1
30
31 %define         _prefix                 /usr/X11R6
32 %define         _mandir                 %{_prefix}/man
33 %define         _winedir                %{_datadir}/%{name}
34
35 %description
36 Wine is a program which allows running Microsoft Windows programs
37 (including DOS, Windows 3.x and Win32 executables) on Unix. It
38 consists of a program loader which loads and executes a Microsoft
39 Windows binary, and a library that implements Windows API calls using
40 their Unix or X11 equivalents. The library may also be used for
41 porting Win32 code into native Unix executables.
42
43 %description -l es
44 Ejecuta programas Windows en Linux.
45
46 %description -l pl
47 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
48 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
49 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
50 Microsoft Windows oraz z biblioteki, która implementuje API Windows
51 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
52 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
53
54 %description -l pt_BR
55 O Wine é um programa que permite rodar programas MS-Windows no X11.
56 Ele consiste de um carregador de programa, que carrega e executa um
57 binário MS-Windows, e de uma biblioteca de emulação que traduz as
58 chamadas da API para as equivalentes Unix/X11.
59
60 %package devel
61 Summary:        Wine - header files
62 Summary(es):    Biblioteca de desarrollo de wine
63 Summary(pl):    Wine - pliki nag³owkowe
64 Summary(pt_BR): Biblioteca de desenvolvimento do wine
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}
67
68 %description devel
69 Wine - header files.
70
71 %description devel -l es
72 Biblioteca de desarrollo de wine.
73
74 %description devel -l pl
75 Wine - pliki nag³ówkowe.
76
77 %description devel -l pt_BR
78 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
79 WINE.
80
81 %package programs
82 Summary:        Wine - programs
83 Summary(pl):    Wine - programy
84 Group:          Applications
85 Requires:       %{name} = %{version}
86
87 %description programs
88 Wine - programs
89
90 %description programs -l pl
91 Wine - programy
92
93 %prep
94 %setup -q
95 %patch -p1
96
97 # turn off compilation of some tools
98 sed -e "s|winetest||;s|avitools||" programs/Makefile.in > .tmp
99 mv -f .tmp programs/Makefile.in
100
101 %build
102 %configure2_13 \
103 %{!?debug:      --disable-debug} \
104 %{!?debug:      --disable-trace} \
105         --enable-curses \
106         --enable-opengl \
107         --with-x
108
109 %{__make} depend
110 %{__make}
111 %{__make} -C programs
112
113 (cd documentation
114 ./db2html-winehq wine-user.sgml
115 ./db2html-winehq wine-devel.sgml
116 ./db2html-winehq winelib-user.sgml)
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_mandir}/man1
121
122 %{__make} install \
123         prefix=$RPM_BUILD_ROOT%{_prefix} \
124         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
125         bindir=$RPM_BUILD_ROOT%{_bindir} \
126         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
127         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
128         datadir=$RPM_BUILD_ROOT%{_datadir} \
129         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
130         libdir=$RPM_BUILD_ROOT%{_libdir} \
131         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
132         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
133         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
134         mandir=$RPM_BUILD_ROOT%{_mandir} \
135         infodir=$RPM_BUILD_ROOT%{_infodir}
136
137 %{__make} -C programs install \
138         prefix=$RPM_BUILD_ROOT%{_prefix} \
139         bindir=$RPM_BUILD_ROOT%{_bindir}
140
141 (cd $RPM_BUILD_ROOT%{_bindir}
142 find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
143
144 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
145         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
146         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
147         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
148         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
149         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
150
151 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
152 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
153 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
154 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
155
156 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
157 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
158 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
159
160 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
161 [mci]
162 cdaudio=mcicda.drv
163 sequencer=mciseq.drv
164 waveaudio=mciwave.drv
165 avivideo=mciavi.drv
166 videodisc=mcipionr.drv
167 vcr=mciviscd.drv
168 MPEGVideo=mciqtz.drv
169 EOF
170
171 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
172
173 %if %{?debug:0}%{!?debug:1}
174 echo "Strip executable binaries and shared object files."
175 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
176 elfexelist=`echo $filelist | xargs -r file | \
177         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
178 elfsharedlist=`echo $filelist | xargs -r file | \
179         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
180 if [ -n "$elfexelist" ]; then \
181         strip -R .note -R .comment $elfexelist
182 fi
183 if [ -n "$elfsharedlist" ]; then
184         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
185 fi
186 %endif
187
188 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post
194 /sbin/ldconfig
195 /sbin/chkconfig --add wine
196 if [ ! -f /var/lock/subsys/wine ]; then
197         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
198 fi
199
200 %preun
201 if [ "$1" = "0" ]; then
202         if [ -f /var/lock/subsys/wine ]; then
203                 /etc/rc.d/init.d/wine stop >&2
204         fi
205         /sbin/chkconfig --del wine
206 fi
207
208 %postun -p /sbin/ldconfig
209
210 %files
211 %defattr(644,root,root,755)
212 %doc *.gz
213 %doc documentation/wine-user
214 %attr(755,root,root) %{_bindir}/wine
215 %attr(755,root,root) %{_bindir}/winebuild
216 %attr(755,root,root) %{_bindir}/winemaker
217 %attr(755,root,root) %{_bindir}/wineserver
218 %attr(755,root,root) %{_bindir}/wineclipsrv
219 %attr(755,root,root) %{_bindir}/winelauncher
220 %attr(755,root,root) %{_bindir}/wineshelllink
221 %attr(755,root,root) %{_bindir}/winedump
222 %attr(755,root,root) %{_bindir}/wrc
223 %attr(755,root,root) %{_bindir}/wmc
224 %attr(755,root,root) %{_bindir}/fnt2bdf
225 %attr(755,root,root) %{_bindir}/function_grep.pl
226 %attr(755,root,root) %{_libdir}/*.so*
227 %{_mandir}/man[15]/*
228 %config(noreplace) %{_sysconfdir}/wine.reg
229 %config(missingok) %{_sysconfdir}/wine.systemreg
230 %config(missingok) %{_sysconfdir}/wine.userreg
231 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
232 %{_winedir}
233
234 %files programs -f programs.list
235 %defattr(644,root,root,755)
236 %attr (755,root,root) %{_bindir}/hlp2sgml
237 %{_bindir}/*.so
238
239 %files devel
240 %defattr(644,root,root,755)
241 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
242 %{_includedir}/wine
243 %{_libdir}/*.a
This page took 0.121491 seconds and 4 git commands to generate.