]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
Version: 1.6
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # NOTE: wine detects the following SONAMES for dlopen at build time:
11 #   libcrypto,libssl (wininet.dll)
12 #   libcups (winspool.dll.so,wineps.dll.so)
13 #   libcurses/libncurses (wineconsole program)
14 #   libfontconfig (gdi32.dll.so)
15 #   libfreetype (wineps.dll.so,gdi32.dll.so)
16 #   libGL (x11drv.dll.so,ddraw.dll.so)
17 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
18 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
19 # thus requires rebuild after change of any of the above.
20
21 # library qualifier in rpm generated deps
22 %ifarch %{x8664} ia64 ppc64 s390x sparc64
23 %define libqual ()(64bit)
24 %else
25 %define libqual %{nil}
26 %endif
27
28 %define         gecko_ver       2.21
29 Summary:        Program that lets you launch Win applications
30 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
31 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
32 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
33 Name:           wine
34 Version:        1.6
35 Release:        1
36 Epoch:          1
37 License:        LGPL
38 Group:          Applications/Emulators
39 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
40 # Source0-md5:  47cf1e121d395e9c8ca1a4ab88f1e658
41 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
42 # Source1-md5:  432eb3a2d05c3f07df67864f53c87c60
43 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
44 # Source2-md5:  580bbabde1ec99ba9caa439c2dbca3f6
45 Source3:        %{name}-uninstaller.desktop
46 Patch0:         %{name}-bison3.patch
47 Patch1:         %{name}-makedep.patch
48 Patch2:         %{name}-ncurses.patch
49 Patch4:         %{name}-disable-valgrind.patch
50 Patch5:         %{name}-ca_certificates.patch
51 Patch6:         %{name}-manpaths.patch
52 Patch7:         desktop.patch
53 URL:            http://www.winehq.org/
54 BuildRequires:  OpenAL-devel >= 1.1
55 BuildRequires:  OpenGL-GLU-devel
56 %{?with_alsa:BuildRequires:     alsa-lib-devel}
57 %{?with_arts:BuildRequires:     artsc-devel}
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 BuildRequires:  bison
61 %{?with_capi:BuildRequires:     capi4k-utils-devel}
62 %{?with_cups:BuildRequires:     cups-devel}
63 BuildRequires:  docbook-dtd31-sgml
64 BuildRequires:  docbook-utils
65 BuildRequires:  flex
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  fontforge
68 BuildRequires:  freetype-devel >= 2.0.5
69 BuildRequires:  fslint
70 BuildRequires:  gettext-devel
71 BuildRequires:  giflib-devel
72 BuildRequires:  gnutls-devel
73 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel}
74 BuildRequires:  icoutils
75 BuildRequires:  lcms-devel
76 BuildRequires:  libgphoto2-devel
77 BuildRequires:  libgsm-devel
78 BuildRequires:  libjpeg-devel
79 BuildRequires:  libmpg123-devel >= 1.5.0
80 BuildRequires:  libtool
81 BuildRequires:  libv4l-devel
82 BuildRequires:  libxslt-devel
83 BuildRequires:  ncurses-devel
84 # db2* failed previously - probably openjade or opensp bug
85 BuildRequires:  libpng-devel >= 1.5
86 BuildRequires:  openjade >= 1:1.3.3-0.pre1
87 %{?with_ldap:BuildRequires:     openldap-devel}
88 BuildRequires:  opensp >= 1:1.5.1
89 BuildRequires:  openssl-devel >= 0.9.7d
90 BuildRequires:  pkgconfig
91 BuildRequires:  prelink
92 %{?with_sane:BuildRequires:     sane-backends-devel}
93 BuildRequires:  unixODBC-devel >= 2.2.12-2
94 #BuildRequires: valgrind
95 BuildRequires:  xorg-lib-libXcomposite-devel
96 BuildRequires:  xorg-lib-libXcursor-devel
97 BuildRequires:  xorg-lib-libXi-devel
98 BuildRequires:  xorg-lib-libXinerama-devel
99 BuildRequires:  xorg-lib-libXmu-devel
100 BuildRequires:  xorg-lib-libXrandr-devel
101 BuildRequires:  xorg-lib-libXrender-devel
102 BuildRequires:  xorg-lib-libXxf86dga-devel
103 BuildRequires:  xorg-lib-libXxf86vm-devel
104 Requires:       libfreetype.so.6%{libqual}
105 Requires:       libpng15.so.15%{libqual}
106 Requires(post): /sbin/ldconfig
107 Suggests:       binfmt-detector
108 Suggests:       ca-certificates
109 Suggests:       cabextract
110 Conflicts:      ca-certificates < 20080809-4
111 # for printing needs lpr
112 Suggests:       cups-clients
113 # for winelauncher
114 Suggests:       xorg-app-xmessage
115 # for ntlm_auth
116 Suggests:       samba-common >= 1:3.0.25
117 # link to wine/ntdll.dll.so, without any SONAME
118 Provides:       libntdll.dll.so
119 Obsoletes:      wine-doc-pdf
120 Obsoletes:      wine-drv-arts
121 Obsoletes:      wine-drv-jack
122 Obsoletes:      wine-drv-nas
123 ExclusiveArch:  %{ix86} %{x8664}
124 ExcludeArch:    i386
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
128 %define         no_install_post_strip   1
129
130 %define         _winedir                %{_datadir}/%{name}
131
132 %description
133 Wine is a program which allows running Microsoft Windows programs
134 (including DOS, Windows 3.x and Win32 executables) on Unix. It
135 consists of a program loader which loads and executes a Microsoft
136 Windows binary, and a library that implements Windows API calls using
137 their Unix or X11 equivalents. The library may also be used for
138 porting Win32 code into native Unix executables.
139
140 %description -l es.UTF-8
141 Ejecuta programas Windows en Linux.
142
143 %description -l pl.UTF-8
144 Wine jest programem dzięki któremu można uruchamiać programy napisane
145 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
146 loadera, który pozwala wczytywać i uruchamiać programy w formacie
147 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
148 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
149 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
150
151 %description -l pt_BR.UTF-8
152 O Wine é um programa que permite rodar programas MS-Windows no X11.
153 Ele consiste de um carregador de programa, que carrega e executa um
154 binário MS-Windows, e de uma biblioteca de emulação que traduz as
155 chamadas da API para as equivalentes Unix/X11.
156
157 %package devel
158 Summary:        Wine - header files
159 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
160 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
161 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
162 Group:          Development/Libraries
163 Requires:       %{name} = %{epoch}:%{version}-%{release}
164
165 %description devel
166 Wine - header files.
167
168 %description devel -l es.UTF-8
169 Biblioteca de desarrollo de wine.
170
171 %description devel -l pl.UTF-8
172 Wine - pliki nagłówkowe.
173
174 %description devel -l pt_BR.UTF-8
175 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
176 WINE.
177
178 %package programs
179 Summary:        Wine - programs
180 Summary(pl.UTF-8):      Wine - programy
181 Group:          Applications
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183
184 %description programs
185 Wine - programs.
186
187 %description programs -l pl.UTF-8
188 Wine - programy.
189
190 %package dll-capi
191 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
192 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
193 Group:          Applications/Emulators
194 Requires:       %{name} = %{epoch}:%{version}-%{release}
195
196 %description dll-capi
197 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
198
199 %description dll-capi -l pl.UTF-8
200 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
201 OpenGL).
202
203 %package dll-d3d
204 Summary:        Direct3D implementation DLLs for Wine
205 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
206 Group:          Applications/Emulators
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 Requires:       OpenGL
209
210 %description dll-d3d
211 Direct3D implementation DLLs for Wine (through OpenGL).
212
213 %description dll-d3d -l pl.UTF-8
214 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
215
216 %package dll-gl
217 Summary:        OpenGL implementation DLLs for Wine
218 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
219 Group:          Applications/Emulators
220 Requires:       %{name} = %{epoch}:%{version}-%{release}
221 Requires:       OpenGL
222
223 %description dll-gl
224 OpenGL implementation DLLs for Wine.
225
226 %description dll-gl -l pl.UTF-8
227 Biblioteki DLL z implementacją OpenGL dla Wine.
228
229 %package dll-twain
230 Summary:        TWAIN implementation DLL for Wine
231 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
232 Group:          Applications/Emulators
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234
235 %description dll-twain
236 TWAIN implementation DLL for Wine (through SANE).
237
238 %description dll-twain -l pl.UTF-8
239 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
240
241 %package dll-ldap
242 Summary:        Win32 LDAP API DLL for Wine
243 Group:          Applications/Emulators
244 Requires:       %{name} = %{epoch}:%{version}-%{release}
245
246 %description dll-ldap
247 Lightweight Directory Access Protocol Library.
248
249 %package drv-alsa
250 Summary:        ALSA driver for WINE mm.dll implementation
251 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
252 Group:          Applications/Emulators
253 Requires:       %{name} = %{epoch}:%{version}-%{release}
254
255 %description drv-alsa
256 ALSA driver for WINE mm.dll (multimedia system) implementation.
257
258 %description drv-alsa -l pl.UTF-8
259 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
260
261 %prep
262 %setup -q
263 %patch0 -p1
264 %patch1 -p1
265 %patch2 -p1
266 %patch4 -p1
267 %patch5 -p1
268 %patch6 -p1
269 %patch7 -p1
270
271 %build
272 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
273 mv -f oic_winlogo_*.png %{name}.png
274
275 %{__autoconf}
276 %{__autoheader}
277 %configure \
278 %ifarch %{x8664}
279         --enable-win64 \
280 %endif
281         --with%{!?with_alsa:out}-alsa \
282         --with%{!?with_capi:out}-capi \
283         --with-cms \
284         --with-coreaudio \
285         --with%{!?with_cups:out}-cups \
286         --with-curses \
287         --with-fontconfig \
288         --with-freetype \
289         --with-glu \
290         --with-gnutls \
291         --with-gphoto \
292         --with-gsm \
293         --with%{!?with_gstreamer:out}-gstreamer \
294         --with-jpeg \
295         --with%{!?with_ldap:out}-ldap \
296         --with-mpg123 \
297         --with-opengl \
298         --with-openssl \
299         --with-oss \
300         --with-png \
301         --with-pthread \
302         --with%{!?with_sane:out}-sane \
303         --with-xcomposite \
304         --with-xcursor \
305         --with-xinerama \
306         --with-xinput \
307         --with-xml \
308         --with-xrandr \
309         --with-xrender \
310         --with-xshape \
311         --with-xshm \
312         --with-xslt \
313         --with-xxf86vm \
314         --with-x
315 %{__make} depend
316 %{__make}
317
318 %install
319 rm -rf $RPM_BUILD_ROOT
320 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
321 %{__make} install \
322         DESTDIR=$RPM_BUILD_ROOT
323
324 findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
325
326 install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
327 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
328
329 install -d \
330         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
331         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
332         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
333         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
334         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
335
336 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
337 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
338 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
339
340 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
341 [mci]
342 cdaudio=mcicda.drv
343 sequencer=mciseq.drv
344 waveaudio=mciwave.drv
345 avivideo=mciavi.drv
346 videodisc=mcipionr.drv
347 vcr=mciviscd.drv
348 MPEGVideo=mciqtz.drv
349 EOF
350
351 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
352
353 dir=$(pwd)
354 > files.so
355 > files.programs
356 cd $RPM_BUILD_ROOT%{_libdir}/wine
357 for f in *.so; do
358         case $f in
359         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
360                 ;;
361         *)
362                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
363         esac
364 done
365 cd -
366
367 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
368 for p in $programs; do
369         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
370         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
371         echo "%{_mandir}/man1/$p.1*" >> files.programs
372         grep -v "$p\.exe\.so$" files.so > files.so.
373         mv -f files.so. files.so
374 done
375
376 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
377 %ifnarch %{x8664}
378 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
379 %else
380 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
381 %endif
382
383 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
384 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
385 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
386
387 %clean
388 rm -rf $RPM_BUILD_ROOT
389
390 %post
391 /sbin/ldconfig
392 %update_desktop_database
393
394 %postun -p /sbin/ldconfig
395
396 %triggerpostun -- wine < 1:0.9.12-1.9
397 rm -f /var/lock/subsys/wine
398 if [ -x /sbin/chkconfig ]; then
399         /sbin/chkconfig --del wine
400 fi
401
402 %files -f files.so
403 %defattr(644,root,root,755)
404 %doc README AUTHORS ANNOUNCE
405 %lang(de) %doc documentation/README.de
406 %lang(es) %doc documentation/README.es
407 %lang(fr) %doc documentation/README.fr
408 %lang(hu) %doc documentation/README.hu
409 %lang(it) %doc documentation/README.it
410 %lang(ko) %doc documentation/README.ko
411 %lang(nb) %doc documentation/README.no
412 %lang(pt) %doc documentation/README.pt
413 %lang(pt_BR) %doc documentation/README.pt_br
414 %lang(ru) %doc documentation/README.ru
415 %lang(sv) %doc documentation/README.sv
416 %lang(tr) %doc documentation/README.tr
417 %attr(755,root,root) %{_bindir}/msiexec
418 %ifnarch %{x8664}
419 %attr(755,root,root) %{_bindir}/wine
420 %else
421 %attr(755,root,root) %{_bindir}/wine64
422 %endif
423 %attr(755,root,root) %{_bindir}/wineboot
424 %attr(755,root,root) %{_bindir}/winedbg
425 %attr(755,root,root) %{_bindir}/winecfg
426 %ifnarch %{x8664}
427 %attr(755,root,root) %{_bindir}/wine-preloader
428 %else
429 %attr(755,root,root) %{_bindir}/wine64-preloader
430 %endif
431 %attr(755,root,root) %{_bindir}/wineserver
432 %attr(755,root,root) %{_libdir}/*.so*
433 %dir %{_libdir}/wine
434 %dir %{_libdir}/wine/fakedlls
435 %{_libdir}/wine/fakedlls/*.acm
436 %{_libdir}/wine/fakedlls/*.cpl
437 %{_libdir}/wine/fakedlls/*.dll
438 %ifarch %{ix86}
439 %{_libdir}/wine/fakedlls/*.dll16
440 %endif
441 %{_libdir}/wine/fakedlls/*.drv
442 %ifarch %{ix86}
443 %{_libdir}/wine/fakedlls/*.drv16
444 %endif
445 %{_libdir}/wine/fakedlls/*.ds
446 %{_libdir}/wine/fakedlls/*.exe
447 %ifarch %{ix86}
448 %{_libdir}/wine/fakedlls/*.exe16
449 %{_libdir}/wine/fakedlls/*.mod16
450 %endif
451 %{_libdir}/wine/fakedlls/*.ocx
452 %{_libdir}/wine/fakedlls/*.sys
453 %{_libdir}/wine/fakedlls/*.tlb
454 %ifarch %{ix86}
455 %{_libdir}/wine/fakedlls/*.vxd
456 %endif
457 %{_mandir}/man1/wine.1*
458 %lang(de) %{_mandir}/de/man1/wine.1*
459 %lang(fr) %{_mandir}/fr/man1/wine.1*
460 %lang(pl) %{_mandir}/pl/man1/wine.1*
461 %{_mandir}/man1/msiexec.1*
462 %{_mandir}/man1/wineboot.1*
463 %{_mandir}/man1/winecfg.1*
464 %{_mandir}/man1/winedbg.1*
465 %{_mandir}/man1/wineserver.1*
466 %lang(de) %{_mandir}/de/man1/wineserver.1*
467 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
468 %{_winedir}
469 %{_desktopdir}/wine.desktop
470 %{_desktopdir}/wine-uninstaller.desktop
471 %{_pixmapsdir}/%{name}.png
472
473 %files programs -f files.programs
474 %defattr(644,root,root,755)
475
476 %files devel
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/fnt2fon
479 %attr(755,root,root) %{_bindir}/function_grep.pl
480 %attr(755,root,root) %{_bindir}/widl
481 %attr(755,root,root) %{_bindir}/winebuild
482 %attr(755,root,root) %{_bindir}/winedump
483 %attr(755,root,root) %{_bindir}/wineg++
484 %attr(755,root,root) %{_bindir}/winegcc
485 %attr(755,root,root) %{_bindir}/winemaker
486 %attr(755,root,root) %{_bindir}/winecpp
487 %attr(755,root,root) %{_bindir}/wmc
488 %attr(755,root,root) %{_bindir}/wrc
489 %{_libdir}/wine/lib*.def
490 # no shared variants, so not separated
491 %{_libdir}/wine/lib*.def.a
492 %{_libdir}/wine/libadsiid.a
493 %{_libdir}/wine/libdx*.a
494 %{_libdir}/wine/libstrmbase.a
495 %{_libdir}/wine/libstrmiids.a
496 %{_libdir}/wine/libuuid.a
497 %{_libdir}/wine/libwinecrt0.a
498 %{_includedir}/wine
499 %{_mandir}/man1/widl.1*
500 %{_mandir}/man1/winebuild.1*
501 %{_mandir}/man1/winecpp.1*
502 %{_mandir}/man1/winedump.1*
503 %{_mandir}/man1/winegcc.1*
504 %{_mandir}/man1/wineg++.1*
505 %{_mandir}/man1/winemaker.1*
506 %lang(de) %{_mandir}/de/man1/winemaker.1*
507 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
508 %{_mandir}/man1/wmc.1*
509 %{_mandir}/man1/wrc.1*
510 %{_aclocaldir}/*.m4
511
512 %files dll-capi
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
515
516 %files dll-d3d
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
519 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
520 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
521
522 %files dll-gl
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
525 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
526
527 %if %{with sane}
528 %files dll-twain
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
531 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
532 %endif
533
534 %if %{with ldap}
535 %files dll-ldap
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
538 %endif
539
540 %if %{with alsa}
541 %files drv-alsa
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
544 %endif
545
546 # additional dependencies in *.so not separated (yet?) from main package
547 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
548 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
549 #   ttydrv.dll.so depends on ncurses
This page took 0.08042 seconds and 4 git commands to generate.