]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
drop unused BR
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 %bcond_without  netapi          # don't use the Samba NetAPI library
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libGL (winex11.drv.so)
14 #   libOSMesa (gdi32.dll.so)
15 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16 #   libcapi20 (capi2032.dll.so)
17 #   libcups (winspool.drv.so)
18 #   libdbus (mountmgr.sys.so)
19 #   libfontconfig (gdi32.dll.so)
20 #   libfreetype (gdi32.dll.so)
21 #   libgnutls (secur32.dll.so)
22 #   libhal (mountmgr.sys.so)
23 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libpng (windowscodecs.dll.so)
27 #   libsane (sane.ds.so)
28 #   libtiff (windowscodecs.dll.so)
29 #   libv4l1 (qcap.dll.so)
30 #   libxslt (msxml3.dll.so)
31 # thus requires rebuild after change of any of the above.
32
33 # library qualifier in rpm generated deps
34 %ifarch %{x8664} ia64 ppc64 s390x sparc64
35 %define libqual ()(64bit)
36 %else
37 %define libqual %{nil}
38 %endif
39
40 %define         gecko_ver       2.24
41 Summary:        Program that lets you launch Win applications
42 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
43 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
44 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
45 Name:           wine
46 # 1.8.x – stable
47 # 1.9.x – development
48 Version:        1.8
49 Release:        1
50 Epoch:          1
51 License:        LGPL
52 Group:          Applications/Emulators
53 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
54 # Source0-md5:  96b51a2f2ae727802d71095354e69fef
55 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
56 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
57 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
58 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
59 Source3:        %{name}-uninstaller.desktop
60 Patch0:         %{name}-gphoto2_bool.patch
61 Patch1:         %{name}-makedep.patch
62 Patch2:         %{name}-ncurses.patch
63 Patch4:         %{name}-disable-valgrind.patch
64 Patch5:         %{name}-ca_certificates.patch
65 Patch6:         desktop.patch
66 Patch7:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 %{?with_alsa:BuildRequires:     alsa-lib-devel}
73 %{?with_arts:BuildRequires:     artsc-devel}
74 BuildRequires:  autoconf >= 2.62
75 BuildRequires:  automake
76 BuildRequires:  bison
77 %{?with_capi:BuildRequires:     capi4k-utils-devel}
78 %{?with_cups:BuildRequires:     cups-devel}
79 BuildRequires:  dbus-devel
80 BuildRequires:  flex >= 2.5.33
81 BuildRequires:  fontconfig-devel
82 BuildRequires:  freetype-devel >= 2.0.5
83 # for findup used after make install
84 BuildRequires:  fslint
85 BuildRequires:  gettext-devel
86 %ifarch %{x8664}
87 BuildRequires:  gcc >= 6:4.4
88 %endif
89 BuildRequires:  gettext-tools
90 BuildRequires:  gnutls-devel
91 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
92 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
93 %{?with_hal:BuildRequires:      hal-devel}
94 # for icotool used in build
95 BuildRequires:  icoutils >= 0.29.0
96 BuildRequires:  lcms2-devel >= 2
97 BuildRequires:  libcap-devel
98 BuildRequires:  libgphoto2-devel
99 BuildRequires:  libgsm-devel
100 BuildRequires:  libjpeg-devel
101 BuildRequires:  libmpg123-devel >= 1.5.0
102 BuildRequires:  libpcap-devel
103 BuildRequires:  libpng-devel >= 1.5
104 BuildRequires:  libtiff-devel
105 BuildRequires:  libv4l-devel
106 BuildRequires:  libxml2-devel >= 2.0
107 BuildRequires:  libxslt-devel
108 BuildRequires:  ncurses-devel
109 %{?with_ldap:BuildRequires:     openldap-devel}
110 BuildRequires:  pkgconfig
111 BuildRequires:  prelink
112 BuildRequires:  pulseaudio-devel
113 BuildRequires:  samba-devel
114 %{?with_sane:BuildRequires:     sane-backends-devel}
115 BuildRequires:  xorg-lib-libX11-devel
116 BuildRequires:  xorg-lib-libXcomposite-devel
117 BuildRequires:  xorg-lib-libXcursor-devel
118 BuildRequires:  xorg-lib-libXext-devel
119 BuildRequires:  xorg-lib-libXi-devel
120 BuildRequires:  xorg-lib-libXinerama-devel
121 BuildRequires:  xorg-lib-libXrandr-devel
122 BuildRequires:  xorg-lib-libXrender-devel
123 BuildRequires:  xorg-lib-libXxf86vm-devel
124 BuildRequires:  zlib-devel
125 Requires:       libfreetype.so.6%{libqual}
126 Requires:       libpng16.so.16%{libqual}
127 Requires(post): /sbin/ldconfig
128 Suggests:       binfmt-detector
129 Suggests:       ca-certificates
130 Suggests:       cabextract
131 Conflicts:      ca-certificates < 20080809-4
132 # for printing needs lpr
133 Suggests:       cups-clients
134 # for winelauncher
135 Suggests:       xorg-app-xmessage
136 # for ntlm_auth
137 Suggests:       samba-common >= 1:3.0.25
138 # link to wine/ntdll.dll.so, without any SONAME
139 Provides:       libntdll.dll.so
140 Obsoletes:      wine-doc-pdf
141 Obsoletes:      wine-drv-arts
142 Obsoletes:      wine-drv-jack
143 Obsoletes:      wine-drv-nas
144 ExclusiveArch:  %{ix86} %{x8664} arm
145 ExcludeArch:    i386
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 %define         no_install_post_strip   1
149
150 %define         _winedir                %{_datadir}/%{name}
151
152 %description
153 Wine is a program which allows running Microsoft Windows programs
154 (including DOS, Windows 3.x and Win32 executables) on Unix. It
155 consists of a program loader which loads and executes a Microsoft
156 Windows binary, and a library that implements Windows API calls using
157 their Unix or X11 equivalents. The library may also be used for
158 porting Win32 code into native Unix executables.
159
160 %description -l es.UTF-8
161 Ejecuta programas Windows en Linux.
162
163 %description -l pl.UTF-8
164 Wine jest programem dzięki któremu można uruchamiać programy napisane
165 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
166 loadera, który pozwala wczytywać i uruchamiać programy w formacie
167 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
168 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
169 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
170
171 %description -l pt_BR.UTF-8
172 O Wine é um programa que permite rodar programas MS-Windows no X11.
173 Ele consiste de um carregador de programa, que carrega e executa um
174 binário MS-Windows, e de uma biblioteca de emulação que traduz as
175 chamadas da API para as equivalentes Unix/X11.
176
177 %package devel
178 Summary:        Wine - header files
179 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
180 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
181 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
182 Group:          Development/Libraries
183 Requires:       %{name} = %{epoch}:%{version}-%{release}
184
185 %description devel
186 Wine - header files.
187
188 %description devel -l es.UTF-8
189 Biblioteca de desarrollo de wine.
190
191 %description devel -l pl.UTF-8
192 Wine - pliki nagłówkowe.
193
194 %description devel -l pt_BR.UTF-8
195 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
196 WINE.
197
198 %package programs
199 Summary:        Wine - programs
200 Summary(pl.UTF-8):      Wine - programy
201 Group:          Applications
202 Requires:       %{name} = %{epoch}:%{version}-%{release}
203
204 %description programs
205 Wine - programs.
206
207 %description programs -l pl.UTF-8
208 Wine - programy.
209
210 %package dll-capi
211 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
212 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
213 Group:          Applications/Emulators
214 Requires:       %{name} = %{epoch}:%{version}-%{release}
215
216 %description dll-capi
217 CAPI 2.0 (ISDN) implementation DLLs for Wine.
218
219 %description dll-capi -l pl.UTF-8
220 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
221
222 %package dll-d3d
223 Summary:        Direct3D implementation DLLs for Wine
224 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
225 Group:          Applications/Emulators
226 Requires:       %{name} = %{epoch}:%{version}-%{release}
227 Requires:       OpenGL
228
229 %description dll-d3d
230 Direct3D implementation DLLs for Wine (through OpenGL).
231
232 %description dll-d3d -l pl.UTF-8
233 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
234
235 %package dll-gl
236 Summary:        OpenGL implementation DLLs for Wine
237 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
238 Group:          Applications/Emulators
239 Requires:       %{name} = %{epoch}:%{version}-%{release}
240 Requires:       OpenGL
241
242 %description dll-gl
243 OpenGL implementation DLLs for Wine.
244
245 %description dll-gl -l pl.UTF-8
246 Biblioteki DLL z implementacją OpenGL dla Wine.
247
248 %package dll-twain
249 Summary:        TWAIN implementation DLL for Wine
250 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
251 Group:          Applications/Emulators
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253
254 %description dll-twain
255 TWAIN implementation DLL for Wine (through SANE).
256
257 %description dll-twain -l pl.UTF-8
258 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
259
260 %package dll-ldap
261 Summary:        Win32 LDAP API DLL for Wine
262 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
263 Group:          Applications/Emulators
264 Requires:       %{name} = %{epoch}:%{version}-%{release}
265
266 %description dll-ldap
267 Lightweight Directory Access Protocol Library for Wine.
268
269 %description dll-ldap -l pl.UTF-8
270 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
271
272 %package drv-alsa
273 Summary:        ALSA driver for WINE mm.dll implementation
274 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
275 Group:          Applications/Emulators
276 Requires:       %{name} = %{epoch}:%{version}-%{release}
277
278 %description drv-alsa
279 ALSA driver for WINE mm.dll (multimedia system) implementation.
280
281 %description drv-alsa -l pl.UTF-8
282 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
283
284 %prep
285 %setup -q
286 %patch0 -p1
287 %patch1 -p1
288 %patch2 -p1
289 %patch4 -p1
290 %patch5 -p1
291 %patch6 -p1
292 %ifarch %{x8664}
293 %patch7 -p1
294 %endif
295
296 %build
297 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
298 mv -f oic_winlogo_*.png %{name}.png
299
300 %{__autoconf}
301 %{__autoheader}
302 %configure \
303 %ifarch %{x8664}
304         --enable-win64 \
305 %endif
306         --with-alsa%{!?with_alsa:=no} \
307         --with-capi%{!?with_capi:=no} \
308         --with-cms \
309         --with-coreaudio \
310         --with-cups%{!?with_cups:=no} \
311         --with-curses \
312         --with-dbus \
313         --with-fontconfig \
314         --with-freetype \
315         --with-gphoto \
316         --with-glu \
317         --with-gnutls \
318         --with-gsm \
319         %{__with_without gstreamer} \
320         %{__with_without hal} \
321         --with-jpeg \
322         --with-ldap%{!?with_ldap:=no} \
323         --with-mpg123 \
324         --with%{!?with_netapi:out}-netapi \
325         --with-openal \
326         --with-opencl \
327         --with-opengl \
328         --with-osmesa \
329         --with-oss \
330         --with-pcap \
331         --with-png \
332         --with-pthread \
333         --with-pulse \
334         --with%{!?with_sane:out}-sane \
335         --with-tiff \
336         --with-v4l \
337         --with-xcomposite \
338         --with-xcursor \
339         --with-xinerama \
340         --with-xinput \
341         --with-xinput2 \
342         --with-xml \
343         --with-xrandr \
344         --with-xrender \
345         --with-xshape \
346         --with-xshm \
347         --with-xslt \
348         --with-xxf86vm \
349         --with-x \
350         --with-zlib
351 %{__make} depend
352 %{__make}
353
354 %install
355 rm -rf $RPM_BUILD_ROOT
356 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
357 %{__make} install \
358         DESTDIR=$RPM_BUILD_ROOT
359
360 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
361 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
362
363 install -d \
364         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
365         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
366         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
367         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
368         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
369
370 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
371 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
372 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
373
374 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
375 [mci]
376 cdaudio=mcicda.drv
377 sequencer=mciseq.drv
378 waveaudio=mciwave.drv
379 avivideo=mciavi.drv
380 videodisc=mcipionr.drv
381 vcr=mciviscd.drv
382 MPEGVideo=mciqtz.drv
383 EOF
384
385 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
386
387 dir=$(pwd)
388 > files.so
389 > files.programs
390 cd $RPM_BUILD_ROOT%{_libdir}/wine
391 for f in *.so; do
392         case $f in
393         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
394                 ;;
395         *)
396                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
397         esac
398 done
399 cd -
400
401 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
402 for p in $programs; do
403         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
404         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
405         echo "%{_mandir}/man1/$p.1*" >> files.programs
406         grep -v "$p\.exe\.so$" files.so > files.so.
407         mv -f files.so. files.so
408 done
409
410 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
411         mv "$dir" "${dir%.UTF-8}"
412 done
413
414 %ifarch %{x8664}
415 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
416 for lang in de fr pl ; do
417 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
418 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
419 done
420 %else
421 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
422 for lang in de fr pl ; do
423 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
424 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
425 done
426 %endif
427
428 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
429 %ifnarch %{x8664}
430 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
431 %else
432 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
433 %endif
434
435 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
436 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
437 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
438
439 %clean
440 rm -rf $RPM_BUILD_ROOT
441
442 %post
443 /sbin/ldconfig
444 %update_desktop_database
445
446 %postun -p /sbin/ldconfig
447
448 %triggerpostun -- wine < 1:0.9.12-1.9
449 rm -f /var/lock/subsys/wine
450 if [ -x /sbin/chkconfig ]; then
451         /sbin/chkconfig --del wine
452 fi
453
454 %files -f files.so
455 %defattr(644,root,root,755)
456 %doc README AUTHORS ANNOUNCE
457 %lang(de) %doc documentation/README.de
458 %lang(es) %doc documentation/README.es
459 %lang(fr) %doc documentation/README.fr
460 %lang(hu) %doc documentation/README.hu
461 %lang(it) %doc documentation/README.it
462 %lang(ko) %doc documentation/README.ko
463 %lang(nb) %doc documentation/README.no
464 %lang(pt) %doc documentation/README.pt
465 %lang(pt_BR) %doc documentation/README.pt_br
466 %lang(ru) %doc documentation/README.ru
467 %lang(sv) %doc documentation/README.sv
468 %lang(tr) %doc documentation/README.tr
469 %attr(755,root,root) %{_bindir}/msiexec
470 %ifnarch %{x8664}
471 %attr(755,root,root) %{_bindir}/wine
472 %else
473 %attr(755,root,root) %{_bindir}/wine64
474 %endif
475 %attr(755,root,root) %{_bindir}/wineboot
476 %attr(755,root,root) %{_bindir}/winedbg
477 %attr(755,root,root) %{_bindir}/winecfg
478 %ifnarch %{x8664}
479 %attr(755,root,root) %{_bindir}/wine-preloader
480 %else
481 %attr(755,root,root) %{_bindir}/wine64-preloader
482 %endif
483 %attr(755,root,root) %{_bindir}/wineserver
484 %attr(755,root,root) %{_libdir}/*.so*
485 %dir %{_libdir}/wine
486 %dir %{_libdir}/wine/fakedlls
487 %{_libdir}/wine/fakedlls/*.acm
488 %{_libdir}/wine/fakedlls/*.cpl
489 %{_libdir}/wine/fakedlls/*.dll
490 %ifarch %{ix86}
491 %{_libdir}/wine/fakedlls/*.dll16
492 %endif
493 %{_libdir}/wine/fakedlls/*.drv
494 %ifarch %{ix86}
495 %{_libdir}/wine/fakedlls/*.drv16
496 %endif
497 %{_libdir}/wine/fakedlls/*.ds
498 %{_libdir}/wine/fakedlls/*.exe
499 %ifarch %{ix86}
500 %{_libdir}/wine/fakedlls/*.exe16
501 %{_libdir}/wine/fakedlls/*.mod16
502 %endif
503 %{_libdir}/wine/fakedlls/*.ocx
504 %{_libdir}/wine/fakedlls/*.sys
505 %{_libdir}/wine/fakedlls/*.tlb
506 %ifarch %{ix86}
507 %{_libdir}/wine/fakedlls/*.vxd
508 %endif
509 %ifnarch %{x8664}
510 %{_mandir}/man1/wine.1*
511 %lang(de) %{_mandir}/de/man1/wine.1*
512 %lang(fr) %{_mandir}/fr/man1/wine.1*
513 %lang(pl) %{_mandir}/pl/man1/wine.1*
514 %else
515 %{_mandir}/man1/wine64.1*
516 %lang(de) %{_mandir}/de/man1/wine64.1*
517 %lang(fr) %{_mandir}/fr/man1/wine64.1*
518 %lang(pl) %{_mandir}/pl/man1/wine64.1*
519 %endif
520 %{_mandir}/man1/msiexec.1*
521 %{_mandir}/man1/wineboot.1*
522 %{_mandir}/man1/winecfg.1*
523 %{_mandir}/man1/winedbg.1*
524 %{_mandir}/man1/wineserver.1*
525 %lang(de) %{_mandir}/de/man1/wineserver.1*
526 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
527 %{_winedir}
528 %{_desktopdir}/wine.desktop
529 %{_desktopdir}/wine-uninstaller.desktop
530 %{_pixmapsdir}/%{name}.png
531
532 %files programs -f files.programs
533 %defattr(644,root,root,755)
534
535 %files devel
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_bindir}/sfnt2fon
538 %attr(755,root,root) %{_bindir}/function_grep.pl
539 %attr(755,root,root) %{_bindir}/widl
540 %attr(755,root,root) %{_bindir}/winebuild
541 %attr(755,root,root) %{_bindir}/winedump
542 %attr(755,root,root) %{_bindir}/wineg++
543 %attr(755,root,root) %{_bindir}/winegcc
544 %attr(755,root,root) %{_bindir}/winemaker
545 %attr(755,root,root) %{_bindir}/winecpp
546 %attr(755,root,root) %{_bindir}/wmc
547 %attr(755,root,root) %{_bindir}/wrc
548 %{_libdir}/wine/lib*.def
549 # no shared variants, so not separated
550 %{_libdir}/wine/lib*.def.a
551 %{_libdir}/wine/libadsiid.a
552 %{_libdir}/wine/libdx*.a
553 %{_libdir}/wine/libstrmbase.a
554 %{_libdir}/wine/libstrmiids.a
555 %{_libdir}/wine/libuuid.a
556 %{_libdir}/wine/libwinecrt0.a
557 %{_includedir}/wine
558 %{_mandir}/man1/widl.1*
559 %{_mandir}/man1/winebuild.1*
560 %{_mandir}/man1/winecpp.1*
561 %{_mandir}/man1/winedump.1*
562 %{_mandir}/man1/winegcc.1*
563 %{_mandir}/man1/wineg++.1*
564 %{_mandir}/man1/winemaker.1*
565 %lang(de) %{_mandir}/de/man1/winemaker.1*
566 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
567 %{_mandir}/man1/wmc.1*
568 %{_mandir}/man1/wrc.1*
569 %{_aclocaldir}/*.m4
570
571 %files dll-capi
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
574
575 %files dll-d3d
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
578 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
579 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
580
581 %files dll-gl
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
584 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
585
586 %if %{with sane}
587 %files dll-twain
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
590 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
591 %endif
592
593 %if %{with ldap}
594 %files dll-ldap
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
597 %endif
598
599 %if %{with alsa}
600 %files drv-alsa
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
603 %endif
604
605 # additional dependencies in *.so not separated (yet?) from main package
606 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
607 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.076692 seconds and 4 git commands to generate.