]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- move widl to main pkg
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20021007
7 Release:        1
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.bz2
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  XFree86-devel
19 %{!?_without_arts:BuildRequires:        arts-devel}
20 BuildRequires:  bison
21 BuildRequires:  chpax >= 0.20020901-2
22 %{!?_without_cups:BuildRequires:        cups-devel}
23 BuildRequires:  docbook-dtd31-sgml
24 BuildRequires:  docbook-utils
25 BuildRequires:  flex
26 BuildRequires:  freetype-devel >= 2.0.5
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  ncurses-devel
29 BuildRequires:  openjade
30 %{!?_without_sane:BuildRequires:        sane-backends-devel}
31 Requires:       OpenGL
32 Requires(post): /sbin/ldconfig
33 Requires(post,preun):/sbin/chkconfig
34 ExclusiveArch:  %{ix86}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
38 %define         no_install_post_strip   1
39
40 %define         _prefix                 /usr/X11R6
41 %define         _mandir                 %{_prefix}/man
42 %define         _winedir                %{_datadir}/%{name}
43
44 %description
45 Wine is a program which allows running Microsoft Windows programs
46 (including DOS, Windows 3.x and Win32 executables) on Unix. It
47 consists of a program loader which loads and executes a Microsoft
48 Windows binary, and a library that implements Windows API calls using
49 their Unix or X11 equivalents. The library may also be used for
50 porting Win32 code into native Unix executables.
51
52 %description -l es
53 Ejecuta programas Windows en Linux.
54
55 %description -l pl
56 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
57 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
58 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
59 Microsoft Windows oraz z biblioteki, która implementuje API Windows
60 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
61 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
62
63 %description -l pt_BR
64 O Wine é um programa que permite rodar programas MS-Windows no X11.
65 Ele consiste de um carregador de programa, que carrega e executa um
66 binário MS-Windows, e de uma biblioteca de emulação que traduz as
67 chamadas da API para as equivalentes Unix/X11.
68
69 %package devel
70 Summary:        Wine - header files
71 Summary(es):    Biblioteca de desarrollo de wine
72 Summary(pl):    Wine - pliki nag³owkowe
73 Summary(pt_BR): Biblioteca de desenvolvimento do wine
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}
76
77 %description devel
78 Wine - header files.
79
80 %description devel -l es
81 Biblioteca de desarrollo de wine.
82
83 %description devel -l pl
84 Wine - pliki nag³ówkowe.
85
86 %description devel -l pt_BR
87 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
88 WINE.
89
90 %package programs
91 Summary:        Wine - programs
92 Summary(pl):    Wine - programy
93 Group:          Applications
94 Requires:       %{name} = %{version}
95
96 %description programs
97 Wine - programs
98
99 %description programs -l pl
100 Wine - programy
101
102 %prep
103 %setup -q
104 %patch -p1
105
106 # turn off compilation of some tools
107 sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
108 mv -f .tmp programs/Makefile.in
109
110 %build
111 #aclocal
112 #autoconf
113 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
114 CFLAGS="%{rpmcflags} $CPPFLAGS"
115 %configure \
116 %{!?debug:      --disable-debug} \
117 %{!?debug:      --disable-trace} \
118         --enable-curses \
119         --enable-opengl \
120         --with-x
121
122 %{__make} depend
123 %{__make}
124 %{__make} -C programs
125
126 cd documentation
127 ./db2html-winehq wine-user.sgml
128 ./db2html-winehq wine-devel.sgml
129 ./db2html-winehq winelib-user.sgml
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
134
135 %{__make} install \
136         prefix=$RPM_BUILD_ROOT%{_prefix} \
137         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
138         bindir=$RPM_BUILD_ROOT%{_bindir} \
139         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
140         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
141         datadir=$RPM_BUILD_ROOT%{_datadir} \
142         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
143         libdir=$RPM_BUILD_ROOT%{_libdir} \
144         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
145         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
146         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
147         mandir=$RPM_BUILD_ROOT%{_mandir} \
148         infodir=$RPM_BUILD_ROOT%{_infodir} \
149         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
150
151 %{__make} -C programs install \
152         prefix=$RPM_BUILD_ROOT%{_prefix} \
153         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
154         bindir=$RPM_BUILD_ROOT%{_bindir} \
155         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
156         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
157         datadir=$RPM_BUILD_ROOT%{_datadir} \
158         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
159         libdir=$RPM_BUILD_ROOT%{_libdir} \
160         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
161         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
162         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
163         mandir=$RPM_BUILD_ROOT%{_mandir} \
164         infodir=$RPM_BUILD_ROOT%{_infodir} \
165         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
166
167 install programs/winhelp/hlp2sgml       $RPM_BUILD_ROOT%{_bindir}
168 install tools/fnt2bdf                   $RPM_BUILD_ROOT%{_bindir}
169
170 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
171         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
172         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
173         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
174         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
175         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
176
177 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
178 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
179 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
180 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
181
182 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
183 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
184 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
185
186 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
187 [mci]
188 cdaudio=mcicda.drv
189 sequencer=mciseq.drv
190 waveaudio=mciwave.drv
191 avivideo=mciavi.drv
192 videodisc=mcipionr.drv
193 vcr=mciviscd.drv
194 MPEGVideo=mciqtz.drv
195 EOF
196
197 %if %{?debug:0}%{!?debug:1}
198 echo "Strip executable binaries and shared object files."
199 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
200 elfexelist=`echo $filelist | xargs -r file | \
201         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
202 elfsharedlist=`echo $filelist | xargs -r file | \
203         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
204 if [ -n "$elfexelist" ]; then \
205         strip -R .note -R .comment $elfexelist
206 fi
207 if [ -n "$elfsharedlist" ]; then
208         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
209 fi
210 %endif
211
212 /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post
218 /sbin/ldconfig
219 /sbin/chkconfig --add wine
220 if [ ! -f /var/lock/subsys/wine ]; then
221         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
222 fi
223
224 %preun
225 if [ "$1" = "0" ]; then
226         if [ -f /var/lock/subsys/wine ]; then
227                 /etc/rc.d/init.d/wine stop >&2
228         fi
229         /sbin/chkconfig --del wine
230 fi
231
232 %postun -p /sbin/ldconfig
233
234 %files
235 %defattr(644,root,root,755)
236 %doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
237 %doc documentation/{wine-user,samples,status}
238 %attr(755,root,root) %{_bindir}/wine
239 %attr(755,root,root) %{_bindir}/winebuild
240 %attr(755,root,root) %{_bindir}/winemaker
241 %attr(755,root,root) %{_bindir}/wineserver
242 %attr(755,root,root) %{_bindir}/wineclipsrv
243 %attr(755,root,root) %{_bindir}/winelauncher
244 %attr(755,root,root) %{_bindir}/wineshelllink
245 %attr(755,root,root) %{_bindir}/winedump
246 %attr(755,root,root) %{_bindir}/wrc
247 %attr(755,root,root) %{_bindir}/wmc
248 %attr(755,root,root) %{_bindir}/widl
249 %attr(755,root,root) %{_bindir}/fnt2bdf
250 %attr(755,root,root) %{_bindir}/function_grep.pl
251 %attr(755,root,root) %{_libdir}/*.so*
252 %{_libdir}/wine
253 %{_mandir}/man[15]/*
254 %config(noreplace) %{_sysconfdir}/wine.reg
255 %config(missingok) %{_sysconfdir}/wine.systemreg
256 %config(missingok) %{_sysconfdir}/wine.userreg
257 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
258 %{_winedir}
259
260 %files programs
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_bindir}/hlp2sgml
263 %attr(755,root,root) %{_bindir}/notepad
264 %attr(755,root,root) %{_bindir}/progman
265 %attr(755,root,root) %{_bindir}/regedit
266 %attr(755,root,root) %{_bindir}/regsvr32
267 %attr(755,root,root) %{_bindir}/uninstaller
268 %attr(755,root,root) %{_bindir}/wcmd
269 %attr(755,root,root) %{_bindir}/wineconsole
270 %attr(755,root,root) %{_bindir}/winedbg
271 %attr(755,root,root) %{_bindir}/winefile
272 %attr(755,root,root) %{_bindir}/winemine
273 %attr(755,root,root) %{_bindir}/winepath
274 %attr(755,root,root) %{_bindir}/winhelp
275
276 %files devel
277 %defattr(644,root,root,755)
278 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
279 %{_includedir}/wine
280 %{_libdir}/*.a
281 %{_aclocaldir}/*.m4
This page took 0.050711 seconds and 4 git commands to generate.