]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- ac regen req ac 2.53. disabled
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20020411
7 Release:        1
8 License:        GPL
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.reg
13 Source3:        %{name}.systemreg
14 Source4:        %{name}.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 Exclusivearch:  %{ix86}
18 BuildRequires:  XFree86-devel
19 BuildRequires:  flex
20 BuildRequires:  bison
21 BuildRequires:  ncurses-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  freetype-devel >= 2.0.5
24 BuildRequires:  chpax
25 Requires:       OpenGL
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
29 %define         no_install_post_strip   1
30
31 %define         _prefix                 /usr/X11R6
32 %define         _mandir                 %{_prefix}/man
33 %define         _winedir                %{_datadir}/%{name}
34
35 %description
36 Wine is a program which allows running Microsoft Windows programs
37 (including DOS, Windows 3.x and Win32 executables) on Unix. It
38 consists of a program loader which loads and executes a Microsoft
39 Windows binary, and a library that implements Windows API calls using
40 their Unix or X11 equivalents. The library may also be used for
41 porting Win32 code into native Unix executables.
42
43 %description -l es
44 Ejecuta programas Windows en Linux.
45
46 %description -l pl
47 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
48 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
49 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
50 Microsoft Windows oraz z biblioteki, która implementuje API Windows
51 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
52 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
53
54 %description -l pt_BR
55 O Wine é um programa que permite rodar programas MS-Windows no X11.
56 Ele consiste de um carregador de programa, que carrega e executa um
57 binário MS-Windows, e de uma biblioteca de emulação que traduz as
58 chamadas da API para as equivalentes Unix/X11.
59
60 %package devel
61 Summary:        Wine - header files
62 Summary(es):    Biblioteca de desarrollo de wine
63 Summary(pl):    Wine - pliki nag³owkowe
64 Summary(pt_BR): Biblioteca de desenvolvimento do wine
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}
67
68 %description devel
69 Wine - header files.
70
71 %description devel -l es
72 Biblioteca de desarrollo de wine.
73
74 %description devel -l pl
75 Wine - pliki nag³ówkowe.
76
77 %description devel -l pt_BR
78 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
79 WINE.
80
81 %package programs
82 Summary:        Wine - programs
83 Summary(pl):    Wine - programy
84 Group:          Applications
85 Requires:       %{name} = %{version}
86
87 %description programs
88 Wine - programs
89
90 %description programs -l pl
91 Wine - programy
92
93 %prep
94 %setup -q
95 %patch -p1
96
97 # turn off compilation of some tools
98 sed -e "s|winetest||;s|avitools||" programs/Makefile.in > .tmp
99 mv -f .tmp programs/Makefile.in
100
101 %build
102 #aclocal
103 #autoconf
104 %configure \
105 %{!?debug:      --disable-debug} \
106 %{!?debug:      --disable-trace} \
107         --enable-curses \
108         --enable-opengl \
109         --with-x
110
111 %{__make} depend
112 %{__make}
113 %{__make} -C programs
114
115 (cd documentation
116 ./db2html-winehq wine-user.sgml
117 ./db2html-winehq wine-devel.sgml
118 ./db2html-winehq winelib-user.sgml)
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT%{_mandir}/man1
123
124 %{__make} install \
125         prefix=$RPM_BUILD_ROOT%{_prefix} \
126         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
127         bindir=$RPM_BUILD_ROOT%{_bindir} \
128         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
129         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
130         datadir=$RPM_BUILD_ROOT%{_datadir} \
131         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
132         libdir=$RPM_BUILD_ROOT%{_libdir} \
133         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
134         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
135         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
136         mandir=$RPM_BUILD_ROOT%{_mandir} \
137         infodir=$RPM_BUILD_ROOT%{_infodir} \
138         dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
139
140 %{__make} -C programs install \
141         prefix=$RPM_BUILD_ROOT%{_prefix} \
142         bindir=$RPM_BUILD_ROOT%{_bindir}
143
144 (cd $RPM_BUILD_ROOT%{_bindir}
145 find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
146
147 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
148         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
149         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
150         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
151         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
152         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
153
154 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
155 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
156 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
157 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
158
159 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
160 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
161 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
162
163 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
164 [mci]
165 cdaudio=mcicda.drv
166 sequencer=mciseq.drv
167 waveaudio=mciwave.drv
168 avivideo=mciavi.drv
169 videodisc=mcipionr.drv
170 vcr=mciviscd.drv
171 MPEGVideo=mciqtz.drv
172 EOF
173
174 gzip -9nf README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
175
176 %if %{?debug:0}%{!?debug:1}
177 echo "Strip executable binaries and shared object files."
178 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
179 elfexelist=`echo $filelist | xargs -r file | \
180         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
181 elfsharedlist=`echo $filelist | xargs -r file | \
182         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
183 if [ -n "$elfexelist" ]; then \
184         strip -R .note -R .comment $elfexelist
185 fi
186 if [ -n "$elfsharedlist" ]; then
187         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
188 fi
189 %endif
190
191 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post
197 /sbin/ldconfig
198 /sbin/chkconfig --add wine
199 if [ ! -f /var/lock/subsys/wine ]; then
200         echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
201 fi
202
203 %preun
204 if [ "$1" = "0" ]; then
205         if [ -f /var/lock/subsys/wine ]; then
206                 /etc/rc.d/init.d/wine stop >&2
207         fi
208         /sbin/chkconfig --del wine
209 fi
210
211 %postun -p /sbin/ldconfig
212
213 %files
214 %defattr(644,root,root,755)
215 %doc *.gz
216 %doc documentation/wine-user
217 %attr(755,root,root) %{_bindir}/wine
218 %attr(755,root,root) %{_bindir}/winebuild
219 %attr(755,root,root) %{_bindir}/winemaker
220 %attr(755,root,root) %{_bindir}/wineserver
221 %attr(755,root,root) %{_bindir}/wineclipsrv
222 %attr(755,root,root) %{_bindir}/winelauncher
223 %attr(755,root,root) %{_bindir}/wineshelllink
224 %attr(755,root,root) %{_bindir}/winedump
225 %attr(755,root,root) %{_bindir}/wrc
226 %attr(755,root,root) %{_bindir}/wmc
227 %attr(755,root,root) %{_bindir}/fnt2bdf
228 %attr(755,root,root) %{_bindir}/function_grep.pl
229 %attr(755,root,root) %{_libdir}/*.so*
230 %{_libdir}/wine
231 %{_mandir}/man[15]/*
232 %config(noreplace) %{_sysconfdir}/wine.reg
233 %config(missingok) %{_sysconfdir}/wine.systemreg
234 %config(missingok) %{_sysconfdir}/wine.userreg
235 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
236 %{_winedir}
237
238 %files programs -f programs.list
239 %defattr(644,root,root,755)
240 %attr (755,root,root) %{_bindir}/hlp2sgml
241 %{_bindir}/*.so
242
243 %files devel
244 %defattr(644,root,root,755)
245 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
246 %{_includedir}/wine
247 %{_libdir}/*.a
This page took 0.039133 seconds and 3 git commands to generate.