]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
b8088ebff60757d97199df9d75ba05f032caa2e6
[packages/wine.git] / wine.spec
1 Summary:        Program that lets you launch Win applications
2 Summary(es):    Ejecuta programas Windows en Linux
3 Summary(pl):    Program pozwalaj±cy uruchamiaæ aplikacje Windows
4 Summary(pt_BR): Executa programas Windows no Linux
5 Name:           wine
6 Version:        20020122
7 Release:        2
8 License:        distributable
9 Group:          Applications/Emulators
10 Source0:        ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
11 Source1:        wine.init
12 Source2:        wine.reg
13 Source3:        wine.systemreg
14 Source4:        wine.userreg
15 Patch0:         %{name}-fontcache.patch
16 URL:            http://www.winehq.com/
17 Exclusivearch:  %{ix86}
18 BuildRequires:  XFree86-devel
19 BuildRequires:  flex
20 BuildRequires:  bison
21 BuildRequires:  ncurses-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  freetype-devel >= 2.0.5
24 BuildRequires:  chpax
25 Requires:       OpenGL
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
29 %define         _prefix         /usr/X11R6
30 %define         _mandir         %{_prefix}/man
31 %define         _winedir        %{_datadir}/%{name}
32 %define no_install_post_strip 1
33
34 %description
35 Wine is a program which allows running Microsoft Windows programs
36 (including DOS, Windows 3.x and Win32 executables) on Unix. It
37 consists of a program loader which loads and executes a Microsoft
38 Windows binary, and a library that implements Windows API calls using
39 their Unix or X11 equivalents. The library may also be used for
40 porting Win32 code into native Unix executables.
41
42 %description -l es
43 Ejecuta programas Windows en Linux.
44
45 %description -l pl
46 Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
47 dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
48 loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
49 Microsoft Windows oraz z biblioteki, która implementuje API Windows
50 przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
51 tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
52
53 %description -l pt_BR
54 O Wine é um programa que permite rodar programas MS-Windows no X11.
55 Ele consiste de um carregador de programa, que carrega e executa um
56 binário MS-Windows, e de uma biblioteca de emulação que traduz as
57 chamadas da API para as equivalentes Unix/X11.
58
59 %package devel
60 Summary:        Wine - header files
61 Summary(es):    Biblioteca de desarrollo de wine
62 Summary(pl):    Wine - pliki nag³owkowe
63 Summary(pt_BR): Biblioteca de desenvolvimento do wine
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}
66  
67 %description devel
68 Wine - header files.
69
70 %description devel -l es
71 Biblioteca de desarrollo de wine.
72
73 %description devel -l pl
74 Wine - pliki nag³ówkowe.
75
76 %description devel -l pt_BR
77 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
78 WINE.
79
80 %prep
81 %setup -q
82 %patch -p1
83
84 %build
85 %configure2_13 \
86         --disable-debug \
87         --disable-trace \
88         --enable-curses \
89         --enable-opengl \
90         --with-x
91
92 %{__make} depend
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_mandir}/man1
98
99 %{__make} install \
100         prefix=$RPM_BUILD_ROOT%{_prefix} \
101         exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
102         bindir=$RPM_BUILD_ROOT%{_bindir} \
103         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
104         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
105         datadir=$RPM_BUILD_ROOT%{_datadir} \
106         includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
107         libdir=$RPM_BUILD_ROOT%{_libdir} \
108         libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
109         localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
110         sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
111         mandir=$RPM_BUILD_ROOT%{_mandir} \
112         infodir=$RPM_BUILD_ROOT%{_infodir} 
113         
114 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
115         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
116         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
117         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
118         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
119         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
122 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
123 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
124 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
125
126 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
127 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
128 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
129
130 cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
131 [mci]
132 cdaudio=mcicda.drv
133 sequencer=mciseq.drv
134 waveaudio=mciwave.drv
135 avivideo=mciavi.drv
136 videodisc=mcipionr.drv
137 vcr=mciviscd.drv
138 MPEGVideo=mciqtz.drv
139 EOF
140
141 gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
142
143 echo "Strip executable binaries and shared object files."
144 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
145 elfexelist=`echo $filelist | xargs -r file | \
146         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
147 elfsharedlist=`echo $filelist | xargs -r file | \
148         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
149 if [ -n "$elfexelist" ]; then \
150         strip -R .note -R .comment $elfexelist
151 fi
152 if [ -n "$elfsharedlist" ]; then
153         strip --strip-unneeded -R .note  -R .comment $elfsharedlist
154 fi
155
156 /sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 %doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
167 %doc documentation
168 %attr(755,root,root) %{_bindir}/*
169 %attr(755,root,root) %{_libdir}/*.so*
170 %{_mandir}/man[15]/*
171 %config(noreplace) %{_sysconfdir}/wine.reg
172 %config(missingok) %{_sysconfdir}/wine.systemreg
173 %config(missingok) %{_sysconfdir}/wine.userreg
174 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
175 %{_winedir}
176
177 %files devel
178 %defattr(644,root,root,755)
179 %{_includedir}/wine
180 %{_libdir}/*.a
This page took 0.058479 seconds and 2 git commands to generate.