]> git.pld-linux.org Git - packages/widelands.git/blob - widelands.spec
- BR: ggz-client-libs-devel
[packages/widelands.git] / widelands.spec
1 #
2 # TODO:
3 # - create bcond for ggz
4 # - check locales
5 #
6 %define         buildver        16
7 Summary:        Game like Settlers II
8 Summary(pl.UTF-8):      Remake gry Settlers II
9 Name:           widelands
10 Version:        0.build%{buildver}
11 Release:        4
12 License:        GPL v2+
13 Group:          X11/Applications/Games
14 Source0:        http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
15 # Source0-md5:  3d8c28e145b73c64d8ed1625319d25a2
16 Source1:        %{name}.desktop
17 URL:            http://widelands.sourceforge.net/
18 BuildRequires:  SDL-devel >= 1.2.11
19 BuildRequires:  SDL_gfx-devel
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel >= 1.2.7
22 BuildRequires:  SDL_net-devel
23 BuildRequires:  SDL_ttf-devel >= 2.0.0
24 BuildRequires:  boost-devel >= 1.35
25 BuildRequires:  cmake
26 BuildRequires:  gettext-devel
27 BuildRequires:  glew-devel
28 BuildRequires:  ggz-client-libs-devel
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtiff-devel
33 BuildRequires:  lua51-devel
34 BuildRequires:  python
35 BuildRequires:  python-modules
36 BuildRequires:  rpmbuild(macros) >= 1.600
37 Requires:       SDL_image >= 1.2.10
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 In Widelands, you are the regent of a small tribe. You start out with
42 nothing but your headquarters, a kind of castle in which all your
43 resources are stored. Every member of your tribe will do his or her
44 part to produce more resources - wood, food, iron, gold and more - to
45 further this growth. But you are not alone in the world, and you will
46 meet other tribes sooner or later. Some of them may be friendly and
47 trade with you. However, if you want to rule the world, you will have
48 to train soldiers and fight.
49
50 %description -l pl.UTF-8
51 W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
52 grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
53 przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
54 wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
55 żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
56 nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
57 spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
58 nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
59 światem, będziesz musiał wyszkolić żołnierzy i walczyć.
60
61 %prep
62 %setup -q -n %{name}-build%{buildver}-src
63
64 %build
65 install -d build
66 cd build
67 %cmake \
68         -DWL_INSTALL_BINDIR=%{_bindir} \
69         -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
70         -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
71         ..
72
73 %{__make}
74 %{__make} lang
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} -C build install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 install -d $RPM_BUILD_ROOT{%{_datadir}/games/%{name},%{_desktopdir},%{_pixmapsdir}}
83
84 # install data
85 cp -a campaigns fonts global maps music pics scripting sound tribes txts worlds $RPM_BUILD_ROOT%{_datadir}/games/%{name}
86
87 # locales
88 cp -a build/locale $RPM_BUILD_ROOT%{_datadir}/games/%{name}
89
90 # unsupported locales
91 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_AU
92 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_CA
93
94 # desktop and icon
95 cp -a pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
96 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc ChangeLog CREDITS
104 %attr(755,root,root) %{_bindir}/%{name}
105 %dir %{_datadir}/games/%{name}
106 %{_datadir}/games/%{name}/campaigns
107 %{_datadir}/games/%{name}/fonts
108 %{_datadir}/games/%{name}/global
109 %{_datadir}/games/%{name}/maps
110 %{_datadir}/games/%{name}/music
111 %{_datadir}/games/%{name}/pics
112 %{_datadir}/games/%{name}/scripting
113 %{_datadir}/games/%{name}/sound
114 %{_datadir}/games/%{name}/tribes
115 %{_datadir}/games/%{name}/txts
116 %{_datadir}/games/%{name}/worlds
117 %dir %{_datadir}/games/%{name}/locale
118 %lang(ar) %{_datadir}/games/%{name}/locale/ar
119 %lang(ast) %{_datadir}/games/%{name}/locale/ast
120 %lang(ca) %{_datadir}/games/%{name}/locale/ca
121 %lang(cs) %{_datadir}/games/%{name}/locale/cs
122 %lang(da) %{_datadir}/games/%{name}/locale/da
123 %lang(de) %{_datadir}/games/%{name}/locale/de
124 %lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
125 %lang(eo) %{_datadir}/games/%{name}/locale/eo
126 %lang(es) %{_datadir}/games/%{name}/locale/es
127 %lang(et) %{_datadir}/games/%{name}/locale/et
128 %lang(eu) %{_datadir}/games/%{name}/locale/eu
129 %lang(fa) %{_datadir}/games/%{name}/locale/fa
130 %lang(fi) %{_datadir}/games/%{name}/locale/fi
131 %lang(fr) %{_datadir}/games/%{name}/locale/fr
132 %lang(gl) %{_datadir}/games/%{name}/locale/gl
133 %lang(he) %{_datadir}/games/%{name}/locale/he
134 %lang(hu) %{_datadir}/games/%{name}/locale/hu
135 %lang(ia) %{_datadir}/games/%{name}/locale/ia
136 %lang(id) %{_datadir}/games/%{name}/locale/id
137 %lang(it) %{_datadir}/games/%{name}/locale/it
138 %lang(ja) %{_datadir}/games/%{name}/locale/ja
139 %lang(ko) %{_datadir}/games/%{name}/locale/ko
140 %lang(la) %{_datadir}/games/%{name}/locale/la
141 %lang(ms) %{_datadir}/games/%{name}/locale/ms
142 %lang(nb) %{_datadir}/games/%{name}/locale/nb
143 %lang(nl) %{_datadir}/games/%{name}/locale/nl
144 %lang(nn) %{_datadir}/games/%{name}/locale/nn
145 %lang(oc) %{_datadir}/games/%{name}/locale/oc
146 %lang(pl) %{_datadir}/games/%{name}/locale/pl
147 %lang(pt) %{_datadir}/games/%{name}/locale/pt
148 %lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
149 %lang(ru) %{_datadir}/games/%{name}/locale/ru
150 %lang(si) %{_datadir}/games/%{name}/locale/si
151 %lang(sk) %{_datadir}/games/%{name}/locale/sk
152 %lang(sl) %{_datadir}/games/%{name}/locale/sl
153 %lang(sr) %{_datadir}/games/%{name}/locale/sr
154 %lang(sv) %{_datadir}/games/%{name}/locale/sv
155 %lang(tr) %{_datadir}/games/%{name}/locale/tr
156 %lang(uk) %{_datadir}/games/%{name}/locale/uk
157 %lang(vi) %{_datadir}/games/%{name}/locale/vi
158 %lang(zh_CN) %{_datadir}/games/%{name}/locale/zh_CN
159 %{_desktopdir}/%{name}.desktop
160 %{_pixmapsdir}/%{name}.png
This page took 0.080037 seconds and 3 git commands to generate.