]> git.pld-linux.org Git - packages/widelands.git/blob - widelands.spec
- pass %__cxx and %rpmcxxflags, but disable optimization (add -O0) becouse
[packages/widelands.git] / widelands.spec
1 #
2 # TODO:
3 # - create bcond for ggz
4 #
5 %define         buildver        14
6 Summary:        Game like Settlers II
7 Summary(pl.UTF-8):      Remake gry Settlers II
8 Name:           widelands
9 Version:        0.build%{buildver}
10 Release:        0.6
11 License:        GPL v2+
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/widelands/Widelands-Build%{buildver}-src.7z
14 # Source0-md5:  06d63783b82b68af7af26198bc0a5afa
15 Source1:        %{name}.desktop
16 #Patch0:                %{name}-syntax.patch
17 URL:            http://widelands.sourceforge.net/
18 BuildRequires:  SDL-devel >= 1.2.11
19 BuildRequires:  SDL_gfx-devel
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel >= 1.2.7
22 BuildRequires:  SDL_net-devel
23 BuildRequires:  SDL_ttf-devel >= 2.0.0
24 BuildRequires:  boost-devel >= 1.35
25 BuildRequires:  libpng-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  p7zip
28 BuildRequires:  scons
29 BuildRequires:  sed >= 4.0
30 Requires:       SDL_image >= 1.2.10
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 In Widelands, you are the regent of a small tribe. You start out with
35 nothing but your headquarters, a kind of castle in which all your
36 resources are stored. Every member of your tribe will do his or her
37 part to produce more resources - wood, food, iron, gold and more - to
38 further this growth. But you are not alone in the world, and you will
39 meet other tribes sooner or later. Some of them may be friendly and
40 trade with you. However, if you want to rule the world, you will have
41 to train soldiers and fight.
42
43 %description -l pl.UTF-8
44 W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
45 grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
46 przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
47 wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
48 żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
49 nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
50 spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
51 nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
52 światem, będziesz musiał wyszkolić żołnierzy i walczyć.
53
54 %prep
55 %setup -q -c -T -n %{name}
56 7z x -o.. %{SOURCE0}
57 #%%patch0 -p1
58 #%{__sed} -i 's/framework-mt/framework/' SConstruct
59
60 %{__sed} -i '/env.strip=1/d' build/scons-tools/scons_configure.py
61
62 %build
63 %scons \
64         cxx="%{__cxx}" \
65         cc="%{__cc}" \
66         extra_compile_flags="%{rpmcxxflags} -O0" \
67         extra_link_flags="%{rpmcxxflags} %{rpmldflags}" \
68         build="release" \
69         pretty_compile_output="false" \
70         install_prefix="" \
71         bindir="%{_bindir}" \
72         datadir="%{_datadir}/games/%{name}" \
73         localedir="%{_datadir}/games/%{name}/locale" \
74         enable_ggz="false"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__scons} install \
80         build="release" \
81         install_prefix="$RPM_BUILD_ROOT%{_prefix}" \
82         bindir="$RPM_BUILD_ROOT%{_bindir}" \
83         datadir="$RPM_BUILD_ROOT%{_datadir}/games/%{name}" \
84         localedir="$RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale" \
85
86 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
87
88 install pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
89 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog CREDITS
97 %attr(755,root,root) %{_bindir}/%{name}
98 %dir %{_datadir}/games/%{name}
99 %{_datadir}/games/%{name}/VERSION
100 %{_datadir}/games/%{name}/campaigns
101 %{_datadir}/games/%{name}/fonts
102 %{_datadir}/games/%{name}/global
103 %{_datadir}/games/%{name}/maps
104 %{_datadir}/games/%{name}/music
105 %{_datadir}/games/%{name}/pics
106 %{_datadir}/games/%{name}/sound
107 %{_datadir}/games/%{name}/tribes
108 %{_datadir}/games/%{name}/txts
109 %{_datadir}/games/%{name}/worlds
110 %dir %{_datadir}/games/%{name}/locale
111 %lang(cs) %{_datadir}/games/%{name}/locale/cs_CZ
112 %lang(da) %{_datadir}/games/%{name}/locale/da_DK
113 %lang(de) %{_datadir}/games/%{name}/locale/de_DE
114 %lang(es) %{_datadir}/games/%{name}/locale/es_ES
115 %lang(fi) %{_datadir}/games/%{name}/locale/fi_FI
116 %lang(fr) %{_datadir}/games/%{name}/locale/fr_FR
117 %lang(gl) %{_datadir}/games/%{name}/locale/gl_ES
118 %lang(he) %{_datadir}/games/%{name}/locale/he_HE
119 %lang(hu) %{_datadir}/games/%{name}/locale/hu_HU
120 %lang(it) %{_datadir}/games/%{name}/locale/it_IT
121 %lang(nl) %{_datadir}/games/%{name}/locale/nl_NL
122 %lang(pl) %{_datadir}/games/%{name}/locale/pl_PL
123 %lang(ru) %{_datadir}/games/%{name}/locale/ru_RU
124 %lang(sk) %{_datadir}/games/%{name}/locale/sk_SK
125 %lang(sv) %{_datadir}/games/%{name}/locale/sv_SE
126 %{_desktopdir}/%{name}.desktop
127 %{_pixmapsdir}/%{name}.png
This page took 0.068 seconds and 3 git commands to generate.