]> git.pld-linux.org Git - packages/widelands.git/blob - widelands.spec
4baaaecf69f5527ef246293a11c6fddb049424dc
[packages/widelands.git] / widelands.spec
1 #
2 # TODO:
3 # - create bcond for ggz
4 # - check locales
5 #
6 %define         buildver        16
7 Summary:        Game like Settlers II
8 Summary(pl.UTF-8):      Remake gry Settlers II
9 Name:           widelands
10 Version:        0.build%{buildver}
11 Release:        4
12 License:        GPL v2+
13 Group:          X11/Applications/Games
14 Source0:        http://launchpad.net/widelands/build%{buildver}/build%{buildver}/+download/%{name}-build%{buildver}-src.tar.bz2
15 # Source0-md5:  3d8c28e145b73c64d8ed1625319d25a2
16 Source1:        %{name}.desktop
17 URL:            http://widelands.sourceforge.net/
18 BuildRequires:  SDL-devel >= 1.2.11
19 BuildRequires:  SDL_gfx-devel
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel >= 1.2.7
22 BuildRequires:  SDL_net-devel
23 BuildRequires:  SDL_ttf-devel >= 2.0.0
24 BuildRequires:  boost-devel >= 1.35
25 BuildRequires:  cmake
26 BuildRequires:  gettext-devel
27 BuildRequires:  glew-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel
32 BuildRequires:  lua51-devel
33 BuildRequires:  python
34 BuildRequires:  python-modules
35 BuildRequires:  rpmbuild(macros) >= 1.600
36 Requires:       SDL_image >= 1.2.10
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 In Widelands, you are the regent of a small tribe. You start out with
41 nothing but your headquarters, a kind of castle in which all your
42 resources are stored. Every member of your tribe will do his or her
43 part to produce more resources - wood, food, iron, gold and more - to
44 further this growth. But you are not alone in the world, and you will
45 meet other tribes sooner or later. Some of them may be friendly and
46 trade with you. However, if you want to rule the world, you will have
47 to train soldiers and fight.
48
49 %description -l pl.UTF-8
50 W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
51 grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
52 przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
53 wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
54 żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
55 nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
56 spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
57 nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
58 światem, będziesz musiał wyszkolić żołnierzy i walczyć.
59
60 %prep
61 %setup -q -n %{name}-build%{buildver}-src
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -DWL_INSTALL_BINDIR=%{_bindir} \
68         -DWL_INSTALL_DATADIR=%{_datadir}/games/%{name} \
69         -DWL_INSTALL_LOCALEDIR=%{_datadir}/games/%{name}/locale \
70         ..
71
72 %{__make}
73 %{__make} lang
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 install -d $RPM_BUILD_ROOT{%{_datadir}/games/%{name},%{_desktopdir},%{_pixmapsdir}}
82
83 # install data
84 cp -a campaigns fonts global maps music pics scripting sound tribes txts worlds $RPM_BUILD_ROOT%{_datadir}/games/%{name}
85
86 # locales
87 cp -a build/locale $RPM_BUILD_ROOT%{_datadir}/games/%{name}
88
89 # unsupported locales
90 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_AU
91 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/games/%{name}/locale/en_CA
92
93 # desktop and icon
94 cp -a pics/wl-ico-128.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
95 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog CREDITS
103 %attr(755,root,root) %{_bindir}/%{name}
104 %dir %{_datadir}/games/%{name}
105 %{_datadir}/games/%{name}/campaigns
106 %{_datadir}/games/%{name}/fonts
107 %{_datadir}/games/%{name}/global
108 %{_datadir}/games/%{name}/maps
109 %{_datadir}/games/%{name}/music
110 %{_datadir}/games/%{name}/pics
111 %{_datadir}/games/%{name}/scripting
112 %{_datadir}/games/%{name}/sound
113 %{_datadir}/games/%{name}/tribes
114 %{_datadir}/games/%{name}/txts
115 %{_datadir}/games/%{name}/worlds
116 %dir %{_datadir}/games/%{name}/locale
117 %lang(ar) %{_datadir}/games/%{name}/locale/ar
118 %lang(ast) %{_datadir}/games/%{name}/locale/ast
119 %lang(ca) %{_datadir}/games/%{name}/locale/ca
120 %lang(cs) %{_datadir}/games/%{name}/locale/cs
121 %lang(da) %{_datadir}/games/%{name}/locale/da
122 %lang(de) %{_datadir}/games/%{name}/locale/de
123 %lang(en_GB) %{_datadir}/games/%{name}/locale/en_GB
124 %lang(eo) %{_datadir}/games/%{name}/locale/eo
125 %lang(es) %{_datadir}/games/%{name}/locale/es
126 %lang(et) %{_datadir}/games/%{name}/locale/et
127 %lang(eu) %{_datadir}/games/%{name}/locale/eu
128 %lang(fa) %{_datadir}/games/%{name}/locale/fa
129 %lang(fi) %{_datadir}/games/%{name}/locale/fi
130 %lang(fr) %{_datadir}/games/%{name}/locale/fr
131 %lang(gl) %{_datadir}/games/%{name}/locale/gl
132 %lang(he) %{_datadir}/games/%{name}/locale/he
133 %lang(hu) %{_datadir}/games/%{name}/locale/hu
134 %lang(ia) %{_datadir}/games/%{name}/locale/ia
135 %lang(id) %{_datadir}/games/%{name}/locale/id
136 %lang(it) %{_datadir}/games/%{name}/locale/it
137 %lang(ja) %{_datadir}/games/%{name}/locale/ja
138 %lang(ko) %{_datadir}/games/%{name}/locale/ko
139 %lang(la) %{_datadir}/games/%{name}/locale/la
140 %lang(ms) %{_datadir}/games/%{name}/locale/ms
141 %lang(nb) %{_datadir}/games/%{name}/locale/nb
142 %lang(nl) %{_datadir}/games/%{name}/locale/nl
143 %lang(nn) %{_datadir}/games/%{name}/locale/nn
144 %lang(oc) %{_datadir}/games/%{name}/locale/oc
145 %lang(pl) %{_datadir}/games/%{name}/locale/pl
146 %lang(pt) %{_datadir}/games/%{name}/locale/pt
147 %lang(pt_BR) %{_datadir}/games/%{name}/locale/pt_BR
148 %lang(ru) %{_datadir}/games/%{name}/locale/ru
149 %lang(si) %{_datadir}/games/%{name}/locale/si
150 %lang(sk) %{_datadir}/games/%{name}/locale/sk
151 %lang(sl) %{_datadir}/games/%{name}/locale/sl
152 %lang(sr) %{_datadir}/games/%{name}/locale/sr
153 %lang(sv) %{_datadir}/games/%{name}/locale/sv
154 %lang(tr) %{_datadir}/games/%{name}/locale/tr
155 %lang(uk) %{_datadir}/games/%{name}/locale/uk
156 %lang(vi) %{_datadir}/games/%{name}/locale/vi
157 %lang(zh_CN) %{_datadir}/games/%{name}/locale/zh_CN
158 %{_desktopdir}/%{name}.desktop
159 %{_pixmapsdir}/%{name}.png
This page took 0.03103 seconds and 2 git commands to generate.